Jump to content

Sign in to follow this  
SmokeDiddy

Britten-Norman BN-2 Islander for P3Dv4 coming soon!

Recommended Posts

1 minute ago, Tomaz Drnovsek said:

I get a CTD after installing the gauge. P3D v4.5 HF3.

How did you install it?

Share this post


Link to post
1 minute ago, Tomaz Drnovsek said:

I copied it into "Prepar3D v4\gauges" folder.

I don't think that's going to work.

Share this post


Link to post
7 minutes ago, Tomaz Drnovsek said:

I thought the original file should be replaced with this one, since the same filenames and all. What should be done then?

I don't know. I'm using the  Aerosoft Catalina version hack.

Let's see what Ernie suggests as the right way to install.

  • Upvote 1

Share this post


Link to post
13 minutes ago, Tomaz Drnovsek said:

I thought the original file should be replaced with this one, since the same filenames and all. What should be done then?

For those who want to use the Catalina KLN90 here's my panel:

 

// This Panel.cfg file created by FS Panel Studio panel editor utility - http://www.fspanelstudio.com
// Built Friday, June 11, 2010 at 16:09 FSPS Build:20340

[Window Titles]
Window00=No 2D Panel
Window01=Mini Panel
Window02=AS_KLN90B


//--------------------------------------------------------
[Window00]
file=No2D.bmp 
Background_color=0,0,0 
size_mm=1024
window_size_ratio=1.000  
position=7
visible=1
ident=0

gauge00=Virtavia_Sound64!Sound,  2,2,2,2, ./gauges/Virtavia_xml_sound.ini
gauge01=Flight1_BN2!Backbone_sound,  40,30,20,20


//--------------------------------------------------------
[Window01]
Background_color=0,0,0 
size_mm=631,100
position=7
visible=1
ident=MINIPANEL
child_3d=1
no_luminous=1

gauge00=Cessna172!Airspeed,  0,1
gauge01=Cessna!Turn_Indicator,  102,0
gauge02=CessnaWAlpha!Attitude_Alpha,  207,0
gauge03=Cessna!Heading_Indicator,  312,0
gauge04=Cessna!Altimeter,  417,0
gauge05=Cessna!Vertical_Speed,  531,0


//--------------------------------------------------------
[Window02]
Background_color=0,0,0 
size_mm=512,384
window_size_ratio=1.000  
position=0
visible=0
ident=30
window_size= 0.500, 0.500
window_pos= 0.000, 0.000

gauge00=AS_KLN90B!KLN90B,  0,0,500,160
gauge01=AS_KLN90B!KLN90_popup,  490,4,20,20


//--------------------------------------------------------
[Vcockpit01]
Background_color=0,0,0 
size_mm=1024,1024
visible=1
pixel_size=1024,1024
texture=$vpanel

gauge00=AS_KLN90B!KLN90B,  500,1,370, 115
gauge01=Flight1_BN2!Altimeter,  2,185,157,157
gauge02=Flight1_BN2!C21AP,  1,1,195,38
gauge03=Flight1_BN2!KN54,  197,1,195,37
gauge04=Flight1_BN2!KR871,  1,105,338,39
gauge05=Flight1_BN2!KR872,  1,145,338,39
gauge06=Flight1_BN2!KX155,  1,40,498,64
gauge07=Flight1_BN2!Stall,  340,105,55,55
gauge08=Flight1_BN2!KT67A,  393,1,31,37
gauge09=Flight1_BN2!KMA24,  883,1,26,78
gauge10=Virtavia_Sound64!Sound,  2,2,2,2, ./gauges/Virtavia_xml_sound.ini
gauge11=Flight1_BN2!Backbone_sound,  84,461,20,20
gauge12=Flight1_BN2!GUV1,  912,1,47,47
gauge13=Flight1_BN2!GUV2,  912,49,47,47
gauge14=Flight1_BN2!Hobbs,  396,105,83,22

[Default View]
X=0
Y=0
SIZE_X=8191
SIZE_Y=6134

Share this post


Link to post

Sadly, I don't own Aerosoft Catalina. My only hope is this new gauge 🙂

I have Flight1 GTNs, I used Berts mod but I find it a bit too small, I can barely see anything on that tiny screen.

Edited by Tomaz Drnovsek

Share this post


Link to post
7 minutes ago, Tomaz Drnovsek said:

Sadly, I don't own Aerosoft Catalina. My only hope is this new gauge 🙂

I have Flight1 GTNs, I used Berts mod but I find it a bit too small, I can barely see anything on that tiny screen.

We'll get you going. 😀

  • Like 1

Share this post


Link to post

I own the Aerosoft catalina and used the old hack to fix things

I have cockpit sounds gps and no rumble sound after t/off

she works like a dream 😁

 


MB Gigabyte Z590 Aorus Master CPU i7 11700K @4.6GHz GPU Gigabyte GTX 1070Ti Cooler Noctua NH-U15 with 2 fans
RAM 16MB Corsair DDR4 Vengeance 3200MHz Power Supply Corsair HX850 850 Watt Case Thermaltake level 20 xt Windows 10 64 bit

Share this post


Link to post
4 hours ago, Tomaz Drnovsek said:

I thought the original file should be replaced with this one, since the same filenames and all. What should be done then?

It seems to be working for me in v5.

Here are the steps I did...

Ran the full Flight1  Islander installer, select the P3Dv5 folder for the install location.

After the install is completed , replace the kln90 gauge with the one provided in the link.

 

It doesn't work if you don't run the F1 installer program first.

 

cYOdck.jpg

 

Edited by JeffLewis4

Share this post


Link to post

CTD here too after replacing "Flight1_BN2_kln90a.gau" with the file Mr Ernie released for us:

P3dV4.5 HF3  here.

Nome do aplicativo com falha: Prepar3D.exe, versão: 4.5.14.34698, carimbo de data/hora: 0x5e94b5c2
Nome do módulo com falha: Flight1_BN2_kln90a.gau, versão: 0.0.0.0, carimbo de data/hora: 0x5ec71d05
Exception code: 0xc0000409
Deslocamento da falha: 0x000000000005ae6c
ID do processo com falha: 0x15ec
Hora de início do aplicativo com falha: 0x01d630a1f455f514
Caminho do aplicativo com falha: xxx:\Prepar3D v4\Prepar3D.exe
Caminho do módulo com falha: E:\Prepar3D v4\Gauges\Flight1_BN2_kln90a.gau
ID do Relatório: 34eb8f6c-1b02-4af9-b8c2-0eb3570555ab
Nome completo do pacote com falha:
ID do aplicativo relativo ao pacote com falha:

 

My process here was install the plane directly in p3dv4 folder and then replace the .gau file. Am i forgetting something?

Thanks!


Flavio Cardoso - P3Dv4.5 HF3

Win 10 Pro 64Bits - i74960X 4.5ghz - ASUS Rampage IV Black Ed. - Corsair H150i Platinum - 32gb  Ripjaws Z - ASUS RTX 2080 SUPER SC - MCP 737R 2015 Virtual Avionics

Share this post


Link to post

I install things to the "\Documents\Prepar3D v4 Add-ons" folder.  I'm wondering if that is the issue for me. 

It does attempt to run with no crashing but I'm getting an error message on the KLN90 screen telling me to "Check Install Settings".  Might be some hard coding in there?

...

Bit the bullet and installed it into the root of P3Dv4.5 and it all works now.  Not sure why but it's all good.

Now to work on the sound.  Thanks again Ernie!

Edited by fsafranek

Frank Safranek - Alphasim/Virtavia Paint Crew

m4fs_banner.jpg

Share this post


Link to post

Still no luck on mine even on freshly installed plane 😞 instant CTD upon loading the islander..

Maybe there is a dependency or runtime files I need somewhere 😞


PC- i9-9900KS, 32gb 3200mhz RAM, Nvidia RTX2080Ti

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,670.00 of $25,000.00 Donate Now
×
×
  • Create New...