clocki

Switching from 4.1 to 4.2

Recommended Posts

Hello mates,

I'm sitting on 4.1 and it feels good so far. But some addons like FSLabs and scenery has started to only develop for 4.2 now. So I'm thinking about also upgrading. But the usual problem what comes to my mind is the following: Will there be any issues with current sceneries in 4.1 (all working good) and maybe other problems? I currently use only addons that are official for v4 and no copy&past from v3 or so.

Can I simply update using all the installers? When I updates from v3.2 to 3.4 month ago I had no problem so far using that method. All worked good. But don't know if it will work in v4 too.

PS: As you see I'm waiting till upgrading :D

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

15 hours ago, pgde said:

Works the same as in v3.

So no problems so far with scenery and other tools? I'm a bit afraid that when I install 4.2 I may get some trouble and ending up in deleting everything...

Share this post


Link to post
Share on other sites

Without knowing what add-ons you have, how can we even say?

Here's what I have that works:

  • Tons of Orbx :D
  • ActiveSky for P3Dv4
  • ActiveSky Cloud Art
  • Rex Soft Clouds and Texture Direct
  • ChasePlane
  • Track-IR
  • A2A Cessna 182T and Comanche 250
  • MilViz DHC-2, 310R Redux, B55, MD530
  • FlightSimWorld Cessna 441
  • Caranado Aero Commander 500 Shrike
  • Aerosoft Twin Otter Extended
  • RealAir Turbine Duke V2 (they made nice new installers even)
  • Flight1 GTN 750/650 Complete (you need to just download a new installer)

You can check the forums for products you're interested in, too, to see if there's any quirks.

Also there's a real good install guide in the Tips section that I followed and things worked real nice.

Share this post


Link to post
Share on other sites

I held off on upgrading myself. I finally got the necessary updated support add ons and took the plunge two days ago. I had no problems.

I deleted the old 4.1 client, then updated to 4.2 client.

I updated my fsuipc and PTA. I also updated Envtex, although not sure I needed to do that. I have Orbx NA global, ireland, hawaii from flight sim jewels. None of these had any issues with the upgrade. Actually I have dozens of other add-ons  they all worked fine.

-Stampee

 

 

Share this post


Link to post
Share on other sites
1 hour ago, stampee said:

I held off on upgrading myself. I finally got the necessary updated support add ons and took the plunge two days ago. I had no problems.

I deleted the old 4.1 client, then updated to 4.2 client.

I updated my fsuipc and PTA. I also updated Envtex, although not sure I needed to do that. I have Orbx NA global, ireland, hawaii from flight sim jewels. None of these had any issues with the upgrade. Actually I have dozens of other add-ons  they all worked fine.

-Stampee

 

 

Are there any issues with ATC window? I heard of you select option using keyboard causes problems such as getting ATC window stuck on screen. Not sure if this is true.

Share this post


Link to post
Share on other sites

I certainly had troubles with the ATC window with the 4.2 client; the window was blank and I couldn't use ATC at all.

I tried the various fixes that others had recommended, but the only solution that worked for me was reinstalling the 4.1 client!

Share this post


Link to post
Share on other sites

Yes, there can be problems with the ATC window (although I didn't have them) and there certainly are problems with the SimConnect window (which is used by for instance Active Sky, ProATC, GSX). The latter is annoying (the window closes before you can choose an option) but there are work arounds. LM will probably fix this with the next update but no one knows what that update will come. 

Share this post


Link to post
Share on other sites
20 minutes ago, J van E said:

...GSX). The latter is annoying (the window closes before you can choose an option) but there are work arounds.

Yes, this is the only annoying issue in v4.2 I experience. Everything else is fine, like under v4.1.

What workarounds, Jeroen, if I may ask?

Cheers
Frank

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, mdata said:

What workarounds, Jeroen, if I may ask?

First, or those who don't know: the problem is that P3D remembers the last pressed number (above QWERTY) and applies it as soon as you open the SimConnect window. This has as a result that either an option you don't want is selected immediately or the window is closed again immediately. 

Tip 1: do not use the number keys to open a SimConnect window. Either apply a letter key to the command or choose something like control-5 instead of 5.

Tip 2: quite obvious but if you open a window and it is closed again immediately, simply open it once more. The second time it should stay open (but only if you didn't open the window with a number!).

Tip 3: do not use the number keys to select options in the menu but use the mouse instead.

Tip 4: if the window you are going to open has selectabe options that open a new window, simply back up one window.

Tip 5: if the window you are going to open has selectable options that immediately have an effect (like GSX) first enter the number you want to choose before opening the window (in which case you obviously have to know or remember which option has what number): the option will be applied as soon as you open the window.

Well, I think you get the idea: whatever the situation is you should be able to work around the problem somehow by thinking ahead a little. At first I was very confused and thought nothing would work but once you know what is happening exactly, it's pretty easy to work around. I use the ProATC and AS menu's all the time without any real problems.

 

Edited by J van E
  • Upvote 1

Share this post


Link to post
Share on other sites

Buffy

Pardon me for butting in. I see you have the RealAir Duke. I thought it was not available for P3D4. I had it in FSX and would really like to get it back!!!

How do I do that?

Lennie

Share this post


Link to post
Share on other sites

Lennie, if you had bought the P3D version of the RealAIr Duke, there is a installer for P3D v4.x that was made recently, but you have to be a previous owner of their P3D version.

Share this post


Link to post
Share on other sites

Martin

So I only had it in FSX; and not available to me at all now?

Lennie

 

Share this post


Link to post
Share on other sites

Lennie,

Yes unfortunately, that is my understanding. Unlikely RealAir will ever return but you never know?

Martin

Share this post


Link to post
Share on other sites
46 minutes ago, J van E said:

Well, I think you get the idea: whatever the situation is you should be able to work around the problem somehow by thinking ahead a little. At first I was very confused and thought nothing would work but once you know what is happening exactly, it's pretty easy to work around. I use the ProATC and AS menu's all the time without any real problems.

Ah, I see, thank you. I thought of something similar and your explanation confirms it. My trouble started always after asking for taxi clearance from (standard) ATC (which I control with numbers ...) or after switching 2D panels in the iFly 737 ...

I shall be more aware of my key typing in the future until LM are going to fix this issue.

Cheers
Frank

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now