Recommended Posts

OK, this might seem odd, can there be an FPS leak?? Something similar to say a memory leak...

I  did a small 30 min flight last night with PMDG 737 and FlightBeam KIAD.  I departed KIAD went on a short around the D.C. area and then returned back to KIAD, landed and then shut down.  It was at night and with ASN current conditions.  Those included overcast and slight rain.  On the ground FPS high 30's - mid 40's.  In the air, high 40's to mid 50's.  When I woke up this morning the sim was still running, with partly cloudy skies, however, the FPS had dropped to the mid 20's...

I don't expect the sim to run forever with high FPS.  I expect it to change as time goes on, but based on weather, AI, settings etc.  Any thoughts??

· Specs:
o Case: EVGA DG-86 (Average Case Temp 28°C)
o Fans: 5xCorsair PML 140 Pro Led (3 Front Case and 2 Rear Case) and 3xCorsair PML 120 Pro Led (Primary Top Case) / EKWB-Furious Vader EVO 140x 3 and EKWB-Furious Vader EVO 120x 3 (As Back-up)
o CPU: Intel 8700k
o GPU: GB Aorus Xtreme Geforce GTX 1080ti Waterfroce WB
o MB: GB Z370 Aorus Gaming 7 (*Note* the top M.2 slot is not utilized, to avoid turning off the 0 SATA Port)
o RAM: G. SKILL TridentZ RGB 32GB SDRAM DD4 3200 CL14
o Audio Card: Creative SBX AE-5 7.1
o PSU: Thermaltake PS-TPG-1250DPCTUS-T G RGB 1250W
o Storage 1: Samsung 960 EVO M.2 500GB (OS) Windows Home 64bit
o Storage 2: Samsung 960 EVO M.2 500GB (P3D) Prepar3d Academic Vs. I am currently enrolled with Embry Riddle Aero
o Storage 3: WD Black 6TB Performance Desktop HDD (Photo Scenery)
o Storage 4: Samsung 860 Pro 500GB (Other Gaming Drive)
o Storage 5: Samsung 860 Pro 500GB (P3D File and Gaming File Storage)
o Storage 6: Samsung 860 EVO 1TB (Music and Document File Storage)
o Storage 7: WD Black 1TB HDD (Movie File Storage)
o Storage 8: WD Black 1TB HDD (TV Series File Storage)
o BT/Wi-Fi: ASUS PCE-AC55BT
o Lighting Rod: LOGISYS UV Deluxe Sound Activated Cold Cathode
o Lighting Strips: CableMod WideBeam Hybrid LED 60CM RGB (UV with an additional 60CM Extension)
o Cables: CableMod Modmesh Nylon Blue
o Monitor: ASUS ROG Swift PG27VQ OC 165GHz
o Speaker: Creative Katana Sound Bar / Logitech G933 Headset for P3DV4

· Cooling:
o CPU/MB: EKWB FB GA Z370 Gaming RGB Monoblock for both the CPU and MB
o GPU: Pre-Installed WB
o M.2 SSD: EKWB NVMe Blue Heatsink x2
o Coolant: EKWB CryoFuel Blue Premix UV Reactive
o Pump: EKWB-XTOP DDC 3.2 PWM Elite
o Reservoir: EKWB RES X3 250 RGB
o Radiator: EKWB Coolstream XE 360 and EKWB Coolstream CE 420 (For Top and Front Positions)
o Cable: EKWB DuarClear UV with PrimoChill Anti-Kink Coil UV Reactive
o Temp Sensor: Thermaltake Pacific Temp Sensor

· Settings:
o OC Settings:
§ CPU: I7-8700K; (OC to 5.0GHz @ 1.435V, Temp: 40-60C°) Verified Stability
· Core 0-5 set to 50x
· Core Voltage: 1.435V / VCore LLC: Extreme / Core Voltage Mode Adaptive
· AVX Ratio: N/R

§ GPU: Gigabyte Aorus Xtreme Geforce GTX 1080ti WF WB; (OC to 1746GHz, Temp: 30-50C°) Verified Stability
· Aorus Graphic Engine: Set to OC Mode
· GPU Boost Clock 1746MHz
· Memory Clock 11448MHz

§ Memory: G. SKILL TridentZ RGB 32GB SDRAM DD4 3200 CL14;
· OC using XMP Profile 1 

o Nvidia Control Panel:
§ All Default, except;
· Prefer Maximum Performance
· Shader Cache Off 

o Nvidia Inspector: PREPAR3D.exe
§ All Default, except;
· Single Display Performance Mode
· Prefer Maximum Performance
· Shader Cache Off 

o System Sound Settings:
§ Speakers Properties;
· 16-bit, 44100 Hz CD Quality
· Allow applications to take exclusive control of this device: Not Selected
· Communications: Do Nothing Selected

o Logitech G933 Headset:
· Surround Settings Not Utilized Only Stereo Option is Selected

o P3D V4.2
§ Traffic:
· Aviation Traffic: None Selected
· Land and Sea Traffic: Road Vehicles 0%, Ships and Ferries 20% and Leisure Boats 0%
§ Display:
· FXAA: Off
· AA: (Day) 2-8xSSAA or (Night) 8xMSAA All depending on location and conditions
· Texture Filtering: Anisotropic 8X
· Texture Resolution: High 2048x2048
· Autofill Main View: Selected
· Black Out Desktop: Not Selected
· VSync: On
· Trippel Buffering: Selected
· Target Frame Rate: Unlimited
· Wide-view Aspect Ratio: Selected
· Mipmap VC Panels: Selected
§ World:
· Level of Detail Radius: Max
· Tessellation Factor: Ultra
· Mesh Resolution: 5m
· Texture Resolution: 15cm
· Scenery Complexity: Dense
· Autogen Draw Distance: Very High
· Autogen Vegetation Density: Dense
· Autogen Building Density: Dense
· Water Detail: Medium (NO Reflections or Bathymetry)
· Special Effects Aircraft and Distance: Medium
§ Lighting:
· HDR Lighting: Selected
· Dynamic Reflections: Medium
· Dynamic Lighting: Selected
· Landing-lights Illuminate Ground: Selected
· Shadow Quality: Medium
· Shadow Draw Distance: High
· Shadows Cast Selected: Internal Vehicle, External Vehicle, Clouds and Terrain
· Shadows Receive Selected: Internal Vehicle, External Vehicle and Buildings
§ Weather:
· Cloud Draw Distance 60mi
· Cloud Coverage Density: Maximum
· Simple Clouds: Not Selected
· Detailed Clouds: Selected
· Volumetric Fog: Selected
· Detailed Precipitation: Selected
· Windshield Effects: Selected
· Thermal Visualization: Natural
· Enable Turbulence and thermal effects on vehicle: Selected
· Rate at which weather changes over time: No Change

o Active Sky Next:
§ General Options;
· Download Interval: 20 minutes
· Prevent Downloads while on app: Selected
§ Simulator Depiction Options;
· Suppress local weather changes: Selected
· Depict Hurricanes: Not Selected
§ Cloud Options;
· Maximum Cloud Layers: 5
· Maximum Cloud Draw Distance: 120nm
· Multi-Layer Thunderstorm: Not Selected
· Cloud Motion Effect: Selected
§ Visibility Options;
· Enable Wing Fade Effect: Selected
· Fog Layer Generation: Selected
· Maximum Surface Visibility: 75nm
· Maximum Upper Visibility: 199nm
· In Cloud visibility reduction: Selected

o Texture Direct:
§ Configuration Settings;
· Texture Resolution: 1024 for all settings
· Texter Compression Algorithm: DXT5 for all Clouds and 32bit for Wave Animation
· DirectX: DX11 for Sun Effects and Wave Animation DX10 for Water
· P3D Settings: HDR Textures Selected

o SkyForce: Only Cloud Textures are utilized
§ Weather Engine not engaged
· 3D Cloud Texture Resolution 1024x1024 with DXT5 Optimization
· Cirro-Type Cloud Texture Resolution 1024x1024 with DXT5 Optimization
· Moon Texture Resolution 1024x1024 

o UTLive:
§ Configuration Flight Sim;
· Airline Density: 60%
· General Avn: 0%
· Aircraft Contrail Length: 60 Sec
§ Configuration Traffic;
· Target Frame Rate: 30 FPS
· Max Altitude ground aircraft visible: 15,000ft
· Distance to spawn ground aircraft: 15nm
· Maximum aircraft to spawn: 150acft
 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

With P3Dv4.2 I have done very many 4 to 16 hour flights PMDG 777/744 & A2A 172/182.

I have done several Flightbeam KIAD to KMSP to KDEN to KPHX to KSFO to KIAD w/NGX.

Even with quite high settings, Orbx global suite (all vector options too), ASP4 (7 layers out to 199 NM), UT Live (all at 85%), my FPS are locked at 20 FPS and stay about 19-20 FPS for days.

Even this moment I have a totally random flight in the PMDG 736 from EDFH to VIAR 3359nm about 7 hours. 2 1/2 into the flight and 19-20 FPS is steady even over some serious weather (37,000 foot TS) so far.

If there was an FPS leak in version 4.2 somebody would have noticed it long ago.

Share this post


Link to post
2 hours ago, nighthawk65 said:

Lighting Strips: CableMod WideBeam Hybrid LED 60CM RGB (UV with an additional 60CM Extension)

I would suspect these. Can you turn them off and try again?
Or maybe these: Storage 8: WD Black 1TB HDD (TV Series File Storage): What TV series did you store? Some may cause a drop in FPS...

With due respect but what on earth have these specs to do with FS (and FPS for that matter)?

 

Share this post


Link to post
Posted (edited)

I had something "similar" today. 

I`m currently flying from KIAD to LOWW with QW787 suddently without changing anything i had 6 FPS with locked and unlocked frame limiter.  

I was quite wondering because KIAD is P3D default ( plan to purchase the flightbeam one).  I played arround with my settings but nothing helped. 

Because the sky is completly full with clouds i thought maybee it helps to set the cloud coverage density back one step from full right. 

And boooomm 31 FPS locked ?!!  I changed nothing else. 

Interestingly a few minutes later when i completed my preflight checks .... again suddently the frames went down to 6 - 7 FPS.  Back to the cloud coverage density slider and put it back to FULL RIGHT. 

Same effect: from 6 to 28 - 31 FPS locked.  

I´m now in the Air since about  30 min and the frames are constantly at 27-30 FPS locked like i expect them to be. 

Prety strange. 

I use AS16 and ASCA with ENVTEX Textures, ENVSHADE and REX Soft Clouds.  Maybee it has soemthing to do with this combination?

 

brgds

Edited by 331BK

Share this post


Link to post
2 minutes ago, Egbert Drenth said:

I would suspect these. Can you turn them off and try again?
Or maybe these: Storage 8: WD Black 1TB HDD (TV Series File Storage): What TV series did you store? Some may cause a drop in FPS...

With due respect but what on earth have these specs to do with FS (and FPS for that matter)?

 

Currently, they are for storage only for deployments to Afghanistan.  While yes they have nothing to do with flight sim or FPS I was merely trying to ensure all information is available in case there is a problem I haven't even thought off.  Alot of info may not be needed, but better to say how it is vs have to potentially provide it later....

Share this post


Link to post
7 minutes ago, 331BK said:

I had something "similar" today. 

I`m currently flying from KIAD to LOWW with QW787 suddently without changing anything i had 6 FPS with locked and unlocked frame limiter.  

I was quite wondering because KIAD is P3D default ( plan to purchase the flightbeam one).  I played arround with my settings but nothing helped. 

Because the sky is completly full with clouds i thought maybee it helps to set the cloud coverage density back one step from full right. 

And boooomm 31 FPS locked ?!!  I changed nothing else. 

Interestingly a few minutes later when i completed my preflight checks .... again suddently the frames went down to 6 - 7 FPS.  Back to the cloud coverage density slider and put it back to FULL RIGHT. 

Same effect: from 6 to 28 - 31 FPS locked.  

I´m now in the Air since about  30 min and the frames are constantly at 27-30 FPS locked like i expect them to be. 

Prety strange. 

I use AS16 and ASCA with ENVTEX Textures, ENVSHADE and REX Soft Clouds.  Maybee it has soemthing to do with this combination?

 

brgds

I am starting to wonder about the mix of texture related software myself...

Share this post


Link to post

to complete my information: 

7900X @ 4,9 Ghz HT off

Nvidia Titan XP

32 Inch 4K G-Sync Monitor

P3D is running on a Samsung 960 Pro 1 TB M2 SSD 

32 GB DDR4  3200 Mhz  CL14

Share this post


Link to post
2 minutes ago, 331BK said:

to complete my information: 

7900X @ 4,9 Ghz HT off

Nvidia Titan XP

32 Inch 4K G-Sync Monitor

P3D is running on a Samsung 960 Pro 1 TB M2 SSD 

32 GB DDR4  3200 Mhz  CL14

Have you tested with and without HT??  I have not been able to find alot of material to read for the I7-8700k to say whether or not P3D V4.2 with W10 is better or worse with or without HT enabled.

Share this post


Link to post

that`s often system specific. 

For my 10 Core system i get less stutters without HT

Share this post


Link to post
Just now, 331BK said:

that`s often system specific. 

For my 10 Core system i get less stutters without HT

I may have to give that a try and see what happens.

Share this post


Link to post

There's no such thing as an 'FPS leak'! FPS aren't stored anywhere or used to improve anything, and is solely presented to you, as parameter of how your computer is performing a given graphic task. If you're experiencing degrading performance over time, that could be due to a number of reasons. 

But there's no such thing as an 'FPS leak' in the technical sense.

Share this post


Link to post

Exactly so.....what the heck is an "FPS Leak"? I don't know what the problem is but that's not it..........Doug

Share this post


Link to post
7 hours ago, Anders Bermann said:

There's no such thing as an 'FPS leak'! FPS aren't stored anywhere or used to improve anything, and is solely presented to you, as parameter of how your computer is performing a given graphic task. If you're experiencing degrading performance over time, that could be due to a number of reasons. 

But there's no such thing as an 'FPS leak' in the technical sense.

OK so bad word choice.  It was the only way I thought I could describe it...  Basically, I am trying to see if I can figure out or find the culprit to losing FPS over time.  For example, I have tested a variety of aircraft and airports, overnight all day etc.  They all lose FPS which can range from single to double digits and through multiple views.  I don't know if it has something to deal with textures loading and unloading or weather engines etc.  I expect to lose FPS during flight and based on the complexity of aircraft, scenery and environmental conditions.  I would just think that as conditions improve, the FPS returns back to normal.  I have looked into locking FPS either in the sim directly or in NI.  However, I notice that the sim becomes very unstable even with FPS over 20.  I don't know if I am missing a setting somewhere or if it might have a conflict with my monitor.  I am looking for advice and places to look, things to try etc...  I haven't found a whole lot of information on fast monitors with G-Sync.  Speaking with certain people within the community, I have been told that with my CPU+GPU+monitor combined, I should not require a need to either limit the FPS or enable V-Sync with Tripple Buffering.  

Share this post


Link to post

Have you tried to lock FPS at 20?

You may want to turn that NVidia Shader Cache ON as well.

 

Share this post


Link to post

I will give the second idea a try, and I am planning on spending tomorrow with different values of locked FPS.  I am reading through the P3D guide on AVSIm pg.146, trying to understand the table in the page a little better in terms of monitor hz, v-sync and triple buffer etc. 

Share this post


Link to post

Could have been a scan, download or some other process that fired up.

Share this post


Link to post

What Anti-virus software are you using? Have you excluded the P3D and associated folders?

Share this post


Link to post
6 hours ago, n99wb said:

Could have been a scan, download or some other process that fired up.

I have thought of that but ensured that I utili9zed the Avsim P3D install guide to minimize processes and startup programs for only what was essentially needed.  I took it one step further and adjusted AM for all programs removing their ability to utilize either Core 0 and 1, except for Windows or other critical system programs via Process Lasso.  Testing was done one at a time for each process, starting with anything that works with or talks with P3D.  Then moving to other outside programs like Microsoft Office, Google Chrome etc.  I also have windows updates set to manual. 

When using P3D, I keep my Norton antivirus in offline mode.  I also have my firewall and antivirus setup to not scan and exclude any and all folder that either deal with P3D or its associated add-ons, such as ASN, VATSIM, ProkectUK etc.

Kris

Share this post


Link to post
On 6/23/2018 at 3:08 PM, 331BK said:

I had something "similar" today. 

I`m currently flying from KIAD to LOWW with QW787 suddently without changing anything i had 6 FPS with locked and unlocked frame limiter.  

I was quite wondering because KIAD is P3D default ( plan to purchase the flightbeam one).  I played arround with my settings but nothing helped. 

Because the sky is completly full with clouds i thought maybee it helps to set the cloud coverage density back one step from full right. 

And boooomm 31 FPS locked ?!!  I changed nothing else. 

Interestingly a few minutes later when i completed my preflight checks .... again suddently the frames went down to 6 - 7 FPS.  Back to the cloud coverage density slider and put it back to FULL RIGHT. 

Same effect: from 6 to 28 - 31 FPS locked.  

I´m now in the Air since about  30 min and the frames are constantly at 27-30 FPS locked like i expect them to be. 

Prety strange. 

I use AS16 and ASCA with ENVTEX Textures, ENVSHADE and REX Soft Clouds.  Maybee it has soemthing to do with this combination?

 

brgds

I've also been dealing with an issue where flying the NGX, fps locked at 30, pretty much stays around 30 until approach to destination. At some point at or about the time the destination airport loads my fps drop, sometimes as low as 8-10. Happens on day or night flights. The other night I did the same thing and started experimenting with graphics settings, changing one setting at a time to minimum, and nothing had any effect UNTIL I moved the cloud coverage slider from "Maximum" to "Low", and BAM, fps jumped back up to 24-30 and stayed there. As a test, I decided to set it back to Maximum, and interestingly, it had no effect on fps, as it remained at 24-30.

Personally I suspect something with either ActiveSky 4, or Active Sky Cloud Art (ASCA), or possibly ENVTEX, or P3D Tweak Assistant (PTA). I don't use the cloud textures from ENVTEX, only ASCA clouds.

I use Hyper Threading with affinity mask set in P3D.cfg to use cores 0, 2-7. All other apps associated with use of P3D are set to use cores 2,7 as P3D seems to make least use of core 2 on my system.

I am going to try some tests with each of these apps, one at a time, disabled/not running to see if it has any effect.

Share this post


Link to post

Update: I spent literally hours if not days reading through forums, watching videos, and testing and trying different results.

What really took me the most was the following video: https://www.youtube.com/watch?v=p8rc1qm5zks. I know each system is different. While the components may be the same, there are always minute and tiny details within the hardware that can cause a difference. However, I thought it might be small in terms of performance. 

I have now been able to complete multiple flights with multiple settings/software (i.e. aircraft, scenery, support etc.) Now before I go into the next part, I am by no means a computer programmer, I just consider myself better than most. The following is areas that I feel may have a potential issue and finally the end result. Also, I am holding off on the P3D v4.3 update until after supporting software is able to ensure compatibility and any applicable updates that might be required.

1. Navigraph Charts uninstalled completely from system and registry and then re-installed without sim-link. I think it was causing a performance degradation with communication between the host software and the sim.

2. Stopped using AvilaSoft EFB and reverted back to Navigraph Charts for chart information and data but without symlink. I will try and do more testing to see if a problem remains for communication between EFB and P3D. However, I am curious to see how their generation two interacts with P3D.

Was having bad issues with sound stuttering, stopping etc., but no effect with, overall system and sim performance. Essentially I had to try and fly with no sound. Either an issue with PMDG, FS2Crew, P3D or Audio Software/Hardware.

3a. Uninstalled Logitech G933 Headset software, not sure if there is a compatibility issue or not.
3b. Changed audio settings from 16-bit 48000hz DVD quality to 16-bit 44100hz CD quality.
3c. Removed Surround Sound Settings and retuned headset settings to stereo mode. 

Before the last two steps, I was able to monitor both my CPU and GPU. The GPU would remain relatively utilized say anywhere from 40%-60%, while the CPU was hammered on Core 0 which always maintained 100% utilization, while the other cores down to 20%-40% utilization.

4. Purchased SimStarter, built new CFG and Scenery Indexes and cleared Shaders. Adjusted the following lines on the CFG.

[DISPLAY]
TextureMaxLoad=9
TEXTURE_BANDWIDTH_MULT=30

[MAIN]
FIBER_FRAME_TIME_FRACTION=0.12
UseGlobalTerrainView=False

[TERRAIN]
SWAP_WAIT_TIMEOUT=30

No Affinity Mask was utilized; NCP monitor kept at 165hz and Gysnce enabled both in Full-Screen and Windowed Mode; NI set the FPS to 35FPS, Prefer Maximum Performance and Single Monitor (all other settings are default).

5. Utilized Process Lasso to affect both affinity mask and system priority for all applications not required by either the OS, P3D or supporting programs. This, however, had no effect on core utilization.

6. Went into the BIOS to verify system integrity and Overclock. No Change, so I decided to adjust and disable Hyper-Threading. 

7. I utilized the Avsim guide just in case and set Norton to exclude all P3D files, folders, and applications to include supporting programs. I also did a complete system defrag for good measure.

All test utilize 3rd Party Scenery, Aircraft, Weather, ACARS etc. No default software is utilized.

Test 1. Leave the system running for over 12 hours, with high-performance aircraft, scenery, and weather etc. No issue. Only changes to FPS was during intense weather and nighttime dynamic lighting (to be expected) FPS returned back to normal.

Test 2. Utilize PMDG 737 with short-haul flight and photo scenery only from KSFO-DEN. No issues, FPS fluctuated as needed between 30-35FPS.

Test 3. Utilize PMDG 777 from KDEN to KIAD during daytime conditions. No issues, FPS fluctuated as needed between 30-35FPS. However, after landing and during the deboarding stage, the sim just vanished straight to desktop, no CTD, no errors reported either in the P3D error log or within the event viewer in Windows Admin Settings.

Test 4. Utilize PMDG 777 from KSFO to EGLL, starting at dusk, however, the test had to be aborted due to the failure of Stabilizer. During the test, no issues and FPS fluctuated as expected due to the current environment and prevailing conditions.

Test 5. Utilize PMDG 747 from KIAD to EGLL started daytime progressed into the night and landed after dawn. FPS fluctuated as needed between 30-35FPS. 2 x hours later it's still running at EGLL with maintained 35FPS. 

I think I have made significant progress. Although the one area I haven't tested yet is with Autogen back in and ORBX, which I am to work on over the next few days. I also know that certain settings need to be scaled back when required, the system can run everything all at once. But its a start and heading in the right direction. I can do things now that I have never been able to do before.

In all I was able to keep UTlive at 60% commercial and 0%GA, within the sim;
Traffic:
Only Ship Traffic at 20%, all other selections are False or 0%
Display:
FXAA on to help with texturing melding; TFx16; AA set to 8xMSAA night and 8xSSAA day, TR Ultra; No VSync, TB, or WWAR.
World:
Terrain all sliders too far right, no HD res for TT; Scenery Comp Dense, no AutoGen; Water High, no Reflections or Bath, Special Effects High Both.
Lighting:
Dynamic Reflections Medium, Dynamic Lighting on, Landing Lights on, Lens Flare False, Shadows High for both, Shadows Cast (IV, EV, Clouds, and Terrain) Recieve (IV, EV, Buildings)
Weather:
CDD 60miles; CCD Maximum, Detailed Clouds, all other selections selected.

ASN: All selections are default except Upper visibility set to 199.

In the end, not all of this was done at once. Generally, one or two items would change and testing would be done. I think what did it was to disable HT. Since Core 0 has not been at 100% utilization. Just food for thought....

Again I am not a system programmer, I just consider myself better with computers than most. I invite any and all questions, feedback and constructive criticism etc. hopefully this may help others in the long run. I am very curious to see if a future vs. can take advantage of software/hardware...

Side note, almost forgot, audio drivers and system drivers were checked and updated as required. Nvidia drivers were causing their drivers to crash while P3D was running, I had to roll-back to 397.64-desktop-win10-64bit-international-whql as this was the only one stable for me

V/R
Kris
 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now