Nemo

Black autogen textures - advice?

Recommended Posts

I think my system is not too bad, but I am still suffering from black scenery/autogen textures. When I am approaching at congested areas (NY. Miamia, Bacelona ORBX/Aerosoft, ....), I see black textures for quite a while before they get completely loaded. I could not find any setting to make those black textures to disappear faster or even better not to show up at all.

Is this issue more CPU or more GPU dependent? Do I need a better CPU or a better video card. Or is there perhaps a setting that I missed to adjust?

Thanks.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

IIRC, it's GPU dependent.

Try adding the line TextureMaxLoad= under [DISPLAY] in your P3D.cfg file. Put a number there that is a multiple of 3. I use =30 with a GTX 1070 card and I rarely get slow loading textures / black textures.

If putting that entry in doesn't work then your settings are too high for your GPU.

Edited by F737NG

Share this post


Link to post

I think this is an inherent issue by Prepar3d. When I take off form KSFO and fly South into the Silicon Valley, Moffett field, KSJC and San Jose Downtown come up black and stay black for a couple of seconds before getting textures. The same applies if I take off from Niagara and fly into Toronto over Lake Ontario, where the Toronto City center is black for seconds.

TextureMaxLoad is often suggested but does not help on my system, I tried it already. 

I vaguely recall LM having stated in a contribution on their forum there is an issue with black textures and they are investigating it, but this has been long (i.e. several subversions) ago and obviously has been forgotten.

I have given up on this (and a couple of more annoyances) for now.

Kind regards, Michael

Share this post


Link to post
12 hours ago, F737NG said:

IIRC, it's GPU dependent.

Try adding the line TextureMaxLoad= under [DISPLAY] in your P3D.cfg file. Put a number there that is a multiple of 3. I use =30 with a GTX 1070 card and I rarely get slow loading textures / black textures.

If putting that entry in doesn't work then your settings are too high for your GPU.

Thanks, I will try this TML tweak.

Share this post


Link to post
2 hours ago, Nemo said:

Thanks, I will try this TML tweak.

Did you try the TML tweak and any improvement? My systems a bit older and slower memory wise, but I always see some black textures with Orbx, especially downtown LAX and FSDT KLAX! It's fine in low autogen areas.

 

48 minutes ago, ffantasy67 said:

Harry, 

If you have FSDT GSX Level 2 installed, run the latest FSDT update, long topic here:

http://www.fsdreamteam.com/forum/index.php/topic,18564.0.html

problem solved, see here:

https://www.facebook.com/virtualisagl

Cheers,

 

I wonder about what exactly the discovered "bug" was?

Seems like the first update placed a c++ library "update" in the system. This was just the FSDT manager without any GSX 2 installed. The reports were to do with an increased CPU load, rather than a GPU load, which was curious?  When add ons place c++ "updates" in the system, I am always a bit worried.....(previous experience with c++ updates not being 100% with my system?)

Anyway if it's fixed, I guess it's "fixed"!

Regards

David

 

Share this post


Link to post
18 hours ago, F737NG said:

IIRC, it's GPU dependent.

Try adding the line TextureMaxLoad= under [DISPLAY] in your P3D.cfg file. Put a number there that is a multiple of 3. I use =30 with a GTX 1070 card and I rarely get slow loading textures / black textures.

If putting that entry in doesn't work then your settings are too high for your GPU.

It may help but I understood that TextureMaxLoad was perfect for photoreal scenery; from the P3D learning center: 

Quote

 

Non-Default entry. This entry will not exist in your Prepar3D.cfg file by default and must be added to the file.

Performance Tuning Tip:

This can induce stutters. Use multiples of 3 only such as 3, 6, 9, etc. This is perfect for photorealistic scenery

 

The entry in the P3D.cfg file your likely needing is:

TEXTURE_BANDWIDTH_MULT=30

Increasing this number will likely help eliminate the black textures, but can slow FPS and cause stutters. DTG increased this setting to 130 for FSX-SE, and that did not cause any issues across the board that I saw, but FSX has so much less autogen (textures) than P3D potentially has (quantity and distance drawn). In FS9, some (myself included) set this to 400 and there was no delay in texture drawing, but again hi-end CPUs & video cards (for the era) were required.  

https://www.flightsim.com/vbfs/showthread.php?54901-what-is-TEXTURE_BANDWIDTH_MULT

So increasing 30 to something like 40 or 60 or even higher can be tried, but how it affects stuttering and performance is up to ones hardware and other P3D settings. You may find that 43 or 57 will do the trick.

Edited by pracines

Share this post


Link to post
1 hour ago, pracines said:

It may help but I understood that TextureMaxLoad was perfect for photoreal scenery; from the P3D learning center: 

The entry in the P3D.cfg file your likely needing is:

TEXTURE_BANDWIDTH_MULT=30

Increasing this number will likely help eliminate the black textures, but can slow FPS and cause stutters. DTG increased this setting to 130 for FSX-SE, and that did not cause any issues across the board that I saw, but FSX has so much less autogen (textures) then P3D potentially has (quantity and distance drawn). In FS9 some (myself included) set this to 400 and there was no delay in texture drawing, but again hi-end CPUs & video cards (for the era) were required.  

https://www.flightsim.com/vbfs/showthread.php?54901-what-is-TEXTURE_BANDWIDTH_MULT

So increasing 30 to something like 40 or 60 or even higher can be tried, but how it affects stuttering and performance is up to ones hardware and other P3D settings. You may find that 43 or 57 will do the trick.


From Avsim's very own P3D guide:

Quote

TEXTURE_BANDWIDTH_MULT
Section: 
[DISPLAY]
Source: LM – Beau Hollis
Default: 30
Description: The texture bandwidth mult value is used but only takes effect when framerate limiter is enabled. It is set up to define the underlying framerate used to calculate texture load and allocation limits. If you lock to a lower framerate than the value of the texture bandwidth mult, then the texture load allowance will be increased to accommodate for the longer than
necessary GPU frames.

The algorithm is basically this: TextureMaxLoad = max(TextureMaxLoad, TextureMaxLoad*TextureBandwidthMult/LimitedFramerate)

Benefits: Can reduce low quality textures (blurriness).
Detriments: Can induce long frames (stutters).

So, in my case using TEXTURE_BANDWIDTH_MULT=150, I follow the algorithm as follows:
TextureMaxLoad = Max(6, (6*150)/30 [FPS value]), which gives me a TextureMaxLoad value of 30, whereas the default value is 6.

Using 43 in Texture_Bandwidth_Mult causes a problem:
6*43 = 258, which requires FPS to be locked to 3 or 6 for there to be a TextureMaxLoad value that is divisible by 3.

Using 57 in Texture_Bandwidth_Mult could be a problem:
6*57 = 342, which requires FPS to be locked to 3, 6, 9, 18, 57 for there to be a TextureMaxLoad value that is divisible by 3.

Since most simmers like to have a FPS value that matches their monitor refresh rate, I found that on a 1070 card with monitors that can work at 30Hz and a CPU with 8 cores spreading the load, that I can lock at 30 FPS using the tweak values I wrote above to give me textures that load without delay and negligible stuttering.
Using the default values delays textures from loading for me.

As in all cases, YMMV!

Edited by F737NG

Share this post


Link to post
16 minutes ago, F737NG said:


From Avsim's very own P3D guide:

So, in my case using TEXTURE_BANDWIDTH_MULT=150, I follow the algorithm as follows:
TextureMaxLoad = Max(6, (6*150)/30 [FPS value]), which gives me a TextureMaxLoad value of 30, whereas the default value is 6.

Using 43 in Texture_Bandwidth_Mult causes a problem:
6*43 = 258, which requires FPS to be locked to 3 or 6 for there to be a TextureMaxLoad value that is divisible by 3.

Using 57 in Texture_Bandwidth_Mult could be a problem:
6*57 = 342, which requires FPS to be locked to 3, 6, 9, 18, 57 for there to be a TextureMaxLoad value that is divisible by 3.

Since most simmers like to have a FPS value that matches their monitor refresh rate, I found that on a 1070 card with monitors that can work at 30Hz and a CPU with 8 cores spreading the load, that I can lock at 30 FPS using the tweak values I wrote above to give me textures that load without delay and negligible stuttering.
Using the default values delays textures from loading for me.

As in all cases, YMMV!

For even more math and an extremely deep explanation, see:

https://www.simforums.com/forums/fsx-tweaks-demystified_topic37948.html

TextureMaxLoad is not needed in the cfg file, it is recommended (perfect) for products like mega scenery earth (photoreal scenery). 

The black texture issue only needs the bandwidth adjustment.

Share this post


Link to post
54 minutes ago, pracines said:

For even more math and an extremely deep explanation, see:

https://www.simforums.com/forums/fsx-tweaks-demystified_topic37948.html

TextureMaxLoad is not needed in the cfg file, it is recommended (perfect) for products like mega scenery earth (photoreal scenery). 

The black texture issue only needs the bandwidth adjustment.

I don't think it's useful linking to discussions for which settings to use in FS9 and FSX.

Having just repeatedly flown in v4.3 using the default settings, then trying again after changing TEXTURE_BANDWIDTH_MULT to various 'recommended' values, and finally again when using my choices of TEXTURE_BANDWIDTH_MULT=150 and TextureMaxLoad=30, I still find that my combination *works best for me* in keeping black textures / slow loading autogen textures away.

Anyone reading this is well able to do what I do when I see recommended tweaks - that is to try them and if they don't work, bin them.

Share this post


Link to post
2 hours ago, F737NG said:

Anyone reading this is well able to do what I do when I see recommended tweaks - that is to try them and if they don't work, bin them.

Exactly, I was giving an alternative for the OP, and I directly quoted you because what you recommended is contrary to what I know and have known for decades because of others trial and error.

I don't think that your calculations apply to the black texture situation, but since you wanted to bring calculations into the mix, I would present you with calculations that apply to where you were leading this. If you read the post you would find the recommendation to leave texturemaxload out and the reasons why. LM leaves texturemaxload out as a default likely for the same reasons and because photoreal scenery (megascenery earth) is not as popular LC textures (orbx).  

The cfg settings do the same thing in FS9, FSX and P3D, they make work in different degrees or effectiveness but they still do the same thing, so the link applies. 

No doubt there is a misunderstanding/disagreement, the main thing is that the OP issue is solved, I hope our responses can help the OP.

I do not have black texture issues and I do not use the texturemaxload setting. 

 

Share this post


Link to post

Thanks for the discussion. I left the TML tweak alone and tried TBM=150 and it seems that it helps a bit. Black autogen/scenery textures still appear but they disappear faster. Hoping this is not a placebo, I'm going to do some additional testing.

Thank you!

Edited by Nemo

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now