Nigge

40 second lockups at end of long haul 747-8 P3dV4.4

Recommended Posts

Hi, really not sure what the source of this problem is but I'll try.

Yesterday I flew KEWR - EDDK about a 7 hour flight if I remember correctly. first part of the flight was completely fine however just before T/D the sim started to freeze for 30-40 seconds, with the feeling of a CTD being unavoidable however after 40 seconds it came back to life for a couple of seconds and then back to freeze again. did this something like 10 times before I gave up and closed p3d.

This has never happened before. have flown longer routes without any freezes. The thing that has changed is that I have updated P3d to version 4.4  and updated the 747-8 to the latest version.

Just wanted to know if anybody else has seen this behaviour? 

I have not changed any settings as automatic save or anything so thats most likely not the problem.

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This is quite a common thing unfortunately, it's referred to often as a 'long frame' where the simulator appears to crash but is actually functioning.. It's most frustrating when it happens on short final.  I don't know the cause, I had always assumed it was to do with how P3D handles the caching / loading of scenery.  Not a lot that can be done about it I am afraid other than remove all scenery from the sim or wait for the problem to be tackled by LM (assuming that's where the problem lies).

Apologies that's not much help, but you're not the only one, this happens to me a lot too, I just 'ignore' it the best I can.

Share this post


Link to post

Hi Craig, thanks for your reply.

I dont think this is the same issue, perhaps related though... The problem was that the freezes kept happening with like 10 seconds interval... so running for 10 seconds, then freeze for 40 seconds, then running fine for 10 seconds then freeze.. so it was not a one time thing...

Share this post


Link to post
1 hour ago, Nigge said:

Hi Craig, thanks for your reply.

I dont think this is the same issue, perhaps related though... The problem was that the freezes kept happening with like 10 seconds interval... so running for 10 seconds, then freeze for 40 seconds, then running fine for 10 seconds then freeze.. so it was not a one time thing...

Are you 100% sure nothing changed regarding Automatic save? For example I installed a new version of the Acars for my VA and the settings reverted back to the default where it has Autosave enabled and could see the behavior you are describing. Removed Autosave and problem fixed

Share this post


Link to post
45 minutes ago, Olympic260 said:

Are you 100% sure nothing changed regarding Automatic save? For example I installed a new version of the Acars for my VA and the settings reverted back to the default where it has Autosave enabled and could see the behavior you are describing. Removed Autosave and problem fixed

Thanks, No Im not 100% sure, however this is something that I have never had enabled so I would be surprised. But sometimes life is surprising;-) I will definately check this.

Share this post


Link to post

Specifically I have flown the newest version of the 748 from Orbx YMML to Flightbeam KSFO (about 16 hours), with several add-ons running (ASP4, UTL 85%, STB, GSX, RC4, NAV Charts, Orbx global ect...), very high P3D 4.4 settings, locked at 20 FPS. I had no performance issues...smooth the whole way.

I never specifically have had this kind of issue (30-40 second freezes) in P3D or FSX.

I personally did a full clean install of 4.4 and reinstalled all add-ons, as is my custom.

 

 

 

Share this post


Link to post
26 minutes ago, pracines said:

Specifically I have flown the newest version of the 748 from Orbx YMML to Flightbeam KSFO (about 16 hours), with several add-ons running (ASP4, UTL 85%, STB, GSX, RC4, NAV Charts, Orbx global ect...), very high P3D 4.4 settings, locked at 20 FPS. I had no performance issues...smooth the whole way.

 

2

Paul,

If you don't mind, what are the p3d.cfg, and nvidia settings that will allow 20 FPS "smooth the whole way"?

Would you be so kind and share those settings, please. 

Share this post


Link to post
5 hours ago, Olympic260 said:

Are you 100% sure nothing changed regarding Automatic save? For example I installed a new version of the Acars for my VA and the settings reverted back to the default where it has Autosave enabled and could see the behavior you are describing. Removed Autosave and problem fixed

Hi, Where is this setting at?

Share this post


Link to post
3 minutes ago, rfelger said:

Hi, Where is this setting at?

FSUIPC Settings Panel - AutoSave / GPSOut tab. Top left.

Share this post


Link to post
15 minutes ago, scandinavian13 said:

FSUIPC Settings Panel - AutoSave / GPSOut tab. Top left.

Thanks Kyle, however I'm not using the registered version of FSUIPC so I don't have that menu, there is a button for "normal defaults". Is the Auotsave function enabled in the unregistered version?

 

Thanks,

Share this post


Link to post
1 minute ago, rfelger said:

Is the Auotsave function enabled in the unregistered version?

Not to my knowledge.

Share this post


Link to post
4 minutes ago, scandinavian13 said:

Not to my knowledge.

Ok, thanks for the info Kyle, much appreciated.

Share this post


Link to post
3 hours ago, killthespam said:

Paul,

If you don't mind, what are the p3d.cfg, and nvidia settings that will allow 20 FPS "smooth the whole way"?

Would you be so kind and share those settings, please. 

I cannot imagine why you would be asking me this, your system is much more powerful! You should be able to keep a steady 30 FPS, perhaps 60.

Just so you know, I have been computing since the very early days, and I have had like 14 PC systems, maybe more, as I give them away too. I have many older systems running even now. I say this because I know how to keep a very clean and efficient machine, I learned the hard way long ago. I bought my first PC for the sole reason to fly MSFS version 3. I saw the FS3 demo at a Radio Shack store and I was determined. 

I'm not claiming to be a "guru", but you will only rarely ( probably never) see me here or anywhere with troubles of my own because of my PC's. I learn from others successes and mistakes. Researching through decades of trial and error.

Using my cfg or NV settings may or may not help you, because there are a myriad of other system (Windows & BIOS) settings, add-on settings, system utilities, and others that can play a part in P3D performance. A book would have to be written to cover it all. Never-the-less my settings you requested, I truly hope it helps you:  

My Nvidia CP is default except for Max rendered frames at 4 and Power Management Mode at Prefer Maximum 

Here is my P3D 4.4 CFG:

[GRAPHICS]
SCREEN_CAPTURE_MAX_JOBS=10
VIDEO_CAPTURE_WIDTH=720
VIDEO_CAPTURE_HEIGHT=480
VIDEO_CAPTURE_FPS=30
VIDEO_CAPTURE_BIT_RATE=3200000
VIDEO_CAPTURE_IS_THREADED=True
VIDEO_CAPTURE_INFO_SEND_RATE=20
VIDEO_CAPTURE_MAX_FRAME_SIZE=500000
VIDEO_CAPTURE_TTL=255
HDR_BRIGHTNESS=1.100000
HDR_BLOOM_THRESHOLD=3.000000
HDR_BLOOM_MAGNITUDE=0.440000
HDR_BLOOM_BLUR_SIGMA=0.800000
TONEMAP_DAY_EXPOSURE_KEY=0.280000
TONEMAP_NIGHT_EXPOSURE_KEY=0.230000
HDR_SATURATION=0.800000
MAX_POINT_LIGHTS=250
MAX_SPOT_LIGHTS=250
RS_MIN_OBJECT_PIXEL_RADIUS=2.000000
MAX_TEXTURE_REQUEST_DISTANCE=1000.000000
ViewGroup_Number=-1
MAP_DRAW_THREADED=1
TEXTURE_MAX_LOAD=2048
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=1
DYNAMIC_LIGHTING=1
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=1
DYNAMIC_REFLECTIONS=0
SHADOW_QUALITY=4
SHADOW_DRAW_DISTANCE=3
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=1
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=1
CLOUD_SHADOWS_CAST=1
PARTICLES_SHADOWS_CAST=0
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=1
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
OPAQUE_SHADOW_TEXTURE_SIZE=2048
TRANSLUCENT_SHADOW_TEXTURE_SIZE=512
OPAQUE_SHADOW_DRAW_DISTANCE=2000
TRANSLUCENT_SHADOW_DRAW_DISTANCE=2000
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=1
EFFECTS_DISTANCE=1
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
MOON_PHASE_LIGHTING=True
See_Self=1
Text_Scroll=1
DYNAMIC_INTERIOR_CAPTURE=False
MIPMAP_VC_PANELS=1

[WEATHER]
CLOUD_FACING_MODE=0
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=0
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=8
DETAILED_CLOUDS=1
OPTIMIZE_DENSE_CLOUDS=1
CLOUD_COVERAGE_DENSITY=8
THERMAL_VISUALS=0
VolumetricFog=0
DetailedPrecipitation=1
WindshieldPrecipitationEffects=1

[DISPLAY]
ChangeTime=2.000000
TransitionTime=2.000000
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperLeftTextColorUser=255,0,0
InfoUpperLeftTextColorNonUser=255,127,0
InfoUpperLeftBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
InfoWeaponSystemEnable=True
InfoCountermeasureEnable=True
InfoUpperRightTextEnable=True
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=90
UPPER_FRAMERATE_LIMIT=20
WideViewAspect=True
FullScreenBackground=False
FullScreenAutoFill=True
Fullscreen=True
TEXTURE_FILTERING=16
MSAA=4
SSAA=0
VSYNC=1
FXAA=0
TRIPLE_BUFFER=1

[SCENERY]
SmallPartRejectRadius=1
AUTOGEN_DRAW_DISTANCE=24000.000000
AUTOGEN_TREE_DRAW_DISTANCE_PERCENT=0.900000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
SCENERY_DRAW_DISTANCE=53333.335938
MaxRegionsPurgePerFrame=16
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
IMAGE_COMPLEXITY=5
AUTOGEN_VEGETATION_TYPE=0

[MAIN]
FIBER_FRAME_TIME_FRACTION=0.08
User Objects=Airplane, Helicopter, Submersible, ExternalSim, Avatar
LabelsSupported=Airplane, Helicopter
Location=0,0,1920,1080,\\.\DISPLAY1
Maximized=1
ShowInfoText=1
HideMenuNormal=0
HideMenuFullscreen=1
LocationFullScreen=0,0,1920,1080,\\.\DISPLAY1

[PANELS]
IMAGE_QUALITY=1
SAVE_AND_LOAD_PANEL_STATE=0
MAX_VC_TEXTURE_RESOLUTION=4096
PANEL_OPACITY=100
QUICKTIPS=0
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
PANELS_ALWAYS_ON_TOP=1

[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
force_master_enabled=0

[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6

[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
HealthPoints=1,5

[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
HealthPoints=2,5

[SlewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5

[SlewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
HealthPoints=1,3

[SlewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
HealthPoints=2,3

[Avatar]
DefaultAvatar=Army Infantry

[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000

[VirtualCopilot]
VirtualCopilotActive=0

[USERINTERFACE]
SHOW_SCENARIO_WINDOW=1
SHOW_MISSION_CAPTIONS=1
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
RestoreTimeOnMove=1
ScreenshotImageFormat=2
ShowMessageText=True
Map_Orientation=2
BroadcastGPSData=0
MUTE_ON_LOST_FOCUS=0
SITUATION=C:\Users\paul_\Documents\Prepar3D v4 Files\START

[PointOfInterestSystem]
CycleSetting=0

[SOUND]
PrimaryPlaybackDevice={644CB5BC-FE21-4C8E-B8F6-32431EFE39D0}
VoicePlaybackDevice={A2A668A2-DF47-4F88-ADD4-9F17E20947F0}
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
SOUND_FADER1=0.500000
SOUND_FADER2=0.500000
SOUND_FADER3=0.500000
SOUND_FADER4=1.000000

[TrafficManager]
AirlineDensity=0
GADensity=0
FreewayDensity=20
ShipsAndFerriesDensity=100
LeisureBoatsDensity=20
IFROnly=0
AIRPORT_SCENERY_DENSITY=0

[AContain]
ShowLabels=0
ShowUserLabel=0
ShowLabelManufacturer=0
ShowLabelModel=0
ShowLabelTailNumber=0
ShowLabelDistance=0
ShowLabelAltitude=0
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
EnableRibbonVisuals=0
ShowRibbonUserObject=0
ShowRibbonUserAvatar=0
ShowRibbonAircraft=0
ShowRibbonGroundVehicles=0
ShowRibbonBoats=0
ShowRibbonAvatars=0
ShowRibbonWeapons=0
ShowRibbonCountermeasures=0
UserObjectRibbonColor=FFFF0000
UserAvatarRibbonColor=FFFF8000
AircraftRibbonColor=FF0000FF
GroundVehicleRibbonColor=FF00FF00
BoatRibbonColor=FF00FFFF
AvatarRibbonColor=FFFFFF00
WeaponRibbonColor=FF800000
CountermeasureRibbonColor=FF640080
RibbonFidelity=5.000000
RibbonMaxDistance=3218.689941

[TERRAIN]
LOD_RADIUS=5.500000
TESSELLATION_FACTOR=90
MESH_RESOLUTION=23
TEXTURE_RESOLUTION=25
AUTOGEN_VEGETATION_DENSITY=4
AUTOGEN_BUILDING_DENSITY=4
DETAIL_TEXTURE=1
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
WATER_REFLECT_CLOUDS=0
WATER_REFLECT_USERAIRCRAFT=0
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_USERAIRCRAFT=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_AUTOGEN_BUILDINGS=0
ENABLE_BATHYMETRY=0
WATER_CLARITY=30
WATER_DETAIL=0
UseGlobalTerrainView=False

[ATC]
AutoOpenAirTrafficWindow=1
UsePilotVoice=1
ShowATCText=0
PilotVoice=0
COMM_MSG_AI_ATC_COLOR=0XFF8C00
COMM_MSG_ATC_AI_COLOR=0X00008B
COMM_MSG_ATC_USER_COLOR=0X006400
COMM_MSG_USER_ATC_COLOR=0XA52A2A
COMM_MSG_ATIS_COLOR=00000000

[INTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0

[REALISM]
PFactor=0.500000
Torque=0.500000
GyroEffect=1.000000
CrashTolerance=1.000000
General=1.000000
UnlimitedFuel=False
AllowEngineDamage=False
TrueAirspeed=False
AutoCoord=False
RealMixture=True
StressDamage=True
GEffect=True
ManualLights=True
GyroDrift=False
CrashWithDyn=True
CrashDetection=False
AvatarNoCollision=False
OnCrashAction=0
MomentumEffect=True

[ATTACHMENTS]
WeaponHighlight=False
HighlightDuration=1.000000
AutoWeaponSwitching=False
UnlimitedWeapons=False
UnlimitedCountermeasures=False
IgnoreAttachmentWeight=True
IgnoreAttachmentForces=True

[RECORDER]
RecordAITraffic=True
RecordAirportVehicles=True
RecordLeisureBoats=True

[SIM]
SYSCLOCK=0
OPTIMIZE_PARTS=1

[STARTUP]
DEMO=0
STARTUP_DEMO=
LOAD_SCENARIO_TOOLS=1
LoadCorePlugins=1
LoadVirtualReality=1
EnableVirtualRealityOnStartup=0
EnableVoiceControl=0
EnableVoiceControlDebug=0
LoadWindow=1

[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=4096

[MISC]
Com_Rate=7

[DISPLAY.Device.NVIDIA GeForce GTX 980.0.0]
Mode=1920x1080x32

[DISPLAY.Device.NVIDIA GeForce GTX 980.0.1]
Mode=1920x1200x32

[FlightPlanMap]
LineWidth=2

[MULTIPLAYER]
VoiceVolume=2.000000
FrameSyncRate=0
 

 

Share this post


Link to post

Thank you Paul,

The reasoning behind is that if I lock my FPS at 30 I get stutters with complex airplanes. In this way I can compare with what I have.

For example with FsLabs and PMDG if I set for 30 FPS I'm hit with stutters versus unlimited where I have none.

Share this post


Link to post
13 minutes ago, killthespam said:

The reasoning behind is that if I lock my FPS at 30 I get stutters with complex airplanes. In this way I can compare with what I have.

For example with FsLabs and PMDG if I set for 30 FPS I'm hit with stutters versus unlimited where I have none.

I've also always had struggles with smoothness when setting a specific TFR in MSFS/P3D. 

Running with TFR unlimited and frame rates limited by VSync to a 30 Hz monitor has been the magic pill for me for the last several years, starting with P3D v3.

Regards

 

Share this post


Link to post

I don't think stutters or jerky animation is related to long frames.  I've convinced myself by observing that most long frames are due to loading scenery objects.  Objects such as terminal buildings and other structures that are not autogen objects or stuff from the default libraries.  I know that these scenery objects are loaded by P3D in a single thread in core 0  based on various comments and explanations from others much more qualified than I.  Were the rendering engine use multithreaded code this problem would be solved.  I hope that LM has this in the works for v5.

I've notice that my Process Explorer indicates unusually high I/O activity during long frames, and that this I/O activity is not disc drive activity.  I'm trying to learn more about what this means.  I/O is defined in the Process Explorer documentation to be drive or device I/0 and not console activity (console take to be the keyboard/display?) so if it's not the drive or video then what is all that activity.  I don't know yet.

Share this post


Link to post
2 hours ago, w6kd said:

Running with TFR unlimited and frame rates limited by VSync to a 30 Hz monitor has been the magic pill for me for the last several years, starting with P3D v3.

 

 

Thank you Bob, that's what I have. I was more interested to do a 30 FPS locked based on what Rob A was showing on a video regarding ground autogen loading issue. 

Share this post


Link to post

I've had this happen once or twice in the past too. Make sure a few things:

don't minimize your sim over a longer time. You can run it in the background just fine, but don't keep in minimized. independent from your computer's or NVIDIA energy settings this will take priority from the sim and can shut the video card down. No chance to get the sim back on the video card once this has happened, you'd have to restart it. You normally should still be able to save though.

Make sure your video card and power supply are clean. Heat from a high load can spool them up. 

Share this post


Link to post
On 1/10/2019 at 10:47 PM, Ephedrin said:

I've had this happen once or twice in the past too. Make sure a few things:

don't minimize your sim over a longer time. You can run it in the background just fine, but don't keep in minimized. independent from your computer's or NVIDIA energy settings this will take priority from the sim and can shut the video card down. No chance to get the sim back on the video card once this has happened, you'd have to restart it. You normally should still be able to save though.

Make sure your video card and power supply are clean. Heat from a high load can spool them up. 

Agree with you, minimize p3D while it is running => 90 % CTD or dxgi_error_device_hung nvidia eror

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now