cobrakev1526

What is the best Nvidia driver version for VR?

Recommended Posts

 This is just a general question because I have been experimenting with different settings trying to eliminate ghost juddering with my oculus rift. Everybody keeps telling me to go with the latest and Nvidia drivers, However there is a negative performance and stability issues with the VR  just by getting the latest drivers.  At least that’s what I have found. So far the best driver I have found that works 80 to 95% of the time is version 388.31. I am running an Nvidia GTX 1080 TI and Core I7 8700k hyperthreading off a 5 ghz.  I have used both the oculus core 2.0 public data and the release versions both run the same. I have found that using the latest 400 series drivers from Nvidia causes instant ghost juddering.  I even tested this with the 400 series with all sliders to the left in P3D 4.4.  So I started my computer up in safe mode and do used  Display driver UnInstaller and then reinstalled still in safe mode version 388.31. I was able to fly to A2A Bonanza  from LAX to Catalina Island then to Santa Barbara to Palm Springs and back to LAX with no VR issues. Needless to say I had a big ring around my face but I also had a big smile too. I think that version 388.31 is the best driver for VR.

 

 Anyways what are your thoughts on driver versions and VR set ups. Currently in my settings are normal for autogen And I have my world details slider on the very top set to medium because Lockheed Martin has a bug with the simulator using a single pass. You can find that topic on the P 3-D forums at Lockheed Martin right here...

http://www.prepar3d.com/forum/viewtopic.php?f=6306&t=130505

Edited by cobrakev1526

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Interesting read, I'm curious as to what other peoples results are.

I still havent been able to get P3D usable in VR for me. I'm primarily using xplane. I get too many stutters in P3D in VR. Admittedly I havent spent long triyng to get it work as the lack of touch control compatibility is pants.

Share this post


Link to post
Share on other sites

Honestly juddering is usually a sign of the settings probably being too high.

Share this post


Link to post
Share on other sites

Can see juddering if asw is on, hence for p3d I turn off asw.

 

Share this post


Link to post
Share on other sites

Yes I messed with ASW using the oculus tray tool and set my ASW  to force Lock at 45fps. 

2 hours ago, HiFlyer said:

Honestly juddering is usually a sign of the settings probably being too high.

As I said I tested a 5ghz with all sliders to the left and I was getting over 100 FPS in sim and still got ghost juddering using the lates 400 series of Nvidia drivers. This also happens in other titles such  as project cars 2. Even flyinside had massive ghost juddering using the latest drivers.  I’ve also noticed using the performance heads up display for oculus that when these ghost judders Start happening the compositor starts reading massive frame rate increases but that’s what’s causing the juddering some how. The frame  start dropping off like crazy in the hud to.  My problem is I don’t understand the technology or the terms used in VR  so I’m kind of making this up as I go trying to do the best I can to explain what I’ve seen and how I fixed it. 

Edited by cobrakev1526

Share this post


Link to post
Share on other sites
17 minutes ago, HiFlyer said:

Thanks this is very useful reading and is helping me figure things out. I was suspect of some of the Nvidia drivers.

Share this post


Link to post
Share on other sites
Quote

but the HUGE problem is in the Compositor Frame Drops: It's 3 (0.05%) versus 108 (1.74%). And this REALLY makes the experience unbearable. Compositor frame drops are frames that drop as a result of the Rift not properly functioning as opposed to frame drops due to performance hunger.

Wow this is what happens in p3d when the juddering starts. The compositor starts dropping frames like crazy and start ghost judders. Like I said I’ve tested driver 388.31 and this is the most stable driver for p3d in my experience.

 

funny thing is when I exit p3d and go to oculus home it’s still ghost juddering. However in p3d if I take the rift off my head and place it on the floor for 10 seconds and then put it on again I t fixes the problem sometimes, but usually starts ghosting very soon after. 

Quote

CONCLUSION: Current Nvidia drivers are HEAVILY broken for Oculus use and it's wise to use older drivers. However, the December 388.59 doesn't do it for us neither and we had to roll back all the way to 384.94 (released July 2017) for acceptable performance. Being developers ourselves, it's totally beyond us, how such an easy to reproduce misbehaviour wasn't already fixed months ago. With all the complaints on the first few pages of this board alone, Nvidia really seems to be either word not allowed or too incompetent, to release actually working drivers for the Rift.

 

Edited by cobrakev1526

Share this post


Link to post
Share on other sites
On 1/21/2019 at 7:44 PM, cobrakev1526 said:

Wow this is what happens in p3d when the juddering starts. The compositor starts dropping frames like crazy and start ghost judders. Like I said I’ve tested driver 388.31 and this is the most stable driver for p3d in my experience.

 

funny thing is when I exit p3d and go to oculus home it’s still ghost juddering. However in p3d if I take the rift off my head and place it on the floor for 10 seconds and then put it on again I t fixes the problem sometimes, but usually starts ghosting very soon after. 

 

 

Yes you are on to something because Helix has hinted at the same with FSX/Flyinside

 

As a data point, I think this can work, but there is of course a lot of complexity. Looking into this problem, it seems fairly clear that the latest Nvidia drivers have damaged this scenario. I DDUed back to the 388 branch, 388.71, last known good branch. My system: 8700K, 1080ti, Win10 1803, 16G, 900p boot drive. Oculus Rift. Clean reinstall of FSX and FlyInside to boot drive. Default settings for both. 3D Vision disabled.

With this high end setup, I'm getting good results. No frame drops like above, and I don't see any stutter when flying close to the ground. Nothing I would call microstutter. I use the Oculus Debug Tool to show the performance monitor, and there are no lost frames counted, and something like 90% headroom available.

Your mileage will of course vary, but I think it's important to note that this can work. Maybe try to match this setup as close as possible. Starting with a known good spot and tweaking it, is superior to hitting a lot of options and trying to get it back to functional.

Most important piece seems to be the video driver.

I think maybe I see what you are seeing. Hard to describe, but it's not what we would normally call microstutter. Maybe stutter is the best description. It looks like the ground has a lower frame rate than aircraft or headset, and makes little jumps instead of being smooth. Like each frame jumps ahead by 3 feet when looking to the side.

I'm not sure how to see FSX frame rate itself. I'm not seeing dropped frames at all in Rift, and the headset is clearly running at a full 90Hz. I'm just not sure the game actually is. If I enable the frame rate indicator in 2D, it seems like it has plenty of headroom, but visually it looks like FSX is dropping frames.

I can dramatically improve this by setting game frame rate to 45 or 90. Infinite does not work very well, that seems to set up a beat frequency between the headset and the game, which is maybe where the stutter comes from. Not flawless at 45, still occasional stutters, but not like a standing wave.

Edited by blueshark747

Share this post


Link to post
Share on other sites

I have exactly this 

upgraded to rtx 2080and still does it

 

Share this post


Link to post
Share on other sites

Welp looks like im too far down the Windows 10 rabbit hole to even try that old of a driver....

Goodbye forever then....FSX

etdsub.png

Edited by blueshark747

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now