Jump to content

Recommended Posts

I think whenever I turn on ground shadows I get these horrid jaggies on the planes.  Does anyone else see this?  Is there a fix?

This is with the latest XP11.30

Aerostar_2_1.png

Share this post


Link to post
Share on other sites

Hi Ryan, you can try do some search shadow fix plugin in org forum, i forgot what is real name, recently i download the file and it fix my jaggy shadow issue, it a plugin not lua script if i am not mistaken.

Share this post


Link to post
Share on other sites

This always bugged me. 

The jaggies become worse as the sun gets lower in the sky.

Nice to know there is a work around.

 

Thanks for the info,  Muhamad.

 

Stu

Share this post


Link to post
Share on other sites

sorry my mistake, it is lua script, not plugin, i confuse with fpm plugin. the lua script is shadow.lua in x plane forum

Share this post


Link to post
Share on other sites

A good system, not a beefy system.

At least Laminar should make an option to have unjagged shadows fot those who have a good system.

Edited by Simicro

Share this post


Link to post
Share on other sites

I don't think it's that

Ground shadows OFF the jaggies go away on the aircraft.  Ground shadows ON gives me the jaggy shadows.

Plus the machine I'm using is Linux with a 7700K and GTX 1070 ti 16gb ram

Share this post


Link to post
Share on other sites

I agree with Paul above, that what you're probably seeing is the sim trying its best to show you both ground shadows and plane shadows, and your rig just isn't able to do both equally smoothly and anti-aliased. 

Ground shadows are a major performance hog. My rig isn't enough to run them. You need seriously beefy hardware to do it, especially if you're running a monitor res higher than 1080p.

Share this post


Link to post
Share on other sites
8 hours ago, Simicro said:

A good system, not a beefy system.

At least Laminar should make an option to have unjagged shadows fot those who have a good system.

Laminar does that very well for plane exterior and cockpit shadows. But ground shadows are a whole different proposition. Look at a forest, and every tree will have its own shadow! That's a massive hit on your hardware.

Share this post


Link to post
Share on other sites
On 1/30/2019 at 8:37 PM, ryanbatcund said:

I think whenever I turn on ground shadows I get these horrid jaggies on the planes.  Does anyone else see this?  Is there a fix?

This is with the latest XP11.30

Aerostar_2_1.png

Play with your AA settings.  I maxed mine and the jaggies went away.  Also turn off ground shadows, for some reason ground shadows caused jaggies for me.

John

Share this post


Link to post
Share on other sites
9 minutes ago, flyingcheese said:

Don't look at the plane from the outside?

Lawl

Share this post


Link to post
Share on other sites
On 2/8/2019 at 10:49 PM, ryanbatcund said:

That's the whole point...this only happens when ground shadows are on.

Hi Ryan,

It is just speculation but maybe there is a bug indeed, or just that there is a single shadow map, therefore, when using both ground and aircraft the single shadow map has to 'bake' a wider area than when just baking the aircraft shadows alone, thus, the shadow map resolution gets lower and the jaggies show up.

Share this post


Link to post
Share on other sites

I found this handy guide that helped me fix my shadows- you have to edit some datarefs within XP to do so but it's not too hard.

https://forum.thresholdx.net/topic/187-a-decent-guide-to-crisp-shadows/

If you do not want to create a script as the link describes, there is a dataref editor plugin that you can install which allows you to edit datarefs from within XP.

The ones I find myself tweaking the most are:

  • sim/private/controls/shadow/csm_split_interior
  • sim/private/controls/shadow/csm_split_exterior

and

  • sim/private/controls/shadow/cockpit_near_adjust
  • sim/private/controls/shadow/cockpit_near_proxy

The first two are persistent- once you change the setting it will hold. csm_split_exterior is the one you want to adjust for your exterior shadows. Valid input is 1 through 4, with higher numbers increasing the resolution. I believe csm_split_interior is how the shadows on the exterior are viewed from the within the cockpit, but don't quote me on that.

The second two are not persistent, and you will have to edit these every time you start XP unless you create a script to do so for you. The link I shared will show you how to create that plugin. cockpit_near_adjust is the shadows inside the cockpit in your immediate vicinity, and I find that a value of 2 usually does the trick. In the case of cockpit_near_proxy, a lower value is preferred and I typically set mine between 0.2 and 0.5.

 

edit: the comments regarding dataref persistence only applies if you're using the dataref editor plugin. if you create the script to edit the datarefs for you, they'll always be applied when you start XP.

Edited by mcphatty
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

Are you by chance using XVision (Impressive preset) using the FlyWithLua script?  If so, open up 11_30_xV_Impressive.lua in the FlyWithLua\Scripts folder and find the following line:

set("sim/private/controls/fbo/shadow_cam_size" , 2048.0)  --jagged shadows

Disable this line by placing two hyphens in front of it:

-- set("sim/private/controls/fbo/shadow_cam_size" , 2048.0)  --jagged shadows

That line sets shadows at very low resolution.  For all the good it does with shaders, Xvision can also introduce unwanted "features" too.  It took me weeks to determine that the SharpernBlurring post-processing effect was killing all my MSAA anti-aliasing.

Edited by MadDog

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...