Anshu

Stuttering every few seconds

Recommended Posts

Posted (edited)

P3Dv4.3, ORBX FTX Global, Vector, Active Sky, FSlabs a320.

I am experiencing a stutter at regular intervals (every 2 seconds or so). I have tried pretty much everything to get rid of it... but i still have no luck. The stuttering is mostly noticeable when making sharp turns.

Any help would be greatly appreciated.

 

 

Edited by anshugiri

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

1 hour ago, anshugiri said:

P3Dv4.3, ORBX FTX Global, Vector, Active Sky, FSlabs a320.

I am experiencing a stutter at regular intervals (every 2 seconds or so). I have tried pretty much everything to get rid of it... but i still have no luck. The stuttering is mostly noticeable when making sharp turns.

Any help would be greatly appreciated.

 

 

A little more information would be helpful.  System specs, monitor refresh rate, and sim settings.  I suspect a vsync/refresh rate issue if you notice it most when turning.

Share this post


Link to post
Posted (edited)
1 hour ago, anshugiri said:

I am experiencing a stutter at regular intervals (every 2 seconds or so). I have tried pretty much everything to get rid of it... but i still have no luck. The stuttering is mostly noticeable when making sharp turns.

Any help would be greatly appreciated.

@anshugiri I have posted about a similar issue in the past few weeks. In my case the sim exhibited a regular slight single stutter every 3 seconds. It was barely noticeable but sufficient to destroy that sense of immersion we are all seeking.

This regular stutter was also visible in Slew mode while stationary on the ground and a slow 360 degree turn was started. I used to use this test to check for the presence of the stutter at the beginning of a session. Lately it hasn’t been necessary as this stutter appears to have resolved spontaneously! Fingers crossed.

I never found the cause, but did discover I could get banish it for the duration of a single simming session by simply rebooting. Restarting Prepar3D was not enough; the regular stutter would persist. A warm or, preferably, cold reboot provided the solution. Might be worth a try.

Regards,

Mike

Edited by Cruachan
  • Like 1

Share this post


Link to post
7 minutes ago, mpw8679 said:

A little more information would be helpful.  System specs, monitor refresh rate, and sim settings.  I suspect a vsync/refresh rate issue if you notice it most when turning.

8600k at 5.0, RTX 2080, Samsung 850 EVO, 16GB Ram, monitor refresh 30 hz.

Share this post


Link to post
Posted (edited)

Sounds like anti-virus scanning could be the cause here. 

Add an exception to the FS folder, or disable AV when you are flying. 

OR

If you have FSUIPC, see if it is autosaving, disable if needed. 

 

Edited by Jude Bradley

Share this post


Link to post

If you have not done so, try enabling write caching on the drive(s) where Windows and P3D are installed.

Doug

Share this post


Link to post
1 hour ago, ddawson said:

If you have not done so, try enabling write caching on the drive(s) where Windows and P3D are installed.

Doug

In a related measure, I set my sim machines up to disable last access file stamping, so that a write doesn't occur every time a file is read.

From an administrator-elevated command window type: fsutil behavior set disablelastaccess 1

This works with Win 7 through Win 10, perhaps with others.

Regards

 

  • Like 1

Share this post


Link to post
3 hours ago, Jude Bradley said:

Sounds like anti-virus scanning could be the cause here. 

Add an exception to the FS folder, or disable AV when you are flying. 

OR

If you have FSUIPC, see if it is autosaving, disable if needed. 

 

Tried all of your suggestions... but the problem still persists.

Share this post


Link to post
2 hours ago, ddawson said:

If you have not done so, try enabling write caching on the drive(s) where Windows and P3D are installed.

Doug

Write cache is enabled.

Share this post


Link to post
Posted (edited)

Delete the following file.....

  • Local Disk (C:) > Users > You > AppData > Roaming > Lockheed Martin > Prepar3D v4 > Prepar3D.cfg

Delete all files in the following folders......

  • Local Disk (C:) > Users > You > AppData > Local > Lockheed Martin > Prepar3D v4 > Shaders
  • Local Disk (C:) > Program Data > Lockheed Martin > Prepar3D v4 > Scenery Indexes x64 >

These are all hidden files, so you will need to select "view hidden files and folders" from the relevant menu (reset this when you have finished). Please note that deleting the Prepar3D.cfg file will require you to input all of your P3D settings again (including controls).

This worked for me when I suffered a "stutter every three seconds" problem shortly after installing P3D v4 and all of my addons.

 
Edited by Christopher Low

Share this post


Link to post
20 hours ago, Christopher Low said:

Delete the following file.....

  • Local Disk (C:) > Users > You > AppData > Roaming > Lockheed Martin > Prepar3D v4 > Prepar3D.cfg

Delete all files in the following folders......

  • Local Disk (C:) > Users > You > AppData > Local > Lockheed Martin > Prepar3D v4 > Shaders
  • Local Disk (C:) > Program Data > Lockheed Martin > Prepar3D v4 > Scenery Indexes x64 >

These are all hidden files, so you will need to select "view hidden files and folders" from the relevant menu (reset this when you have finished). Please note that deleting the Prepar3D.cfg file will require you to input all of your P3D settings again (including controls).

This worked for me when I suffered a "stutter every three seconds" problem shortly after installing P3D v4 and all of my addons.

 

Tried it, makes no difference.

Share this post


Link to post
22 hours ago, anshugiri said:

Tried all of your suggestions... but the problem still persists.

What specific directories and process have you exempted?

 

Share this post


Link to post
47 minutes ago, Luke said:

What specific directories and process have you exempted?

 

I uninstalled the antivirus, and disabled windows defender antivirus.

Share this post


Link to post

I'd be curious what process' CPU time spikes on an autosave. I'd set your interval to 2-3 seconds and then watch task manager to see what's spiking.

Cheers!

 

Share this post


Link to post

Turns out it was a monitor refresh rate issue. The pattern of micro-stutter changes as i change the refresh rate. Looks like i need a g-sync monitor.

Share this post


Link to post
On 3/24/2019 at 1:41 PM, anshugiri said:

8600k at 5.0, RTX 2080, Samsung 850 EVO, 16GB Ram, monitor refresh 30 hz.

Hi,

Just wondering, what have you set in your target frame rate and vsync settings? Since your monitor refresh rate is 30 hz, I would suggest trying with 28 or 29 as target frame rate setting with vsync = on.

Kind regards,

Share this post


Link to post
On 3/24/2019 at 6:33 AM, Cruachan said:

@anshugiri I have posted about a similar issue in the past few weeks. In my case the sim exhibited a regular slight single stutter every 3 seconds. It was barely noticeable but sufficient to destroy that sense of immersion we are all seeking.

This regular stutter was also visible in Slew mode while stationary on the ground and a slow 360 degree turn was started. I used to use this test to check for the presence of the stutter at the beginning of a session. Lately it hasn’t been necessary as this stutter appears to have resolved spontaneously! Fingers crossed.

I never found the cause, but did discover I could get banish it for the duration of a single simming session by simply rebooting. Restarting Prepar3D was not enough; the regular stutter would persist. A warm or, preferably, cold reboot provided the solution. Might be worth a try.

Regards,

Mike

Use Unlimited and Windows 10!  🙂

bs

Share this post


Link to post
12 minutes ago, bean_sprout said:

Use Unlimited and Windows 10!  🙂

bs

Ha,ha @bean_sprout if nothing else, I award you full marks for persistence! 😊

It will take much more than that to convince me that Windows 10 should be my default O/S. No doubt that day will come. However, my experience to date tells me MS still have some work to do.

Lately I have not had any issues, as described, but I know I have an effective 'workaround' should they recur.

Meantime, I'm about to try the latest NVIDIA driver set since they do seem to be performing well for others.

Regards,

Mike

 

 

Share this post


Link to post

Looks like it was indeed a driver issue. No such problems noted with the 419.67 driver set....so far. As others have commented, these drivers do seem very solid and are performing well. Sim even more fluid than before with frame rate locked internally at 30fps (No VSync or TB).

Mike

Share this post


Link to post
On 3/24/2019 at 6:16 AM, ddawson said:

If you have not done so, try enabling write caching on the drive(s) where Windows and P3D are installed.

Doug

I have write behind caching disabled, because a system lockup, though it has not happened to me yet, can cause data to be lost which has happened to me once when we had a sudden power failure when my ups was low, I had corrupted files that I had just downloaded.  I have seen no difference in P3D with right behind caching disabled, or Xplane, I have no stutters during turns or panning around the aircraft, just an occasional scenery access brief pause every thirty minutes or so, not enough to detract from the fluidity, just something I notice.

Sometimes too aggressive AA settings can cause a stutter, and too much AI in the background.

John

Share this post


Link to post
3 hours ago, Cruachan said:

Looks like it was indeed a driver issue. No such problems noted with the 419.67 driver set....so far. As others have commented, these drivers do seem very solid and are performing well. Sim even more fluid than before with frame rate locked internally at 30fps (No VSync or TB).

Mike

Glad I scan these threads, have not updated my drivers since the beginning of time, lol.  Maybe placebo effect but the sim seemed more fluid to me too, I lock my frame rate at 33 fps, just like the number for some reason and the sim always keeps up with it. 

John

Share this post


Link to post
Posted (edited)

Hi John,

Try locking internally at 30fps (without VSync or TB). It should release some performance overhead without compromising fluidity. If this does not achieve the desired result then choose a frame rate which is a proper fraction of your monitor’s refresh rate. For example, 30fps would be 1/2 of 60Hz, 1/4 of 120Hz. As you can see from my signature, my 144Hz capable monitor has been set to refresh at 120Hz. That way I have increased the likelihood of a screen refresh coinciding with my chosen Prepar3D frame rate of 30fps. My rig is not dedicated to Prepar3D and I find a 120Hz Screen refresh more than adequate for everything else, so it never needs to be changed.

Quoting a paragraph from a response made by Steve a few days ago:

The internal limiter is not a 'limiter'. It makes look ahead frames stored into a buffer. When the buffer is full, only then are frames limited. Since there's always going to be a difference in time to construct each frame there's inconsistency. That inconsistency is filled in with the look ahead. When any of the look ahead is depleted another is built as well as the one to display. That's why you see high CPU use with the internal Locked fps slider.”

So, with a lock of 33fps your 1060 GTX is working quite hard to keep up with demands unless, of course, you have elected to run with appropriate settings commensurate with the capabilities of your hardware and flight preferences.

Regards,

Mike

Edited by Cruachan

Share this post


Link to post

HERE'S THE FIX.
Works perfectly for me to remove the micro-stutter (for native 60hz monitors). There's no need to set monitor refresh rate to 30hz.

  1. P3Dv4
    1. Set Frames to "Unlimited"
    2. Vsync to OFF
    3. Triple Buffering to OFF
  2. RivaTunerStatistics Server
    1. Create profile for P3D
    2. Set Scanline Sync to "Scanline Sync x/2" by clicking twice on the text label that says "Scanline Sync".
    3. In the textbox to the right of "Scanline Sync x/2", set value to 60hz (if your monitor is native 60hz).

I tried setting 1/2 refresh rate from Nvidia Inspector, but that didn't work for me. Instead... RivaTunerStatistics Server (MSI Afterburner) works perfectly to achieve the same thing.

  • Like 4
  • Upvote 1

Share this post


Link to post
Posted (edited)
1 hour ago, anshugiri said:

HERE'S THE FIX.
Works perfectly for me to remove the micro-stutter (for native 60hz monitors). There's no need to set monitor refresh rate to 30hz.

  1. P3Dv4
    1. Set Frames to "Unlimited"
    2. Vsync to OFF
    3. Triple Buffering to OFF
  2. RivaTunerStatistics Server
    1. Create profile for P3D
    2. Set Scanline Sync to "Scanline Sync x/2" by clicking twice on the text label that says "Scanline Sync".
    3. In the textbox to the right of "Scanline Sync x/2", set value to 60hz (if your monitor is native 60hz).

I tried setting 1/2 refresh rate from Nvidia Inspector, but that didn't work for me. Instead... RivaTunerStatistics Server (MSI Afterburner) works perfectly to achieve the same thing.

For us dummies, how do you create a profile for P3D?  I only use computer for P3D sim.  Is profile necessary?

Edited by kenthom
Additional information

Share this post


Link to post
3 hours ago, anshugiri said:

HERE'S THE FIX.
Works perfectly for me to remove the micro-stutter (for native 60hz monitors). There's no need to set monitor refresh rate to 30hz.

  1. P3Dv4
    1. Set Frames to "Unlimited"
    2. Vsync to OFF
    3. Triple Buffering to OFF
  2. RivaTunerStatistics Server
    1. Create profile for P3D
    2. Set Scanline Sync to "Scanline Sync x/2" by clicking twice on the text label that says "Scanline Sync".
    3. In the textbox to the right of "Scanline Sync x/2", set value to 60hz (if your monitor is native 60hz).

I tried setting 1/2 refresh rate from Nvidia Inspector, but that didn't work for me. Instead... RivaTunerStatistics Server (MSI Afterburner) works perfectly to achieve the same thing.

I typically use NVI's framerate limiter2 at 30 fps, and that works well also, with lower CPU utilization..

But I must say after trying this, it does seem smoother and more fluid than NVI.. :smile:

Lets try it for a few more flights to see if that sense continues..

One more little trick that seems to work for me (snake oil?) is to reset Affinity for the prepar3d.exe process in task Manager to "all cores" after starting up P3D.

  • Like 2

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now