Rogen

NVidia setting - SILK smoothness

Recommended Posts

Hey folks,

Just thought I share a little discovery.

I was giving some thought to if I I could further improve P3D and it's already smooth 30hz-30fps vsync'd operation and that got me thinking about smooth motion functions of TV's to bring 24 fps up to 60 fps for smooth playback and if there were any similar options for applying to P3D.

As it turns out games do not lend well to such motion interpolation due to the way they output frames, but I decided to take a good look through all the options in the NVidia inspector anyway.

And found "SILK Smoothness" which although it doesn't bring the fps up to 60 fps, it certainly trims the rough edges off P3D, so much in fact that my already smooth 30hz-30fps now feels a lot closer to 60 fps.

Will it prove to be the *perfect* tweek? Not at all, but it is a further effective tweek in the search for improved P3D performance.

======================================

SILK Smoothness
Silk reduces stutters in games caused by variable CPU or GPU workloads by smoothing out animation and presentation cadence using animation prediction and post render smoothing buffer.
• Off – Silk is disabled.
• Low – Moderate smoothing is enabled and most microstutter is eliminated.
• Medium – Many stutters and hitches are removed in typical games.
• High – More smoothing is applied and may result in observable input lag.
• Ultra – Maximum smoothing is applied and most stutters and hitches in games are eliminated. Lag may be unacceptable in some games.

Note: Selecting High or Ultra settings for silk can increase noticeable lag when playing, and may not be appropriate for first person shooters or competitive gaming.

======================================

The setting is located in the NVidia Inspector under "Other" and there are only 5 settings as hex 0 to 4.

Just choose the value to trial from the drop down.

I started with trialing 4 (Ultra) and then trialed others to see how P3D changed.

Note: I running a 1070Ti and version 418.67 GPU drivers.

As usual results may vary, but it is an easy tweek to trial out.

Cheers

  • Like 1

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Just tried it and I'm not really seeing what you are seeing. At 4K 30Hz V-Sync + TB, it increased the input lag quite a lot, which could be felt pretty severely when looking around the cockpit with the mouse. Yet, the image didn't really appear smoother, at least not for me. I'd even say it looked more jittery than usual.

Share this post


Link to post

That's not what P3Dv4 devs say since 4.3 you better of not using NVI or AM.

Share this post


Link to post
30 minutes ago, Sethos1988 said:

Just tried it and I'm not really seeing what you are seeing. At 4K 30Hz V-Sync + TB, it increased the input lag quite a lot, which could be felt pretty severely when looking around the cockpit with the mouse. Yet, the image didn't really appear smoother, at least not for me. I'd even say it looked more jittery than usual.

I don't know if this is a good thing or not as I haven't looked at it, but if it does help then  you'll have to have your 4K TV set to at least 60Hz for it to work so long as you have VSync enabled (which I'm guessing you have enabled).

 

 

  • Upvote 1

Share this post


Link to post
Posted (edited)
20 minutes ago, DaveCT2003 said:

I don't know if this is a good thing or not as I haven't looked at it, but if it does help then  you'll have to have your 4K TV set to at least 60Hz for it to work so long as you have VSync enabled (which I'm guessing you have enabled).

I'll give it a go. Could you elaborate on why I'd need 60hz for an interpolation feature to work?

EDIT: Didn't change much, reduced the input lag slightly but still a bit higher than without the setting. Image is pretty much identical to just running 30Hz / V-Sync / Unlimited. Might just be something in my setup that is preventing it from working.

Edited by Sethos1988

Share this post


Link to post
23 minutes ago, Sethos1988 said:

I'll give it a go. Could you elaborate on why I'd need 60hz for an interpolation feature to work?

Because Vsync effectively halves the refresh rate you have set.

 

Share this post


Link to post
5 minutes ago, DaveCT2003 said:

Because Vsync effectively halves the refresh rate you have set.

 

No it doesn't? V-Sync synchronizes your frame rate with the monitor's refresh rate.

Share this post


Link to post
12 minutes ago, Sethos1988 said:

No it doesn't? V-Sync synchronizes your frame rate with the monitor's refresh rate.

Keep researching my friend!

Best wishes!

 

Share this post


Link to post
Posted (edited)
1 hour ago, DaveCT2003 said:

Keep researching my friend!

Best wishes!

What an odd rebuttal.

https://www.pcworld.com/article/229024/geek101-vsync.html

Quote

It's short for vertical synchronization, an optional setting on your graphics card that throttles the frames being drawn to match the number of times your monitor refreshes itself every second.

https://www.techopedia.com/definition/92/vertical-sync-vsync

Quote

Vertical sync synchronizes the output video of the graphics card to the refresh rate of the monitor.

https://www.maketecheasier.com/what-is-vsync/

Quote

Enabling VSync will cap the FPS to the monitor’s refresh rate and stop the excessive strain on the graphics processor

 

V-Sync does not straight halve your frames. It simply syncs the application's frame rate to the monitor's current refresh rate.

You may be thinking of something else.

Edited by Sethos1988

Share this post


Link to post
6 hours ago, DaveCT2003 said:

Keep researching my friend!

Best wishes!

 

Vsync does not half your framerates, but a lot of people use Vsync at half refresh rate to lock at 30fps.

  • Upvote 3

Share this post


Link to post

Thanks for this tip Rogen. Setting low at “1” has removed all the tiny stutters and shudders that I had in my FSX:SE setup. I am indeed now running as smooth as I’ve ever achieved. Superb!

Share this post


Link to post

Induces more stutters for me than anything, but hope it works for others.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now