Jump to content
Sign in to follow this  
BWBriscoe

Nvidia performance article

Recommended Posts

@SteveW, at the third time of trying the flight was fine. Multiple switching of internal and external views and the sim was fine. I didn’t dare access the menu system.

I exited, cleared the Shaders folder and reloaded. Accessed the Vehicle menu and cancelled without making any changes and all was fine.

I may clear the shaders folder at the start of each day’s flying. Keep it clean.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Clearing the shaders makes no sense as it gives the sim more to do to recreate them. Shaders are created when they don't exist then are accessed in the normal use of the sim. Only recreate the shaders when the code has changed.

  • Upvote 1

Steve Waite: Engineer at codelegend.com

Share this post


Link to post
27 minutes ago, Ray Proudfoot said:

@SteveW, at the third time of trying the flight was fine. Multiple switching of internal and external views and the sim was fine. I didn’t dare access the menu system.

I exited, cleared the Shaders folder and reloaded. Accessed the Vehicle menu and cancelled without making any changes and all was fine.

I may clear the shaders folder at the start of each day’s flying. Keep it clean.

(Just reposting what I posted a couple of days ago, since it is exactly about non-VRAM-DXGI-errors:)

I will just add my experience to it:

There seem to be two types of DXGI errors:

1. The VRAM one. That's pretty easy to solve.

2. The other one. It seems to me that that one occurs when the load or rather the GPU clock rapidly changes (up/down fluctuation / spike) due to something you or the simulator does. Typical scenarios are:
a) Changing graphics settings: The menu alone does drastically reduce the clock speed, then when changing settings it does of course fluctuate again (quite a lot, since it loads things one after another).
b) Changing views (inside / outside aircraft basically). Since the cockpits of most jets (and the Feelthere E-Jets are probably the worst offenders here) are really heavy on the GPU, the GPU will "relax" once you switch to an outside perspective. Anyone can notice that: FPS outside of a PMDG plane is substantially better then inside the cockpit.
c) Looking from something really GPU heavy (like half London / half your Cockpit) into the sky (I get a FPS difference of about 80!). Well, you cannot really prevent that, but it is what it is.

I've had a lof of DXGI errors on my 1080ti, but it was never outside of those situations, especially never when I had a constant high GPU load (like at EGLL).
There are a couple of ways to mitigate this, the most important one the already mentioned "Max Performance Setting" in the NCP. This keeps the power / load / clock most of the times at maximum, so you'll have a lot less fluctuations. Another one is disabling factory overclock on your GPU, using the "debug mode" in the NCP. This reduces your max. clock and therefore reduces fluctuations, since it's on max. clock most of the times. I know, it sound dumb to "weaken" your GPU to reduce crashes, but my observations would explain why this seems to predominantly happen to x080ti cards (I had a 1660ti before and I never had those crashes; well instead I had VRAM crashes but that's another story...).

So tl;dr: If you use a good GPU with high settings, in NCP
a) enable "Max Performance"
b) enable "Debug mode"
c) Don't change graphics settings mid-flight
d) Use FSUIPC autosave, so a CTD after 8hrs only means you have to wait 5 minutes to reload. Anything else is just masochistic.
e) Have a clean install of a studio driver, they seem to be more stable

This should drastically reduce those CTDs. Worked for me, I only have one once every 50 (real-time) hours, and most of the time it was because I needed to reduce some settings mid-flight (yeah, you can run out of 11 GB VRAM at KMIA or even worse KFLL...).

  • Like 1

Share this post


Link to post
1 hour ago, SteveW said:

Clearing the shaders makes no sense as it gives the sim more to do to recreate them. Shaders are created when they don't exist then are accessed in the normal use of the sim. Only recreate the shaders when the code has changed.

It was worth asking Steve, thanks.

1 hour ago, Fiorentoni said:

I've had a lof of DXGI errors on my 1080ti, but it was never outside of those situations, especially never when I had a constant high GPU load (like at EGLL).
There are a couple of ways to mitigate this, the most important one the already mentioned "Max Performance Setting" in the NCP.

But @simbol specifically stated not to do this and to use the standard setting. But since doing that I've had more DXGI issues than I had before. The "official line" from LM is to enable Max Performance so in the absence of any change from them I'm going to try that for a while.

It was very frustrating this morning when you've setup a flight in the PMDG737, are taxiing out and just accessing the Addon menu for FSUIPC causes the DXGI. 😞

  • Like 1

Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
18 minutes ago, Ray Proudfoot said:

The "official line" from LM is to enable Max Performance so in the absence of any change from them I'm going to try that for a while.

Will be interesting Ray since Optimal Power is supposed to provide the best situation. Perhaps LM are just discouraging using Adaptive:

From Nvidia tests: "While there are slight variances here and there, for the most part, they don’t make a big difference.  Based on our findings we recommend to keep the driver at its default setting of “Optimal Power”.  This seems to provide the best Idle power savings and gaming performance. 
It seems “Prefer Maximum Performance” might even hurt your performance on certain video cards in certain games. Unless you are having trouble getting your video card to run at the intended clock speeds, don’t enable this power mode.   It can actually cause your clock speeds to drop slightly, affecting performance. 
With Optimal Power we don’t really see the need for the Adaptive setting, they both almost do the same thing.  They both have the same power and performance.  In our opinion, NVIDIA should cut down the options back to just two toggles.  Optimal Power and Prefer Maximum Performance is all you need, and the latter being there for just legacy purposes.
"

 

Edited by SteveW

Steve Waite: Engineer at codelegend.com

Share this post


Link to post

...I re-read that report and it could be that the max performance setting can prevent over power situations that result in the GPU errors by throttling down the clock. So that advice from LM may be best.

  • Like 1

Steve Waite: Engineer at codelegend.com

Share this post


Link to post
32 minutes ago, SteveW said:

...I re-read that report and it could be that the max performance setting can prevent over power situations that result in the GPU errors by throttling down the clock. So that advice from LM may be best.

I agree if for no other reason than that setting prevented a DXGI error when changing default vehicles. Even default to default caused it until I changed to Max Perf.

  • Like 1

Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Good to know that you can see a real difference Ray because usually it would need a specific setup to show those differences and that can be hard to recreate.

It seems that the adaptive and optimum settings maintain performance depending on demand give max performance but the max performance setting does not actually maintain performance in the same way and will slow the clock and reduce performance to avoid over power situations. The setting explanations for that item need rewriting.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post

@SteveW, these errors when changing default vehicles have to be a bug in the code. Maybe when they’re fixed Adaptive may be the best setting.

I hope this is being fed back to LM. I did raise this issue on their forum but they never seem to acknowledge these kind of posts. Pity.

Looking at your last post have you mixed up adaptive and maximum? Surely Max Performance runs as fast as possible.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

The "Prefer max performance" setting is concerned with maintaining maximum power and not keeping fps performance, so it reduces the clock to maintain power use.

Edited by SteveW
  • Upvote 1

Steve Waite: Engineer at codelegend.com

Share this post


Link to post

to be honest prefer max performance in most cases give higher boost clock , its depending on the vga bios.

some bios have powertarget and max power, tthen bios with only max power in that case no diff at all.

you have perf cap reason, temp gpu voltage and power the stop boost start downclock to not pass the temp power or voltage targets

  • Like 1

Share this post


Link to post

It seems that the reason Ray gets the error during menu selection with the "Optimal Power" setting is because of spikes in the power delivery. The "Prefer max performance" setting stops that happening by maintaining power usage.

In the test report: “Prefer Maximum Performance” might even hurt your performance on certain video cards in certain games. Unless you are having trouble getting your video card to run at the intended clock speeds, don’t enable this power mode.   It can actually cause your clock speeds to drop slightly, affecting performance."


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
16 minutes ago, SteveW said:

It seems that the reason Ray gets the error during menu selection with the "Optimal Power" setting is because of spikes in the power delivery. The "Prefer max performance" setting stops that happening by maintaining power usage.

In the test report: “Prefer Maximum Performance” might even hurt your performance on certain video cards in certain games. Unless you are having trouble getting your video card to run at the intended clock speeds, don’t enable this power mode.   It can actually cause your clock speeds to drop slightly, affecting performance."

nvida , "might " , "certain video cards" , "certain games" how to know if it affect you , we call that a nvidia longshot

 

Edited by westman

Share this post


Link to post
23 minutes ago, SteveW said:

It seems that the reason Ray gets the error during menu selection with the "Optimal Power" setting is because of spikes in the power delivery. The "Prefer max performance" setting stops that happening by maintaining power usage.

Surely I can’t be alone in having this issue? It’s easy enough to test. Default vehicle in your startup scenario and once the sim has loaded try selecting another default vehicle. Even selecting an avatar causes the problem. You can’t get a less hungry vehicle than that.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
1 hour ago, Ray Proudfoot said:

Surely I can’t be alone in having this issue? It’s easy enough to test.

Ray,

I have been plagued by DXGI crashes in V5 for quite some time. I haven't associated menu use  or "aircraft select" with the crashes but the crashes were regular and completely repeatable even in a plain vanilla default V5 installation. When I get time I will try your aircraft selection scenario but I would expect that it very well may initiate a crash. My test became a flight set up with the default Commander at KAUS. Crashes always occurred before I could even make one circuit.

I have seen two solutions work reliably for me. I can use MSI Afterburner to lower max power to 93% or I can use the Nvidia Control Panel Prefer Max Performance setting. In either case I have yet to experience a single crash.

Hope this is helpful,

Jesse

  • Upvote 1

Jesse Cochran
"... eyes ever turned skyward"

P3D v5.3 Professional, Windows 10 Professional, Jetline GTX, Gigabyte Aorus X299 Gaming 7 mobo, i7 7740X @ 4.9 GHz, Corsair H115i Liquid Cooling, 32Gb SDRAM @ 3200MHz, Nvidia GeForce GTX1080Ti @ 11 GB

ORBX Global + NALC, ASP3D, ASCA, ENVTEX, TrackIR, Virtual-Fly Yoko Yoke, TQ6+, Ruddo+ Rudder Pedals

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...