Jump to content
Sign in to follow this  
joepoway

F1 GTN750 Updated for v5.3HF1

Recommended Posts

As the title says just update the GTN750 to v1.24 and all is good.

Not sure if it will work for the next Hotfix for the airport lights always on issue but we will see.

 

 

  • Like 1

Joe (Southern California)

SystemI9-9900KS @5.1Ghz/ Corsair H115i / Gigabyte A-390 Master / EVGA RTX 2080 Ti FTW3 Hybrid w 11Gb / Trident 32Gb DDR4-3200 C14 / Evo 970 2Tb M.2 / Samsung 40inch TV 40ku6300 4K w/ Native 30 hz capability  / Corsair AX850 PS / VKB Gunfighter Pro / Virpil MongoosT-50 Throttle / MFG Crosswind Pedals /   LINDA, VoiceAttack, ChasePlane, AIG AI, MCE, FFTF, Pilot2ATC, HP Reverb G2

Share this post


Link to post

I thought I heard that F1 wasn't updating this product anymore?


i7 6700K @ 4.6GHz, ASUS Z170-PRO GAMING, 32GB DDR4 2666MHz, 750W EVGA SuperNOVA, 512GB Samsung 960 PRO, 1TB Western Digital - Black Edition
RTX 2080Ti (MSI trio), Corsair H115i - 280mm Liquid CPU Cooler

Share this post


Link to post
Just now, IAhawkeyeDDS said:

I thought I heard that F1 wasn't updating this product anymore?

They aren't but these small mods aren't affecting the GTN750 installation which I believe is version 2.22 that works with P3Dv5

These updates just enable the compatibility link or something which probably has to do with the P3D version references or something.

There will be an update to P3D probably v6  when the F1 GTN750 v2.22 will no longer work and no more updates will ever be made requiring us to move to the other developer of the GTN750.

I'm not sure who is updating the "connector piece" that was recently updated to 1.23 for P3Dv5.3 and now 1.24 for the hotfix.

I don't have all the info for sure but am glad the minor updates that make the current version work are still coming.


Joe (Southern California)

SystemI9-9900KS @5.1Ghz/ Corsair H115i / Gigabyte A-390 Master / EVGA RTX 2080 Ti FTW3 Hybrid w 11Gb / Trident 32Gb DDR4-3200 C14 / Evo 970 2Tb M.2 / Samsung 40inch TV 40ku6300 4K w/ Native 30 hz capability  / Corsair AX850 PS / VKB Gunfighter Pro / Virpil MongoosT-50 Throttle / MFG Crosswind Pedals /   LINDA, VoiceAttack, ChasePlane, AIG AI, MCE, FFTF, Pilot2ATC, HP Reverb G2

Share this post


Link to post
3 hours ago, IAhawkeyeDDS said:

I thought I heard that F1 wasn't updating this product anymore?

I had the same initial thought prior to leaving version 5.1 Hf1 for 5.3 and was hesitant in doing so wondering if my F1 GTN 750 & 650 would work.. I was ready to purchase the RXP versions, however, I was pleasantly surprised when I clicked on the update tool and it updated for ver. 5.3! Not sure how much longer the update tool will continue to work and probably in the near future I will be switching over to the RXP versions of the 750 & 650 if for nothing else needed support if necessary.

Share this post


Link to post

Now that the version changed from 0 to 1 after the new hotfix update to the hotfix update, I guess we wait again for a update. Happy Holidays


Keith (Grand_Pubah) Sacramento, Ca USA

i7 11700k 3.6ghz/ MSI MPG Z590 Gaming Carbon Wifi/ Nvidia RTX 3080ti FE/ Corsair Vengeance LPX 64GB DDR4 3600(PC4-28800)/ Windows 10 (21H2)/ Prepar3D v5.3 hf2 v5.3.17.28160

Share this post


Link to post

just waiting for the Flight 1 Update Tool to provide version 1.25 now for the Hotfix for lights at the airports

  • Like 1

Joe (Southern California)

SystemI9-9900KS @5.1Ghz/ Corsair H115i / Gigabyte A-390 Master / EVGA RTX 2080 Ti FTW3 Hybrid w 11Gb / Trident 32Gb DDR4-3200 C14 / Evo 970 2Tb M.2 / Samsung 40inch TV 40ku6300 4K w/ Native 30 hz capability  / Corsair AX850 PS / VKB Gunfighter Pro / Virpil MongoosT-50 Throttle / MFG Crosswind Pedals /   LINDA, VoiceAttack, ChasePlane, AIG AI, MCE, FFTF, Pilot2ATC, HP Reverb G2

Share this post


Link to post

My understanding is the Flight1 GTN750 does not work with the latest version of the Garmin Trainer -- has that changed?

Al

Edited by ark

Share this post


Link to post
51 minutes ago, ark said:

My understanding is the Flight1 GTN750 does not work with the latest version of the Garmin Trainer -- has that changed?

I am not sure what the latest version of the Garmin Trainer is. In P3D ver. 5.3 without Hf1. I am using the Flight1 GTN 750 & 650 complete ver. 2.22 & version 6.62.4 Garmin Trainer. I do not know if there is any newer version of the trainer than that one. I purchased both nearly a year ago when I went from P3D 3.4xx to version 5.1.Hf1 

Share this post


Link to post
On 12/23/2021 at 1:26 PM, joepoway said:

just waiting for the Flight 1 Update Tool to provide version 1.25 now for the Hotfix for lights at the airports

I just updated to 5.3 Hf1+1 (updated hotfix) and now my Flight 1 GTN 750 & 650 are not compatible--I do have version 1.24 and I am hoping that the Update Tool will come through for me with 1.25. I will wait for a little while longer and if no update to 1.25, I will have to go with the "Other Vendor".

  • Upvote 1

Share this post


Link to post

Well, I updated P3D to version 5.3.17.28160 and my Flight 1 GTN750 say "incompatible" with current version. No update available. Might have to step back to HotFix 1 for a few more miles out of it. 🥺

Edited by Beckanator

P3Dv5x - MS Windows 10 X-64 - Intel Core i7-6700 CPU @ 3.40GHX - NIVIDIA GeForce GTX 1080 - 64 Gig Memory - Samsung EVO 970 EVO SSD - ORBX Global, TrueEarth, UT Live, ChasePlane, AS, ASCA, FSUIPC + A Hanger Full of AC

Share this post


Link to post

Flight1 doesn't seem to get on to HF2. The last fixes the made after about 5 days. Now it's remarkably longer. I feel like uninstalling this software. Time to say goodbye.


OS=WIN11 Home, Sim=P3D5 actual version (P3D4 and FSX installed but unused)
Addons=ORBX, ASCA, AS, TOGA and tons of sceneries, aircraft
MB=ASUS Z390F-Gaming, CPU=i9700K OC @4.9 GHz, Cooling=Arctic Liquid Freezer II
GPU=KFA2 RTX3090 24 GB, RAM=32 GB DDR4-3200, HOTAS=Logitech G Saitek X52 Pro

My Website: https://sites.google.com/view/dans-p3d-mods

Share this post


Link to post
8 hours ago, blaunarwal said:

Flight1 doesn't seem to get on to HF2. The last fixes the made after about 5 days. Now it's remarkably longer. I feel like uninstalling this software. Time to say goodbye.

I waited for about 5-6 days after HF 2 for a F1 update via their "Update Tool" but it never happened. I highly suspect that the Flight1 GTN 750 & 650 has finally come to the end of the road for hotfix updates. For that reason I have moved on to the RXP version and enjoy it a lot. It was an easy download and install. If you should do the same I highly advise you not to uninstall the Flight1 version. The RXP install module will replace the Flight1 version of either the GTN 750 or 650 that you currently have installed with the RXP version. Right now I am in the process of converting over to RXP in my installed addon aircraft. Also, from what it looks like there is great support for the RXP version as well and its right here at the AVSIM forum.

Raymie

  • Like 3
  • Upvote 2

Share this post


Link to post
On 12/22/2021 at 12:32 PM, joepoway said:

As the title says just update the GTN750 to v1.24 and all is good.

I remain baffled by their website and chose the Reality XP because it seemed to me Flight1's GTN750 was dead as a door nail in P3Dv5. No complaints about Reality XP, but happy you were able to break the Flight1's code.

  • Like 1

 

 

 

Share this post


Link to post
2 hours ago, Tim_Capps said:

I remain baffled by their website and chose the Reality XP because it seemed to me Flight1's GTN750 was dead as a door nail in P3Dv5. No complaints about Reality XP, but happy you were able to break the Flight1's code.

No code to break they (someone we don't know who) provided update 1.24 and then 1.25 for the two previous v5.3's  and all works great but it's been 3 weeks and no update 1.26 for the latest version so we all might have to head to Reality XP finally.


Joe (Southern California)

SystemI9-9900KS @5.1Ghz/ Corsair H115i / Gigabyte A-390 Master / EVGA RTX 2080 Ti FTW3 Hybrid w 11Gb / Trident 32Gb DDR4-3200 C14 / Evo 970 2Tb M.2 / Samsung 40inch TV 40ku6300 4K w/ Native 30 hz capability  / Corsair AX850 PS / VKB Gunfighter Pro / Virpil MongoosT-50 Throttle / MFG Crosswind Pedals /   LINDA, VoiceAttack, ChasePlane, AIG AI, MCE, FFTF, Pilot2ATC, HP Reverb G2

Share this post


Link to post

 

1 hour ago, joepoway said:

No code to break they (someone we don't know who) provided update 1.24 and then 1.25 for the two previous v5.3's  and all works great but it's been 3 weeks and no update 1.26 for the latest version so we all might have to head to Reality XP finally.

I held off installing Hotfix 2 simply for that reason, hoping that update 1.26 would soon follow. I waited for 5-6 days afterward and with no update available, I went ahead and "pulled the trigger" in purchasing the RXP version of the GTN 750. I had no issues in purchasing, downloading and installing as all went well. The installation module for the RXP GTN gauge is pretty simple and straight forward and there are several helpful tutorials also available if needed; they can be found on the RXP forum here at AVSIM. Now I am ready to install Hotfix 2!

Raymie

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...