Jump to content
Sign in to follow this  
Joseph29

P3D asking me to enable Orbx sceneries every time I start P3

Recommended Posts

I bought a few Orbx sceneries and now P3D is asking me to enable the sceneries every time I start P3D. I bought ENTO, Pilot Plus Bristol, MKStudio Donegal, and Split Croatia. The install went fine, scenery is working good in the sim. Is this happening with anyone else? I have other Orbx products and P3D doesn't ask me to enable the other ORBX stuff I have all the time.

  • Like 1

Share this post


Link to post

When this problem was reported before, the user was not running P3D with Administrator enabled.

If you are already doing this, the 2nd thing I would try is to select the Sync Siuulator option in Orbx Central.

 

Hope that helps.


Spoiler

System specs: MFG Crosswind pedals| ACE B747 yoke |Honeycomb Bravo throttle
Now built: P3Dv5.3: Intel i5-12600K @4.8Ghz | MSI Z690-A PRO | Asus TUF Gaming RTX3070 OC 8Gb| 32Gb Corsair Vengeance LPX DDR4 3200Mhz |Samsung 980Evo Pro PCIe 500Gb | WD Black SN850 PCIe 2Tb | beQuiet 802 Tower Case|Corsair RM850 PSU | Acer Predator 34p 3440x1440p

Mark Aldridge
P3D v5.3 HF2, P3Dv4.5 and sometimes FSX!

Share this post


Link to post

I already have full administrator permission. And I tried your suggestion of the Sync Simulator option in Orbx, but that didn't work. I still have to enable the sceneries every time I start P3D.

Share this post


Link to post

The administrator permission in question is not yours but that of Prepar3D.exe.

Share this post


Link to post
Posted (edited)
12 minutes ago, Reader said:

The administrator permission in question is not yours but that of Prepar3D.exe.

The P3D.exe (and my computer in general) already has full administrator permission.

 

What I don't get is that only recent purchases (the last 3 purchases) are asking me to enable every time. None of the Orbx stuff I have bought in the past asks me. Maybe it has something to do with Orbx central itself?

Edited by Joseph29

Share this post


Link to post
Posted (edited)

Have  you tried  using the option  verify files  in the options

Edited by pete_auau

I7-800k,Corsair h1101 cooler ,Asus Strix Gaming Intel Z370 S11 motherboard, Corsair 32gb ramDD4,    2  ssd 500gb 970 drive, gtx 1080ti Card,  RM850 power supply

 

Peter kelberg

Share this post


Link to post
8 minutes ago, pete_auau said:

Have  you tried  using the option  verify files  in the options

 

That kind of worked. The Orbx scenery for Split Croatia and ENTO do not ask me to enable the scenery anymore, but MKStudios Donegal and Pilot Plus Bristol still ask to enable the scenery.

Share this post


Link to post
3 hours ago, Joseph29 said:

The P3D.exe (and my computer in general) already has full administrator permission.

Like this though?

2.jpg

Just checking.

Share this post


Link to post
1 hour ago, Reader said:

Like this though?

2.jpg

Just checking.

Yes, like that.

Share this post


Link to post
Posted (edited)

@Joseph29Why not download the excellent 'Lorby Addon Organiser' and see if any anomalies show up ?

Even if none do, just save setup before you exit the Lorby prg. and see if that resolves you problem.

May take two restarts of P3D.

Download here:-

Lorby addonorganizer_1_56_b11

Edited by Sparkrite

Share this post


Link to post

I just wanted say thank you for the help and suggestions guys. I contacted Orbx and they will be helping me out now.

Share this post


Link to post

You should never ever ever run a game or its addons with administrator privileges. I'm amazed that people still give this terrible advice after all these years. You have no idea what you're doing so stop it right now.

If the issue is because of a filesystem permission error, fix the broken file ACL. If the game or addon requires administrator privileges by design, stop using it right now and ask the lazy and terrible developer for a refund until its fixed.

Please don't reply with the usual myths that administrator privileges gives better performance or any other common flightsim misconception.

Share this post


Link to post
12 hours ago, Multisim said:

You should never ever ever run a game or its addons with administrator privileges. I'm amazed that people still give this terrible advice after all these years. You have no idea what you're doing so stop it right now.

If the issue is because of a filesystem permission error, fix the broken file ACL. If the game or addon requires administrator privileges by design, stop using it right now and ask the lazy and terrible developer for a refund until its fixed.

Please don't reply with the usual myths that administrator privileges gives better performance or any other common flightsim misconception.

Not sure where you are coming from but I have been running P3D with administrator privileges for years without any issues..........

Share this post


Link to post
Posted (edited)
13 hours ago, Multisim said:

You should never ever ever run a game or its addons with administrator privileges. I'm amazed that people still give this terrible advice after all these years. You have no idea what you're doing so stop it right now.

This statement by Multisim is completely FALSE.

While I do agree that running with Administrator privileges has nothing to do with performance benefits, it has everything to do with avoiding the clutches of UAC, which in Windows 10 is more aggressive than in previous versions (I can't speak for Win 11, since I don't run that). Installing outside the default path will go a long way to help there, but still!

I agree completely with Nocturnal, I have been running P3D, FSX and other applications with Administrative privileges for years and have never had problems with that.

Jorgen

Edited by jorgensandersen
  • Like 2

Share this post


Link to post

It’s interesting that Multisim said not to run with admin privileges but never explained why. I suggest he explains or desists.

He has a history of stirring things up in this forum.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...