Jump to content
Sign in to follow this  
BlodhemnUK

Confused as hell at low frame rates

Recommended Posts

Hi all, hoping some of my fellow flight simmers can give me some advice as to where I am going wrong. 

I am completely confused and have tried so many things I have lost count. 

I thought I had a decent set up, but now I am starting to wonder. 

My system is as follows:-

Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz

Geforce RTX 3090Ti

32Gb Ram

But I am struggling to get above 20 FPS, and anywhere built up I am as low as 8 FPS, even though my CPU and GPU are both only running at around 30% (although I do notice sometimes there may be one or two cpu cores running higher than the rest). As flying Helicopters is my preference, especially in VR, I simply cannot fly it with such low frame rates. 

I do have a fair few addons such as traffic via FSLTL, REX Weather Force, and I try to use FSHud for my ATC, but even without them running, I am getting these awful frame rates. At one time I was getting OK, but never great frame rates, but since the last couple patches, I seem to be getting worse frame rates than people with 1080Ti cards. 

Any one got any ideas? is my CPU not up too scratch?  I am so confused, and just want to fly...

Hoping someone out there can get back up in my Helicopters. 

Kind regards

Rob

 

Share this post


Link to post
Share on other sites
1 minute ago, BlodhemnUK said:

Hi all, hoping some of my fellow flight simmers can give me some advice as to where I am going wrong. 

I am completely confused and have tried so many things I have lost count. 

I thought I had a decent set up, but now I am starting to wonder. 

My system is as follows:-

Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz

Geforce RTX 3090Ti

32Gb Ram

But I am struggling to get above 20 FPS, and anywhere built up I am as low as 8 FPS, even though my CPU and GPU are both only running at around 30% (although I do notice sometimes there may be one or two cpu cores running higher than the rest). As flying Helicopters is my preference, especially in VR, I simply cannot fly it with such low frame rates. 

I do have a fair few addons such as traffic via FSLTL, REX Weather Force, and I try to use FSHud for my ATC, but even without them running, I am getting these awful frame rates. At one time I was getting OK, but never great frame rates, but since the last couple patches, I seem to be getting worse frame rates than people with 1080Ti cards. 

Any one got any ideas? is my CPU not up too scratch?  I am so confused, and just want to fly...

Hoping someone out there can get back up in my Helicopters. 

Kind regards

Rob

 

Hi Rob,

Your hardware is perfect for enabling ultra smooth, completely stutter-free animation, so something's way off.  It would help to also know what resolution you're running.  The other ultra useful info will be you running Dev Mode's framerate overlay to help pinpoint where the bottleneck is.  For starters:

  • O/C your CPU as high as stable
  • Does your GPU have a reliable recent driver install, a clean install?
  • What settings are you using that are not default Global in NV Control Panel?

I'm personally not familiar w/ VR's unique demands so can't speak to that.

 


Noel

System:  7800x3D, Thermal Grizzly Kryonaut, Noctua NH-U12A, MSI Pro 650-P WiFi, G.SKILL Ripjaws S5 Series 32GB (2 x 16GB) 288-Pin PC RAM DDR5 6000, WD NVMe 2Tb x 1, Sabrent NVMe 2Tb x 1, RTX 4090 FE, Corsair RM1000W PSU, Win11 Home, LG Ultra Curved Gsync Ultimate 3440x1440, Phanteks Enthoo Pro Case, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, RTSS Framerate Limiter w/ Edge Sync for near zero Frame Time Variance achieving ultra-fluid animation at lower frame rates.

Aircraft used in A Pilot's Life V2:  PMDG 738, Aerosoft CRJ700, FBW A320nx, WT 787X

 

Share this post


Link to post
Share on other sites
2 minutes ago, Noel said:

Hi Rob,

Your hardware is perfect for enabling ultra smooth, completely stutter-free animation, so something's way off.  It would help to also know what resolution you're running.  The other ultra useful info will be you running Dev Mode's framerate overlay to help pinpoint where the bottleneck is.  For starters:

  • O/C your CPU as high as stable
  • Does your GPU have a reliable recent driver install, a clean install?
  • What settings are you using that are not default Global in NV Control Panel?

I'm personally not familiar w/ VR's unique demands so can't speak to that.

 

Hi Noel, Thanks for the super fast reply.

I usually run in 4k, but even when I drop it to lower resolutions, it does not get any better, if anything it runs better at the higher resolution. I am running it in Dev mode with framerate up, and it keeps switching between 2 things I forget what they were, but am loading it up right now to find out, lol. 

Have never OC anything before, so will go watch some vids on what to do and will give that a try. 

GPU latest Nvidia driver, with clean install yes. 

I changed a couple of things in NVidia Control panel, but need to reboot to get it back on as I am currently in clean boot mode, will report back on that one. 

Share this post


Link to post
Share on other sites

something is way off, u have any extra programs running in the back round ?   I have a similar setup, I don't look at frames, but have a pretty much  nice smooth sim. 


10700kf, 3080 nividia, 32gbs 3400mhz, 1,000 watts power, M.2 DVMe !tb, boot, 1tb 7200rpm, storage, windows 10 home

Share this post


Link to post
Share on other sites
9 minutes ago, Sunshine13 said:

something is way off, u have any extra programs running in the back round ?   I have a similar setup, I don't look at frames, but have a pretty much  nice smooth sim. 

Running with a clean boot curently and getting 13fps over new york

Share this post


Link to post
Share on other sites
11 minutes ago, BlodhemnUK said:

Running with a clean boot curently and getting 13fps over new york

Looks like you are running DX12... try DX11 as a test.

Depending on graphics options, the fps counter may show 50% of actual... are you running DLSS or stuff like that?

Do you have multiple screens?

 


Bert

Share this post


Link to post
Share on other sites
1 minute ago, Bert Pieke said:

Looks like you are running DX12... try DX11 as a test.

Depending on graphics options, the fps counter may show 50% of actual... are you running DLSS or stuff like that?

Do you have multiple screens?

 

I just switched it back to dx11, rebooting back into sim, will report back on that. Turned off DLSS as it was not much better, and horrible blurring on anything moving on screen, and no, just one screen. which is a Sony Bravia 4K tv that can run at up 120hz

Share this post


Link to post
Share on other sites

Also just tried switching between HDR on and off, made no noticable difference, apart from nicer graphics in HDR

Share this post


Link to post
Share on other sites

OK,  so back in sim with DX11, and down to 10-14FPS and still limited by Main Thread, main thread now showing 80-150ms

Share this post


Link to post
Share on other sites

are your system temps ok ?

 


ROG Crossair Hero X670e , 7800X3D, TUF 4090 , X4 NVME's. OS on a 2TB 980 Pro , MSFS on " 2TB WD Black , G Skill F5 32 GB RAM  6000 ( allegedly) Corsair RM1000 PSU, Artic Freezer iii 360 AIO  . Phanteks P600s Case ,TCL QM8B 50" 120/144 Hz ( allegedly ) TV, Warthog Stick and TCA Captains throttle ( full pack) Logitech / Saitek Rudder Pedals , Streamdeck XL / Streamdeck +

Share this post


Link to post
Share on other sites
1 minute ago, sonny147 said:

are your system temps ok ?

 

CPU running at 39% Temp  = 67

GPU running at 25% Temp = 62

Share this post


Link to post
Share on other sites

@BlodhemnUKTake screenshots of your settings in MSFS and of your 'Program Settings' specifically for MSFS under 'Manage 3D Settings' in Nvidia Control Panel.
Link the screenshots here, so we can see how you are running your sim.

  • Like 1

AMD Ryzen 5800X3D; MSI RTX 3080 Ti VENTUS 3X; 32GB Corsair 3200 MHz; ASUS VG35VQ 35" (3440 x 1440)
Fulcrum One yoke; Thrustmaster TCA Captain Pack Airbus edition; MFG Crosswind rudder pedals; CPFlight MCP 737; Logitech FIP x3; TrackIR

MSFS; Fenix A320; A2A PA-24; HPG H145; PMDG 737-600; AIG; RealTraffic; PSXTraffic; FSiPanel; REX AccuSeason Adv; FSDT GSX Pro; FS2Crew RAAS Pro; FS-ATC Chatter

Share this post


Link to post
Share on other sites
37 minutes ago, BlodhemnUK said:

Limited by Main Thread PC D3D12

and main thread is constantly in red at 50 to 100+ ms 

In Windows search field enter Disk Cleanup then select DX shader cache and delete it, reboot, retry.  How old is the system?  Has it ever been excellent and recently went down hill?  Something very basic must be screwed up like you don't have the full chipset drivers installed but as it's Win 10/11 presumably that shouldn't be an issue, it just seems like something that basic.

8 minutes ago, BlodhemnUK said:

CPU running at 39% Temp  = 67

GPU running at 25% Temp = 62

CPU temp fits with the high mainthread use you're seeing.


Noel

System:  7800x3D, Thermal Grizzly Kryonaut, Noctua NH-U12A, MSI Pro 650-P WiFi, G.SKILL Ripjaws S5 Series 32GB (2 x 16GB) 288-Pin PC RAM DDR5 6000, WD NVMe 2Tb x 1, Sabrent NVMe 2Tb x 1, RTX 4090 FE, Corsair RM1000W PSU, Win11 Home, LG Ultra Curved Gsync Ultimate 3440x1440, Phanteks Enthoo Pro Case, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, RTSS Framerate Limiter w/ Edge Sync for near zero Frame Time Variance achieving ultra-fluid animation at lower frame rates.

Aircraft used in A Pilot's Life V2:  PMDG 738, Aerosoft CRJ700, FBW A320nx, WT 787X

 

Share this post


Link to post
Share on other sites

I have taken the screen shots, but Cant remember where I needed to upload images. 

Its gone midnight here in UK, so gonna have to get to bed, but you guys have been legendary helping me out, and I cant thank you enough, i'll check back here in the morning for where to upload images, and any other things to try, and hopefully, ill get this thing running better. 

Once again, thanks to all of you for assisting me. 

Best regards

Rob 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...