Sign in to follow this  
Guest jcmckeown

Blurries and contention (round 2)

Recommended Posts

With the advent of SP2/acceleration I'd like to restart the discussion originally started after SP1 in the following thread:http://forums.avsim.net/dcboard.php?az=sho...01559&mode=fullSo I have tried acceleration (that includes the SP2 fixes) and I must admit that I am feeling a little let down.Let's just recap:* FSX RTM absolutely no blurries* Install FSX SP1 the dreadecd blurries are all over* Installed acceleration, same issue as in SP1* Revert to RTM (no other changes) blurries are goneI'm using photo scenery with small texture tiles. I hoped that in SP2 there would be a fix but unfortunately that didn't materialize.Another interesting item is that some people, especially those with older setups (and single core) are not getting the blurries with SP1.I honestly think that Phil had a point when he originally mentioned "contention" some while back. I have tried upteen fixes, have installed all the suggested vista patches, tried running under XP, tried to run FSX using just one core using the AffinityMask directive, tried lowering frame rate to 20 or less, nothing sorts out the issue except... a simple revert to RTM.I'm sure this is something configuration specific, but there again the configuration is fairly common:* Core 2 duo 6600* 8800 GTS* RAID 0 disk array* Asus P5B DeluxeI'm sure we are a minority of people affected and equally sure that there is some sort of vicious contention bug but I've never been able to nail it down and nor have ACES in SP2. Could the same type of issue be causing issues with some people's directX 10 setup and not others?I wonder if there is a way to disable one of the cores on my Core 2 duo to emulate a single core machine.Best regards to all,JC

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

JC,I hate to say it but I have a P4-3.4ghz, single core and have had the blurries since SP1 and now even more so with Acceleration. I have been about "tweaked out" trying to get rid of those little monsters. CarlDell E510, P4-3.4ghz, 2gram, 7600GS-256mb, window XP.

Share this post


Link to post
Share on other sites

Can someone explain what RTM means?I searched this forum, but never found an explanation.-z-

Share this post


Link to post
Share on other sites

Interesting-I have a system almost identical to you except I have a 512mb 7600 and vista. I don't get the blurries at all.Just a question, as I think all of us would like to help solve this issue.Have you tried Luis F

Share this post


Link to post
Share on other sites

from http://en.wikipedia.org/wiki/RTMRelease to manufacturing or Ready to market, in the Software release life cycle so RTM==release to manufacturing in our context.when we ( the release team at Aces ) push the "send the ISO bits to the DVD manufacturing process" button in the corporate release tool we have reached that stage.

Share this post


Link to post
Share on other sites

The reason the single core may not have blurries is because of this parameter.{MAIN}FIBER_FRAME_TIME_FRACTION=.60This works in single core and its moot in multi core. If I understood correctly.ctiger,Put that parameter under MAIN and see if you still get bluries. that value should be betteen .01 - 1.0 Try .60 if it jitters or pauses too much reduce it to .33 and then try some value between .33 and .60 etcHope that helpsManny

Share this post


Link to post
Share on other sites

Thanks for the tip Manny but I already had 0.6 for the FIBER FRAME FRACTION and unfortunately it isn't helping.JC

Share this post


Link to post
Share on other sites

I have no blurries what so ever with SP2 under DX9.You may want to try renaming your fsx.cfg file and let FSX rebuild a new one. Especially if you have done some tweaking.

Share this post


Link to post
Share on other sites

Geofa,Yes, I have tried that and sometimes there are no blurries and then at other times blurries appear. I can use the "pause" and watch the textures get better with time. It is very confusing since there have been times I have no blurries with medium settings for an entire flight. The next day I can do the same trip and have blurries. Maybe there are little gremlins inside my computer. I must say this forum has been most helpful and patient for those of us that still can't seem to get rid of the blurries. Since the start of FSX many folks have been trying to wrestle with this problem. I believe I have read every potential fix that has been presented on this board. In fact there are several times when I thought I had the magic bullet but the blurries always find away back on my screen. Since it appears the only difference we have is the video card and I use XP and DX9.0 maybe your NVdia card settings could be helpful. I have tweaked the card settings and fsx many times but no long term change. By the way, Manny, my Fiber Frame TF is set at 0.40. Have tried between 0.33 and 0.60. No change.Have no stutters and frames are reasonable using "unlimited" or fixed at 20 fps.Appreciate everyone's help,Carl

Share this post


Link to post
Share on other sites

I don't think that it worth trying to emulate single core. I have a single core machine (Pentium M770), an ATI X1950 Pro, and I have exactly the same problem. This is so upsetting...It works nicely without blurries in RTM, but is awfully blurry on photo realistic sceneries (France VFR) in SP1 and SP2, even without autogen, with a high fiber frame time fraction and after having tried all tweaks I found on the web.My only option now is to have 2 installations of FSX: one RTM to fly on photo realistic sceneries, and one SP2/acceleration to fly on the non photo realistic sceneries. I am not sure it is actually possible, but I will try.

Share this post


Link to post
Share on other sites

Well we will keep trying-hopefully there is a magic answer.One other thing I didn't mention is I have no virus checker on my fs computer-I found even with excludes it was causing performance issues. I know, maybe not for the faint of heart-but my simming performance is more important to me.I am just using the stock nvidia settings and letting "application decided" everything. Then setting aa,and aniosotropic in fs.http://mywebpages.comcast.net/geofa/pages/rxp-pilot.jpgForum Moderatorhttp://geofageofa.spaces.live.com/

Share this post


Link to post
Share on other sites

You can add my single core system to the list of those with SP1/SP2 blurries, and of course the only fix I have found is reverting to RTM.If I use 1.0 Fiber Frame Fraction it does in fact reduce the blurries a bit, but the textures are still a step or two behind and never snap into full sharpness like they do with RTM, and that is not a practical setting as it cuts my framerate down below the RTM value and I get horrible stuttering.

Share this post


Link to post
Share on other sites

When FSX was first out there was a lot of hope when the Mip Map solution came up, which eliminated the blurries. The problem is shimmering was introduced, which also made the screen somewhat grainy. If I have no filtering set in FSX, it will eliminate the blurries but shimmering will occur. If I add bilnear,or trilinear the blurries will come back. Carl

Share this post


Link to post
Share on other sites

thanks,Will give it a try since that is one that I have not tried and would be most obvious. Carl

Share this post


Link to post
Share on other sites

Hi Carl, what's your Global Texture Quality at? If maxed, perhaps try a notch or two lower. IMHO, many of the blurries statements make sense because 256/320MB GPUs won't bite FSX at max texture sizes (1024x textures), high settings and hi AA/AF. The 'scenery composition' blurries and not enough resources causing blurries are two separate issues as far as I would dare to judge. Kind regards Jaap

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this