Archived

This topic is now archived and is closed to further replies.

ideoplastic

Antialiasing

Recommended Posts

Over the years I have read in various Forae that Antialiasshould be adjusted in the Graphic Card settings and turned offinside the Sim.Some months ago I purchased an Nvidia 8800GT and after playing with the settings I found I still had jaggies, even though ithad been set to the highest level. So I tried having it enabledin both FS and Graphic Card settings and found all my jaggieshad disappeared. What is more haven't found any hit in performance,but rather a slight improvement.Similar contradictory result with the Render to Texture setting.Turned it off even though I use some DXT textures and never hada single crash.Question is, how much should we trust these so called settingstweaks in Forae. Regards

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The simple answer is that if it works for you and your system, go for it and don't worry about anything else. Every PC seems to have a very slightly different configuration and some things that work for one person may not work at all for another and vice versa. If your sim performance is actually improved by setting AA to on, even better! JS

Share this post


Link to post
Share on other sites

My experience as well. I switched from a Radeon 1650 Pro to the Geforce 8800 GT and run AA "on" in the sim and at 16X in Nhancer. I also have trilinear filtering set in the sim and the graphics and frame rates are great.

Share this post


Link to post
Share on other sites

Thanks guys for the replies, good to know some of you areexperiencing similar results.Regards

Share this post


Link to post
Share on other sites

Search the hardware forum, for the way to unlock the power of your new card. You are seeing the full effect of it yet. You have to copy the FS profile, then delete it, or something like this.Rick

Share this post


Link to post
Share on other sites

Yes, Antialiasing is weird with the newer Nvidia cards.In fact, I think I had better AA and better frame rates with my 7800 SLI setup!!!!! If you h4X0r about being 1337, then you can adjust the settings. 16XS is awesome but waaaaay to slow for me on a 8800GT.So I just went back to application controlled and left it at that.

Share this post


Link to post
Share on other sites

Bought a nVidea 7600GS 4 months ago and, with nHancer, I get excellent results. I, too, have AA activated on FS9, contrary to all I've read, and my jaggies are virtually gone with great FPS. It really does depend on one's system and thinking 'outside the box' is often a good thing.Bob

Share this post


Link to post
Share on other sites

I suspect that what is being reported here is a difference between ATI and nVidia cards. No question that using the videocard settings in my system is far preferable to doing it in the sim.But then, I do have an older system and a less than cutting edge ATI card. I also still have the cost differential in my bank account.:-beerchugMy antiquegigaByte 8INXP @ Intel P4@3.06 HT Enabled2G PC 266RAM3 7200RPM ATA HDsTurtle Beach Santa Cruz soundATI Radeon x850Pro 256, CAT 8.4 w/o Cat Control Center (ATI Tray Tools)WinXP SP3Ed GreenKCLT


http://www.oncourse-software.co.uk/forum_images/fdc_beta.jpg

Share this post


Link to post
Share on other sites

My AA works only with AA turned on in game also. But for some strange reason, my 2D panel doesn't completely fill up the screen (thus leaving some tiny strips on the edges) when AA is turned on in the Hardware settings in FS9. I've played with the settings but AA is the culprit of my 2D problem. I guess I just have to run FS9 w/o AA even though my system is more than enough to run all settings maxed with high AA/AF.But has anyone had this problem before? If so, what did you do to fix it?System specs: E8400, Rampage Formula, Crucial Ballistix 4GB, 9800GTX, Windows XP SP2, LG L246WP.

Share this post


Link to post
Share on other sites

Just went through it myself with an 8800GT. I found that if I left an FS9 game profile active in nHanser or the Nvidia control panel (they're connected, BTW), no manner of jiggering with nHanser, the Nvidia control panel settings or in-game settings would enable any level of AA in FS9. The jaggies would not go away. I tried to delete the game profile, but it would not delete. Finally, I deleted nHanser's FS9 game profile association with the corresponding "FS9.exe" file. nHanser complained the profile would not autoload because I had deleted its .exe file. "Good." I mumbled. "That's the point." I looked in on Nvidia's control panel and found the nHanser action had also deleted the FS9 profile in the N's control panel. They are connected. Then, I went back into nHanser and set the Global settings to AA Combined/8xS, "Enhance in-game AA settings" Off, Gamma correction On, AS to 16X, Vert Sync On. The idea was FS9 would then use these Global settings. Then, I fired up the game and checked AA in FS9's hardware tab. Bingo. Finally, I got AA. Looks pretty good too. With FS9 versions of my FSX-standard scenery/mesh/landclass add-on sets of GE/FE/UT/FSG and the FSG landclass, I Can tell a difference between my standard benchie: "Manhattan Flyby, Hudson River run" in FS9 vs FSX . . . but Not much. It's such pleasure to turn the corner over Manhattan at RW31's IAP at 40-60 FPS in the PMDG 744. Such a pleasure.

Share this post


Link to post
Share on other sites

If you have a flat panel monitor (LCD) this problemcould be caused by the wrong scaling setting.Go to Nvidia settings and choose (if available)the option to use your monitor's built in scaling.Good luck.Regards

Share this post


Link to post
Share on other sites

Hi, Sam. In all my installs and uninstalls between my nVidia card and the ATI X2 I've been doing over the past month based on some of your suggestions (and everyone elses) over in the Hardware Forum, I have learned that the two secrets with the nVidia card on my system was to COPY the default FS9 profile in nHancer, as directed in the various recent threads, and then go back to the v169 drivers. The copying of the default profile is critical -- I always rename the copied profile and disassociate it from fs9.exe, too -- as is the complete reboot after setting preferences. AA is now sharp as a tack on my 8800 GTX.This whole AA/nHancer/Control Panel/Add/Delete/Driver Clean/Boot/Reboot has had me pulling my hair out and has been a big time waster in diagnosing my other problems -- this is exactly why I ended up running to ATI last year.BTW. I just finished reformtting my hard drive and reinstalling XP -- tonight I reinstall FS9 and hopefully fly all weekend. But that's a story for another . . . er . . . forum.

Share this post


Link to post
Share on other sites

By whatever means, the trick (for FS9) is to remove Any nVidia profile association with FS9.exe. FS9 does not like to run with a profile. Don't let nVidia load a profile for FS9. Force the sim to run with the Global settings. Do whatever is necessary to disassociate the FS9.exe with Any Control panel or nHanser profile. If copy/paste/stand-on-one's-head does that, do that. Then check the AA box in the game. FSX runs OK with nVidia's profile feature. Nothing special there except to select a good set of options in the FSX profile.

Share this post


Link to post
Share on other sites

>FS9 does not like to run with a profile. Don't let nVidia load a >profile for FS9.I

Share this post


Link to post
Share on other sites

To D17S and DJT01:First off thanks for the posts - I'm testing....First thing - what do you both have set in nhancer for both the Optimziations and Compatibility tabs? I only read your option settings for the Enhancement tab. Also should it always be Global that is selected at the top right corner of the nhancer screen and not Profile?Second - could each of you let me know what values you have in your FS9.CFG file for the following parameters:UPPER_FRAMERATE_LIMITTEXTURE_BANDWIDTH_MULTTextureMaxLoadThanks and I will continue to test.

Share this post


Link to post
Share on other sites

>To D17S and DJT01:>>First off thanks for the posts - I'm testing....>>First thing - what do you both have set in nhancer for both>the Optimziations and Compatibility tabs? I only read your>option settings for the Enhancement tab. Also should it>always be Global that is selected at the top right corner of>the nhancer screen and not Profile?>>Second - could each of you let me know what values you have in>your FS9.CFG file for the following parameters:>>UPPER_FRAMERATE_LIMIT>TEXTURE_BANDWIDTH_MULT>TextureMaxLoad>>Thanks and I will continue to test.>I

Share this post


Link to post
Share on other sites

Ok thanks and oh forgot to ask you - in your lovely screenshots - what airport is that in the very first screen shot of your set of awesome pics I might add (again)? :)Thanks again.

Share this post


Link to post
Share on other sites

>Ok thanks and oh forgot to ask you - in your lovely>screenshots - what airport is that in the very first screen>shot of your set of awesome pics I might add (again)? :)>>Thanks again.It

Share this post


Link to post
Share on other sites

Great: I'll look into it.And as before, what are your nhancer settings for all three tabs - not just the first one (Enhancements)?Thanks.

Share this post


Link to post
Share on other sites

Here's the drill ("Quote from another post")"Scroll down the profile list until you find the Microsoft Flight Simulator 2004 (or) Microsoft Flight Simulator X profile. Click on it once to highlight it. Once it is highlighted, click the DUPLICATE button. You will get a message, select YES to complete the duplication. What that will do is DEACTIVATE the Nvidia profile and ACTIVATE your new duplicate.b.With the new profile in the list, make sure there is a bullet in PROFILE on the right. Go down the list on the right and select the following:AA:For FSX select SUPERSAMPLING and 8xS (use 8xS Steve)NOTE: Slower cards and systems in FSX, set to MUTISAMPLING and 4X or SUPERSAMPLING and 4xSNOTE: FOR THE BETA VERSION THIS HAS CHANGED... SET AA TO COMBINED 8xSUnder the next box, check GAMMA CORRECTIONDO NOT ENABLE THE SECOND SUPERSAMPLE FEATURE IN THIS AREAUNCHECK "ENHANCED AA" if it is checked by defaultAF: CHECKEDBullet in: 16XVERTICAL SYNC: CHECKED, Bullet in: FORCE ONOPTIMIZATIONS Tab:Texture Filtering CHECKED Bullet in - High QualityTrilinear Opt CHECKED, Bullet in - OffAniso. sample opt. CHECKED, Bullet in - OffNegative LOD BIAS, CHECKED, Bullet in - ClampCheck the next three items but do not change their valuesCOMPATABILITY TAB:Place a CHECK in all header values but only change the following if needed:Force Mip-Maps = NONEConformant Texture Clamp = ONHi Dynamic Range HDR (Enabled)All others should be at their default values.Under the CPU Multicore Support, REGARDLESS OF THE TYPE OF CPU YOU USE:FOR WINDOWSXP SET CPU TO SINGLEFOR WINDOWS VISTA SET CPU TO MULTICORE"If still no joy, delete the FS9.exe association and let FS9 use the global settings. The Global/Profile check boxes only select which mode you are setting. The setting remain in effect just as if you set them in Nvidia's control panel . . . because that's where you are setting then. nHancer is just a an (e)nhansed GUI for the regular panel.

Share this post


Link to post
Share on other sites

Thanks for all this guys - i can see my sim working better already - and lots better (so far) with lots of weather - especially clouds - it would really slow down once a lot of clouds were present.However, now with these changes, it's starting to run a lot better with more 'weather' present.Thanks again and KEEP the help and tweaks coming.Later.Paul.

Share this post


Link to post
Share on other sites

>Great: I'll look into it.>>And as before, what are your nhancer settings for all three>tabs - not just the first one (Enhancements)?>>Thanks.pgaudet,The results in the screens above were not obtained from using nHancer but just the Nvidia 175.16

Share this post


Link to post
Share on other sites

Well I currently run FS9 on a Gateway PIV 2.4 Ghz with 4GB Ram on Windows XP (3.3 GB recognized by XP as not 64 bit operating system) and a nvidia 7600 GS 512MB vid card using video driver version 174.74.160GB internal drive - 300 GB and 500 GB external drives.Yes the machine is a few years old now but still runs FS9 pretty good. I've capped my frames at 26 fps.Have any of you used version 174.74 of the drivers before? and do you think I could get any more fps' from switching to the 175.16 version drivers?Thanks once again.Paul.

Share this post


Link to post
Share on other sites

>Have any of you used version 174.74 of the drivers before? >and do you think I could get any more fps' from switching to>the 175.16 version drivers?I update drivers every time there is a new beta at Nzone.com or a WQHL at Nvidia.com, so yes I have used the 174.74

Share this post


Link to post
Share on other sites