Archived

This topic is now archived and is closed to further replies.

Guest soberon

Vertical Sharp Lines

Recommended Posts

It only happens in fsx, not fs9. It does not always happens. It comes and goes. And it is annoying. tens to hundreds black vertical lines in bunches together from the ground to high in the sky.It is not vista , as I play in xp. And I didn't have the problem in the past.Anyone please?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

did you install Acceleration?My current system cant handle it. I got the black lines (autogen spikes?). I removed Accelerationand I've been fine since.

Share this post


Link to post
Share on other sites

Video driver is/could be corrupt or incompatible; uninstall - reboot to safe mode - reinstall. If this doesn't fix it - go forward to the latest drivers, and if still not fixed - go backwards to previous drivers.This problem is (almost, he said with crossed fingers) video drivers, as the guys above have said.Regards,

Share this post


Link to post
Share on other sites
Thats a video memory issue, usually following by FS crashing
Do you think its more than that? Graphical anomalies like this and floating autogen (etc) have been attributed to video memory problems (not enough). Assuming drivers and hardware are fine, asking for less (cutting back on sliders) can fix this. However, in FS9 I never remember this happening. Asking for too much in FS9 only seemed to decrease FPS, whereas in FSX these graphical anomalies seem to be an additional manifestation of asking for too much. If so, I wonder if FSX is programmed differently than FS9 to get better FPS at the cost of graphical integrity? I would personally, rather have a momentary drop in FPS than these glitches.

Share this post


Link to post
Share on other sites

Yes, FSX is written much differently then fs9Soberon, What video card do you have? Other specs might help, also.Bob

Share this post


Link to post
Share on other sites

What would be especially helpful, is the information why it SOMETIMES happens, not always. Althought starting in the same configuration, same setting of sliders, same airport, aircraft etc...My hardware must be sufficient as it is all high end especially bought for fsx.

Share this post


Link to post
Share on other sites

After googling around it seems indeed, like someone said, that the name for the lines is "autogen spikes"One phrase got my attention in particular as I did not understand itFPS drops to single digits when these spikes appear so the texture de-grade down to lower mip levelsdoes someone can explain? I found it onhttp://www.flightsimworld.com/forums/index...howtopic=142905where the topic was discussed

Share this post


Link to post
Share on other sites

I tried tweaking the fsx.config in order to get a better cpu performance but I got left with small white dots flickering on the edge of the gauges. So I replaced the original fsx.config , that I had backupped, but the dots stayed.

Share this post


Link to post
Share on other sites

I had gotten that strange grapic problem before I think its a weried bug or something, most likely. I would love to know exactly what causes it but I think its going remain a mystery. and I have in old setup E6600 evga 7800GS CO. 2gigs of ram.

Share this post


Link to post
Share on other sites
Thats a video memory issue, usually following by FS crashing
I agree. It has been discussed often over on the Hardware Forum. When it happened to me on my high end system, I lowered some of my scenery sliders and turned off Autogen and it went away. The main setting that affected my system was the top scenery slider, the Level of Detail radius. I lowered it from High to Medium and the problem went away. I turned it back to High and the problem came back. I suspect having your settings turned way up on your video card, plus settings turned way up in FSX.cfg, plus using a commercial aircraft and using commercial scenery will hurt any current system. When you see the spikes, check out your fps and see how low they are getting. The good thing: you can fix this problem.Best regards,Jim

Share this post


Link to post
Share on other sites
When you see the spikes, check out your fps and see how low they are getting. The good thing: you can fix this problem.Best regards,Jim
What I notice is that FPS is almost normal for the level of detail desired, except that some spikes and floating autogen appear. Then, without changing any sliders, the spikes and floating autogen gets worse until finally, FPS tanks and the are major graphical problems (transparent plane, blank screen, etc). It

Share this post


Link to post
Share on other sites

I'm not a computer guy so take this for what its worth:In looking at your system specs, it seems you have .9Gig in total video memory but only 2Gig of system memory.I would add another 2Gig. (or jump immediately to 8Gig and just use your Vista64)

Share this post


Link to post
Share on other sites

I got the spikes when I installed a freeware alternative set of autogen trees. When I went back to the default, they went away.Petraeus

Share this post


Link to post
Share on other sites
I got the spikes when I installed a freeware alternative set of autogen trees. When I went back to the default, they went away.Petraeus
Was the alternative set bigger in size (pixel x pixel)? If its the same as the default, then I cannot see how that would matter. Interesting.

Share this post


Link to post
Share on other sites

I also like others have floating building around airports in times when the autogen spikes come to visit. But still , no clue as to why one time they are there and another not.

Share this post


Link to post
Share on other sites

The others who said it is a video memory saturation issue are most likely correct;and keep in mind it is inconsistent--sometimes it will occur, and other times, no. It seems to be limited to SP2/Accel also, which some of us concluded may be because of the new autogen batching introduced in SP2.There is another recent thread about this. It's been discussed in the last couple of weeks I know, so you may want to search for that thread.

Share this post


Link to post
Share on other sites

This is DEFINITLY an unfixed bug in FSX SP2 and there is no definite cure. It goes away when you deinstall SP2 or dramatically lower your settings, which is nonsense on highend systems. What I did, I installed lower resolution Autogen textures. No visual difference, but obviously less load on your VRAM.Don't let anyone here tell you that it is related to your hardware... it can happen to anyone with any system, it is A BUG IN FSX. I get it on fresh installs no matter if Vista or XP, no matter how much RAM, no matter which airport or settings. You will have to fiddle around and try to find a way to make it work. If you can't - thank Microsoft.

Share this post


Link to post
Share on other sites
This is DEFINITLY an unfixed bug in FSX SP2 and there is no definite cure. It goes away when you deinstall SP2 or dramatically lower your settings, which is nonsense on highend systems. What I did, I installed lower resolution Autogen textures. No visual difference, but obviously less load on your VRAM.Don't let anyone here tell you that it is related to your hardware... it can happen to anyone with any system, it is A BUG IN FSX. I get it on fresh installs no matter if Vista or XP, no matter how much RAM, no matter which airport or settings. You will have to fiddle around and try to find a way to make it work. If you can't - thank Microsoft.
Hmmm...FWIW, with the specs below, and SP2, AI @ 40%, Scenery objects @ max, Terrain max or nearly so, ingame filtering(not because I have too), 178... drivers( system freezes with the new ones) fresh install of Vista 32 , no autogen spikes. I got them before reformat with anything newer than 169.25 drivers. Right now I'm sitting on runway 27 at Heathrow, middle of the day, major thunderstorm, getting wet 'cause I'm in the trike, 26 fps(that's my lock). If I look at the terminal fps goes down, of course. All I mean is that it's hard to speak in definites when everybody's box is so different.Bob

Share this post


Link to post
Share on other sites
Hmmm...FWIW, with the specs below, and SP2, AI @ 40%, Scenery objects @ max, Terrain max or nearly so, ingame filtering(not because I have too), 178... drivers( system freezes with the new ones) fresh install of Vista 32 , no autogen spikes. I got them before reformat with anything newer than 169.25 drivers. Right now I'm sitting on runway 27 at Heathrow, middle of the day, major thunderstorm, getting wet 'cause I'm in the trike, 26 fps(that's my lock). If I look at the terminal fps goes down, of course. All I mean is that it's hard to speak in definites when everybody's box is so different.Bob
I'm not saying everybody gets them. But the bottom line of all threads on this and other FSX boards is that it is totally random and there is no known 'fix'. One might be lucky, or find a workaround, but SP2 has this issue and there is no denying it. It has nothing to do with the slider settings.

Share this post


Link to post
Share on other sites
I'm not saying everybody gets them. But the bottom line of all threads on this and other FSX boards is that it is totally random and there is no known 'fix'. One might be lucky, or find a workaround, but SP2 has this issue and there is no denying it. It has nothing to do with the slider settings.
Have you experimented with your BufferPool setting as outlined in the above-mentioned thread? It may very well solve the problem, as it has for others...

Share this post


Link to post
Share on other sites
I'm not saying everybody gets them. But the bottom line of all threads on this and other FSX boards is that it is totally random and there is no known 'fix'. One might be lucky, or find a workaround, but SP2 has this issue and there is no denying it. It has nothing to do with the slider settings.
Hey, no problem. I was just trying to figure out why something that is totaly random could be a bug. Especially when(as in my case) I had another problem ( I thought.) But I guess it's SP2 since Nvidia drivers are perfect. :( Bob

Share this post


Link to post
Share on other sites
Was the alternative set bigger in size (pixel x pixel)? If its the same as the default, then I cannot see how that would matter. Interesting.
From memory Yes, the alternative set was bigger.Petraeus

Share this post


Link to post
Share on other sites