Sign in to follow this  
Bert Pieke

If you are using RXP GNS gauges

Recommended Posts

The Malibu starts up with the default GPS and wants you to go to the configuration windowevery time you start up the plane, to select the RXP gauges..If you would like to make this choice permanent, this is how you do it..First of all, make sure the RXP gauges are installed and working in the Malibu.Then, create a text file with this content

<Gauge Name="Control_init" Version="1.0"><!-- RXP gauges -->  <Element>	 <Select>	  <Value>		  (L:ControlInit,bool) 1 != if{			1 (>L:SWGPS530XPVIS,bool)			1 (>L:SWGPS430XPVIS,bool)  			1 (>L:ControlInit,bool)							 }		  </Value>		 </Select>   </Element></Gauge>

call this file Control_Init.xml and put it in a new subfolderto your panel folder, named Controls.Then edit your panel.cfg file, by adding one line[Vcockpit01].....gauge07=Controls!Control_init, 0,0,1,1If you only have one RXP gauge, try deleting the GPSXXXVIS line that does not apply.

Edited by Bert Pieke

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This is nice but I only use GNS430W and with it enabled their stock GPS doesn't work... I can't manipulate any of the buttons. Am I the only one using the jetprop with just the 430W?

Share this post


Link to post
Share on other sites

Hi guys,is the reality xp working well, I mean apart the problem Bert is pointing out? Does it support both reality xp gns 530 and 430 in 3D?Thanks

Share this post


Link to post
Share on other sites
Hi guys, is the reality xp working well, I mean apart the problem Bert is pointing out? Does it support both reality xp gns 530 and 430 in 3D? Thanks
Yes, it does.

Share this post


Link to post
Share on other sites

Neat airplane, a lot to like. However, I have noticed one problem when RXP GNS are enabled (I have both the 430 and 530).After selecting RXP from the window (I haven't performed the XML edit) they units appear and work just fine. However, several buttons on avionics around the GNS no longer work. None of the buttons on the digital transponder work, I can't tune the ADF, nor can I increase / decrease the radar range.Any other RXP users experiencing this? The buttons work fine with the Carenado GNS units installed.

Share this post


Link to post
Share on other sites
Neat airplane, a lot to like. However, I have noticed one problem when RXP GNS are enabled (I have both the 430 and 530).After selecting RXP from the window (I haven't performed the XML edit) they units appear and work just fine. However, several buttons on avionics around the GNS no longer work. None of the buttons on the digital transponder work, I can't tune the ADF, nor can I increase / decrease the radar range.Any other RXP users experiencing this? The buttons work fine with the Carenado GNS units installed.
Ding ding ding we have a winner! Thank you! Finally someone who actually tried the plane! YES! I just got my money back by my request and was hoping they'd fix this. So the clickspots disappear with the 530W too? I own the 430W and was having these issues.

Share this post


Link to post
Share on other sites

Yes, it is a problem with the 430/530 combination as well. Has anyone reported this to Carenado? As this is an unofficial forum perhaps I shouldn't assume they will see this problem and instead report it to them directly. I tried the RXP transponder and audio panel; they worked fine but their apperance didn't match, They had bright silver panels rather than black to match the other avionics, Other than that they worked. Obviously all of Carenado's customers wouldn't have those addons.

Share this post


Link to post
Share on other sites

Thanks - I reported it as well. I got a message from Carenado support this morning stating that they are working on a patch for it so I'm sure this will be fixed soon. This bug is the biggest issue but not the only one. Of course, some of the issues may be because I don't know what I'm doing!It does appear to me that the ICE DOOR switch does nothing. I would expect a drop in torque and the ICE DOOR indicator to change but it doesn't. Likewise placing the IGNITION switch in the AUTO mode results in the IGNITION indicator staying lit continuously. I would expect the IGNITION indicator to only come on when torque was reduced below a certain value, not stay on continuously. The TAXI LIGHTS switch is labeled as three position switch (PULSE / TAXI / OFF) but it only has two positions, TAXI and OFF.Obviously none of these are dealbreakers and I really do enjoy flying the plane. The flight dynamics feel very real to me, and it is beautiful to look at like all Carenado aircraft.I still wish some of these small problems could be fixed. Or maybe it is just me? Anyone else observed these switch problems?

Share this post


Link to post
Share on other sites

One more thing for GNS530W users - If it nags you about setting the Course,you need to add one line in the rxpgns.ini file for this airplane (since the G500sets the course for you..)AutoCourse=On

Share this post


Link to post
Share on other sites

I just installed the Carenado patch and it fixed the buttons around the RXP GNS units. It also seems to have eliminated the menu box that you had to check after loading the plane to use the RXP units. After I ran the RXP installer program the airplane loaded with both RXP units in the panel.Thanks Carenado for a very fast fix! Now, about that ICE DOOR, AUTO IGNITION, TAXI LIGHT...

Share this post


Link to post
Share on other sites

Bert,Thanks again for your Malibu (and other...) files.Because Carenado has just issued a SP for the Malibu, are your two files (one, with the AP changes and the other for having RXP gauges permanent) still good?(I mean do they correct or enhance anything not covered by the SP).Thanks!

Share this post


Link to post
Share on other sites
The Malibu starts up with the default GPS and wants you to go to the configuration windowevery time you start up the plane, to select the RXP gauges..If you would like to make this choice permanent, this is how you do it..First of all, make sure the RXP gauges are installed and working in the Malibu.Then, create a text file with this content
<Gauge Name="Control_init" Version="1.0"><!-- RXP gauges -->  <Element>	 <Select>	  <Value>		  (L:ControlInit,bool) 1 != if{			1 (>L:SWGPS530XPVIS,bool)			1 (>L:SWGPS430XPVIS,bool)  			1 (>L:ControlInit,bool)							 }		  </Value>		 </Select>   </Element></Gauge>

call this file Control_Init.xml and put it in a new subfolderto your panel folder, named Controls.Then edit your panel.cfg file, by adding one line[Vcockpit01].....gauge07=Controls!Control_init, 0,0,1,1If you only have one RXP gauge, try deleting the GPSXXXVIS line that does not apply.

One other thing to note is that the original release makes no attempt to generate a RXPGNS.ini file - if you want to configure these gauges to enable the full functionality you need to run the RXP configuration tool. Users of the Unlimited gauges should edit the panel.cfg and substitute the _2 version for one of the gauges as well.DJ

Share this post


Link to post
Share on other sites

This modification should no longer be required if you have SP1 installed.Regarding the ini file, yes you have to create one using the RXP config app, or copy one from another aircraft.Important is, to add AutoCourse=On, or the G530 will nag you about setting the correct course..Not sure you have to have a _2 gauge for Unlimited to do it's thing... just add Crossfill=On.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this