Jump to content
Sign in to follow this  
Rockliffe

Just one big stutter

Recommended Posts

All in all I'm pretty pleased with how I've got FSX running. Sure, we always want more but, overall I'm pretty happy... except... although the flying is pretty smooth, for some reason that I can't remember seeing before, I seem to have dveleoped a stutter every so often. It's got quite annoying because when it happens it's as though the whole screen jumps. It often happens about five seconds after changing views. I have done all the obvious things. Tried with AG set to sparse, no difference, tried a vanillla cfg, no change. I've tried three alternative Nvidia drivers, no change. I've tried all manner of different settings in Inspector but still with no change. Different cfg tweaks such as bufferpools, no change. I've tried shutting programs down in the background, no change. I've tried flying with AV and the firewall switched off and hey, guess what? No change. So fellas, is there anything that I've missed or any magic cure that one of you could suggest. I will wait with baited breath and hope I can get to the bottom of this....cheers :(


Howard
P3DV4.5, MSFS2020, MSI Mag Z490 Tomahawk MB, i7-10700 CPU @ 4.8ghz, Nvidia RTX3090 GPU, 32gb RAM@3200Mhz, SSD/2Tb+SSD/500Gb+OS, Corsair 1000W PSU, Philips BDM4350UC 43" 4K IPS, MFG Crosswinds, TQ6 Throttle, Fulcrum One Yoke

Share this post


Link to post
Share on other sites

Uhhhhhh..........a really hard one.You basically counted everything except new installs.I don't know what to say else.

Share this post


Link to post
Share on other sites

Glad you've brought this up as I more or less have everything running as smoothly as I can, and yet, like you a I get a momentary blip/stutter which I have never quite figured out why it does so. I have all the usual tweaks, i.e. Buffer Pools, MemFix,,etc,etc. So,it will be very interesting to see what feedback you get on this.


Rick Almeida

Share this post


Link to post
Share on other sites

You may still have something that comes on in the background - I found I had to run Procmon to trap the fact that Java was checking for updates and would briefly interrupt FSX. Try running Procmon concurrently with FSX and pause FSX right after a stutter.Skip out of FSX, stop Procmon and see what was happening - you'll quickly spot if anything but FSX commands was executing...If it is Java, uncheck Quickstarter..

Edited by Bert Pieke

Bert

Share this post


Link to post
Share on other sites

Here's a question for the techies: Would increasing the amount of pre-bufferred frames help with stutter?

Share this post


Link to post
Share on other sites
Guest

Odd. Does it only happen when you switch views? The only thing I can think of right now is look at the hardware. You didn't mention you did that. So pull the ram out and the GPU and put them back in. The same for the hard disks and ssd's. I didn't have this kind of stutter, but I did have a problem with stuff locking up which, so I found out after a loooooooong time, simply had to do with the ssd cable not sitting tight in the socket. Since you tried all software options, this might help.... maybe... If you have a few sticks of ram, try flying with half of it. Things like that. Unplug a hard disk that's not used when you flyt. Et cetera...

Edited by J van E

Share this post


Link to post
Share on other sites
Here's a question for the techies: Would increasing the amount of pre-bufferred frames help with stutter?
Actually, increasing this setting can introduce more stutters. You'll get better performance (more FPS, less stuttering) with a lower count. I can't see it hurting playing around with this, though. I'd say try it!Howard, I know I harp on this issue, but I'm going to mention it anyway. The conclusion I've come to is that most stutters forum members and myself have encountered are effects of certain cloud texture programs and/or AA settings. I know you have a strong card, but it wouldn't hurt to disable AA and see if that clears your symptoms up, then work from there.

___________________________________________________________________________________

Zachary Waddell -- Caravan Driver --

Facebook: http://www.facebook.com/zwaddell

Avsim ToS

Avsim Screenshot Rules

Share this post


Link to post
Share on other sites

Mmm, thanks fellas, some good suggestions there. It's past my bed time now, so I'll try some of these things and let you all know tomorrow... Cheers.


Howard
P3DV4.5, MSFS2020, MSI Mag Z490 Tomahawk MB, i7-10700 CPU @ 4.8ghz, Nvidia RTX3090 GPU, 32gb RAM@3200Mhz, SSD/2Tb+SSD/500Gb+OS, Corsair 1000W PSU, Philips BDM4350UC 43" 4K IPS, MFG Crosswinds, TQ6 Throttle, Fulcrum One Yoke

Share this post


Link to post
Share on other sites
You may still have something that comes on in the background - I found I had to run Procmon to trap the fact that Java was checking for updates and would briefly interrupt FSX. Try running Procmon concurrently with FSX and pause FSX right after a stutter.Skip out of FSX, stop Procmon and see what was happening - you'll quickly spot if anything but FSX commands was executing...If it is Java, uncheck Quickstarter..
Thanks for that tip, Bert, as I do have ProcMon, but my Java is disabled as I do not use the FSX machine to have anything to do with the Net. Nevertheless, it is a worthwhile tip to try soon after a stutter.Mine happens when I'm in Outside View Locked. RAM modules, and GPU only recently taken out for a blow-air dust-off and re-seat to refresh the contact points in respective slots. Nevertheless, good tips. Thanks.

Rick Almeida

Share this post


Link to post
Share on other sites
Howard, I know I harp on this issue, but I'm going to mention it anyway. The conclusion I've come to is that most stutters forum members and myself have encountered are effects of certain cloud texture programs and/or AA settings. I know you have a strong card, but it wouldn't hurt to disable AA and see if that clears your symptoms up, then work from there.
Zach, amazingly, you could be on a winner there, because this happens when I have my weather set to download from Jeppessen(hope that's spelt right),and sometimes I will get an error message sometimes not. But I have the weather being controlled by FSUIPC, so why should that make a difference?

Rick Almeida

Share this post


Link to post
Share on other sites
Zach, amazingly, you could be on a winner there, because this happens when I have my weather set to download from Jeppessen(hope that's spelt right),and sometimes I will get an error message sometimes not. But I have the weather being controlled by FSUIPC, so why should that make a difference?
I'm going to try and keep this post on topic, so PM me the error message you're getting. I'll be able to sit down and get to it once I leave work.

___________________________________________________________________________________

Zachary Waddell -- Caravan Driver --

Facebook: http://www.facebook.com/zwaddell

Avsim ToS

Avsim Screenshot Rules

Share this post


Link to post
Share on other sites

Concerning the buffer: I see major differences with 1 and 8, 1 being much smoother than 8. I think I'll keep it at default 3, since I have a feeling that it actually starts to stutter more at 1 than at 3 when in a dense autogen area.

Share this post


Link to post
Share on other sites
I'm going to try and keep this post on topic, so PM me the error message you're getting. I'll be able to sit down and get to it once I leave work.
Thanks Zach, but after a very, very late night last night, I've shut down the sim for tonight, but will do

Rick Almeida

Share this post


Link to post
Share on other sites

HowardThe last time I catalogued stutter causes in FSX I got to about 20 and gave up.A couple or so that seem to crop up more frequently.Any tweaks to the fsx.cfg file and complex nvidia Inspector settings.Overclocking cpu or gpu.SLI cards one slightly out of sync.Vsync turned on plus no triple buffering and fps limit not set to 60 fps can give rise to a stutter (which is idiosyncratic and intermittent).'Pause on task switch' is ticked in the sim.Using 'override application settings' in nvidia Inspector as someone says above just try default settings in the nvidia control panel plus rebuilt fsx config, latest driver (workable) as a clean install with nothing checked letting FSX set its own AA/AF, no vsync etc and see if that helps.As I say the list goes on and on and again using VMMAP as the stutter gets more pronounced/frequent so does fragmentation of the VAS (on my system)Food for thought.PeterH

Share this post


Link to post
Share on other sites

Howard - don't know whether this is valid anymore, but I did have this issue back about a year or so ago - every 4-5 seconds the whole screen 'hesitated' .... 'jumped'... for a split second. I turned off EZCA - Gone.. turned it back on, and it was back. In the interim we might have gone up a couple of version iterations, and it has fully disappeared - gone - and I have no idea what fixed it.



i7 4790K@4.8GHz | 32GB RAM | EVGA RTX 3080Ti | Maximus Hero VII | 512GB 860 Pro | 512GB 850 Pro | 256GB 840 Pro | 2TB 860 QVO | 1TB WD HDD Black.| Seagate 3TB Cloud | X750W | Win10 Pro | EK Custom water cooling.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...