Sign in to follow this  
Sesquashtoo

Hooray! Instructions to get no more DEP induced BEX or STACK errors/crashes

Recommended Posts

For W7  (probably W8 as well?!?) users:

 

Follow these instruction EXACTLY!  If after following these instructions to universally turn off D(ata)E(xecute)P(rotection aka; DEP you receive in the command box 'operation successful ', congrats, you just ended your BEV and StackHash errors crashing FSX.

 

You can always turn DEP back on by the same instructions. If you have gotten these errors with FSX freezing or shutting down (CTD) try this solution. If you have adequate protections in place, you most likely don't need DEP (you never had it with XP) plaguing you.  DEP has been known to shut down legitimate programs and processes like FSX or programs you have running alongside it.

 

Important!---->  when typing the command prompt, do it exactly, with spaces as seen and the proper brackets as shown. If you do not get a  'operation successful' on the first attempt, just take your time and make sure your entry is as shown. It took me a couple of times typing it before I got a 'successful' reply in the command box.

 

A suggestion, so this post doesn't get buried...it should be pinned to the top.

 

Cheers!

 

If DEP's analysis of a process startup execution makes DEP think the resulting code will cause some sort of unwanted activity, DEP intervenes and shuts down the process.

It sounds good in theory, but DEP also shuts down legitimate programs such as FSX and FS9 in some cases.

If you have adequate defenses in place, DEP won't really provide you any benefit and will likely get in your way. You can turn it off completely.

Turning DEP off requires the use of the command prompt space. 

1. Open the Start menu, and in the search box, type "Cmd" and wait for the results box to populate. 

2. Right-click on the cmd shortcut that appears and select Run as administrator. You'll probably have to acknowledge a UAC prompt to get it done unless you have already turned UAC off.

3. Once you're at the command prompt, type the following:

4. bcdedit.exe /set {current} nx AlwaysOff

You should get a success message back. 

If you ever want to turn it back on, use the same procedure to get to an elevated command prompt, and then type:

bcdedit.exe /set {current} nx AlwaysOn

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Mitch, check this link.  Maybe creating an exception is better?

 

http://ask-leo.com/how_do_i_turn_off_data_execution_prevention_errors.html

Perhaps, but when I try to exclude fsx.exe using the procedure that's recommended in the link you provide, I get this message: "This program must run with data execution protection (DEP) enabled. You cannot turn off DEP for this program."

Share this post


Link to post
Share on other sites

Mitch, check this link.  Maybe creating an exception is better?

 

http://ask-leo.com/how_do_i_turn_off_data_execution_prevention_errors.html

Wayne, you can't except FSX.  You have to turn DEP right off, in the manner that I posted.  It does work!  

 

Perhaps, but when I try to exclude fsx.exe using the procedure that's recommended in the link you provide, I get this message: "This program must run with data execution protection (DEP) enabled. You cannot turn off DEP for this program."

That is true.  W7 will not let you to turn off DEP from monitoring FSX.  You need to run the command module and follow what I posted. That will do the trick. I have my DEF turned off and have had no further crashes with FSX at any time of the flight, or with what programs I am running with it.  This was a major cause of BEX and stackhash close-downs of FSX.

 

Mitch, check this link.  Maybe creating an exception is better?

 

http://ask-leo.com/how_do_i_turn_off_data_execution_prevention_errors.html

Dave, as I posted to others in this thread, you can't execpt FSX from DEF. You have to totally shut it down.  I really don't need that W7 feature as I have not had it in other O.S.'s and still follow my system security protocols. I'm not missing it!  I am not missing all the FSX crashes this sub-routine causes. That's for sure.

Share this post


Link to post
Share on other sites

This is an automatic message.

This topic has been moved from "MS FSX Forum" to "Crash To Desktop (CTD) Forum". This move has been done for a number of possible reasons.



There are many individuals with BEX and Stackhash errors here in this forum.  Let's see how many problems this fixes!

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

FYI, this problem did not fix one individual who had this problem - http://forum.avsim.net/topic/403700-fsx-crashing-mid-flight/.  I'm hoping that others with the BEX/StackHash errors report here whether the "fix" as described above works or does not work.

 

Best regards,

Jim

--------------------------------------------

 

Hi Jim,

 

Jim, it might be that this user did not get an actual successful action confirmation from the CMD window.  Before you close that window, you have to verify that you see one/received one. Then...the DEP sub-routine is no longer monitoring programs.  I had to try twice to get that command to be accepted.  Hope this helps.

 

Mitch

Share this post


Link to post
Share on other sites

Thanks for this Tip, I how ever have not be able to get this to work for me I am the user that Jim refered to in previous posts. When entering the above command into the command prompt I get a success response and this is running CMD as an administrator.

 

Thanks

Stuart Turbefield

Share this post


Link to post
Share on other sites

Hi Mitch,

 

Thanks for the update.  I personally hope this helps everyone as the BEX/StackHash error is quite common in FSX.  This is one of the reasons why I moved your post over here so that individuals who have a CTD might see your post.  From my limited research though, this does not work for FSX as FSX requires DEP to run properly.  I will refer members who have this error to this post in the hopes it will fix their issue(s).

 

Thanks for the information!!

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

I've read on some websites that a reboot is required after entering the command.  No mention of it on this thread.  Would I need to reboot after disabling or re-enabling DEP in Windows7?

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

Shouldn't be required as you are doing it in DOS (CMD Mode).  You cannot do it within Windows.  As with any changes to your computer system (services, startup programs, etc.), you should always do a restart.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for your excellent post which gave me hope of stemming the flow of consant BEX crashes (about every 30 minutes- if I'm lucky!) in FSX. I am using by the way a brand new, top spec i7 PC with enough memory, factory delivered 4.3GH Overclocking etc etc and  I have already completely re-installed everything once, thats FSX and all my add-ons, in a desperate effort to fix the problem, After scenery and PMDG aircraft which had no adverse effect, the more add-ons I install, gradually increase the number and frequency of crashes, not too many at first, until I top it out by installing REX + Overdrive and then - meltdown.

 

I tried your fix, got the required positive success message back at the prompt line and bingo - no more BEX crashes....

 

.... except that these have now been replaced in exact timing and number by APPCRASH errors. Reverse the process... BEX crashes, change back again, APPCRASH same timing and frequency.

 

Regrettably, it does not seem to be the answer I was hoping for...   :unknw:

 

Thanks for 24 hours of hope in my sad ongoing fighting with FSX.

 

Any other thoughts gratefully received.

 

Best wishes

 

Andrew

Share this post


Link to post
Share on other sites

Hi guys,

I had had exactly the same problem with OOM. Most of the time when I had a long flight my game crash showing the same message OOM please change setting..blah blah blah (or it was happening with Aerosoft sceneries like Eidhoven X or Budapest etc..) before that I also experienced many problems with blurry textures. (Everything was perfect until I install some add on - I think it was VFR Czech Rep. )

I've read thousand of forums and solutions and what I did was:

1) Fix the scenery manually. Moved some relevant scenery down and some up. Then I have fixed order of my sceneries using great tool FSTScennery (you can google it)

2) I use your (Sesquashtoo)

solution: http://forum.avsim.net/topic/403927-hooray-instructions-to-get-no-more-dep-induced-bev-or-stack-errorscrashes/ (first post on the top)

4. bcdedit.exe /set {current} nx AlwaysOff

 

 

3) Used once again Boyote tool in order to FSX.cfg.

4) The very last thing someone passed me was to perform the same flight where I was getting OOM in Window mode... I stretched the size of the Win and left a RAM and CPU Monitor to check how they behave.

I get no more OOM so far (no more blurry textures either) ... Perform the same flight 4 times yesterday. What I noticed was usage of the memory up to 4.92 RAM and my CPU on 96% when I was over the Alps ( I use Switzerland X scenery) although my frame rates drops drastically when I touch down (but it cause of my specification)

My machine is not like very good one:
AMD FX8120 (8 cores 3.1)
RAM 8 GB
Sapphire HD 5770
1920x1080 48' Samsung
Logitech G940.
Logitech G930.
Windows 7 (no any updates etc... I don't accept them) all security etc. has been switched off.
Pc is used only for FSX.

Also I'm using: http://www.razerzone.com/gamebooster . You will notice a big frame rate improvement.



My add ons. 
GEX
UTX
UT2
REX
AES 
OPUS
Airbus Extended X 1.10
FSUIPC
 
I have 155 additional sceneries (mostly for Europe) 
 
As you can see it is not a great sys spec so if it works on mine should work fine on your "monsters" .
 
Hope it will work for you too. 
Good luck
Jack.

Share this post


Link to post
Share on other sites

Hello, This happened to me too... But I found out in my case Windows 7 updated SP1. This was my problem. After I did a system restore to delete the SP1 update, all worked well with no BEX CTD. Thanks! Ralph...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this