Sign in to follow this  
mrb32854

New 320.18 Nvidia Driver toxic to FS9?

Recommended Posts

Has anybody tried to update their FS9-PC's to the latest 320.18 Nvidia Driver?

 

Seems to have a real negative effect on FS9, doing something to the elemental shading/lighting/reflection-rendering properties of the sim.

 

- Default 172SP's and other default plane’s rotating-icons on the entry-screen seemed to have an overall shadow, with only the doors, float-struts, and seemingly random control-surfaces retaining their correct shading/lighting/coloring aspects, giving the planes an all-over haphazard two or three-tone effect.

 

- This effect from the start-up screen’s rotating icon’s carries through to the 3d-game -world; all over normal coloring/shading is shadowed or otherwise darkened, and the same selective lightening for doors, struts, random parts of the control surfaces was evident, too.

 

- Happens to non-default planes, too.  My Aerowork King-Air had its normally overall bright-white finish dulled down to an almost light-gray.   Only the doors retained their normal bright-white shine.  Also, the ailerons, flaps, and one of the horizontal-stabilizers and elevator were a silvery natural-metal, being neither the dulled/light-gray or original white.  A real 4-tone effect.

 

Reverting to the previous 314.22 driver was a remedy, but, I’d be very interested to learn if any other users had the same or similar experience.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Same effects here:

The rotating default C172SP has a white door and a lot of other planes has strange lightning and shadow effects, kind of "Patchwork"!

 

I tried to install three times the driver but the effects remain; it seems the driver can not read correctly alpha channel textures.

 

I can only say , shame on Nvidia !

Share this post


Link to post
Share on other sites

 

 


I can only say , shame on Nvidia !

There not going to optimize their drivers for an eight yr old program. Switch back to a previous version and goes to show "If it's not broke don't fix it! "

Share this post


Link to post
Share on other sites

I have no problems, this driver increased performance of my FS9 something about 5-10 FPS

 

Peter

Share this post


Link to post
Share on other sites

 

 


There not going to optimize their drivers for an eight yr old program. Switch back to a previous version and goes to show "If it's not broke don't fix it! "

 

Words to live by.

Share this post


Link to post
Share on other sites

Has anybody tried to update their FS9-PC's to the latest 320.18 Nvidia Driver?...

 

.....Reverting to the previous 314.22 driver was a remedy, but, I’d be very interested to learn if any other users had the same or similar experience.

 

I had similar experience with 3.20 beta drivers.   Incorrect lighting and shading etc,  but they were very fast.   I reverted to the 314 drivers and all is ok.

Share this post


Link to post
Share on other sites

Aware of the likely solutions, e.g., roll back to an earlier driver, and, that Nvidia is not going to burn-down the gates in a race to solve the issues in an old game/sim.

 

Still, I like to find out if others are finding similar behaviors/problems as their experiences often can help me map out a solution, or, at least, a work-around.

Share this post


Link to post
Share on other sites

I installed this set a couple of days ago, and found it has given be across FS9/FSX/XPX---25 to 33 percent greater FPS in any situation.

 

Simply amazing, we finally cashed in on the FPS wagon!

 

I also want to say that I have no issues or graphic anomalies with 320.18.  Everything looks as good, as with the last certified driver suite.

 

If somebody is having issues, and also is running the EVGA Precision X software, you have to unlock it from auto-start in windows, reboot, and then do a CLEAN install of the nVidia suite. Then, you fire back up Precision X upon your reboot after you had installed the driver suite, and click the 'start with Window's mask once more. This might be what is causing some to see graphic corruption with FS9.....  Make sure you use the CUSTOM mask on the nVidia install so you can pick what you want to install, and most importantly, that you click on the 'do a clean install' before you run the installer.

 

 

Share this post


Link to post
Share on other sites

Sesquastoo:

 

Tried everything you suggested, and then some.....still getting same 4-tone effects with this driver.

Share this post


Link to post
Share on other sites

Hey!
No problems here at my place with FS9, that 320.18 driver seems OK to me.
Greetz
Jive1

  • Upvote 1

Share this post


Link to post
Share on other sites

Sesquastoo:

 

Tried everything you suggested, and then some.....still getting same 4-tone effects with this driver.

I can't figure out why you would have issues, whereby so many of us, merely installed, and enjoyed. Could it be your settings within nVidia Inspector?  Try removing nVidia Inspector from your system, then shut down. Re-seat your card...in your PCIe slot.  Fire up your system again, and see what gives. If you get satisfying performance, then reinstall  nVidia Inspector, and set it up to your pref's. See what happens then.

 

Hey!

No problems here at my place with FS9, that 320.18 driver seems OK to me.

Greetz

Jive1

For a lot of people...they did a clean install, rebooted, and carried on.....

Share this post


Link to post
Share on other sites

No problem with the new 320.18 driver on either FS9 or FSX in fact both look at lot better. :smile:

Share this post


Link to post
Share on other sites

Maybe the ones with problems are running some tweaks, enb etc?

Share this post


Link to post
Share on other sites

Have seen some weird texture changes,i kicked mine into touch!

Share this post


Link to post
Share on other sites

Finally found this issue being discussed. I too have had the same problem - weird model shading issues like shading depending on camera point of view instead of the light source position, and that patch work effect where the fuselage can have the shade on top and the brighter area under but the passenger and cargo doors are shaded opposite, as is the aircraft nose, giving that weird patchwork effect. 

Share this post


Link to post
Share on other sites

This has happened with every version of Nvidia drivers since 320.xxx for me but I run a gtx 780 so need the 320 or later drivers.  Every version continues to break the FS9 shadows and shading though.

Share this post


Link to post
Share on other sites

Thanks to this thread I was able to solve it by uninstaling the 320 and reinstalling the previous version (314). But the fall in FPS is very very noticeable, specially with clouds in view. I may have to learn to live with this issue..

 

My card is GeForce GT 610, with XP on an old PC. I wonder if this could be solved somehow, as not everyone seem to be having this problem.

Share this post


Link to post
Share on other sites

I run 337.50 and live with the issue when in FS9...  Much less evident in the sim than in the preview box and only seems to affect aircraft (weird)

Share this post


Link to post
Share on other sites

Im having this same issue. Searched high and low about this and could find nothing on it, even posted a topic in the video card section as it was after a video card replacement that this happened. For me, its happening with the 335.28 drivers (latest from nvidia). I'll have to search for older drivers and see what works and what doesnt.

Share this post


Link to post
Share on other sites

Anything before 320.xxx seems to work or maybe it was 314.xxx but if you have a series 7 video card only the newer drivers work and every version has the same issue...

Share this post


Link to post
Share on other sites

I use the latest Nvidia Driver with an old 9800 GT video card which works fine! In fact, the last two updates brought a marked improvement in both graphics quality, speed and smoothness (up to 60% more fps depending on load). But using this card I have never had anyissues whatsoever with FS9 graphics wise.

 

This suggests to me that it is the new cards which cause the problem.

 

Sascha

Share this post


Link to post
Share on other sites

I use the latest Nvidia Driver with an old 9800 GT video card which works fine! In fact, the last two updates brought a marked improvement in both graphics quality, speed and smoothness (up to 60% more fps depending on load). But using this card I have never had anyissues whatsoever with FS9 graphics wise.

 

This suggests to me that it is the new cards which cause the problem.

 

Sascha

Could be Sascha...  I also had the same issue with my 670 SC card before I moved to the 780.   I have seen it with every instance of drivers from 320.xx to the current 337.50

Share this post


Link to post
Share on other sites

Does anybody know if a solution for this weird lighting problem on aircraft in FS9 with Nvidia drivers 320 onwards has been found? Just curious.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this