Archived

This topic is now archived and is closed to further replies.

aviationfan

Good FPS but scenery stuttering

Recommended Posts

Hi all,

 

I am having a problem with stuttering. The best way to describe it is: when I am at a low altitude and look out the window the scenery will hesitate for a split second and then it resumes again. I would call it micro stuttering. This happens with the standard FSX scenery. I have not other scenery installed at the moment.

 

However, I achieve a good performance with a good steady FPS of around 30 with the external framerate limiter in Nvidia Inspector.

I have a good system, custom built for FSX (see my PC specs, with SSD’s), but the stuttering is there no matter what aircraft, weather, display settings, and config settings I try.

 

I have the problem since I had an automatic Nvidia driver update. Before that driver update, FSX ran very smooth with no stutters at all. (also with the B737 NGX)

 

I tried many things: I have put the original system image back, a complete fresh reinstall of Windows 7 and FSX was done, many Nvidia Inspector settings and many fsx.cfg tweaks were tried (with the Software & Hardware Guide available on this site). But the scenery stuttering is still there.

 

The stuttering of the scenery that I see when I look out is very annoying.

 

When I lock the frames internally at 30 FPS, FSX runs very smooth with the default Cessna, but with a complex aircraft like the B737 NGX the frames get low to like 22 FPS and FSX doesn’t run smooth.

 

What can I do to solve this issue?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This has happend very recently to me too. Out of the blue im getting the very same things you describe, and like you say, regardless of any setting within FSX, it make no diffrence what so ever.Sliders way up, or at minimum, the annoying stutter remains.

 

I have tryed the latest drivers, rolled them back, defragged my HDD, ensureed no AV is running and tryed multiple NVIDEA setting, also scanned with Malwarebytes whitch came back clean.

 

Just out of interest, do you or did you have the Q400 installed? Im not pionting the finger at that plane, but i distinctivly remember the stutters happening on the 1st test flight with that plane. Ofcourse it could just be coinsidental that the stutters started at that time and may not have anything to do with it. I uninstalled mine but the stuter remains.

 

You explain it well.

 

The effect on screen is like somthing on the system is bottlenecking, its all smooth then massive jolts in quick succession..then all smooth again. This happens in the air or on the ground.

 

I have also noticed that my fps will be in double digits, around 30, and without me moving or doing anything ( plane parked looking down the runway) my fps suddenly drop to 7, then back to 30, and i can sit here watching it do over n over.

 

Its when the fps drop i get the nasty stutter, but what is causing that i dont know...

My sim has ran fine for 6 years before this, and im outta ideas :(  :sorry:

 

Share this post


Link to post
Share on other sites

Hi,

 

No, I don't have the Q400, and I do not have fps drops like you describe.

I do not have sufficient computer knowledge in order to analyze if there's a bottleneck indeed, and if so what that bottleneck is.

 

I hope someone can help us out.

Share this post


Link to post
Share on other sites

Lock your frame rate at 20.

 

Use a video card driver that gave you the better performance. The newest is not always the best.

Share this post


Link to post
Share on other sites

Have you read the AVSIM Software and Hardware guide pinned at the top of this forum.  It provides many useful suggestions for tweaking and setting up FSX.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Have you tried using the internal framerate limiter rather than the external one?

 

EDIT: I see you mention it in the original post, are you using vsync?

Share this post


Link to post
Share on other sites

I've been having the same problems as you describe. It happened after I upgraded to an i7 3770K. I have a GTX 560 1GB and 8GB RAM. I started with a clean fsx.cfg and proceeded to follow the avsim tweaking guide to the letter, to no avail. The problem seemed to go away to an extent only after I did a complete uninstall of the previous NVidia drivers, (not a clean install, but a complete uninstall including deleting the folders of the previous drivers), and then installed the new driver released on 5/12. I'm running in DX10 mode. The problem still persists if I am running a complex aircraft (PMDG), and autogen anything more than "normal". The stutters will go away though if I lessen the load a bit on the GPU by reducing the autogen slider a bit. I don't run with any AI traffic, either in the air or on the roads. I also run locked at 30FPS internally and use inspector to vsync at 1/2 refresh rate.

When monitoring my GPU load, it will run constantly at around 65-75%, and then when I pan the view to the left or right it will jump to 99% for just a second or two which is when I get the stutters. I have tried a combination of different tweaks in the config with TBM, affinitymask, bufferpools, FFTF....you name it. None of it seems to give a performance boost of any kind, so I have omitted most of them.

Be careful with your IQ levels in the inspector. I can't run any of the sparse grid supersampling, as that really bogs down my GPU. Try backing those down if you continually get the stutters regardless of autogen slider setting, etc.

Also - I had recently tried SweetFX, which was around the same time I got the persistent stutters. I have since deleted the SweetFX .dll files and .fx files that were included in the install, which, while I have no evidence to back it up, I did seem to notice an increase in overall performance after the delete.

Good luck. Let us know if you find anything that helps.

Share this post


Link to post
Share on other sites

OK, here's my current NVidia profile that has been giving me good results in DX10 with Steve's fix applied:

 

Also, FSX config settings worth note:

 

[bufferpools]

Usepools=0

 

TEXTURE_BANDWITH_MULT=80

 

HIGHMEMFIX=1

 

Note that I have left out AffinityMask, Fiber_Frame_Time_Fraction and any of the other "magic bullet" type entries.

 

With these settings I can run most of the scenery sliders to max, with bloom, except for autogen and traffic.  Autogen I can run at very dense in most scenarios and maintain a constant and smooth 30FPS.  Make sure that the box for "aircraft casts shadows on itself" remains UNCHECKED.  This caused major stuttering for me.

 

8851716560_2d2aa208ab_o.jpg

Share this post


Link to post
Share on other sites

 

 


Be careful with your IQ levels in the inspector. I can't run any of the sparse grid supersampling, as that really bogs down my GPU. Try backing those down if you continually get the stutters regardless of autogen slider setting, etc.

 

When I had the GTX 480, I could run with 2x Sparse Grid Supersampling without getting stutters, I now have the 680 and can now run 4x Sparse Grid Supersampling. So its weird that your 560 cant handle it, Im not an expert but isn't the 560 a better gpu than 480?

 

 

 


Note that I have left out AffinityMask, Fiber_Frame_Time_Fraction and any of the other "magic bullet" type entries.

 

For me the most important tweak was the Affinetymask 14, If Im not using it I get nasty stutters no matter how much I lower the settings. So in my case it was indeed a "magic bullet" that penetrated my sim and killed all the stutters B)

Share this post


Link to post
Share on other sites

Matt has good settings. I would turn off Hyperthreading in BIOS since FSX doesn't use it and it icreases the CPU temp by about 8 C. Then add the following to FSX.CFG:

 

[JOBSCHEDULER]

AffinityMask=14 //Added

 

Try unlimited FPS in FSX and NI locked at 30, or maybe even 20.

 

Dave

Share this post


Link to post
Share on other sites

Same problem here and this just started recently, will be watching this for any definitive answers

Share this post


Link to post
Share on other sites