Archived

This topic is now archived and is closed to further replies.

MatthewL

Autopilot Disconnect Alert won't shut off

Recommended Posts

So I can't seem to get the AP Disconnect alert to shut up. On the ground I can clear the warn message fine, but when flying the message doesn't seem to be clearing. 

 

Any help? Thanks. 777 Btw.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you tried the disconnect button on the yoke or key press CTRL + SHIFT + Z, once to disconnect, then again about 3 seconds later to cancel the warning?

Share this post


Link to post
Share on other sites

Issue Tracking Thread:

 

- Master warning siren/wailer doesn't turn off.

  • This is a realistic feature that is an option on the airplane. Look for RESETTABLE SIREN in the EQUIPMENT section of the aircraft options in the FMC.
  • With respect to the autopilot disconnect form of this sound, it takes two presses of the AP disconnect button/key to silence it. The second press must come at least 1.5 seconds after the first. Again, accurate to the real world airplane.

Share this post


Link to post
Share on other sites

 

 


Any help?

Sure, reading the introduction manual and the tutorial might help...

Share this post


Link to post
Share on other sites

Bad habit that was discussed in the PIC767 addon manual in the year 2001.

 

Don't press the "disconnect 'bar' " on the MCP. This hard disconnects the autopilot by literally cutting the computer linkages circuits. The Disconnect alarm will not stop sounding while this bar is in the down position.

 

The only time the pilots should use this method to disconnect the autopilot is if it has failed and is not turning off properly.

(I have heard unsubstantiated rumors that 'excessive G force' can also pull the MCP disconnect bar down, ie during periods where the autopilot is well out of parameters and about to destroy the aircraft... not sure about that one, haven't seen any documentation to support it)

 

Instead, use the disconnect buttons on the yoke. (to do this, assign the ctrl+shift+z keypress to a yoke/joystick button, or literally press ctrl+shift+z)

PMDG 777 also has the "TOGA screw" clickspot. A right-click on this clickspot will disconnect autopilot as if you pressed the button on the yoke.

 

A second click (yoke autopilot disconnect button press) at least 1.5 seconds later, will cancel the warning.

if you click it too soon, it won't cancel the warning.

 

Don't use simple "z", as this just toggles between "Autopilot on" and "Autopilot off". So you will click once, starting the alarm, and click a second time, turning the autopilot back on in an endless loop. lol.

Share this post


Link to post
Share on other sites

So I can't seem to get the AP Disconnect alert to shut up. On the ground I can clear the warn message fine, but when flying the message doesn't seem to be clearing. 

 

Any help? Thanks. 777 Btw.

 

Read the manual!

Share this post


Link to post
Share on other sites

Also be aware of another issue that has been identified and is being corrected by PMDG. No matter what method you use to disconnect the A/P, it is not possible if you have used your own "saved panel" to begin your flight. It's fine if you use a pre-set panel status but not one you have created yourself (i.e Ready to taxi etc).

Share this post


Link to post
Share on other sites

I am curious about why in this aircraft the AP cannot be disconected by just pressing the AP button and unlit it.-

Share this post


Link to post
Share on other sites

I am curious about why in this aircraft the AP cannot be disconected by just pressing the AP button and unlit it.-

Because the real airplane doesn't work like that perhaps?

Share this post


Link to post
Share on other sites

Also be aware of another issue that has been identified and is being corrected by PMDG. No matter what method you use to disconnect the A/P, it is not possible if you have used your own "saved panel" to begin your flight. It's fine if you use a pre-set panel status but not one you have created yourself (i.e Ready to taxi etc).

 

 

I have a startup state I created, and I have no such problem.  As long as you don't use the PMDG-supplied C&D startup as your starting point, you shouldn't have a problem.  I created mine from the default engines-on state and have flown many,many flights beginning with my created startup state with no problems attributable to the startup state. 

 

Edit:

Just realized you were referring to saved panel states.  Haven't had a problem with those either.

 

Everyone, just to repeat, you need to map a key or button for autopilot on and another one for autopilot off.  Use the PMDG key mapping feature in the CDU. 

 

 

Mike

Share this post


Link to post
Share on other sites

Because the real airplane doesn't work like that perhaps?

 

I remember a long time ago (2002) when some of the actions of the hijackers of the September 11 planes, namely the United 93 one, included trying to turn off the autopilot several times, then re-engaging it (at which point it returned to it's cruise altitude and course).

Apparently on the 'transmissions' they made over the ATC frequency (telling the "Air Traffic Controller" to sit down and remain calm and remain seated) there was the Autopilot disconnect horn going off in the background.

 

This was also shown in Paul Greengrass' movie United 93 with the actor playing Ziad Jarrah (UAL93 hijacker pilot) trying desperate to silence the Autopilot alarm by pressing random buttons, (Including the "engage autopilot" Button) and not getting anywhere.

 

The alarm continues wailing for several minutes through the cockpit scenes in the movie.

 

Later he decides that he will "Descend to speed up", thereby increasing the aircraft's Indicated airspeed (into Overspeed clacker warning) but ultimately decreasing the aircraft's Ground speed and Mach (ie: he actually slowed due to not understanding what Indicated Airspeed is).

 

Maybe these details make me more annoyed/angry at n00bs than I would otherwise be, since they seem to have the same misconceptions about the operation of airliners that the movie (and possibly real) UAL93 hijackers did.

Share this post


Link to post
Share on other sites

Everyone, just to repeat, you need to map a key or button for autopilot on and another one for autopilot off.  Use the PMDG key mapping feature in the CDU. 

 

 

Just one for Autopilot Off is enough. Use the mouse to get autopilot on ;)

 

There's actually 3 options.

 

  • (Best): Map a Joystick button to "Autopilot Off"
  • (okay): Use right mouse button to click the bottom left screw on the MCP (The one which prompts TOGA Thrust with a left click)
  • (hard): Press Ctrl+Shift+Z twice.

 

Remember the disconnect (one of the 3 options above) needs to be pressed once (Which causes disconnect and alarm) then after 1.5 seconds a second press (of the disconnect key) will silence the alarm.

 

If you use the disconnect bar, the warning will continue "forever" (till the bar is replaced, and one of the 3 options is pressed).

 

If you press the Autopilot CMD button (the one you press to turn on the Autopilot with the mouse) nothing will happen. The button will be pushed into the solenoid, the computer will recognize that the autopilot is already on, and leave it on. No warnings, no disconnect.

 

If you press Z once, you will toggle from Autopilot On state, to Autopilot off (and alarm warning sounding) state. A second press of Z will toggle from Autopilot off (and alarm sounding) to Autopilot back on.

 

ONLY one of the 3 options will work. No other methods will.

 

My suggestion: Joystick (or yoke) button near your (left) Thumb.

Share this post


Link to post
Share on other sites

Just one for Autopilot Off is enough. Use the mouse to get autopilot on ;)

 

There's actually 3 options.

 

  • (Best): Map a Joystick button to "Autopilot Off"
  • (okay): Use right mouse button to click the bottom left screw on the MCP (The one which prompts TOGA Thrust with a left click)
  • (hard): Press Ctrl+Shift+Z twice.

 

Remember the disconnect (one of the 3 options above) needs to be pressed once (Which causes disconnect and alarm) then after 1.5 seconds a second press (of the disconnect key) will silence the alarm.

 

If you use the disconnect bar, the warning will continue "forever" (till the bar is replaced, and one of the 3 options is pressed).

 

If you press the Autopilot CMD button (the one you press to turn on the Autopilot with the mouse) nothing will happen. The button will be pushed into the solenoid, the computer will recognize that the autopilot is already on, and leave it on. No warnings, no disconnect.

 

If you press Z once, you will toggle from Autopilot On state, to Autopilot off (and alarm warning sounding) state. A second press of Z will toggle from Autopilot off (and alarm sounding) to Autopilot back on.

 

ONLY one of the 3 options will work. No other methods will.

 

My suggestion: Joystick (or yoke) button near your (left) Thumb.

 

Thank you Mike777 and Hopskip but I have been trying all your options for weeks but I cannot stop the A/P alarm from sounding. I have reassigned keys, joystick buttons both inside the FSX menu and the PMDG cdu but nothing solves it. I really hope that maybe PMDG could confirm if my problem is an error of my own making or not.

Share this post


Link to post
Share on other sites

Thank you Mike777 and Hopskip but I have been trying all your options for weeks but I cannot stop the A/P alarm from sounding. I have reassigned keys, joystick buttons both inside the FSX menu and the PMDG cdu but nothing solves it. I really hope that maybe PMDG could confirm if my problem is an error of my own making or not.

 

Press once = Autopilot turns off and alarm starts.

 

If you immediatley press again, nothing happens, alarm continues.

 

After alarm sounds 3 or 4 times, a second press of the disconnect options will silence the alarm.

 

No double clicks. Disconnect, Listen to 4 alarm sounds (Bwaarp Bwaarp Bwaarp Bwaarp) Then press once to silence the alarm. you MUST listen to 4 "cycles" of the alarm before attempting to silence it.

 

Share this post


Link to post
Share on other sites

Just to clarify my problem once again. If I fly using a pre-set panel status (long, short etc) I can turn the A/P Disconnect siren off. If however I use my own "ready to taxi" panel (for when I have limited time to fly) I simply cannot turn off the siren. No matter which option I try. It appears that the creation of your own "saved panel" status causes this problem.

 

This problem is a pain after landing and turning off the runway. I taxi to my gate with the siren blaring. No problems in the 737, you simply press the button that is flashing and off goes the siren.

Share this post


Link to post
Share on other sites

 

 


If however I use my own "ready to taxi" panel (for when I have limited time to fly) I simply cannot turn off the siren. No matter which option I try. It appears that the creation of your own "saved panel" status causes this problem.

 

Not at my computer now, but there is an option to allow the alarm to to be shut off. Probably in your ready to taxi state that option is not checked. So the alarm cannot be silenced. If you find that option and check it, and save the state again, that should fix the problem.

 

In the  http://forum.avsim.net/topic/418750-pmdg-777-issue-tracking-thread-read-before-posting/thread it says:

 

"- Master warning siren/wailer doesn't turn off.

  • This is a realistic feature that is an option on the airplane. Look for RESETTABLE SIREN in the EQUIPMENT section of the aircraft options in the FMC.
  • With respect to the autopilot disconnect form of this sound, it takes two presses of the AP disconnect button/key to silence it. The second press must come at least 1.5 seconds after the first. Again, accurate to the real world airplane."

Mike

Share this post


Link to post
Share on other sites

Not at my computer now, but there is an option to allow the alarm to to be shut off. Probably in your ready to taxi state that option is not checked. So the alarm cannot be silenced. If you find that option and check it, and save the state again, that should fix the problem.

 

In the  http://forum.avsim.net/topic/418750-pmdg-777-issue-tracking-thread-read-before-posting/thread it says:

 

"- Master warning siren/wailer doesn't turn off.

  • This is a realistic feature that is an option on the airplane. Look for RESETTABLE SIREN in the EQUIPMENT section of the aircraft options in the FMC.
  • With respect to the autopilot disconnect form of this sound, it takes two presses of the AP disconnect button/key to silence it. The second press must come at least 1.5 seconds after the first. Again, accurate to the real world airplane."
Mike

 

Hi Mike. Sorry but I have never found an option re A/P Disc siren. You can change it from wailer to siren and there is a resettable siren for the master warning but that's all.

Just to reconfirm again, I have waited 1.5 seconds, for 4 blasts of the siren, as advised but still no joy.

 

If anyone from PMDG reads this could they offer their thoughts?

Share this post


Link to post
Share on other sites

There are two issues here:

  1. Not following proper AP disconnect procedure - if you don't do so, the alarm will continue to go off.  This is a realistic behavior.
  2. An acknowledged bug (so PMDG has already essentially offered their thoughts).  The C/D Panel state and some user states will cause issues.  Using the default Short/Long states should be fine until the update comes out.

Always, always, always, always check the stickies.  You'll note one says "READ BEFORE POSTING."  There's an acknowledgement of the in there.  It's not quite fair to ask a small team to answer each post individually, particularly when the issues has already been addressed there.

Share this post


Link to post
Share on other sites

 

 


Hi Mike. Sorry but I have never found an option re A/P Disc siren. You can change it from wailer to siren and there is a resettable siren for the master warning but that's all.

Just to reconfirm again, I have waited 1.5 seconds, for 4 blasts of the siren, as advised but still no joy.

 

Hi,  Jon,

 

The general resettable siren option includes the autopilot siren. 

 

See if this fixes the problem:  Be sure to load an aircraft that you know is giving you a problem.  In the 3rd CDU (open with Shift-4) choose the Menu button on the keypad, then PMDG SETUP>AIRCRAFT>EQUIPMENT then scroll down until you see "Resettable Siren".  If "Yes" is not lit up in green, click so that it is.  See if that fixes the problem.  You may have to shut down and restart FSX.  Be sure to load the same exact aircraft, as this option is aircraft specific.  See if it works properly after the reload. 

 

You also need to have a key mapped to the "A/P L" (Autopilot-left) command.  I have  the following:  Z is mapped to Autopilot on/off IN THE FSX CONTROLS MENU.  Ctrl-Z is mapped to "A/P L" (Autopilot-left) IN THE PMDG CONTROLS MAPPING.  This may not be standard, but it works for me.  With this setup, Z turns off the autopilot and starts the siren.  Another press on Z a few seconds later stops the siren.  Ctrl-Z turns on the autopilot.

 

To find the PMDG mapping, again open the 3rd CDU, click on Menu, then PMDG SETUP>OPTIONS>KEY COMMANDS .   Click on Autoflight.  Scroll down to A/P-L.  Set the command there to ctrl-Z.    I think this will work for all panel states, but never hurts to save your panel state, close down, start up, etc . 

 

Mike


 

 


Not following proper AP disconnect procedure - if you don't do so, the alarm will continue to go off. This is a realistic behavior.

 

Kyle, I think maybe then there is a bug.  When I click on the Autopilot disconnect bar, the bar moves down, the siren sounds.  When I then press Z  (see my setup in previous post) after a few seconds, the alarm stops. 

 

Mike

Share this post


Link to post
Share on other sites

 

 


Kyle, I think maybe then there is a bug. When I click on the Autopilot disconnect bar, the bar moves down, the siren sounds. When I then press Z (see my setup in previous post) after a few seconds, the alarm stops.

 

If you think there is a bug, then it should be reported.

Share this post


Link to post
Share on other sites

There are two issues here:

  1. Not following proper AP disconnect procedure - if you don't do so, the alarm will continue to go off.  This is a realistic behavior.
  2. An acknowledged bug (so PMDG has already essentially offered their thoughts).  The C/D Panel state and some user states will cause issues.  Using the default Short/Long states should be fine until the update comes out.

Always, always, always, always check the stickies.  You'll note one says "READ BEFORE POSTING."  There's an acknowledgement of the in there.  It's not quite fair to ask a small team to answer each post individually, particularly when the issues has already been addressed there.

 

Thank you Kyle for all your kind advice.

Hi,  Jon,

 

The general resettable siren option includes the autopilot siren. 

 

See if this fixes the problem:  Be sure to load an aircraft that you know is giving you a problem.  In the 3rd CDU (open with Shift-4) choose the Menu button on the keypad, then PMDG SETUP>AIRCRAFT>EQUIPMENT then scroll down until you see "Resettable Siren".  If "Yes" is not lit up in green, click so that it is.  See if that fixes the problem.  You may have to shut down and restart FSX.  Be sure to load the same exact aircraft, as this option is aircraft specific.  See if it works properly after the reload. 

 

You also need to have a key mapped to the "A/P L" (Autopilot-left) command.  I have  the following:  Z is mapped to Autopilot on/off IN THE FSX CONTROLS MENU.  Ctrl-Z is mapped to "A/P L" (Autopilot-left) IN THE PMDG CONTROLS MAPPING.  This may not be standard, but it works for me.  With this setup, Z turns off the autopilot and starts the siren.  Another press on Z a few seconds later stops the siren.  Ctrl-Z turns on the autopilot.

 

To find the PMDG mapping, again open the 3rd CDU, click on Menu, then PMDG SETUP>OPTIONS>KEY COMMANDS .   Click on Autoflight.  Scroll down to A/P-L.  Set the command there to ctrl-Z.    I think this will work for all panel states, but never hurts to save your panel state, close down, start up, etc . 

 

Mike

 

 

 

Kyle, I think maybe then there is a bug.  When I click on the Autopilot disconnect bar, the bar moves down, the siren sounds.  When I then press Z  (see my setup in previous post) after a few seconds, the alarm stops. 

 

Mike

 

Thank you again Mike for your kind help. I will continue to try the various options you suggest but I suspect, as Kyle has said, that a bug does exist. The SP will no doubt clear it up.

 

Thank you again Mike.

Share this post


Link to post
Share on other sites

Thank you again Mike for your kind help. I will continue to try the various options you suggest but I suspect, as Kyle has said, that a bug does exist. The SP will no doubt clear it up.

 

Actually I was the one who mentioned a bug, but having the siren go off continuously after an autopilot disconnect is NOT a bug.  It is an option that some airlines use.  You can fix the continuous siren by turning on "Resettable siren" option in the CDU (what many simmers refer to as the FMC) as I described above. 

 

Edit:

 

Maybe an easier way to fix this is to use the PMDG Operations Center.  Make sure FSX is not running.  Open the PMDG Operations Center, choose the 777 option, then click on "Aircraft Specific Settings".  You will see a list of all the PMDG 777s you have installed.  Find one in which you are having the problem that the siren won't shut off.  Click on it.  Look in the right window, which shows many options for that particular aircraft.  Scroll down to the Warnings section.  You will see the option "Resettable Siren."  If it says "No," click on "Resettable Siren."  You will then have a little box to the right where you can change it to "Yes".   Click "Save".  You are done.  Now restart FSX and load the same aircraft.  Should be fixed now.

 

This is a complex aircraft.  You need to learn how to adjust the various settings. 

 

Mike

Share this post


Link to post
Share on other sites

Actually I was the one who mentioned a bug, but having the siren go off continuously after an autopilot disconnect is NOT a bug.  It is an option that some airlines use.  You can fix the continuous siren by turning on "Resettable siren" option in the CDU (what many simmers refer to as the FMC) as I described above. 

 

Edit:

 

Maybe an easier way to fix this is to use the PMDG Operations Center.  Make sure FSX is not running.  Open the PMDG Operations Center, choose the 777 option, then click on "Aircraft Specific Settings".  You will see a list of all the PMDG 777s you have installed.  Find one in which you are having the problem that the siren won't shut off.  Click on it.  Look in the right window, which shows many options for that particular aircraft.  Scroll down to the Warnings section.  You will see the option "Resettable Siren."  If it says "No," click on "Resettable Siren."  You will then have a little box to the right where you can change it to "Yes".   Click "Save".  You are done.  Now restart FSX and load the same aircraft.  Should be fixed now.

 

This is a complex aircraft.  You need to learn how to adjust the various settings. 

 

Mike

 

Hi Mike

 

I am so grateful for your help but I should point out that I have been exploring the same options that you mention for several weeks now. Through the CDU menu and the PMDG Ops menu and nothing works. I have just gone through your procedure once more and still my siren will not switch off.

 

I adjusted the config file for the Aeromexico livery and then loaded it up. I use my ready to taxi saved panel and brought in the new config file. The problem remains. I think I recall a couple of people mentioning this problem a few weeks ago so I don't think I'm alone. Maybe the SP will solve this when it arrives. Other than this I cannot imagine what I could be doing wrong.

 

Thank you!

Share this post


Link to post
Share on other sites

 

 


Other than this I cannot imagine what I could be doing wrong.

 

Sorry, Jon, I am stumped as well.

 

As a temporary fix, until this gets sorted out, you can go into

... Flight Simulator X\Sound\PMDG\777X\CAWS

and find the PMDG_777_MasterWarning.wav or PMDG_777_Wailer.wav file (I think it's the second oneyou want) and rename it.  That will stop the endless wailing sound, but you won't hear it when you might need it.  Anyway that was my solution until I got my setup to do what I want.

 

Mike

Share this post


Link to post
Share on other sites