Sign in to follow this  
Sandy_Bridge

Problem with Saitek Pro Flight Rudder Pedals

Recommended Posts

Hello,

 

I have a problem with my Saitek Rudder Pedals. When I apply the toe brakes, I can't release them. BRAKES is displayed on the bottom left of the screen even when my feet aren't on the pedals. The only way to release them is by setting and releasing the parking brake. Can anyone help me?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You will probably need to tick the reverse box as well if you are using FSX to assign the brakes.

Share this post


Link to post
Share on other sites

Please provide more information to encircle the issue.  Are you using FSUIPC?  Does the issue affect more than one aircraft model?  Did you make any recent changes to your system or to your flight simulator version or add-ons, Etc.

Share this post


Link to post
Share on other sites

I'm not using FSUIPC, I think it affects all aircraft (I have tried the PMDG 737-800NGX and the default Ultralight). I reinstalled Windows about a month ago it worked fine before that.

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

I suggest you try to remove the driver with a sweeper program and then reinstall the Saitek Driver.

Share this post


Link to post
Share on other sites

Did you check that the pedals are working properly by using the Saitek Control Panel?  Does the calibration look good?

Share this post


Link to post
Share on other sites

I think I had the same problem initially when I got saitek pedals.. It was a couple of years ago but as I recall, I found I had brakes (not parking brakes) still configured in the yoke. When I got rid of that it then all worked ok.

Share this post


Link to post
Share on other sites

I checked my settings and only the rudder pedals had brakes assigned. I even tried using a different USB port, but it still hasn't fixed it.

Share this post


Link to post
Share on other sites

Hi,

 

Go to your main setting screen.

 

From the main setting screen click on the sensitivities icon

 

From the Controller - Sensitivities page click on the drop arrow next to the box called 'Joystick Type' in the  upper right of the screen, when the arrow is pressed a drop down menu will appear listing the game controllers connected to your PC.  In this list you will see the Saitek Pro Flight Rudder Pedals.

 

Click on this controller, on the screen you will see Simple and  Advance radio buttons, make sure the simple radio button is selected.

 

Just under and to the right of the simple button you will see two sliders, one marked Sensitivity - all axes and the other marked Null zone - all axes.  Move the sensitivity slider ALL the way over to the right and move the Null zone slider about 3% to the left, click OK and the toe brakes should now work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this