Sign in to follow this  
Bert Pieke

KAS297C Altitude Preselector

Recommended Posts

Regarding the KAS297C preselector and it's operation:

 

1. Dial in the target altitude

 

2. Push ALT ARM

 

3. Adjust the VS speed (default 500 fpm) with the knob, or the rocker switch on the autopilot

 

Note:  The VS ENG button engages VS mode, without ALT capture..

 

With my mods, you'll find that this works with the correct indications, and in FD as well as AP mode.

 

Send me a PM (with your email address) if you want a copy.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks Bert!

This helps a lot

Message with my mail address was already sent to you!

 

Thanks mate!

 

Cheers,

Mark

Share this post


Link to post
Share on other sites

Your fixes are brilliant thank you very much.

 

Will you incorporate any fixes to the engine gauges? itt is very low at cruising altitudes.

 

I wonder if Carenado will add strobe lights to the model. Why is the switch missing?

Share this post


Link to post
Share on other sites

The start/stop button does not work on the transponder. It sets to a weird time and does not count up. I can replace it with the rxp gtx but it looks out of place without a black front.

Share this post


Link to post
Share on other sites

Hi Bert,

 

did  you get my mail request for your mod file?

Would be great if you could sent it to me!

Thanks in advance!

 

Cheers,

Mark

Share this post


Link to post
Share on other sites

Hi Bert , I dont have a mouse wheel, I use a marble track ball ,I dont get any way to move the knobs for alt setting , my saitek panel does not chage the Alt there either, although in flight it can change it and the plane responds...

 

any help...I will send a PM for the SW fix...

 

Thankyou  Jorge

Share this post


Link to post
Share on other sites

The start/stop button does not work on the transponder. It sets to a weird time and does not count up. I can replace it with the rxp gtx but it looks out of place without a black front.

 

I've got a fixed version ready to go (have sent it to Carenado)

Hi Bert , I dont have a mouse wheel, I use a marble track ball ,I dont get any way to move the knobs for alt setting , my saitek panel does not chage the Alt there either, although in flight it can change it and the plane responds...

 

any help...I will send a PM for the SW fix...

 

Thankyou  Jorge

 

That is going to be a problem in other planes as well - maybe get a mouse with wheel for FSX..

Share this post


Link to post
Share on other sites

The clickspots for the numbers are small and hard to find.. with my mods, they are bigger and on the numbers.  In the original, they are lower and to the right a bit.

Share this post


Link to post
Share on other sites

 

 


The clickspots for the numbers are small and hard to find.. with my mods, they are bigger and on the numbers. In the original, they are lower and to the right a bit.

 

I hope they keep a copy of your changes of all these things and toss their old versions.  They'll be useful on future airplanes.

 

Gregg

Share this post


Link to post
Share on other sites

I hope they keep a copy of your changes of all these things and toss their old versions.  They'll be useful on future airplanes.

 

Gregg

 

I hope so too - would save me a lot of trouble, believe me  :rolleyes:

Share this post


Link to post
Share on other sites

Hi Bert,

 

I tried to send you a PM to request a copy of your mods to the autopilot, but got a message that you cannot accept any more messages.  Any thoughts on how I can get a copy from you?

 

Please send me a PM.  Thanks!

 

 

Gerald

Share this post


Link to post
Share on other sites

Hi Bert,

 

Thank you for your work, I've installed your mods and they work great.

 

I have 2 additional points regarding the AP :

1/ There is no GA mode by default, but if you go and modify the aircraft.cfg [autopilot] section with "pitch_takeoff_ga=8" instead of "0" you will get the proper pitch for take-off/go around by hitting "Ctrl-Shift-G" (default FSX command for activating GA mode). I find this very helpful and probably realistic

 

2/ Is there any way to modify the default VS speed when arming the alt capture mode. It's set at 500fpm which is really low compared to normal climb schedule (I normally hit 1500fpm @180kts). Modifying it in the aircraft.cfg has no effect, I guess it's inside an xml gauge which I understand nothing about... :(

 

Any insight appreciated...

 

Regards!

Share this post


Link to post
Share on other sites

2/ Is there any way to modify the default VS speed when arming the alt capture mode. It's set at 500fpm which is really low compared to normal climb schedule (I normally hit 1500fpm @180kts). Modifying it in the aircraft.cfg has no effect, I guess it's inside an xml gauge which I understand nothing about...

No unfortunately, that default 500 FPM cannot be changed (I liaised with Bert when the PC-12 first came out, and asked him the same question).  I believe it's embedded in to a gauge, rather than using the entry in the CFG file.

 

It is annoying having the default 500fpm - especially when even IAS mode firstly moves to 500 fpm, and then to the correct fpm to manage pitch for target speed.

 

Good find with the TO/GA mod! :smile:

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the reply, yes it is very annoying (same here with the IAS mode, it first goes to 500fpm and then adjusts pitch to keep the IAS). Bumpy ride :sorry: :sorry:

 

Surely the fact that default VS is +/-500fpm must be written somewhere in the xml gauges, relating to AP, so there are only 2 possible, right ? Gauge_KMC321.xml or Gauge_KAS297.xml (and their vc variants)

 

Is there any other possibility ? Any gauge gurus out there ?

Share this post


Link to post
Share on other sites

Hi

 

if you edit Gauge_KAS297.xml and Gauge_KAS297VC.xml in these sections from 500/-500 to 1500/-1500 respectively

 

                                 1500 (>K:AP_VS_VAR_SET_ENGLISH)
                                     (>K:AP_ATT_HOLD_ON)    
                                     (>K:AP_PANEL_ALTITUDE_ON)
                                   1 (>L:ALT_SEL_ON)
                                   
                                 1500 (>L:AP_VS_VAR_SET_ENGLISH)
...

                                -1500 (>K:AP_VS_VAR_SET_ENGLISH)
                                     (>K:AP_ATT_HOLD_ON)    
                                     (>K:AP_PANEL_ALTITUDE_ON)
                                   1 (>L:ALT_SEL_ON)
                                 -1500 (>L:AP_VS_VAR_SET_ENGLISH)  

 

 

 

 

then you get a FT/Min of 1500 after clicking the ALT arm button.

 

Just confirmed it working as such on the tarmac, will ammend if I see problems.

 

Nils

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this