Sign in to follow this  
Robert McDonald

Solved! Stuttering/Freezes/Sync issues XPlane 10 w Nvidia GPUs

Recommended Posts

Until recently, I never really had any serious issues with stutters (even small ones) and only very occasionally had very brief "freezing" on my triple-screen triple-pc XP10 setup.  A friend had begun having issues and mentioned them to me, and sure enough, when I looked at MY setup, I was having the same problems but on a smaller scale.  Happily, after a lot of experimentation, we discovered the 'solution' and are now enjoying the butter-smooth graphics our systems were built to deliver.  So I share our 'solution' for the benefit of those who may be in a similar situation.


 


Heart and Soul of our fix is simple:


  • ROLL DRIVERS BACK to nVidia 337.88 WHQL (Windows Hardware Quality Lab Certified driver) May 26, 2014 available here.  This step is VERY important.  You do NOT have to uninstall your current nVidia drivers to install this older driver.  Just download the file and run it.  Tech explanation: Nvidia has been optimizing for Direct X, NOT OpenGL in their most-recent driver releases, the 377.88 driver appears to be the one best-suited to OpenGL which is what drives XPlane 10.  Some folks in this thread have said that the newer 9-series cards from NVidia will require a NEWER driver than this one.  The nVidia website will ask you to select your gpu series, then model, and 'search' and you will be presented with a list of compatible drivers.  If you're having issues as described here, try selecting the oldest COMPATIBLE WHQL driver in the list for your specific graphics card.  DO NOT select a 'beta' driver.
  • Right click on any empty spot on your desktop and then left-click on nVidia CONTROL PANEL.
  • Click on the left side of the nVidia control panel 3-D Settings
  • Under the GLOBAL SETTINGS tab, there is a setting "Multi-Display/mixed GPU acceleration".  If you use only ONE monitor for EACH PC, select Single PC performance mode.
  • The very next setting is Power management mode, change to Prefer Maximum Performance.
  • Near the bottom of the Global Settings window is Vertical Refresh Rate, select Adaptive (use half refresh rate).  This will lock your frames at 30fps.  Even though your video card (in our case nVidia GTX 770 and nVidia Titan) is capable of much much higher rates, because we both are using triple computers to drive 3 separate monitors, the goal is to have all three screens in perfect sync with no 'break apart' of the image.  Setting frames to 30 on all 3 PCs results in optimal smoothness and synchronization between all three monitors.
  • Finally:  REPEAT these steps on each PC that is driving a monitor in your xPlane setup.

Please rate this post if you found it helpful.  This post is aimed at nVidia 7-series (and older) owners.


Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Another member also suggested turning off Threaded Optimization (also located in the Nvidia Control Panel).  I didn't need that to stop the issues - so I did not alter that setting, but it might be worth a try if all of the above steps don't solve it for you.

Share this post


Link to post
Share on other sites

Thanks so much for posting this!  I was flying last night and was experiencing some freezing about every 30 seconds - very disconcerting when on base and final!

Share this post


Link to post
Share on other sites

Thanks so much for posting this!  I was flying last night and was experiencing some freezing about every 30 seconds - very disconcerting when on base and final!

 

You're welcome.  Hope you had a great outcome trying this fix.

Share this post


Link to post
Share on other sites

Robert.

I can't thank you enough for the tip to turn off Threaded Optimization. I have been having a horible time with X=Plane since I got it a couple of weeks ago. No matter what my settings in X Plane were set to, when I got to my destination,the airport would be nothing more than a field, no runway at all,and the surrounding scenery was totally devoid of any features   It was always fine when I took off,but on landing there was nothing there. I was just about to give up on X Plane when I saw your tip in the Video cards and drivers section of the forum and I gave it a try. Wow! what a difference! Airports are now displaying as they should,and silky smooth performance and the frame rate is very good now too.

I am using the latest drivers (347.25) and they are just fine now with Threaded Optimization turned off,but I have taken note of the 337.88 drivers recomendation just in case.

All the best and thank you.

Dennis

Share this post


Link to post
Share on other sites

agreed, finally was able to update to latest nvidia drivers and gain some fps without stutters, all by just turning of Threaded Optimization.

Dont use any other nvidia settings.

Share this post


Link to post
Share on other sites

Great news one and all!  Happy it gave you some improvement!

 

I personally think the power management in nvidia control panel should be "maximum performance"

and you should select how many monitors you are driving.  I have 1 monitor per PC, so I set  to "Single Monitor Performance" as I mentioned in the first post in this thread.

 

Running very high definition graphics across 3 screens with Skymax 2.x weather and complex aftermarket airports.

 

Locking frames at 30 is a no-brainer for me.  Seeing frames at 100+ is meaningless.  What matters is silky smooth edge to edge across 3 screens with no break-apart between the monitors.  30 frames locked made that a reality.


Robert.

I can't thank you enough for the tip to turn off Threaded Optimization. I have been having a horible time with X=Plane since I got it a couple of weeks ago. No matter what my settings in X Plane were set to, when I got to my destination,the airport would be nothing more than a field, no runway at all,and the surrounding scenery was totally devoid of any features   It was always fine when I took off,but on landing there was nothing there. I was just about to give up on X Plane when I saw your tip in the Video cards and drivers section of the forum and I gave it a try. Wow! what a difference! Airports are now displaying as they should,and silky smooth performance and the frame rate is very good now too.

I am using the latest drivers (347.25) and they are just fine now with Threaded Optimization turned off,but I have taken note of the 337.88 drivers recomendation just in case.

All the best and thank you.

Dennis

 

Hi Dennis,

 

FYI 'by default' many airports in XPlane are still "only runways"  There are many free as well as payware airports available to you on X-Plane ORG.

Share this post


Link to post
Share on other sites

 

Until recently, I never really had any serious issues with stutters (even small ones) and only very occasionally had very brief "freezing" on my triple-screen triple-pc XP10 setup.  A friend had begun having issues and mentioned them to me, and sure enough, when I looked at MY setup, I was having the same problems but on a smaller scale.  Happily, after a lot of experimentation, we discovered the 'solution' and are now enjoying the butter-smooth graphics our systems were built to deliver.  So I share our 'solution' for the benefit of those who may be in a similar situation.

 

Heart and Soul of our fix is simple:

  • ROLL DRIVERS BACK to nVidia 337.88 WHQL (Windows Hardware Quality Lab Certified driver) May 26, 2014 available here.  This step is VERY important.  You do NOT have to uninstall your current nVidia drivers to install this older driver.  Just download the file and run it.  Tech explanation: Nvidia has been optimizing for Direct X, NOT OpenGL in their most-recent driver releases, the 377.88 driver appears to be the one best-suited to OpenGL which is what drives XPlane 10.  Some folks in this thread have said that the newer 9-series cards from NVidia will require a NEWER driver than this one.  The nVidia website will ask you to select your gpu series, then model, and 'search' and you will be presented with a list of compatible drivers.  If you're having issues as described here, try selecting the oldest COMPATIBLE WHQL driver in the list for your specific graphics card.  DO NOT select a 'beta' driver.
  • Right click on any empty spot on your desktop and then left-click on nVidia CONTROL PANEL.
  • Click on the left side of the nVidia control panel 3-D Settings
  • Under the GLOBAL SETTINGS tab, there is a setting "Multi-Display/mixed GPU acceleration".  If you use only ONE monitor for EACH PC, select Single PC performance mode.
  • The very next setting is Power management mode, change to Prefer Maximum Performance.
  • Near the bottom of the Global Settings window is Vertical Refresh Rate, select Adaptive (use half refresh rate).  This will lock your frames at 30fps.  Even though your video card (in our case nVidia GTX 770 and nVidia Titan) is capable of much much higher rates, because we both are using triple computers to drive 3 separate monitors, the goal is to have all three screens in perfect sync with no 'break apart' of the image.  Setting frames to 30 on all 3 PCs results in optimal smoothness and synchronization between all three monitors.
  • Finally:  REPEAT these steps on each PC that is driving a monitor in your xPlane setup.

Please rate this post if you found it helpful.  This post is aimed at nVidia 7-series (and older) owners.

 

Share this post


Link to post
Share on other sites

fixed my problem as well turning off threaded optimization, i have 16 gigs of ram and bought 8 more and thought it was causing the problem on my z97 board with a 4790k, gonna try and put it back now.

Share this post


Link to post
Share on other sites

Glad to hear it.  I tried to get this 'fix' put up as a sticky, but the board admins are trying to hold the stickies to a minimum.  

Share this post


Link to post
Share on other sites

This fixed it for me too. I had all but given up on X-Plane 10 due to the stuttering and freezing. It made it completely unplayable. Now I have smoothness again!

 

Perhaps it should be made a sticky.
 

Thanks for the tip.

Share this post


Link to post
Share on other sites

This fixed it for me too. I had all but given up on X-Plane 10 due to the stuttering and freezing. It made it completely unplayable. Now I have smoothness again!

 

Perhaps it should be made a sticky.

 

Thanks for the tip.

 

Proposed it be made a sticky.  Senior management declined.

Glad it helped some of our members.

Share this post


Link to post
Share on other sites

337.88 doesn't support GTX 970 !!! (no hardware detection)

So what next? Wait a new driver!!

Share this post


Link to post
Share on other sites

337.88 doesn't support GTX 970 !!! (no hardware detection)

So what next? Wait a new driver!!

I have a 970 GTX and the fix worked for me. I'm using 347.25.

Share this post


Link to post
Share on other sites

337.88 doesn't support GTX 970 !!! (no hardware detection)

So what next? Wait a new driver!!

Cut and pasted from my post:

 

Some folks in this thread have said that the newer 9-series cards from NVidia will require a NEWER driver than this one.  The nVidia website will ask you to select your gpu series, then model, and 'search' and you will be presented with a list of compatible drivers.  If you're having issues as described here, try selecting the oldest COMPATIBLE WHQL driver in the list for your specific graphics card.  DO NOT select a 'beta' driver.

Share this post


Link to post
Share on other sites

I can confirm this works for my GTX580 too. I had downloaded the most recent drivers for OpenGL 4.5 support and found it unusable.

Reverting back to 337.88 fixed the stuttering.

Share this post


Link to post
Share on other sites

Great fix! Thank you. Turning off threaded optimization with the latest drivers did it for me!

 

Cheers, 

Share this post


Link to post
Share on other sites

Yes for me too! Turning off threaded optimization is like magic! another experience, XP10 is now back to full life.

Share this post


Link to post
Share on other sites

WARNING!  Windows Update will attempt to 'upgrade' your nVidia drivers, as will nVidia Experience!  You want to exclude ("hide update") from Windows Updates "OPTIONAL UPDATES" any offers to update the nvidia drivers or you will be back to having to do the fix in this thread again!  Same thing with nVidia experience.  Disable updating drivers in Nvidia Experience as well.

Share this post


Link to post
Share on other sites

This is strange. My card is the GeForce GTX 780.  I had to type the 337.88 WQHL in the search bar to even find it!  When I did, I downloaded it and when I rechecked the vs number it now says 340.52.  

Thoughts?  ...I did get the other settings done, although, with my version card was wondering if I had to do the adaptive half refresh rate part.  I'm using Benq GL2460 monitors.

Thanks!

Share this post


Link to post
Share on other sites

I don't know for sure, but if I had to 'guess' I would surmise possibly you may have installed a different driver than you thought?

 

Locking the monitors at 30 frames via adaptive half refresh rate seems like a good protocol for most peeps I've run into.  Assuming your Benqs refresh at 60 fps...

Share this post


Link to post
Share on other sites

I am using a GTX980ti on a 6core @ 3.5G w 64G DDR@3300 and was shocked by the stutters , same I had with 970 on a 3year old I7

 

having the latest drivers I just changed that setting and now all is SMOOTH and FAST..

 

A recommended fix. I think this helps a lot of people

Share this post


Link to post
Share on other sites

For my GTX680 2GB card, I have never gone past this driver suite for any length of time. No stutters, and stellar performance (max FPS) in all my sim platforms.  I think this suite was the last general power performance driver, and not single aimed tweaks for games, not in the flight simulator genre.

 

I tried the latest nVidia driver set with my card not a week ago...out of curiosity, and lost 5-7 FPS on average. I cleaned...reinstalled this suite, and got back all prior FPS performance. No placebo...this driver suite was/is the last of the Mahicans..., my view anyways, with a GTX680 as the card, driven.

 

:)

Share this post


Link to post
Share on other sites

Is it still relevant to roll back driver?

 

I'm experiencing pretty bad stutters and freezes. I've done everything on the list except roll back driver. Currently running latest Nvidia driver as it works best with P3D 3.2.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this