Sign in to follow this  
ideoplastic

P3D Additional black screen when loading 737

Recommended Posts

No issues with the aircraft but a bit puzzled why and additional black screen appears when selecting it. Is this normal in P3D?

 

Thanks 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I often get this too. Certainly not normal in P3D. But seemingly has no adverse impact.

Share this post


Link to post
Share on other sites

I get the same, and I hate it. One way I use to avoid this black (windowed-type) screen, is loading a default aircraft first and then from within the P3D main menu, selecting a B737NGX aiircraft. This practice is not recommended by PMDG itself, but it works ok at least for me.

Edward

Share this post


Link to post
Share on other sites

What do you guys mean by an additional black screen? Any chance of a screenshot? Sorry I don't have P3D so I can't replicate it but I'm interested in your issue all the same

Share this post


Link to post
Share on other sites

Wait, so are any of you loading P3D with a PMDG aircraft set as the default aircraft?

 

P3D and FSX should both be loaded with a default aircraft spinning in the window. Only then should you select and load a PMDG aircraft.

Share this post


Link to post
Share on other sites

Hi, the additional black screen (I'm using P3Dv2.4) only happens when a B737NGX model of the base package is selected (that means that no problems with any 600 or 700 aircraft for me). A default aircraft is first spinning in the window, and after selection of any 800 or 900 aircraft, a kind of windowed-screen (black) appears. Then after, the only solution I've found is to exit P3D after hitting the Escape Key, otherwise the application (P3D) will crash. The 777 works Ok.

The only workaround I've found is to load any 800 or 900 aircraft directly from the P3D main menu, after originally selecting a default airplane (and having it completely loaded in the sim).

Thanks for any help.

Edward

 

 

Share this post


Link to post
Share on other sites

Thanks for the replies. I've always loaded the PMDG aircraft while the default F35A spins in the window but immediately after selecting the 737-800 a minimized additional screen titled Loading PMDG 737NGX appears which then expands into black background and stands behind the Prepar3D Scenario Startup interface. If I then select the airport and start the sim , all then proceeds as normal. However if I select a 737-600 or 737-700 no such window appears. Just thought this was a bit strange since I never encountered it before in all the platforms where I have used PMDG aircraft. Also I no longer see the small window loading the navdata.

 

Regards

Share this post


Link to post
Share on other sites

I would suggest you don't use the F35(f22?) make a default with the maul, set it up how you like the save and make default.

Share this post


Link to post
Share on other sites

I was having this same problem until today. I discovered when the Estonia Migration Tool is installed I get the black screen. It doesn't matter if Virtual FSX is active or not. When I uninstalled the migration tool the Base Package planes loaded normally. I installed and uninstalled the migration tool multiple times on two different computers and 100% of the time the black screen showed up with it installed and didn't without it installed. 

Share this post


Link to post
Share on other sites

I was having this same problem until today. I discovered when the Estonia Migration Tool is installed I get the black screen. It doesn't matter if Virtual FSX is active or not. When I uninstalled the migration tool the Base Package planes loaded normally. I installed and uninstalled the migration tool multiple times on two different computers and 100% of the time the black screen showed up with it installed and didn't without it installed. 

 

Interesting. I'll give it a try. Thanks,

Edwaed

Share this post


Link to post
Share on other sites

I was having this same problem until today. I discovered when the Estonia Migration Tool is installed I get the black screen. It doesn't matter if Virtual FSX is active or not. When I uninstalled the migration tool the Base Package planes loaded normally. I installed and uninstalled the migration tool multiple times on two different computers and 100% of the time the black screen showed up with it installed and didn't without it installed. 

I tried the Ralgh suggestion, removing EMT and black screen disappeared NGX starts normally ... Thanks for the remedy for this inconvenience

Share this post


Link to post
Share on other sites

I'm glad to help out. This drove me crazy during testing because I was the only one seeing it so we figured it was a problem on my end. I get a bit obsessed whey truing to track down issues like this :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this