Sign in to follow this  
Rob Ainscough

nVidia 347.88 drivers out

Recommended Posts

Focus is Titan X support, not much in the release highlights -- BattleField hardline?  No idea what that is, assume another 3D shooter?

 

Hoping nVidia didn't break anything with P3D again.

 

Cheers, Rob.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hoping nVidia didn't break anything with P3D again.

I'll join you Rob, and second that! :BigGrin:

Share this post


Link to post
Share on other sites

I'll have no choice when I get my Titan X order in tomorrow ... but I'm interested to see if any other guinea pig is willing and able to try 347.88 and report back?  From the release notes is looks very minor so one hopes they didn't break anything ... says the spider to the fly.

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

I'm pretty happy with my current configuration.   I"m getting really nice performance at 5760.  I've been playing with a note 4, limelight - which uses Nvidia streaming to android, tri-def, and a VR headset called Homido.  My understanding is that the first ultraHD phone screens will be out from Samsung in August, so I imagine that the Titan X claim that it's ready for VR means that it's ready to crank out what would be abe to process for 2 1920x2160 views in an 4k phone screen at reasonable framerates.    For average user that means 30fps.  For gamers they usually want 60fps.  But for good VR they are saying 90fps is what is needed for immersion.

 

24GB framebuffer???


Rob, the experience even on the note 4 is amazing.  If you don't use a Oculus Rift shader you can read the gauges just fine at 90x90 FOV.  The Homido headset has about 100FOV, which is not much smaller than my 3 27" screens at 124FOV.  Shaders bring distortion in the views, which makes gauges unreadable.  It's something I think that will need to be addressed in the future.  I am using DSR to smooth things out (no shader), and the visual results cross the line of being satisfying enough to use all the time.  A Homido does not come with any head tracking, so freetrack and a home made LED set is what I've done.   I am considering the Samsung Gear VR now, which has a high end gyro, basically the main difference.  Also, I had to grind out the viewport in the Homido to make it a bit larger to use the whole note 4 screen, about 1/4 inch on each side.  My only complaint is lighting could be a bit more dynamic, darker darks, lighter lights, in P3D overall.  It's much more noticeable in a VR headset.  I have my Yoke programmed well, so I don't need to fumble for anything.  But seriously, this is the next level.

Share this post


Link to post
Share on other sites

BattleField hardline?  No idea what that is, assume another 3D shooter?

 

Yep, cops/criminals-themed first person shooter. People have been getting lots of driver crashes since the release yesterday. I haven't read the patch notes yet, but I'd assume it's crash-related? I'm glad to see that NVIDIA has released a fix so quickly if that's the case.

Share this post


Link to post
Share on other sites

I get nervous if I don't have bleeding edge tech. The drivers are great.  In other words, no issues. 


Off note, this optimize parts tweak thing is amazing. Flying the Majestic Q400 at ~60fps it so fluid and amazing. 

Share this post


Link to post
Share on other sites

Works for me as well with my 980. I still have PAPI, runway, and apron lights so it doesn't appear nVidia broke anything.

Share this post


Link to post
Share on other sites

I'll have no choice when I get my Titan X order in tomorrow ... but I'm interested to see if any other guinea pig is willing and able to try 347.88 and report back?  From the release notes is looks very minor so one hopes they didn't break anything ... says the spider to the fly.

 

Cheers, Rob.

 

I will have to wait until it is on newegg and an evga product - I would assume you are buying it direct from Nvidia as there is an add to cart - I expect a report brother

Share this post


Link to post
Share on other sites

 

 


buying it direct from Nvidia

 

No, they were never "in stock" ... at least I never got a page refresh that showed them in stock.  I have another source.

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

No, they were never "in stock" ... at least I never got a page refresh that showed them in stock.  I have another source.

 

Cheers, Rob.

 

Heres the link Rob

 

http://www.geforce.com/geforce-gtx-titan-x/buy-gpu

 

Well hit add to cart and it said out of stock - so much for that

 

I would be amazed if this card's performance is not day and night over a regular Titan never mind any other nvidia card in P3D

Share this post


Link to post
Share on other sites

I`ll be getting the Titan X, but not now. Maybe until P3D will come out with their 64 bit. Than is a time to get the greatest GPU.

That beast ever have a water cooler for it.

 That is crazy.

Share this post


Link to post
Share on other sites

Well hit add to cart and it said out of stock - so much for that

 

I did that the second I noticed the 347.88 driver for Titan X was available ... I was hitting the check for updates about every 5-7 minutes most of the day.  So if they really were available they all sold within 5-7 minutes.  But I have other sources ... lets hope I can twitch and type faster ;)

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

Cheers, Rob.

 

 

So if they really were available they all sold within 5-7 minutes

 

​Exactly and probably only had a few or none - just a place holder I would my money on the latter

Share this post


Link to post
Share on other sites

Got to test the driver tonight, all seems good, haven't spotted anything broken ... performance seems the same.

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

I've been trying to resolve an issue with stuttering when panning. It happens in any view but is really noticeable in VC mode where panning is not very smooth. I tried pretty much everything I could think of from reducing my texture settings to deleting the shaders. 

 

I reverted to 347.52 and the problem went away. 

 

I'm curious to see if anyone experienced this issue.

Share this post


Link to post
Share on other sites

I reverted to 347.52 and the problem went away. 

 

Interesting ... I have noticed (for P3D v2.5) that some lights (KIAH) are odd looking with 347.88 and seem to revert to a "normal" state as I approach them.  Also noticed that some airport lights (not all) are missing (LTBA) whoever PAPI lights are working fine ... don't know if this is an issue with the drivers or with the airport or some Orbx FTX Global/OpenLC/Vector conflict.  I can't really test driver side of this equation because there are no earlier drivers for the Titan X.

 

Also noted a strange issue with ShadowPlay at 4K @ 60Hz but recording at 30 fps ... my actual in-flight experience was extremely smooth, yet ShadowPlay's recording was full of "Jitters" (similar to how the Q400 is in Spot view).  You can see "jitters" in my video, but in the upper left my FPS is locked solid at 30 (no fluctuation).  

 

If I set my monitors refresh back to 30Hz and lock at 30 fps, the ShadowPlay recording has no jitters ... but my flight experience isn't as smooth at 30Hz (same panning issue) vs. when I set the monitor to 60Hz even thought I'm locked at 30 fps in both cases.

 

Going to have to ponder this one ... it's almost as if ShadowPlay was operating at 60Hz rather than the 30Hz (30 fps) I had it set to in ShadowPlay options.  Hmmm ... so ShadowPlay locks to monitor refresh regards of recording FPS setting.  I wonder if this is a bug or just how ShadowPlay works?  Or could this be the nvidia G-Sync is getting confused with my Sony which isn't G-Sync

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

Rob, that sounds like hanging on to old frames which twice as long @30, than 60, (when the next sync demands a new frame and it's not ready). Shows up in the sim or in the movie depending on where you set 30.

Share this post


Link to post
Share on other sites

 

 


Shows up in the sim or in the movie depending on where you set 30.

 

ShadowPlay is set to record at 30 fps.  P3D is locked at 30 fps (Vsync off and triple buffer off).  Monitor refresh is set to 60Hz.  What seems to be happening is that P3D likes the 60Hz/30FPS combo but ShadowPlay does NOT.

 

I can try FRAPS but I'm certain it will introduce performance issues as FRAPS records 4K at VERY high bit rates compared to Shadow Play.

 

I think my only option "for now" is a BMD 4K capture card ... but as I understand it the BMD 4K card only captures YCrCb420 @ 60Hz, not YCrCb444 @ 60Hz.

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

A-B 420 with 444 there's better colour with 444, got you.

Share this post


Link to post
Share on other sites

Interesting ... I have noticed (for P3D v2.5) that some lights (KIAH) are odd looking with 347.88 and seem to revert to a "normal" state as I approach them.  Also noticed that some airport lights (not all) are missing (LTBA) whoever PAPI lights are working fine ... don't know if this is an issue with the drivers or with the airport or some Orbx FTX Global/OpenLC/Vector conflict.  I can't really test driver side of this equation because there are no earlier drivers for the Titan X.

 

Also noted a strange issue with ShadowPlay at 4K @ 60Hz but recording at 30 fps ... my actual in-flight experience was extremely smooth, yet ShadowPlay's recording was full of "Jitters" (similar to how the Q400 is in Spot view).  You can see "jitters" in my video, but in the upper left my FPS is locked solid at 30 (no fluctuation).  

 

If I set my monitors refresh back to 30Hz and lock at 30 fps, the ShadowPlay recording has no jitters ... but my flight experience isn't as smooth at 30Hz (same panning issue) vs. when I set the monitor to 60Hz even thought I'm locked at 30 fps in both cases.

 

Going to have to ponder this one ... it's almost as if ShadowPlay was operating at 60Hz rather than the 30Hz (30 fps) I had it set to in ShadowPlay options.  Hmmm ... so ShadowPlay locks to monitor refresh regards of recording FPS setting.  I wonder if this is a bug or just how ShadowPlay works?  Or could this be the nvidia G-Sync is getting confused with my Sony which isn't G-Sync

 

Cheers, Rob.

 

I probably should have mentioned that I am also on P3D 2.5. What's interesting is that on the same hardware, I got better performance (same FPS but smoother) with 2.4 than I am now getting with 2.5. I can only assume that there are some things that 2.5 does differently in the background vs 2.4. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this