Sign in to follow this  
Matthew Kane

My Traffic 6 error

Recommended Posts

I think I am missing something but I am dyslexic and I am finding the installation process for My Traffic 6 to be tedious. I did everything as instructed unless their is something I missed. I am still getting this error message when starting up FSX-SE and no traffic:

 

mt6.jpg

 

Any ideas?

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Check the working scenery.cfg and check to location of where you installed MyTrafficProfessional.  The location in your scenery.cfg is not valid.

 

Best regards,

Share this post


Link to post
Share on other sites

As Jim stated your path to Mytraffic in your working scenery.cfg is incorrect.

It should read as follows but your path should point to the location where you installed MyTraffic

 

[Area.125]
Title=MyTraffic
Local=E:\MyTraffic Professional\MyTraffic
Layer=125
Active=TRUE
Required=FALSE

Share this post


Link to post
Share on other sites

 

 


It is still giving the same error message

 

Then your path is still wrong, where did you install MyTraffic ?

Did you use the communicator to localise the FSX-SE path ?

Share this post


Link to post
Share on other sites

Then your path is still wrong, where did you install MyTraffic ?

 

It is installed in D:\MyTraffic Professional\MyTraffic

 

 

 

Did you use the communicator to localise the FSX-SE path ?

 

Yes I did the steps as follows:

 

I started communicator

Localize My Traffic....OK

Localize FSX....OK

Manage FSX.cfg - Add My Traffic - Save and close

Enter FSX and select scenery directory

 

When I start up then that error message pops up. I've gone through the steps a few times now

 

I am only using FSX:SE without FSX so it says to localize FSX, Only localize FSX:SE if you have both installed but I am only using FSX:SE

Share this post


Link to post
Share on other sites

I started communicator

 

Localize My Traffic....OK

 

Localize FSX....OK

 

Manage FSX.cfg - Add My Traffic - Save and close

 

Enter FSX and select scenery directory

 

Do you also have FSX box edition installed ?

Can you browse to the location where you have MyTraffic installed and paste the path here,

Share this post


Link to post
Share on other sites

Do you also have FSX box edition installed ?

 

 

No I do not. I decided to migrate from FSX to FSX:SE so I did a clean install of Windows 7, then a clean install of FSX:SE. It has been problem free other then this issue.

 

Reason why I went with MyTraffic6 is because Ultimate Traffic 2 is no longer supported so I never did use MyTraffic6 in FSX boxed version. I purchased it after I did a clean install of WIndows7 and FSX:SE

 

So I am not sure what is going on here

Share this post


Link to post
Share on other sites

Have you checked the Scenery.CFG?

 

Yes when I follow the steps it is not making an entry into the Scenery.cfg file and when I manually add it that didn't do anything either

Share this post


Link to post
Share on other sites

Had the installer elevate to "Run as Admin" when it was supposed to update the scenery.cfg?

Share this post


Link to post
Share on other sites

I was getting this same message.  I had to use "FS2004/FSX Scenery Config Editor" to select the scenery folder.  For some reason, I was able to select the correct folder when trying to open through fsx.

Share this post


Link to post
Share on other sites

Matthew, until you post the path to where you have MyTraffic installed there is nothing we can do further to help you.

If we had this information it is a straightforward fix

Share this post


Link to post
Share on other sites

I had this same error. I just browsed to the location where My Traffic was installed and right-clicked on the address bar and selected copy address as text. Then I opened the scenery.cfg, found the My Traffic entry and pasted the proper address over the top of the erroneous one and that fixed it.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Matthew, until you post the path to where you have MyTraffic installed there is nothing we can do further to help you.

If we had this information it is a straightforward fix

 

Sorry I had to run to work yesterday

 

The path is located here - D:\MyTraffic Professional\MyTraffic\

Share this post


Link to post
Share on other sites

Matthew, your area 125 in your working scenery.cfg located in C:\ProgramData\Microsoft\FSX\ should read

 

[Area.125]
Title=MyTraffic
Local= D:\MyTraffic Professional\MyTraffic
Layer=125
Active=TRUE
Required=FALSE

 

And your FSX.cfg should contain the line

 

SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6="D:\MyTraffic Professional\MyTraffic\Aircraft"

 

Note the quotation marks in the SimObjectPaths.6="D:\MyTraffic Professional\MyTraffic\Aircraft" line, this is a windows convention but the scenery library entry does not seem to need them.

 

These are the only two entries that MyTraffic needs to work, so as long as you are editing the correct scenery.cfg (C:\ProgramData\Microsoft\FSX\scenery.cfg) it should work

Share this post


Link to post
Share on other sites

 

 


These are the only two entries that MyTraffic needs to work, so as long as you are editing the correct scenery.cfg (C:\ProgramData\Microsoft\FSX\scenery.cfg) it should work

 

That was my problem right there, I was modifying the Scenery.cfg file located in D:\Program Files (x86)\Steam\steamapps\common\FSX

 

I didn't realize their was another Scenery.cfg file located in C:\ProgramData\Microsoft\FSX\scenery.cfg

 

Thanks a million for your help Glynn, I have made the change and I now have AI Traffic working

 

Cheers  B)

Share this post


Link to post
Share on other sites

Seems great that you've finally managed to manually circumvent the problem by applying a setting that had not been properly made in C:\ProgramData\Microsoft\FSX\scenery.cfg when it should have been. So although it's working now, isn't it still a mystery as to why you had the trouble?

 

Either the installer does not edit the file, or the permissions on that folder did not allow it to be edited.

 

With FSX, "Users" get the permission to modify that folder, however with FSX-SE, they do not ordinarily get permission. Maybe that's your real problem.

Share this post


Link to post
Share on other sites

I also had this issue. For whatever reason the installer set the path to

 

Local=..\..\..\..\My Traffic\MyTraffic   instead   of B:\Program Files\My Traffic

 

Maybe it's an issue that needs to be looked into? 

Share this post


Link to post
Share on other sites

I just spent the last 2 hours getting this working, searched the forums or MyTraffic but all the help didn't do much.  But I finally got it working.

 

First Problem: The guide states that you go into Add Scenery and MyTraffic should be a folder that you can select.  It was not in mine so in the end I had to got add scenery and direct it to the file in my C drive.  No Matter what I did a MyTraffic Folder never appears in my Steam\FSX Folder

 

Next Problem: I had the config error and all post told you to look in C:Users/All Users.  I had no such path on mine and kept wrongly putting the C:MyTraffic Professional\MyTraffic fix in the wrong scenery config file.  Its not the on in your Steam\Common|FSX folder, but mine was in C:Programe Files\Microsoft\Flight Simulator.

 

Anyway now working but FPS hit a bit too much set on 30% so need to look into that.

 

Regards

Share this post


Link to post
Share on other sites

Hello,

 

I did what you guys suggested but still got the scenery error. I then decided to copy the My Traffic folder into the

FSX-SE folder making it local and was able to install it from within FSX-SE instead of manually.

Hope this helps anyone still having installation problems.

 

MAJ

Share this post


Link to post
Share on other sites

Hi,

Recently I have installed MY TRAFFIC 6 following the installation guide. I have did the changes that explain in the guide, but when I start FSX and create a new flight in any airport, it is empty, there isn't any aircraft.

The steps that I have followed:

1. Open my traffic comunicator and selected the folders to my traffic and fsx.

- E:\MYTRAFFIC 6\MyTraffic     (I have installed it in other hard disk)

- C:\FSX\

2. Add the line mytraffic in fsx.cfg

[Main]
FIBER_FRAME_TIME_FRACTION=0.25
HideMenuFullscreen=1
HideMenuNormal=0
Location=1689,335,2327,766,\\.\DISPLAY1
Maximized=2
PerfBucket=7
ProcSpeed=8512
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\IVAO_MTL
SimObjectPaths.7="E:\MYTRAFFIC 6\MyTraffic\Aircraft"
User Objects=Airplane, Helicopter

 

3. Add MY TRAFFIC in scenary.cfg

[Area.122]
Title=Objetos de helice
Texture_ID=
Layer=122
Active=TRUE
Required=TRUE
Local=Scenery\Props

[Area.123]
Title=MyTraffic
Local=E:\MYTRAFFIC 6\MyTraffic
Active=TRUE
Required=FALSE
Layer=123

[Area.124]
Title=Escenario adicional
Texture_ID=
Layer=124
Active=TRUE
Required=FALSE
Local=Addon Scenery

 

4. Disable FSX AI traffic from Mytraffic comunicator.

 

5. Finally, I had a error in mytraffic comunicator that said:  TrafficDataBasebuilder not found

I have read about this problem, I find the SDK folder in C:\fsx and I have copied and pasted the TrafficDataBaseBuilder .exe in E:\MYTRAFFIC 6\mytraffic

Then, this error has disappeared

 

 

 

Then, What I do wrong?

Thank you very much and I hope someone can help me

 

Share this post


Link to post
Share on other sites

 There are two things that look wrong from what I can see.

 

 First would be to remove the quotation marks from your SimObjectPaths.7="E:\MYTRAFFIC 6\MyTraffic\Aircraft"

 

Second would be to ensure that your scenery.cfg is actually pointing to the scenery folder where your MyTraffic scenery bgl's are located. For instance, MyTraffic Professional\MyTraffic\Traffic\scenery

Share this post


Link to post
Share on other sites

Dear Dave,

 

First, thank you so much for your help.

 

I have removed the quotation marks as you said. The result is as follows:

 

SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\IVAO_MTL
SimObjectPaths.7=E:\MYTRAFFIC 6\MyTraffic\Aircraft
User Objects=Airplane, Helicopter

 

Second,  I have found the route C:\ProgramData\Microsoft\FSX\scenary.cfg  

 

In this route, I have this area and I have added Scenary in local line

[Area.123]
Title=MyTraffic
Local=E:\MYTRAFFIC 6\MyTraffic\
Scenary
Active=TRUE
Required=FALSE
Layer=123

 

 

Finally, the most important. I had a confusion with the option "disable FSX default AI traffic" in MY TRAFFIC COMMUNICATOR . I thought that MY TRAFFIC 6 not  needed  that "AirlineDensity and GADensity" in FSX traffic settings should have any value. These were at 0! Therefore had no aircraft or traffic in any airport  :fool: 
 

Thank you so much for your help! The problem is solved! ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this