Sign in to follow this  
Poppet

Anti-Aliasing, This works for me.

Recommended Posts

 

I feel a bit silly posting this because this is old news to everyone else,  but i have found what works,  for me anyway.  
 
I'm using a GTX 690 4 gig Sli card.  
 
My biggest problem in Prepar3D was the shimmering around the Dials/Gauges and clocks, all the displays really.  Never had a problem with anything on the outside it was all in the Cockpit/VC,
used to drive me nuts.   And now i can gladly say,  every bit of shimmering is now gone from all areas of the Cockpit/VC.   
 
Maybe this might help some people like myself who are not as advanced as the rest of you's.
 
So what did i do ?  I just followed Rob Ainscough's  Nvidia Inspector Settings,  (Thank you Rob)
 
So what exactly did i do,  step by step.  Went to my P3D panel and set it like this  (haven't got a clue if this makes any difference)
 
16659108094_589723db56_b.jpgCapture[/url] by *poppet*[/url], on Flickr
 
 
 
 
 
Then opened up my Nvidia Control Panel and hit (Restore Default) at the top right of my panel, then hit the (Apply) at the bottom right,  i done this for Global settings and Program settings.
 
Then opened up my Nvidia Inspector and input the settings exactly like Rob's diagram showed.  (don't forget to hit apply at the top right)  Here is the screen shoot. 
 
 
16661110853_0af68b4df6_o.pngCapture.PNGgg[/url] by *poppet*[/url], on Flickr
 
 
As you can see,  i dropped the the Anistropic Filtering Settings down to 8 in the Nvidia Inspector Panel,  only to gain a little more performance as i don't have the Monster machine Rob has. 
 
I went back to my Nvidia Control panel and it looked like this,  so obviously after Restoring it,  the Nvidia Inspector changed it. 
 
 
17074541397_e92a6f1b02_o.pngCapture.PNGp by [url=https://www.flickr.com/people/131429773@N03/]*poppet*, on Flickr
 
 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

it is because you used SGSS AA that your have (almost)no shimmering...

All other AA settings only work through the P3D menu or NV Control Panel.

Share this post


Link to post

SGSS Makes everything look just fine, but really kills FPS when there are clouds in the area.

Share this post


Link to post

it is because you used SGSS AA that your have (almost)no shimmering...

All other AA settings only work through the P3D menu or NV Control Panel.

Hello Gerard, I understand you.  I tried to do this loads of times and failed (my own doing)  Its only up till last night i understood how it all worked. It makes a massive difference whilst panning around the cockpit, very happy with  :rolleyes:

SGSS Makes everything look just fine, but really kills FPS when there are clouds in the area.

Hello Brendan,  well that's true,  i only fly little to middle stuff so i'm hoping it will be ok.   

Share this post


Link to post

What is the true alternative for 4xGSSS AA for P3D without losing a quality?

Share this post


Link to post

What is the true alternative for 4xGSSS AA for P3D without losing a quality?

 

DSR 4x + MSAA 4x

Share this post


Link to post

DSR 4x + MSAA 4x

Thanks, NVI should be disabled, I presume. Is it correct?

Share this post


Link to post

Thanks, NVI should be disabled, I presume. Is it correct?

I do not use Inspector.

Share this post


Link to post

Thanks again -  I will try. Funny how people are able to run shimmering - free P3D without NVI these days.

Share this post


Link to post

 

 


Thanks, NVI should be disabled, I presume. Is it correct?

 

One doesn't enable or disable NI, it only can affect the NVidia settings. Just use the NVidia CP to reset your graphic settings to default and don't use NI to adjust anything.

 

As for shimmering, just using 4xMSAA and FXAA cures any shimmering for me at my default desktop resolution of 1920x1080.

Share this post


Link to post

As for shimmering, just using 4xMSAA and FXAA cures any shimmering for me at my default desktop resolution of 1920x1080.

 

Hello Philip, that's interesting, change this only in your Nvidia Control Panel? And not in NI

Share this post


Link to post

It's just two different places to access the same settings- I think Nvidia inspector gives more options and a wider range of profiles, but essentially it's just a fancy "nvidia control panel." 

Share this post


Link to post

Hello Philip, that's interesting, change this only in your Nvidia Control Panel? And not in NI

 

I just set it through P3D.

 

The only changes I make in NVidia Control Panel are:

 

1. Enable MFAA

2. Enable High Performance Mode

3. Enable Single Display Mode

4. Set LOD to Clamp

Share this post


Link to post

Thank you Brendan

 

 

 


I just set it through P3D.

 

Oh right,  ill certainly try that,  thank you for the reply Philip 

Share this post


Link to post

What is MFAA? I don't see that in my anti aliasing settings

Share this post


Link to post

Hi Brendan, it's a new AA technique but only available on the 9XX series Nvidia cards...

Share this post


Link to post

I just set it through P3D.

 

The only changes I make in NVidia Control Panel are:

 

1. Enable MFAA

2. Enable High Performance Mode

3. Enable Single Display Mode

4. Set LOD to Clamp

Are you sure that this works as the game needs to support this and none of the Fs is one of them.

 

"Nvidia is introducing this nice new AA mode which gives the same quality as 4x MSAA but has only the performance costs of 2x MSAA. It is based on a Temporal Synthesis."

 

http://www.guru3d.com/articles-pages/mfaa-multi-frame-sample-aa-guide-review,1.html

Share this post


Link to post

Hey Gerard,

 

No I'm not sure whether P3Dv2 supports MFAA, but it's ticked on regardless! :)

Share this post


Link to post

Actually you can see it working if you enable it and take a flight in a chopper...AA should be apparent, but there is also some strange "artifacting" if you look at clouds through the rotor effects (I'm guessing this is the algorithm trying to work out the difference between the two frames)... 
 

Share this post


Link to post

You know what did it for me- getting rid of SweetFX/Reshade- I was able to modify the prepar3d native HDR.hlsl to achieve the same result, and it actually softened the cockpit nicely, without blurring out detail. 

Share this post


Link to post

Thank you for all the posts and tips,  learning loads and finally chasing that magic dragon of the Simming world   B)

 

Thank you 

Share this post


Link to post

By the way, I get by with a very modest 2xSGSS on the GTX670, in my experience it eliminates most flicker; of course 4x is better, but also much harder on frames, at least on my aging GPU. :)

 

P3D settings are FXAA off, 4xMSAA, 4xAnisotropic; then, using NI, set Antialiasing mode to "Enhance the application setting" and add the 2xSGSS Transparency Supersampling.

Share this post


Link to post

By the way, I get by with a very modest 2xSGSS
Yes i have been playing with the settings and dropped mine down to 2xSGSS as well and keep everything else the same as my original NI post and i am still happy with it.  Its a nice balance between quality and performance. 
 
Here is my P3D settings,   the strange thing is though,  when i up my MSSA from 4 to 8, its like it goes in reverse,  the Anti-Alaising comes back into it, i then drop it back to 4 and its perfect again!! Strange, not a problem though, i'm happy. 
 
16659108094_18997862f5_o.pngCapture by *poppet*, on Flickr

Share this post


Link to post

 

 


down to 2xSGSS as well

 

I'm with you on this one Elaine. 2xSGSS is fine here. I'd bump up the anisoptropic to 16 though, I doubt that would have a noticeable affect on performance.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this