Sign in to follow this  
fppilot

Turbine Duke V2 - losing mouse pointer function in flight

Recommended Posts

As far as I recall the issue I am having has so far appeared in the Turbine Duke v2. Have had this happen at least three times in flight and cannot figure out how to resolve the issue or how to prevent it. I have also had it happen on the ground a small number of times.  When the issues occurs my mouse pointer ceases to perform any function in the VC. The pointer is there and moves about freely (this does not appear to be the FSX issue where the pointer freezes in the lower right corner) and the pointer does provide access to the FSX menus.  But when this occurs the mouse pointer will not perform any VC function such as changing frequencies, altimeter setting, toggling pop-up GPS windows, et al, and will not change shape at VC spots where it normally does. 

 

On the ground the issue can usually but not always be resolved by switching to another aircraft, then back. But in flight that presents other issues.

 

Anyone else experiencing this? Any known resolution?

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Frank,

 

It's a known issue and can happen from time to time.  The issue (I think) is related to the lights they use and the water effects you have set...some conflict or some overload of a system resource...at least that's what I've noticed.  For my system, I have to turn my water effects to Low 2.0 and the problem never happens.  Alternately, you can switch to the other set of landing lights RealAir provided in their config panel and that should fix it as well.  Either way should work.

 

Gregg

Share this post


Link to post
Share on other sites

I've had this issue in a few payware aircraft. Fixed it by removing the camera listings in the aircraft.cfg file and make sure in the panel.cfg all the gaugeXX entries were correctly starting at gauge00 and counting up

Share this post


Link to post
Share on other sites

Hi Frank,

 

It's a known issue and can happen from time to time.  The issue (I think) is related to the lights they use and the water effects you have set...some conflict or some overload of a system resource...at least that's what I've noticed.  For my system, I have to turn my water effects to Low 2.0 and the problem never happens.  Alternately, you can switch to the other set of landing lights RealAir provided in their config panel and that should fix it as well.  Either way should work.

 

Gregg

Thanks Gregg, will try that and see. Any way you know of to recover in flight when it does happen?

Share this post


Link to post
Share on other sites

 

 


Any way you know of to recover in flight when it does happen?

 

I've never tried it since I adjusted my water slider, but you might try adjusting your water slider when in flight.  Might work.

Share this post


Link to post
Share on other sites

make sure in the panel.cfg all the gaugeXX entries were correctly starting at gauge00 and counting up

 

Will have to try that out as well. I note that in my .cfg file the gauges are currently numbered starting at 01. Looking at the copy I made of the original panel.cfg file (immediately after installaton) I note the same numbering beginning at 01. 

 

Do you mean the entries in say the [VCockpit##] entries? or in the [Window##] entries?

Share this post


Link to post
Share on other sites

if you are using ezdok also double check that your view hasn't moved back a bit into the seat (slide it forward a tiny bit)...visually you can't see anything unusual in this case but the inside of the headrest can be collecting all the clicks.

cheers

-andy crosby

Share this post


Link to post
Share on other sites

I've never tried it since I adjusted my water slider, but you might try adjusting your water slider when in flight.  Might work.

 

So do you believe the water slider would cause the issue even when not near water? Not sure I was unless it was the Ohio river 24,000 ft below and under an overcast.

Share this post


Link to post
Share on other sites

 

 


I have to turn my water effects to Low 2.0

 

Humm. Checked. That is the water effects setting I have been at.  

 

I have just configured so that I am not using the 3D lights. Will see if that does the trick.  Makes me wonder if an in-flight solution would be to turn the lights off and on again with the "L" key.  Also trying to remember if the issue occurred always at night. Interesting because on my system I have had issues with the lights on the MilViz B55 and especially with the MilViz C310. 

Share this post


Link to post
Share on other sites

 

 


That is the water effects setting I have been at.

 

Looking at your system, it's less powerful than the one I have now so you might have to turn the slider down some more if you try the water slider route.  On the other hand, if you've changed out the lights you'll probably be okay.  I really like the 3D lights.  I rarely fly it at night but, when I do, they are just amazing.

Share this post


Link to post
Share on other sites

A known issue. Several aircraft had it but Real is the last to have not corrected it. The workaround is kill the 3d lighting effects. That solves the problem for good.

Share this post


Link to post
Share on other sites

 

 


if you are using ezdok also double check that your view hasn't moved back a bit into the seat (slide it forward a tiny bit)...visually you can't see anything unusual in this case but the inside of the headrest can be collecting all the clicks.

 

I have had this occur using TrackIR also. Recentering with F12 will correct it.

Share this post


Link to post
Share on other sites

A known issue. Several aircraft had it but Real is the last to have not corrected it. The workaround is kill the 3d lighting effects. That solves the problem for good.

 

So does it only occur at night? or when using the lights?

 

With the 3D's unconfigured I am unable to even tell if the taxi lights are on.

Share this post


Link to post
Share on other sites

It has nothing to do with having the lights on or not. In the settings you can choose their 3D lights or default FSX lights. Just having it set to the 3D lights is enough to cause it.

Share this post


Link to post
Share on other sites

Here is something interesting about this. I am still learning the locations of the switches and controls in this Turbine Duke v2 (TDv2) vs the checklists. To better learn them I have been changing VC views via the FSX "A-key" and "Shift-A-key" functions. Twice this afternoon, on the ground, I shift-a'd from another view back to the primary VC view and found I had lost the interactive mouse pointer. It happened once more when I Alt-Tab'd out of and back into FSX to look at the RealAir TDv2 Flying Guide. So I started experimenting. Turning the lights on/off with the "L" key, etc. No success! Then I started toggling through the various VC views, again with the A-key/Shift-A-key. Both times I found a VC view where the interactive mouse pointer was available. Each time I used the pointer to do something in those views and returned to the primary VC view the interactive pointer was once again available!

 

This will take some more verification, but perhaps this way it will be possible to use the 3D lights and have an emergency procedure if the interactive pointer goes away.

Share this post


Link to post
Share on other sites

This whole issue is a very sporadic thing. I had been dealing with it for years since the first more advanced aircraft have come out. Sometimes everything is fine for days and even weeks and then all of a sudden the problem happens out of the blue. You can change views and a host of other things and it seemingly solves the problem and then it happens again.

 

In the end the lights setting solves the problem for just about everyone so that must be the true issue.

 

Of course you might be one of the outliers where it's caused by some other issue.

Share this post


Link to post
Share on other sites

Well today convinced me to permanently deselect the 3D lights for this TDv2. Two hour flight and constantly lost the interactive pointer. If you are interested, the most frequent action to bring it back was to toggle on and off the FSX menu bar. This in full screen mode. I do not fly in windowed mode. I did try some of that today to see if it would make any difference.  It did. In windowed mode I never, not once, got the interactive pointer back.

Share this post


Link to post
Share on other sites

if you are using ezdok also double check that your view hasn't moved back a bit into the seat (slide it forward a tiny bit)...visually you can't see anything unusual in this case but the inside of the headrest can be collecting all the clicks.

cheers

-andy crosby

This is most likely the cause.

Share this post


Link to post
Share on other sites

 

 


This is most likely the cause.

 

Do not (never have) use EZdok here.

Share this post


Link to post
Share on other sites

Do not (never have) use EZdok here.

 

make sure all the gauge listings are numbered correctly in the panel.cfg file for each section, then if still not fixed, delete the camera sections in the aircraft.cfg file. doing both fixed the loss of clickspots for me. Are you still having this problem?

Share this post


Link to post
Share on other sites

Disable the 3D landing lights in the Turbine Duke V2 Configuration program (the standalone configuration program, not the installer). This is a well documented issue for a number of users.

Share this post


Link to post
Share on other sites

Disable the 3D landing lights in the Turbine Duke V2 Configuration program (the standalone configuration program, not the installer). This is a well documented issue for a number of users.

You do not have to lose that feature. The solution is as I explained to make sure your gauges are numbered correctly in the panel.cfg and then to remove all the camera settings from the aircraft.cfg file

 

I just reinstalled the duke v2 and the same thing happened with a loss of clickspots until I did those 2 steps

 

Also unrelated to this but to correct the error in the contact points, the aircraft.cfg has a contact_points error one of the numbers on the first point.0 line is 3,1 and should be 3.1

 

I have a small issue with the radios not turning off, my avionics and battery are off but I still hear radio transmissions.

Share this post


Link to post
Share on other sites

then to remove all the camera settings from the aircraft.cfg file

 

What is the effect of doing this?  What then is lost with the model when these are removed?

 

Can I PM you my panel.cfg file? My gauges are in order from 01 to 23, no gaps, so I would like to know what numbering issue you refer to.

 

I will point out that I have with my system also had significant issues with the 3rd party landing lights included in a couple of MilViz GA models.

Share this post


Link to post
Share on other sites

What is the effect of doing this?  What then is lost with the model when these are removed?

 

Can I PM you my panel.cfg file? My gauges are in order from 01 to 23, no gaps, so I would like to know what numbering issue you refer to.

 

I will point out that I have with my system also had significant issues with the 3rd party landing lights included in a couple of MilViz GA models.

Do you use the default avionics? They should start gauge00 and count up from there. I use RealityXP and had to re-number them

 

Also in the aircraft.cfg you have to remove the camera sections

 

Then it "should" fix the loss of mouse control in the vc.

 

I had the same loss of clickspots in other aircraft like Milviz and A2A and doing these steps fixed it (but for A2A I lost the camera sections so I lost the walk around ability)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this