Sign in to follow this  
ashepherd316

P3D v3 Ultimate traffic 2 smartassembly error

Recommended Posts

Hello i have tried everything to install UT2 in p3d v3 but when i start p3d i get an error message saying this feature requires that {smartassembly} is available on this computer p3d still loads and i can play it but there are no ai aircraft i have windows 7 64 bit ultimate and net framework 4.5.2 am i doing somrthing wrong thanks.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I too would like to know the correct installation method without using a conversion tool. 

Share this post


Link to post

I've always wondered if Mr. Embly was a rude Microsoft employee.

  • Upvote 1

Share this post


Link to post

I've always wondered if Mr. Embly was a rude Microsoft employee.

You beat me to it Jay.... :Party:    (and thanks for the hu about Rapport!!).

Share this post


Link to post

Can anyone help please i am also getting this error Program Error Erroro loading aircraft assignments InvalidArgument=Value of '0' is not valid for 'SelectedIndex'. Parameter name: SelectIndex please help i'm losing my mind.                          

Share this post


Link to post

Can anyone help please i am also getting this error Program Error Erroro loading aircraft assignments InvalidArgument=Value of '0' is not valid for 'SelectedIndex'. Parameter name: SelectIndex please help i'm losing my mind.                          

 

Take the error message. Load it into Google search. Follow the instructions in the topics you find.

 

You could have solved this immediately if you used the search function in the forum.

Share this post


Link to post

On the smartassembky error, I once had it occure when UT2 first came out, albeit it was FSX. After doing a trouble shooting phone call with a fellow from Flag Mountain which was the architect of UT2, it turned out that I didn't have the correct version of Simconnect installed. Once that was installed I hadn't had a problem since.

 

So having said that, have you installed all three versions of Simconnect that come with P3D? Not sure that will fix it, but it shouldn't harm anything either.

Share this post


Link to post

How do you install the simconnect where is it thanks.


I installed the sdk that came with p3d v3 the version is 3.0.10.14945 does that not have all 3 versions thanks.

Share this post


Link to post

How do you install the simconnect where is it thanks.

I installed the sdk that came with p3d v3 the version is 3.0.10.14945 does that not have all 3 versions thanks.

C/LockheedMartin/P3dV3/redist/interface

 

You will see these folders click them then retail/lib/SimConnectInstaller

Id just install all 4

 

 

ESPv1

FSX-RTM

FSX-SP1

FSX-SP2-XPACK

Share this post


Link to post

Did that still exactly the same what else could it be thanks.


ok i think the other errors have gone but i am getting this error now Program Error Error loading default UT2 or FSX settings. The 'Launch.Addon' start tag on line 7 does not match the end tag 'SimBase.Document'. Line 15, postion 3. what on earth does that mean thanks.

Share this post


Link to post

There's actually a lot of discussion regarding this error in the CTD subforum. Here's what Jim Young suggests:

 

http://www.avsim.com/topic/319532-fsx-ctd-with-smartassembly-error/?p=2885147

 

I'd first look to see what versions of .NET are installed. UT2 is pretty old and no longer supported. And it was never supported in any version of P3d to my knowledge. It requires one of the earlier versions of .NET(Microsoft .NET 3.5 Service Pack 1). Here's how to check on what versions of the .NET framework are installed on your computer:

 

https://msdn.microsoft.com/en-us/library/hh925568(v=vs.110).aspx

 

The registry key locations vary from one version of Windows to the other, but for example, I have .NET 2.0, 3.0, 4.0, 4.5 and 4.6 installed.

Share this post


Link to post

i have net framework 4.5.2 according o that do i need to update.


I installed 4.6 didn't do anything still get the same error.

Share this post


Link to post

If an app needs .NET 3.5 SP1, any of the 4.x versions will not help with this error. Only the minor revisions like 4.5, 4.6, etc., would be backwards compatible only to 4.0 but not to any 3.x, 2.x and 1.x versions.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this