Sign in to follow this  
markmco

IRIS Simulations

Recommended Posts

I couldn't find this posted, but IRIS Simulations are offering big discounts on many of their aircraft.  Just picked up the Battlefield Airlifter for 50% off.  Some discounted more.

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Curious, all these work fine in P3D v3?  Always been wanting to try their planes...

Share this post


Link to post
Share on other sites

Curious, all these work fine in P3D v3?  Always been wanting to try their planes...

V2 installer appeared to install to v3.1 fine. Still learning the aircraft, but it appears to run fine in 3.1. Will need some more time, but initially no problems. Just my own experience so far with the Battlefield Airlifter.

Share this post


Link to post
Share on other sites

All Iris products seem a fair bit cheaper at flightsimstore (unless there's another price correction!) - got me the new Grob for Aus$14 - so get in quick.

Share this post


Link to post
Share on other sites

All Iris products seem a fair bit cheaper at flightsimstore (unless there's another price correction!) - got me the new Grob for Aus$14 - so get in quick.

Yes. This time I purchased before posting... Didn't wanna miss out like I did with the Milviz stuff...

Share this post


Link to post
Share on other sites

All Iris products seem a fair bit cheaper at flightsimstore (unless there's another price correction!) - got me the new Grob for Aus$14 - so get in quick.

As of this morning, you're right. They're even cheaper at FSS! Excellent models too. Have to get one or two more.

 

Merry Christmas!

Share this post


Link to post
Share on other sites

Passing along my findings, bought the BD-5J, Grob P3D, PC-9 P3D, Texan P3D and Airlifter P3D from FSS with the great sale at FSS (although still annoyed with them about the Milviz issue)... yeah I splurged ha, don't tell the wife.

 

Everything but the PC-9 P3D installed and is flying in P3Dv3.1.... for some reason the PC-9 is using a different installer that is looking specifically for P3D 2.5, and errors out... I don't really want to have to reinstall 2.5, so will research options (any help please!!!), but the others all install and work great.

 

The BD5 is the oldest and only $5, but man, it is a complete riot to fly, love it!  All have great models and panels, and at least from first basic flights feel good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this