Sign in to follow this  
Blue Baron

Aircraft fuselage disappears minutes into a flight!

Recommended Posts

I am having issues with FSX I've never encountered with FS9! I noticed some aircraft bodies disappearing (leaving just the cockpit window panes and blinking exterior lights) a few minutes after takeoff. The noise suggests the aircraft is still there. Does anyone know what is going on?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

DX10 preview mode checked in your FSX/Customize/Graphics setting?  Are you running FSX+Acceleration

 

from discs or just FSX with SP1 and SP2.  Most addon aircraft will require SP2.

Share this post


Link to post
Share on other sites

DX10 preview mode checked in your FSX/Customize/Graphics setting?  Are you running FSX+Acceleration

 

from discs or just FSX with SP1 and SP2.  Most addon aircraft will require SP2.

I don't have DX10 preview mode checked in my FSX. I installed FSX + Acceleration with disks.

Share this post


Link to post
Share on other sites

Typically this is due to graphics cards not being able to keep up with the load , do you have an older machine running with high settings ?

 

Turning the aircraft shadows off will probably free up some gpu cycles as that duplicates the mesh.

 

Best CJ 

Share this post


Link to post
Share on other sites

Typically this is due to graphics cards not being able to keep up with the load , do you have an older machine running with high settings ?

 

Turning the aircraft shadows off will probably free up some gpu cycles as that duplicates the mesh.

 

Best CJ 

Thank you. Still, I am puzzled. I have a NVIDIA GeForce GTX 980 card

Share this post


Link to post
Share on other sites

Thank you. Still, I am puzzled. I have a NVIDIA GeForce GTX 980 card

Just to make sure since your using the boxed version of FSX, have you put the Highmemfix=1 in the [GRAPHICS] section of your FSX.cfg? Without that entry you can get graphic corruption from time to time.

 

You could also try rebuilding your shader cache files. Follow the instructions here to rebuild them https://fsxtimes.wordpress.com/2011/07/11/clean-up-shader-cache/

Share this post


Link to post
Share on other sites

Just to make sure since your using the boxed version of FSX, have you put the Highmemfix=1 in the [GRAPHICS] section of your FSX.cfg? Without that entry you can get graphic corruption from time to time.

 

You could also try rebuilding your shader cache files. Follow the instructions here to rebuild them https://fsxtimes.wordpress.com/2011/07/11/clean-up-shader-cache/

I must confess, I'm a novice to FSX :rolleyes: . How would I get to the FSX.cfg area?

Share this post


Link to post
Share on other sites

must confess, I'm a novice to FSX . How would I get to the FSX.cfg area?

 

 

easy  just type fsx.cfg   in the search box  at the start menu will get  you there  quickly  or  just naviagate   to your  c  drive/user/your name/app data/roaming/Microsoft/fsx  and  the fsx.cfg  will be  3/4  way  down  on the list  once  you open it  up using notepad  look for  the graphic  section  and  insert Highmemfix=1 anywhere in the graphic  section  save  and  close

Share this post


Link to post
Share on other sites

 

 

easy  just type fsx.cfg   in the search box  at the start menu will get  you there  quickly  or  just naviagate   to your  c  drive/user/your name/app data/roaming/Microsoft/fsx  and  the fsx.cfg  will be  3/4  way  down  on the list  once  you open it  up using notepad  look for  the graphic  section  and  insert Highmemfix=1 anywhere in the graphic  section  save  and  close

I've done those things already but I am still not seeing the specific items (i.e. fsx.cfg, App data) you pointed out. By the way, I am using Windows 7. This may explain why I am having these issues. Any suggestions...?

Share this post


Link to post
Share on other sites

I've done those things already but I am still not seeing the specific items

 

Confused  you say  you have  entered   the highmenfix=1  and  you say your  not seeing  the appdata,  you would have  seen this  since  you have  entered  the fix in your  fsx.cfg

Share this post


Link to post
Share on other sites

I must confess, I'm a novice to FSX :rolleyes: . How would I get to the FSX.cfg area?

The file path, replace Yourname with what ever you named your computer.

C:\Users\Yourname\AppData\Roaming\Microsoft\FSX\fsx.CFG.

 

You can just click through the folders in My Computer until you find it but it's a hidden folder so you need to unhide it by doing this.

 

To show hidden files on Windows 7

 

Open 'My Computer'

'Organize' Tab

> 'Folder and search options'

> 'View' Tab

> Then you'll see where to select 'show hidden files folders and

drives'

 

Here's a youtune video that might help or search youtube for finding fsx.cfg.

 

https://m.youtube.com/watch?v=TlKWZ-WAjE4

 

 

 

Confused you say you have entered the highmenfix=1 and you say your not seeing the appdata, you would have seen this since you have entered the fix in your fsx.cfg

I think he's means he followed your instructions and couldn't find it.

Share this post


Link to post
Share on other sites

Yes, the files were indeed hidden. I can see them all now. Thanks for tip. I've finally found the Shader and Shader10 folders as well. I noticed there are folders within those folders. Am I supposed to completely delete the contents of the subfolders for both the Shader and Shader10 folders?

Share this post


Link to post
Share on other sites

Not sure if you got this fixed or not as it looks like it's been about 2 months, but incase you haven't fixed it yet, I had this same issue one time and the HighMemFix alone didn't work on my plane, the fix I used was to add these lines in my fsx.cfg, NOTE: add them in the [Graphics] section of the fsx.cfg, (only if they are not there already, they don't need to be there twice)

SPECIAL NOTE: I always FIRST make a copy of my original fsx.cfg just incase something goes wrong, just right click on it and copy and paste it on your desktop

1) Add the 2 lines in the section shown (don't overwrite or remove ANYthing else and don't duplicate if they are already there)
[Graphics]
HIGHMEMFIX=1
STALE_BUFFER_THRESHOLD=2147483647

2) Then, go to your Shaders folder shown here: https://fsxtimes.wordpress.com/2011/07/11/clean-up-shader-cache/

And delete the folder OR folders inside the "Shaders" folder. (Like the article says FSX will rebuild the shaders once you restart it.)


3) Restart FSX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this