Sign in to follow this  
AdvancedFollower

GPU tesselation still broken in P3D v3?

Recommended Posts

So I upgraded to P3D v3 from 2.5, and unfortunately it's broken.

 

http://imgur.com/a/9TziU

 

The first image is with Tesselation enabled. Note:

Blurry textures

Light, black triangle on the ground and further black lines in the distance, faint black line roughly following the contour of the road. These faint black lines fade in and out depending on viewing angle and elevation and seem to appear especially around roads and other vector objects.

 

Second image with tesselation disabled: sharper textures, no visual artifacts.

GTX 970, driver 364.72

 

Is it a driver issue, or were the P3D beta testers not paying attention again?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Third option - it may be your system or settings.

 

Obviously it is not broken or we all would have the problem. Some have said that going back to the 353.30 drivers is better than 364.72 but YMMV.

 

 

Vic

Share this post


Link to post

Are you using 3.2? Come to think of it I haven't tried turning tessellation off to see if that solves the blurries I'm having.

Share this post


Link to post

Are you using 3.2? Come to think of it I haven't tried turning tessellation off to see if that solves the blurries I'm having.

Bloom, if you have a 4 core CPU with H.T. capability...turn it on...and at the top of the P3D v3.2 config file....add:

 

[JOBSCHEDULER]
AffinityMask=244
 
P3D v3.2 loves H. T....and the above setting for 4 real, and 4 virtual cores...     The sim runs like a Swiss watch! :)

Share this post


Link to post

Bloom, if you have a 4 core CPU with H.T. capability...turn it on...and at the top of the P3D v3.2 config file....add:

 

[JOBSCHEDULER]

AffinityMask=244

 

P3D v3.2 loves H. T....and the above setting for 4 real, and 4 virtual cores...     The sim runs like a Swiss watch! :)

What do you mean by "4 real and 4 virtual"...? You don't mean using them all right? Because that AF doesn't use the complete 1st core or the second logical...: 11 11 01 00 = 244

Share this post


Link to post

What do you mean by "4 real and 4 virtual"...? You don't mean using them all right? Because that AF doesn't use the complete 1st core or the second logical...: 11 11 01 00 = 244

 

Right...because P3D v3.2 doesn't address those core much...so free them for system work.

 

244 is for a 4 core running in Hyperthreading Mode.

 

244 prevents thread collisions, and gives silky smoothness in H.T.  I use it across all my sims, and I only run my system in H.T.

 

http://www.avsim.com/topic/444793-one-tweak-to-rule-them-all-how-to-set-affinity-mask-correctly/

 

:)

 

Mitch

Share this post


Link to post

Right...because P3D v3.2 doesn't address those core much...so free them for system work.

 

244 is for a 4 core running in Hyperthreading Mode.

 

244 prevents thread collisions, and gives silky smoothness in H.T.  I use it across all my sims, and I only run my system in H.T.

 

http://www.avsim.com/topic/444793-one-tweak-to-rule-them-all-how-to-set-affinity-mask-correctly/

 

:)

 

Mitch

 

For P3D the recomendation on 4 core with HT enabled is 85 or 116

Share this post


Link to post

For P3D the recomendation on 4 core with HT enabled is 85 or 116

Glenn, if you using either of those settings, try 244 and see how it runs for you....you might like it!  I can go as low as 11-12 FPS and still have no visual stutter!

 

Just out of curiosity...I'll replace 244 with your 85 and see if there is a performance difference, in either FPS to any particular scene, as well as animation smoothness.  I'll report back if there is anything different from running under my normal 244 setting.

 

Post Edit:   Just came off an '85' setting flight.  Result....blurry ground textures, and stutter

 

Went back to 244....and clear ground textures and stutter-free one more.

 

No thanks....244 it stays!

 

Cheers,

Share this post


Link to post

Bloom, if you have a 4 core CPU with H.T. capability...turn it on...and at the top of the P3D v3.2 config file....add:

 

[JOBSCHEDULER]

AffinityMask=244

 

P3D v3.2 loves H. T....and the above setting for 4 real, and 4 virtual cores...     The sim runs like a Swiss watch! :)

I'm using 238 now. Seems the same though. Also Steve doesn't recommend any am that unmasks 5 cores/LPs he says it reduces performance. 4 or 6 cores seem to be the way to go. 244,248 and etc are all 5 core unmasks.

Share this post


Link to post

I'm using 238 now. Seems the same though. Also Steve doesn't recommend any am that unmasks 5 cores/LPs he says it reduces performance. 4 or 6 cores seem to be the way to go. 244,248 and etc are all 5 core unmasks.

Well, it's weird then, for with am AM=85, at my FBO...I started having microstutter, and blurry ground textures, not very blurry, but still out of focus, as well as trees shimmering.

 

I went back on my i7-975 4 core (in HT mode enabled) at 4.3 Ghz...to AM=244, and on the next usage, crystal clear scenery the likes of my Portland shots, and staying mostly at 27-32.9 with no stutter whatsoever.  It could be that in using 244, all the threads are working with each other, 3rdP's are also behaving...etc...but the end game, is that it is a great settting on my system.  It may not be theoretically correct as per Steve's input,  but in usage on my system....the AM setting earns a 'wow'....

 

Bottom line I guess, as always, however way you 'get there'....but as long as you do... :wink:

Share this post


Link to post

For P3D the recomendation on 4 core with HT enabled is 85 or 116

 

There is no "the recommendation". Just because some guy on a forum who sounds credible tells you that some value is better than the other doesn't mean it's right. If a person says that 244 or whatever value "gives silky smoothness" like in this case, I would say that this is the right value for that particular system. Every setup is different.

Share this post


Link to post

So I upgraded to P3D v3 from 2.5, and unfortunately it's broken.

 

http://imgur.com/a/9TziU

 

The first image is with Tesselation enabled. Note:

Blurry textures

Light, black triangle on the ground and further black lines in the distance, faint black line roughly following the contour of the road. These faint black lines fade in and out depending on viewing angle and elevation and seem to appear especially around roads and other vector objects.

 

Second image with tesselation disabled: sharper textures, no visual artifacts.

GTX 970, driver 364.72

 

Is it a driver issue, or were the P3D beta testers not paying attention again?

 

I can confirm this problem with my setup (P3DV3.2, Win 10, GTX980T1, Driver 361.91)

 

https://www.dropbox.com/s/umte5xney3xciu9/TessHigh.jpg?dl=0

https://www.dropbox.com/s/n5med8cd3s8yv6o/TessOff.jpg?dl=0

 

gb.

Share this post


Link to post

Hi gb,

 

I could be wrong but I'm not sure what you are seeing has much to do with Tesselation.

 

http://www.nvidia.com/object/tessellation.html

 

Perhaps the high setting is sucking resources needed for other stuff like anisotropic filtering. Does seem unlikely, however, as you have a GTX 980Ti. What's your CPU?

 

Regards,

Mike

Share this post


Link to post

Not completely off topic, but I tried the AM 244 and I'm keeping it.

Share this post


Link to post

There is no "the recommendation". Just because some guy on a forum who sounds credible tells you that some value is better than the other doesn't mean it's right. If a person says that 244 or whatever value "gives silky smoothness" like in this case, I would say that this is the right value for that particular system. Every setup is different.

Thanks for your input.

 

I will only say that Steves extensive testing and graphs show exactly what I have seen for myself and this is from a guy that use to use 244 himself.

Share this post


Link to post

Hi gb,

 

I could be wrong but I'm not sure what you are seeing has much to do with Tesselation.

 

http://www.nvidia.com/object/tessellation.html

 

Perhaps the high setting is sucking resources needed for other stuff like anisotropic filtering. Does seem unlikely, however, as you have a GTX 980Ti. What's your CPU?

 

Regards,

Mike

 

Mike I have a 4770K @4.3.

Seems to me like resources are not being allocated correctly with tessellation on. My screen shots are of a virtually static scene so it's not like the system does not have enough time to load those textures.

 

gb.

Share this post


Link to post

The screenshots you posted seem to me like their the opposite of what they should be? The first image looks like tessellation is off and the second seems like it is on.

Share this post


Link to post

The screenshots you posted seem to me like their the opposite of what they should be? The first image looks like tessellation is off and the second seems like it is on.

The blurrier one definitely has tessellation turned on,

as for the OP.

As Mike suggests I don't think ground textures have anything to do with tessellation but for that same reason you would not expect the textures to get worse with it on.

 

gb.

Share this post


Link to post

The blurrier one definitely has tessellation turned on,

as for the OP.

As Mike suggests I don't think ground textures have anything to do with tessellation but for that same reason you would not expect the textures to get worse with it on.

gb.

Don't quite get what you mean? Tessellation affects all textures, ground included.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this