Sign in to follow this  
martinlest2

How to stop scenery 'rippling'?

Recommended Posts

One of the reasons I hardly ever fly FSX is that for some reason (how was this an improvement on FS9??) my second monitor is always black when FSX in in full screen view on my main screen. I sometimes use FS-Simitizer, which looks like you are full screen, but it is clear you are still in windowed mode, as scenery in spot view is not drawn at exactly the same rate as you pan in spot view (or so it appears), creating a 'billowing/rippling effect'. I guess you'll all know what I mean...

 

Is there some way to stop this, so that scenery is drawn as solidly and accurately  in window mode as I am used to in FS9? My PC is reasonably high-end, with an i7-4790K (4 GHz), a GTX-970 4GB and 16GB of RAM, so I'd expect OK results (I do get very good frame rates) even from FSX. (To be honest though, even in full-screen mode, the drawing is not as steady/solid as I get in FS9, with some discernible wobble as you pan).

 

Does everyone have this issue? How do you solve it (if you can)?

 

Thanks,

 

Martin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi. Thanks, yes, it is:

 

ForceFullScreenVSync=1

 

(in Display)

 

- but that has no effect in windowed mode as far as I can tell.

Share this post


Link to post
Share on other sites

You need to go into your nvidia settings and try vsync there.

Also you could consider P3D, it runs much better graphically than the 'old' FSX, as it makes more use of the modern video cards.

Share this post


Link to post
Share on other sites

I think I am using nVidia Inspector (not at PC right now, but pretty sure I am; definitely have it set for FS9).

 

I know nothing at all about P3D, apart from the name and have never even considered investigating it: you have set me thinking. I'd need to see if my various (expensive) addons for FSX will also be OK in P3D. As far as I know, they'll set up in P3D the same as FSX?

 

I have FSX+Acceleration, (and rarely fly it to be honest, I am very much an FS9 guy!) - need to do some Googling about this. Is it really worth the change?? Can I run two monitors with (full screen) P3D (as I commented in my original post here)?

 

I can see how I am going to be spending my Sunday! You've set a cat amongst the pigeons with this! :wink:

Share this post


Link to post
Share on other sites

Martin, if you haven't already tried it, in NVIDIA Inspector (assuming you have a 60Hz monitor), try setting Vertical Sync to "1/2 Refresh Rate" and in FSX limit the frame rates to 30.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks. I already have FSX set to 30fps max.

 

My nVidia Inspector settings no longer correspond to what I was used to. Which version do you have? Mine is 1.9.7.2. My Vertical Sync options in the drop down box are: FORCEOFF; FLIPINTERVAL4; FLIPINTERVAL2; FORCEON; PASSIVE; FLIPINTERVAL3; 0x08416747; 0x47814940; 0x60925292

 

.. which apart from FORCEOFF and FORCEON are, as they say, 'as clear as mud'... Why on earth did they change from what was understandable to this jargon?

 

As for P3D - I see it costs $199, so that's not going to happen!

Share this post


Link to post
Share on other sites

Hi. Thanks, yes, it is:

 

ForceFullScreenVSync=1

 

(in Display)

 

- but that has no effect in windowed mode as far as I can tell.

That's because you need this entry for windowed mode, in the same section of course.

 

ForceWindowedVSync=1

 

Try that and see how you get on.

Share this post


Link to post
Share on other sites

Ah yes, thanks, I had forgotten there's an equivalent for windowed mode... I have a vague memory that when I tried to sort this out last time (a couple of years ago) I did have that line there.. not there now, whatever.

Anyway, I added both lines, FullScreen and Windowed to the Graphics section, (not Display, as I wrongly wrote above). I tried nVidia Inspector with VSync set to FORCEON, PASSIVE and FLIPINTERVAL4 (whatever that is). Also tried with just the Windowed line added, no full screen.

For now, I see no difference I'm afraid in FSX: in windowed mode, as I pan in spot view, the scenery and clouds do not move synchronised, they break up, giving the effect of a ripple. In fullscreen, with the vertsync 'fix' the effect is less marked but the scenery still wobbles slightly, like jelly/(jelo!). Totally unacceptable, so I shall stick to FS9, which is rock solid.

 

I am sure I am not alone in regretting that Microsoft gave up FS after FSX rather than before! If I can fix this somehow of course, I'd be delighted even so, of course! (I wish someone could explain to me why in FSX full screen mode blacks out all monitors apart from the one FSX is on. It's absurd, FS9 doesn't do that).

Share this post


Link to post
Share on other sites

Should these settings be in the [Graphics] or [Display] section?

Share this post


Link to post
Share on other sites

Actually, now I've rebooted, reloaded and retested, there is an appreciable difference with the 'windowed mode' line added to the fsx.cfg file. Flyable, certainly, so thanks...

 

On the other hand, the 'wobbling jelly' effect is still there, it's just that the 'jelly' is 'stiffer' and the wobble tighter. It is certainly, even now, no match at all for the rock-solid stability of the scenery drawing in FS9...

Share this post


Link to post
Share on other sites

an appreciable difference with the 'windowed mode' line added to the fsx.cfg file. Flyable, certainly, so thanks...

Welcome.

 

 

On the other hand, the 'wobbling jelly' effect is still there, it's just that the 'jelly' is 'stiffer' and the wobble tighter.

Sounds like your comparing a silicone vs saline breast augmentation, lol.

 

 

It is certainly, even now, no match at all for the rock-solid stability of the scenery drawing in FS9...

I think that if you were able to get it in FS9 then you should be able to achieve it in FSX as well. It's probably just something haywire with the settings. Since I don't run mine like that I can't offer any other suggestions however, sorry.

Share this post


Link to post
Share on other sites

My nVidia Inspector settings no longer correspond to what I was used to. Which version do you have? Mine is 1.9.7.2. My Vertical Sync options in the drop down box are: FORCEOFF; FLIPINTERVAL4; FLIPINTERVAL2; FORCEON; PASSIVE; FLIPINTERVAL3; 0x08416747; 0x47814940; 0x60925292

 

.. which apart from FORCEOFF and FORCEON are, as they say, 'as clear as mud'... Why on earth did they change from what was understandable to this jargon?

 

I'm using 1.9.7.3. Here are the options I get under Vertical Sync: https://www.dropbox.com/s/7phw7vw44rag4lt/NVI.jpg?dl=0

Share this post


Link to post
Share on other sites

I've updated my nVidia Inspector to v.1.9.7.6 and will try again.. thanks.


LATER: OK, good  have the latest version, but changing the settings has made no difference to the rippling when I pan in FSX. If other people don't have this issue, I can't help but wonder what the problem is with my setup, as I say. I've had FSX (Acceleration) on at least three different PCs over the years and it's always been like this - one good reason I hardly ever fly with it. My current PC really should have no problem with FSX.. I don't know what else to try tweaking.

 

Thanks again for the input.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this