Sign in to follow this  
mystific

Plane freeze on gear up / gear down

Recommended Posts

Hi!

 

I have a serious problem with my 737NGX - P3D version.

 

I use it together with FS2Crew and simserver but otherwise vanilla P3D v3

 

Sometimes (not always) when i choose gear up or gear down the aircraft freezes (displays, control surfaces, gear). When this happen in gear up one way to fix it is to click the left PFD to get it as a separate window, the aircraft then suddenly returns to normal.

 

When gear down that does not help but sometimes it has helped to do the same with the FOs right PFD.

 

Is this something known and/or how do I fix it permanently?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Is this something known and/or how do I fix it permanently?

 

Never heard of this issue. Sounds like something else is interfering.

 

Full names in the forums please - first and last.

Share this post


Link to post
Share on other sites

Full name as in the signature (I added that now)?

 

I forgot to mention that the problem goes away if you turn the gear back to previous state (eg. if frozen when gear down, if you select gear up again everything is back to normal until next time, vice versa for gear up)

 

How can I find out more about what might interfere?

 

 

Share this post


Link to post
Share on other sites

How can I find out more about what might interfere?

 

What is simserver? I'd honestly start there.

Share this post


Link to post
Share on other sites

Simserver is lika virtual-CDU, a web server that allows you to use any touch devide as FMC. I disabled that and still encountered the error thou.

 

I also thought it might be Active sky but disabled that as well and still same behaviour. (running a presaved scenario over and over again,

Share this post


Link to post
Share on other sites

 

 


(running a presaved scenario over and over again,

 

This might be the issue. Try it using a fresh panel state.

Share this post


Link to post
Share on other sites

But it does also happen when i start from scratch, the repeating scenario was for testing with or without addons to see if that had any effect. Is there any logs for the ngx?

Share this post


Link to post
Share on other sites

But it does also happen when i start from scratch, the repeating scenario was for testing with or without addons to see if that had any effect. Is there any logs for the ngx?

 

Not directly. What version of Prepar3D v3 are you using? 3.1, 3.2, 3.3?

Share this post


Link to post
Share on other sites

That makes sense, Vernon, and might help OP. Maybe a panel state, even one used with "start from scratch" is the culprit.

 

This is a really odd problem, and those are usually in the corrupted panel or flight files category.

Share this post


Link to post
Share on other sites

The saved panel states is somehow messing with the NGX. But it doesn't happen alot though!

Share this post


Link to post
Share on other sites

So to reload a panel to a built-in pmdg state b4 each flight might help?

That is a good way to troubleshoot; however, as Vernon mentioned, corrupt panel states are rare. I have a set of my own that I use for setting up at the gate on ground air/power and I've never had them corrupted.  Also every saved flight/scenario has a panel state file unique to it and I've had one of those act odd over a period of several years with almost daily use.  It happens but not often.

Share this post


Link to post
Share on other sites

I have encountered the error in a lot of different situations, and sometimes the problem occurs just the first time and when I solve it (By at gear up clicking to get a 2D version of the PFD) and then it occurs no more during a flight (Seemingly a bit random when it occurs and not).

 

What can be the issue that when the gear is moved all displays freeze and even the controls are increadibly sluggish. Could it be that some communication in the airplane gets overloaded with some kind of communication that the communications between the ngx and the sim cannot get through?

Share this post


Link to post
Share on other sites

 

 


Could it be that some communication in the airplane gets overloaded with some kind of communication that the communications between the ngx and the sim cannot get through?

 

That would not be my first guess, Mats, the gear animation and functions do not go thorough a communications channel such as simconnect but are part of the model and are implemented (to my knowledge) though the simObjects in the aircraft container.

 

My first guess would be some interaction between FS2Crew and the NGX, I believe it does use simconnect for such things.  See if removing FS2Crew changes symptoms.  Try their forum where you will find support and help readily available.

Share this post


Link to post
Share on other sites

 

I'm having the same problem now. 2D Panel state doesn't fix it. It only happens sometimes, including a brand new flight. Sometimes it happens after takeoff, other times on approach (gear won't go down). All the displays freeze and the controls are very laggy.

Sometimes the problem fixes itself too, for example just now my landing gear wouldn't retract after takeoff, but when I tried again at FL180 it worked.

 

Share this post


Link to post
Share on other sites
2 hours ago, mrjeeves said:

 

I'm having the same problem now. 2D Panel state doesn't fix it. It only happens sometimes, including a brand new flight. Sometimes it happens after takeoff, other times on approach (gear won't go down). All the displays freeze and the controls are very laggy.

Sometimes the problem fixes itself too, for example just now my landing gear wouldn't retract after takeoff, but when I tried again at FL180 it worked.

 

Please start a new topic and fully describe your problem.  Also include if FSX or P3D and other addons you are using.  I suggest you may want to review the PMDG forum rules and note they ask that we sign all our posts in their forums.

Share this post


Link to post
Share on other sites

I can honestly say that on V4.3 and the latest update to the NGX, I am encountering this freeze/lock up problem every time I take off. I always start in P3D  at a gate with engines running. I shut down the engines after the "setup countdown" so as to do my Virt. Airline / GSX stuff. I can taxi fine, but come take off and raising gear, the sim stutters a few times - like way too many textures trying to load in - then freezes. I can do the gear thing and have tried the clicking on the screen(s), but no luck getting back into the flight.

My system is i7 8700k, 32gb RAM with an EVGA GTX 1080i 11GB, 1TB SSD drive and a 4TB HDD. This is a new computer, only a week old. I use nearly all ORBX products, from the airports to the most all LC, Regional and Global scenery textures, FTX Vector. All are up to date - spent nearly a week reloading it all 😀. I do not use the HDR or the dynamic lighting at this time. At first I was and the problem began right after the update, so I turned off HDR and Dyn Ltg to see if t hat was it. 

Don't know if the above will help. Right now only recourse seems to be uninstalling and re-installing the 737 and not do the update.

Kind regards,

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this