Sign in to follow this  
IMH747

FS9 Stutters with Quad core: really?

Recommended Posts

Hi there.
Somone please help me.

 

This is really crazy. I suppose to have a good PC and a good graphic card as well, but the simulator does stutters. One each minute. :fool:

 

The configuration is AMD Q10 quad core 3.8GHz (4.2GHz ) 8Go of RAM and Nvidia 780GTX 3Go   2 Matrox TreapleHead2Go  6 monitors LENOVO and the simulator is FS9. This computer is set for the outside view.

I tested in FS9,  all the graphics settings back to minimum. And the stutters was still there, one each minute. :Hmmmph:

 

Now I try to find out if the problem come from the fs9.cfg :Cuppa:
If nothing is find here I have to work on the Nvidia settings which makes me freaking out as I know nothing about it.

I've followed all the Nick bible recommendations. Except for the AMD.

 

Thank you so much

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi.

 

Three things come immediately to mind...

 

The first is that it's morning here and I haven't quite woken up yet.

 

The second is that FS9.exe is coded to run on only a single thread, so any other cores can't do more than take other work (like external weather programs). FS9 works on cycles of a fixed set of tasks; if that core is overloaded then everything will stop until it's caught up. I think some tasks are what might be called critical and will cause a delay while others may just be dropped until the next cycle. From experience I'd say that loading photoscenery textures is a non-critical task which is why photoscenery may not show up for a while. I think some aspects of AI traffic are critical -- lots of AI is one cause of stutters on a weak system (like mine).

 

The third is that if you suspect a bad line in fs9.cfg, move it (not copy) to a different location (same as deleting and making a backup). When you start a new flight, FS9 will build a new basic cfg file. The stutters probably won't happen. Inside FS9, start increasing resolution, mip mapping, AI traffic, cockpit complexity et c. one by one until the stutters start again.

 

Best regards,

Dave

Share this post


Link to post
Share on other sites

How is performance when running in a single monitor, instead of the 2xTH2G, 6-monitor setup? Set-up in this configuration and, after ensuring smooth performance, then extend to the 6-monitor layout.

 

Also, are you sure FS9 is using the 780GTX GPU and not the A10 (I never saw a Q10 AMD CPU) inbuilt GPU?

Share this post


Link to post
Share on other sites

 

 


GPU and not the A10 (I never saw a Q10 AMD CPU)

 

My apologie Luis Hernandez it's AMD A10 5800

 

Here was the first test 

 

 

 


The third is that if you suspect a bad line in fs9.cfg, move it (not copy) to a different location (same as deleting and making a backup). When you start a new flight, FS9 will build a new basic cfg file. The stutters probably won't happen. Inside FS9, start increasing resolution, mip mapping, AI traffic, cockpit complexity et c. one by one until the stutters start again.

I will work on that next week-end
as even if all the settings are at "0" stutters still occurds

 

 

wilco

Imhotep

Share this post


Link to post
Share on other sites

Hi,

Last weekend while tests goes on I didn't notice any significant change. The only thing that did a slightly better smooth was after an O&O defragmentation.

 

It might be possible the problem comes from the Nvidia configuration.

 

Well, this gone be a tough one.

 

I will post some pictures later

 

All the best

Share this post


Link to post
Share on other sites

Hi Imhotep, your settings are almost identical to mine, in fact mine are slightly higher (I have my hardware lights and a couple of other settings at 100%). I have a 6-core CPU and I still get stutters too. I'm doing a lot of GA flying at less than 5000ft, and the stutters happen while my AI aircraft (also at 100%) are spawning at nearby airfields, and then the stutters go away again. Knowing what causes it, I can put with it.

Share this post


Link to post
Share on other sites

As mentioned above -- multi-core CPUs weren't really a thing when FS9 (or even, to an extent, FSX) was released. I suspect MS developed the code based on what had been true up to that point -- the assumption CPU speeds would continue to increase over the years and therefore over time the hardware would catch up with the software and when we were all running 8GHz CPUs we'd be able to whack the sliders up with impunity. In that regard, it was no different to any other MSFS release -- generally the software was slightly ahead of the hardware available at the time but soon enough the hardware caught up.

 

Unfortunately, CPU development went in a different direction -- so we currently have roughly similar clock speeds to what was available at the top end a decade ago, but instead have multiple cores to spread the load. Neither FS9 (especially) nor FSX (that much) were optimised for this situation, which is why performance still isn't that great.

 

However, given the regularity of your stutters -- do you happen to have FSUIPC (and particularly Autosave) by any chance?

  • Upvote 1

Share this post


Link to post
Share on other sites

Dear Skelsey,

 

You make the point.

But take a look at this one:

http://fspassion.canalblog.com/archives/2008/10/22/11061148.html

 

I might become crazyyyyy, just take a look of benchmark: :fool:
http://cpuboss.com/cpus/Intel-Core2-Quad-Q9650-vs-AMD-A10-5800K

 

It doesn't make any sens.

 

For the moment, did this:
- Re install FS9

- install ground environment

- install fs global

- install aerosoft EGLL

- install aerosoft LFPG

- install aerosoft EBBR

- Re place my FS9 config

- Re place my Nvidia config

- on going O & O Degrag (it will take 20h00)

 

wilco :wink:

Share this post


Link to post
Share on other sites

No good news.

 

After 22 hours of O&O defrag, Stutters are still there.

 

Maybe FSX needs to be uninstall too.

I'm missing something. But what????

 

so stuck down here

Share this post


Link to post
Share on other sites

No good news.

 

After 22 hours of O&O defrag, Stutters are still there.

 

Maybe FSX needs to be uninstall too.

I'm missing something. But what????

 

so stuck down here

If the stutter happens at exact 60 second intervals, it is not FS9, but some other process on your computer that is running at regular intervals and either momentarily hogging the CPU, or causing a disk access that is interfering.

 

Do you have a wireless network card in your computer? I had one once which would re-scan the local wifi network environment at exact 1-minute intervals. It had a poorly-written driver, which would cause the CPU load to spike to 100 percent every time the card did a new network scan.

 

Also, if you use FSUIPC, check its setup menu to insure that its autosave option is turned "off".

  • Upvote 2

Share this post


Link to post
Share on other sites

Totally shutting down any firewall, internet, virus protection should be the first thing to do. Make sure nothing is attempting anything like starting an automatic scan.

Share this post


Link to post
Share on other sites

Thanks

 

After a quick check on Task Manager, there is no wire less program running.

The PC2 is completely dedicate to Flight Simulator, there is no anti-virus no
firewall and no automatic update thanks to Nick's Bible of FSX

 

Also, some other stuff were closed by iobit advanced systemcare

 

For the FSUIPC, I didn't find were is the "auto-save"

Share this post


Link to post
Share on other sites

Hi there,

 

I'm assuming that you have FS9.1 and not just FS9.

 

Ok, on that assumption, find and download a program called CFF Explorer (http://www.ntcore.com/exsuite.php)

 

Follow instructions to install it.

 

Once installed, open your FS9 folder and find the FS9.exe and right click it.

 

http://s1058.photobucket.com/user/RichDutt/media/CFF3_zpsj4d164tc.jpg.html?sort=3&o=2

 

When CFF opens, click File Header, then click 'click here.

 

http://s1058.photobucket.com/user/RichDutt/media/CFF1_zpschkdbbb0.jpg.html?sort=3&o=1

 

When you have done that, ONLY tick where I have shown.

 

http://s1058.photobucket.com/user/RichDutt/media/CCF2_zpsw932h0lc.jpg.html?sort=3&o=0

 

Then save it.

 

What you have just done basically, is tell the computer that FS9 can use more memory than it thinks.  Not sure, read the site I gave you.

 

My FS9 runs like yours without it, and that's on Win 7, i7 12 gig ram, GFX 640 2 gig ram.

 

Good Luck

 

Rich

Share this post


Link to post
Share on other sites

Thanks you RichD, :smile:

 

 

I will try it probably today.

Maybe this will be interresting.

Check this out, it looks like my PC2
fire up many process. Actually too many.

 

Capture01.png

 

Capture02.png

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this