Jump to content

Sign in to follow this  
Flugsimulatorpilot

How do you manage completing a flight without OOMs

Recommended Posts

Hi,

 

I did several flights and was not able to manage it to complete one without an Out of Memory. I'm using Windows 10 and P3D v3.3.5.

 

Installed Addons:

---------------------

ORBX FTX Global

ORBX OpenLC EU

ORBX Vector (only highways and golf parks are activated)

REX 4 Texture Direct with Soft Clouds

Aerosoft Airbus A320/321

FS2Crew for the Airbus

AS Mega Airport Frankfurt v2 / FlyTampa Vienna X \ AS Heathrow Extended

FSUIPC, SimConnect

ActiveSky Next SP5

PRO ATC/X

 

 

When I load the Airbus and choose Frankfurt VAS is about 2650 MB. While performing all checklists and preparing the aircraft for takeoff VAS goes up to 3100 MB. After taking off it continues to increase up to 3300MB. When reaching the cruise altitude (34000ft) it stays with 3250MB. P3D does not clear the VAS. While approaching I'm reaching the limit of 4GB VAS and the error message appears.

 

I also did other flights with the same result.

 

How do you manage it to finish a flight without a OOM.

 

 

Thanks in advance

 

 

Share this post


Link to post

Hi,

 

I did several flights and was not able to manage it to complete one without an Out of Memory. I'm using Windows 10 and P3D v3.3.5.

 

Installed Addons:

---------------------

ORBX FTX Global

ORBX OpenLC EU

ORBX Vector (only highways and golf parks are activated)

REX 4 Texture Direct with Soft Clouds

Aerosoft Airbus A320/321

FS2Crew for the Airbus

AS Mega Airport Frankfurt v2 / FlyTampa Vienna X \ AS Heathrow Extended

FSUIPC, SimConnect

ActiveSky Next SP5

PRO ATC/X

 

 

When I load the Airbus and choose Frankfurt VAS is about 2650 MB. While performing all checklists and preparing the aircraft for takeoff VAS goes up to 3100 MB. After taking off it continues to increase up to 3300MB. When reaching the cruise altitude (34000ft) it stays with 3250MB. P3D does not clear the VAS. While approaching I'm reaching the limit of 4GB VAS and the error message appears.

 

I also did other flights with the same result.

 

How do you manage it to finish a flight without a OOM.

 

 

Thanks in advance

 

Have you tried the same thing with version 3.2. Some  on facebook P3D group had OOMs with 3.3 and rolled back to 3.2, which solved their problem.  

  • Upvote 1

Share this post


Link to post

Hi,

 

I would first try again without Orbx Vector (fully deactivated) and setting the LOD radius no more than HIGH and the autogen sliders no more than DENSE. Furthermore, I would only activate EGLL and EDDF airport sceneries and disable all other sceneries.

 

I had the same problem with 3.3.5 but solved it by reducing autogen and LOD radius.

 

If you really want to go back I would recommend to install both the CLIENT and CONTENT as the latter will affect 3rd party menus such as GSX or SODE.

  • Upvote 1

Share this post


Link to post

I will try it without Vector. I actually have only installed the above mentioned airports at the moment. I did not tweak the cfg file and road traffic is also set to off since users reported higher VAS usage with it.  I set the Lod Radius to LOW and reduced the Autogen Sliders to DENSE.

 

I'm going to do a test flight and report the result.

Share this post


Link to post

Thank you for your quick reply. I didn't try the same situation with version 3.2. Is it neccessary to reinstall whole P3D or is it sufficient to reinstall only the Client?

 

Only the client, I rolled back to 3.2 and it took about 10 minutes at most. If that doesn't fix the problem you can go back to 3.3 just as easily. 

Hi,

 

I would first try again without Orbx Vector (fully deactivated) and setting the LOD radius no more than HIGH and the autogen sliders no more than DENSE. Furthermore, I would only activate EGLL and EDDF airport sceneries and disable all other sceneries.

 

I had the same problem with 3.3.5 but solved it by reducing autogen and LOD radius.

 

If you really want to go back I would recommend to install both the CLIENT and CONTENT as the latter will affect 3rd party menus such as GSX or SODE.

 

I saw no difference in GSX between 3.2 and 3.3 regarding menus, 

  • Upvote 1

Share this post


Link to post

  • Mega Airport Frankfurt and Heathrow Extended are amongst the most VAS heavy sceneries you can get, so I would disable them in the scenery library when not needed.

HD clouds are also a big VAS consumer, set a lower cloud resolution in REX4 (1024 instead of 4096).

The only ORBX products I've seen issues with are their detailed regions, Vector and OpenLC haven't caused me any problems

Any moving traffic tends to hit frames badly (not so sure about VAS) so I have my road, sea and airport vehicle sliders set very low. AI traffic in FSX is known to gobble up VAS.

After the above actions, you can turn down the LOD and Autogen sliders slightly, as others have said.

  • Upvote 1

Share this post


Link to post

ORBX FTX Global - Check


ORBX OpenLC EU - No, but have UTX instead


ORBX Vector (only highways and golf parks are activated) - As above


REX 4 Texture Direct with Soft Clouds - Check


Aerosoft Airbus A320/321 - Check


FS2Crew for the Airbus - No


AS Mega Airport Frankfurt v2 / FlyTampa Vienna X \ AS Heathrow Extended - Kind of. I make sure to have only the departure and arrival airports switched on in the scenery library. Usually UK2000 EGKK to somewhere (FSDT LSGG would be a good example as I can do that in 1 go).


FSUIPC, SimConnect - No/Check


ActiveSky Next SP5 - Check


PRO ATC/X - No


 


I don't have problems with OOM, and it looks like I have a fairly similar setup to you. I have most of the sliders up quite high and I run Nvidia DSR x4.0 on a single monitor. I run without AI traffic (air or ground) and keep the cloud layers to an absolute minimum in ASN (I think I only have it set to 1 maximum). Hope that helps.


  • Upvote 1

Share this post


Link to post

First of all, thahk you all for your help. I was really desperated due to the high VAS usage.

 

I loaded the default P3D Vehicle (Jet) and Mega Airport Frankfurt V2. ORBX FTX Global and OpenLC were activated. Default Cloud and Sky Textures were used. Lod Radius set to low, all traffic was set to 0%. At the beginning I had a VAS of 1860MB, after a few minutes it went up to 2100MB. After taking of and waiting about 20 minutes VAS stayed stable (2050MB).

 

Is it normal that P3D does only clean up 50MB when leaving the Airport. Why does VAS does not decrease to the initial value (1850MB)?

Share this post


Link to post

I was trying Egll over weekend similar setup to yourself and had the Lam3a approach . Usually I am very good with vas management but had to turn settings heavily down to achieve an approach without oom . Anywhere around the Lam vor oom would stike.Took four attempts . I managed it just!!! without looking out the the side windows of the plane lol. Real problems flying over London. Vas load seems to spike 300-400 mb then settles down but if you change view at the wrong time oom . No idea of answer . Disabled vector but only minimal vas reduction. The thing that made most difference and enbled me to land was running textures at 1024 . Sparse autogen , High L.O.D . Dense on  everthing alse. Tried a demo of uk2000 scenary . Same issue.  Was using Ifly 747 which is vas heavy.

  • Upvote 1

Share this post


Link to post

Ground Textures are set to 1m on my system. When using REX Textures I always set them only to 512.

I also get my OOM's when changing the view. On my system Prepar3D does not clear RAM anymore when more Addons are installed. I always take off with VAS of 3100MB. The Problem is that P3D does not clear it during the flight. It stays stable with 3100MB. When reaching another addon airport it needs additional 400-500MB. Thus, the best solution would be in my opinion that VAS is cleared during the flight on a higher altitude.

Share this post


Link to post

How are you monitoring your VAS usage in P3D? I'm also getting OOM's and cannot complete flights as well. I am using P3D v3.3.5 running at 2560x1600. I am using the FSUIPC method where it shows in the titlebar to monitor it. When loaded up and sitting at the gate in the PMDG 777, m VAS number is around 650000-700000 (Which I'm assuming that I have 650-700MB available. When I'm reaching close to my destination and approach, the number will start to drop to around 250000, which is when I'll start hearing those DINGS to warn me that my system is running out of memory. Then finally when I'm in site of the airport it'll drop to around 150000 down to 110000, and at that point i get OOM error and crash. Looks as thought a combination of Pro-ATC and MyTraffic 6 is causing this. I have to give up one or the other. i tried limiting my FTX Vector settings, that didn't really seem to help much. My P3D settings are very conservative as well. Looks like when flying with PMDG or Aerosoft Airbus, I'll have to sacrifice a lot more to avoid OOM. However when flying GA, i can pretty much crank it up. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...