Sign in to follow this  
FredricG

Atrocious framerates for FSX on a gaming laptop

Recommended Posts

I probably should have posted this earlier, but I'm getting so fed up with it that I'm going to post it now.

 

For the past few months, I've been getting absolutely atrocious framerates on FSX:SE on my MSI GP70 2PE Leopard gaming laptop. My average framerate during a flight is 2-8 FPS on takeoff and landing, and 20fps during cruise :mad: . I almost can't even go on VATSIM anymore because I'll almost crash the plane on the approach due to the framerate drop. I've tried reinstalling FSX, tweaking the .CFG file, overclocking, and setting my sceneries down to their bare minimums, but nothing is working. Also, I can play other games on my computer (e.g. Team Fortress 2, Minecraft) at almost max settings and still get more than 60fps. What could be causing my FSX to run so poorly??? :(

 

MY SPECS:

 

CPU: Intel i5 4210H dual-core @2.9GHz, turbo to 3.5GHz (overclocked to 3.9GHz once or twice)

GPU: NVIDIA GeForce 840M (With MSI Afterburner overclock)

RAM: 2 x DDR3L-1600MHz, 16gb

Storage: 256gb SSD

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Your laptop is almost at the bottom of the pile of all of the current "gaming" laptops - http://www.cpubenchmark.net/cpu.php?cpu=Intel+Core+i5-4210H+%40+2.90GHz.  FSX is a really old game with really old programming.  You might get 15-20 fps.  This is why you should limit the fps to 20.  Just because a computer says "gaming" on the package does not mean it will work well with FSX.  FSX was never developed to take full advantage of the modern computer systems like current games like Team Fortress and Minecraft.  Microsoft got rid of the team that was going to update it to take advantage of modern systems (yours is close to modern).  We will never see updates.  Dovetail did some modifications to try to help performance but they can only do so much without violating their license agreement with Microsoft.  Same goes with Lockheed Martin's Prepar3D (which is FSX too).  As new technology is found to increase the performance of a product, as update is released.  VATSIM takes up a lot of resources too.  You may have to scratch your enjoyment of VATSIM until you can upgrade to a more modern and powerful system.

 

If you threw in any tweaks to your FSX-SE.cfg, that could be taking up resources too.  If the tweak was not employed properly, it will do more damage to your enjoyment.  One tweak setting does not fit all. 

 

Best regards,

Share this post


Link to post
Share on other sites

I probably should have posted this earlier, but I'm getting so fed up with it that I'm going to post it now.

 

For the past few months, I've been getting absolutely atrocious framerates on FSX:SE on my MSI GP70 2PE Leopard gaming laptop. My average framerate during a flight is 2-8 FPS on takeoff and landing, and 20fps during cruise :mad: . I almost can't even go on VATSIM anymore because I'll almost crash the plane on the approach due to the framerate drop. I've tried reinstalling FSX, tweaking the .CFG file, overclocking, and setting my sceneries down to their bare minimums, but nothing is working. Also, I can play other games on my computer (e.g. Team Fortress 2, Minecraft) at almost max settings and still get more than 60fps. What could be causing my FSX to run so poorly??? :sad:

 

MY SPECS:

 

CPU: Intel i5 4210H dual-core @2.9GHz, turbo to 3.5GHz (overclocked to 3.9GHz once or twice)

GPU: NVIDIA GeForce 840M (With MSI Afterburner overclock)

RAM: 2 x DDR3L-1600MHz, 16gb

Storage: 256gb SSD

Hi, I think you machine runs with Optimus which switches applications between the integrated Intel card and dedicated Nvidia card. Ensure in the Nvidia Control Panel under 3D Settings that the "High Performance Nvidia Processor" is selected under the FSX.EXE application in the program settings and that in the graphics settings inside FSX-SE that the Nvidia Card is selected.

Share this post


Link to post
Share on other sites

Agree with Pete, it's most likely a config issue with the two cards.  You've got a very similar machine to mine (the GT70 2PC), and I get way more than that.  

 

I can't push top settings, but 2-8 on the ground suggests you are either running the NGX/ASN/ORBX with sliders all the way to the right, or there is a more fundamental config error.

Share this post


Link to post
Share on other sites

I probably should have posted this earlier, but I'm getting so fed up with it that I'm going to post it now.

 

For the past few months, I've been getting absolutely atrocious framerates on FSX:SE on my MSI GP70 2PE Leopard gaming laptop. My average framerate during a flight is 2-8 FPS on takeoff and landing, and 20fps during cruise :mad: . I almost can't even go on VATSIM anymore because I'll almost crash the plane on the approach due to the framerate drop. I've tried reinstalling FSX, tweaking the .CFG file, overclocking, and setting my sceneries down to their bare minimums, but nothing is working. Also, I can play other games on my computer (e.g. Team Fortress 2, Minecraft) at almost max settings and still get more than 60fps. What could be causing my FSX to run so poorly??? :sad:

 

MY SPECS:

 

CPU: Intel i5 4210H dual-core @2.9GHz, turbo to 3.5GHz (overclocked to 3.9GHz once or twice)

GPU: NVIDIA GeForce 840M (With MSI Afterburner overclock)

RAM: 2 x DDR3L-1600MHz, 16gb

Storage: 256gb SSD

Fredric,

 

Seeing as though you and I have gaming laptops, may I suggest something that may help quite a bit, but I'm sure something you wouldn't look forward to?

 

Nuke your system and start all over.  Clean the laptop and start with a fresh install of Windows.  When you get to the point of dealing with your graphics, don't opt in to installing anything dealing with Optimus.  This, in my opinion, was a great failure of nVidia.  I used to have a gpu that utilized optimus, and like you, suffered horrible frames and crashes.  What you can do is nuke anything that Windows installs for your specific gpu, and then download drivers from nvidia directly.  Only install the gpu driver, then go in to the nvidia control panel and make sure that you set your gpu to run globally, meaning that you want to tell Windows to use your gpu for everything and not even touch optimus.

 

You are using a SSD, which is great, so when reinstalling FSX, make sure you don't install it to the default path, just to be safe. If your cpu is overclocked, make sure it is a stable overclock.  Sometimes you can overclock without stress testing it and it can cause bad results.  FSX doesn't run like a typical game, so keep that in mind too.  There are plenty of reliable resources here at AVSIM that outline how to set up your FSX optimally.  Your system isn't ready for the boneyard yet, so there is still hope. :)

Share this post


Link to post
Share on other sites

Are you sure you are using the Nvidia graphics and not intelHD? I have an Alienware 17r2 with a GTX970m and when I first setup P3D I had a similar experience until I noticed it was using the wrong graphics.

Share this post


Link to post
Share on other sites

Are you sure you are using the Nvidia graphics and not intelHD? I have an Alienware 17r2 with a GTX970m and when I first setup P3D I had a similar experience until I noticed it was using the wrong graphics.

I agree Pete..I have a GTX860m card with Optimus. Also upon first installing P3D v3 had terrible frames in the single figures..found out it was using the Intel integrated and not the nvidia. it's simple just to assign the nvidia card in the nvidia control panel....no need to erase your system FredricG. I now get 20-30 fps with the simple switch.

Share this post


Link to post
Share on other sites

I agree Pete..I have a GTX860m card with Optimus. Also upon first installing P3D v3 had terrible frames in the single figures..found out it was using the Intel integrated and not the nvidia. it's simple just to assign the nvidia card in the nvidia control panel....no need to erase your system FredricG. I now get 20-30 fps with the simple switch.

Unless of course, your system magically reverts back to the optimus, which is what I fought with in the past.  I too followed the suggestions online about assigning a program to use the dedicated graphics over the intel integrated graphics, but found that I either still could not get FSX to recognize the gpu or the gpu assignment changed.  It sounds strange, but anythign is possible these days.

 

I only recommended a full reinstall of Windows as a precaution against latent issues in the background that may cause problems for the sim.  It's completely up to the OP what he wants to do and while he could easily do the assignment, that may or may not work.  I just thought the OP could use some options.

Share this post


Link to post
Share on other sites

Unless of course, your system magically reverts back to the optimus, which is what I fought with in the past.  I too followed the suggestions online about assigning a program to use the dedicated graphics over the intel integrated graphics, but found that I either still could not get FSX to recognize the gpu or the gpu assignment changed.  It sounds strange, but anythign is possible these days.

 

I only recommended a full reinstall of Windows as a precaution against latent issues in the background that may cause problems for the sim.  It's completely up to the OP what he wants to do and while he could easily do the assignment, that may or may not work.  I just thought the OP could use some options.

Yes..fully agree with you. What i meant was to attempt the quick fix first, and then take it further. I was successful in "forcing" P3D to use Nvidia every time the application is fired up..I can see by the colour of the LED on the laptop power button which card is in use..another option which I used when Optimus was problematic was to reset the EC (Embedded Controller) and it worked a charm..my Laptop wouldn't turbo boost, etc and after resetting the EC, all was fine...It's a simple action with MSI laptops by holding down the power button for over 5 seconds with the PC on and with the battery installed, and then removing the battery for a while. An upset with the EC can cause a lot of strange issues.

Share this post


Link to post
Share on other sites

Yes..fully agree with you. What i meant was to attempt the quick fix first, and then take it further. I was successful in "forcing" P3D to use Nvidia every time the application is fired up..I can see by the colour of the LED on the laptop power button which card is in use..another option which I used when Optimus was problematic was to reset the EC (Embedded Controller) and it worked a charm..my Laptop wouldn't turbo boost, etc and after resetting the EC, all was fine...It's a simple action with MSI laptops by holding down the power button for over 5 seconds with the PC on and with the battery installed, and then removing the battery for a while. An upset with the EC can cause a lot of strange issues.

Sounds like a good plan, but the OP is using FSX:SE.  I can recall very clearly when I used to run FSX:SE (and even boxed FSX), getting multiple gpus listed in the fsx.cfg file or, in the case of what the OP is going through, the fsx.cfg file would start showing the wrong graphics, obviously a nefarious scheme by some shadowy forces of a dark underworld.  Once I figured out how to strip out all evidence of drivers that wanted to install optimus and just go with drivers directly from nvidia, my issues ceased and could use the gpu exclusively.

Share this post


Link to post
Share on other sites

Unless of course, your system magically reverts back to the optimus, which is what I fought with in the past.  I too followed the suggestions online about assigning a program to use the dedicated graphics over the intel integrated graphics, but found that I either still could not get FSX to recognize the gpu or the gpu assignment changed.  It sounds strange, but anythign is possible these days.

 

I only recommended a full reinstall of Windows as a precaution against latent issues in the background that may cause problems for the sim.  It's completely up to the OP what he wants to do and while he could easily do the assignment, that may or may not work.  I just thought the OP could use some options.

I don't think there's any need to wipe my system because, thankfully, I'm getting a brand-new PC soon, running an i7 processor at 4GHz with water cooling, and it has a MUCH better graphics card with a LOT more VRAM and just plain RAM (And a 256GB SSD and a 1TB HDD.) I have changed my NVIDIA 3D settings to performance and set my graphics card for the game to the NVIDIA card. Thanks everyone for the suggestions :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this