Sign in to follow this  
Pluto7777

Black vehicles very slowly taking livery colors

Recommended Posts

When starting aerosoft airbus 318/19 at JFK, my vehicle starts black, other planes too are black even trucks, after a delay, my plane takes the livery and about 10 airliners in the backround, slowly colorize, sometimes 30-50 seconds to have everything in color. Then everything runs OK, but when changing outside view to other angle; same issue, black vehicles taking 20 seconds to colorize. Some guys say, if it becomes finally OK then it must be a memory or disk acces problem, not the addon nor P3D. But my PC is a brand new i7, high performance, GTX980ti, HSS and 60% of free space. To test the mem i ran the heavy 3D benchmark test for high performance gaming PCs; result very good score at 94% of the best score ever.

Strange remark: i tried traffic slider to 10% , LOD, shadows off, tweaks, etc, nothing changes the black vehicles issue, exept one thing: when going to settings menu and go back to the airport view (even without changing anything) , then instantly every vehicle colorises in 1 second !  Rather poor handling to speedup the liveries, but what system is triggering the livery so fast when coming back from menu, these colorise-events takes 30 to 40 seconds when waiting for it...

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Do you have your frame rate locked or unlimited? I used to have the frame rate at unlimited and use EVGA's Precision to lock frames at 30fps and it was giving me all kind of texture problem (blurry ground texture and won't load up, black livery like yours, etc). I then switch back to lock at 35 in P3D and uninstall EVGA's utility and everything works fine. I'm using a EVGA 980Ti, 8G 2400MHz, and a 4770K @ 4.3

Share this post


Link to post

I had a video driver do some pretty unusual things with texture mapping.., this is one more thing to investigate.

Share this post


Link to post

I have a Titan X and used to have the same problem.  You might want to check this out:

 

Windows Vista & Windows 7 ONLY

For those of you who are using Windows Vista or Windows 7 may be disappointed to find out the dual, quad or octal core processors that you invested in isn't actually using all of the cores. That's right... out of the box these operating systems do not fully enable the distribution of processes over the cores for certain system configurations.

The reason for disabling multiple cores really comes down to energy consumption. The default power profiles set forth by Microsoft opt for an energy savings based configuration, even when the power settings are set to full performance. By disabling core parking, you will see significant increase in all of processor intensive tasks including Flight Simulation.

To check whether or not your cores are parked:

1. Open the Task Manager;
2. Select the Performance tab;
3. Open the Resource Monitor;
4. Within the resource monitor, select the CPU tab and look at the graphs on the right hand side.
5. None of the CPUs should say, in text, that they are parked. If they do not, then your processor cores are not parked.

How To Disable CPU Core Parking For Dual And Quad Processors:

* We recommend that you back up your Windows registry prior to applying this tweak.

1. Copy the following registry key entry:
0cc5b647-c1df-4637-891a-dec35c318583

2. Select your Start button;
3. In the search box, type regedit and press enter;
4. Once your registry editor is open, select Edit and Find;
5. Paste the above registry key in the box and select Find;
6. Once it has located it, look for the keys on the right hand side labeled MinValue and MaxValue; **1
7. Double click on each value and make sure they are both set to 0; **2
8. Select Edit and Find Next;
9. Continue to replace MinValue and MaxValue for each entry until you have replaced them all;
10. Close the registry editor and shut down your computer;
11. Power the computer back up;
12. Core Parking should now be disabled.

Thank you Marc.

**1 - my values were 'ValueMin' and 'ValueMax'.
**2 - hexidecimal is fine - you may see 64 as a value-don't worry-change it to 0

Share this post


Link to post

I found setting a minimum fibre time improved my slow loading textures (didnt eliminate), basically when you run unlimited in the sim but then use an external limiter, P3d wastes rendering overhead above your FPS limiter because the terrain thread is sleeping as opposed using the spare miliseconds to do terrain/rendering work. I think the VAS improvements made also tell the app to unload textures out of view

 

Add this to force P3d to spend a minimum amount of time performing terrain rendering

 

MIN_FIBER_TIME_SEC=0.20

 

 To your P3d.cfg in the [main] section

 

Higher numbers mean more work is done on the terrain rendering leaving less for the higher FPS, you need to find the right balance to keep your FPS where you want them. 

 

original source here

 

http://www.prepar3d.com/forum/viewtopic.php?f=6312&t=120133&p=139706#p139706

Share this post


Link to post

I'm just back to Prepar3d since I've upgraded my PC to a Skylake 6700K @ 4.5Mhz. I've also updated to latest P3D v3.3.5 (was on 3.0 on my old PC) and now I'm running it from an SSHD instead of the dedicated SSD I used to have on the old machine. GPU is the same 980Ti 6 Gb.

I'm getting this odd black textures that keep staying sometimes forever unless I "force" a refresh for example by simply opening and closing the settings panel.

I've tried every possible tweak to Prepar3D.cfg (MIN_FIBER_TIME_SEC=0.20, FIBER_FRAME_TIME_FRACTION=0.33, TEXTURE_BANDWIDTH_MULT=180 and  TEXTURE_MAXLOAD=30) with no luck.

The hardware is quite high specced and I don't think this is a HDD (only piece of the new hardware that is slower than the old one) problem: the HDS activity light is off while the textures aren't loaded. It just seems they are not "kicked in". SO TO ME THIS LOOKS LIKE A PREPAR3D CLIENT BUG!

Hope they will fix it soon. :( 

 
 

Share this post


Link to post

Thank you NeedForSpeed73 !

At least one member that shares my opinion !

This has nothing to do with PC performance, it must be a PD3D client bug, related with the combination of:  P3DV3 / W10/ high performance GUI

I hope too they are willing to fix it soon

Share this post


Link to post

If it was a bug, then why wouldn't everybody be reporting this issue to LM?

With a lot of high resolution AI aircraft models moving about a big international airport, the hardware is not able to keep up with P3d.

Share this post


Link to post

Thank you NeedForSpeed73 !

At least one member that shares my opinion !

This has nothing to do with PC performance, it must be a PD3D client bug, related with the combination of:  P3DV3 / W10/ high performance GUI

I hope too they are willing to fix it soon

Do you have affinity mask tweak on? This was causing this exact issue on mine. If you have it on try disabling it and see if that helps.

Share this post


Link to post

Backup your prepar3d.cfg or rename it and let P3D rebuild a new one.  Delete the shaders folder. You're not using PTA I assume.

 

The vanilla no tweak P3D should render objects very quickly as expected so I assume you have introduced a problem someplace. Time to step back and start from a fresh configuration.

Share this post


Link to post

How high is  texture resolution set to? 2048... 4096 .. ? If running 2k or 4k textures, along with high settings across the board + addon aircraft, scenery ... reduce your setting until issue is gone.. then increase one setting at a time.. no quick fix am afraid...

Share this post


Link to post

Finally ! after 3 months and posting on 7 forums - devinepotts18 brought the one and only solution:

delete affinity mask !  He had exact the same issue, so what was causing these black vehicles ?

Disappointed that even the expert-level-guys from P3D and AVsim did not propose this simple solution !

@jabloom:  no hardware problem with this kind of high performance PC and GUI, even with traffic at 10%, the only 2 aircrafts on a calm airport were black. I ran the terror of PC's: Benchmark 3D test, this test will pull the toughest PC's on the knees, altough my score was 94%.

 

Whats about affinity mask ?

This guy give a rule to calculate aff mask: should i do it ?

 

http://www.avsim.com/topic/444793-one-tweak-to-rule-them-all-how-to-set-affinity-mask-correctly/

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this