Sign in to follow this  
citationjet

Problems with Nvidia Card detection in FSX

Recommended Posts

HI guys,

 

I set up my gaming laptop with WIN 7 and installed  my FSX Gold Edition. The System is set up with all actual drivers for the Nvidia Card but my problem is that FSX didnt recognize my nvidia card. In the settings (fsx.cfg) and in the in game settings  it shows alsways Intel Graphics HD. I have no chance to select my nvidia card.

 

Even if I start FSX from the desktop as Admin and select which card should be used ( i choose nvidia as standard ) the FSX shows only the Intel Card. I try to run the nvidia control panel and select to use the nvidia as standard card for the FSX.EXE but as well this doesnt fix the problem.

I also tried to rebuilt several times the fsx.cfg but at the end I have again only the intel card available.

 

The strange thing is that if I start dxdiag it shows also only the intel card. In the past there was my nvidia card shown.....i dodnt know what Im doing wrong but I need your help please! Where is my mistake or the error that my nvidia card is not shown?

Thanks in advance for your support!

 

Cheers,

Mark

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sounds like your laptop is equipped with onboard Intel graphics.  If you installed an Nvidia card, I suspect you will need to enter the BIOS and turn off the onboard Intel graphics.

Share this post


Link to post
Share on other sites

Hi Stans,

 

already checked this in BIOS there is nothing to dis or enable.

 

You could try seeing if both the Intel and Nvidia are listed in Device Manager under Display adapters.  If so, then right click on the Intel entry and disable it.

Share this post


Link to post
Share on other sites

Hi Donor,

 

thx for your feedback. I tried this already and when I disable the Intel one the Laptop remains black after restarting and I can run windows only within the safe modus

Share this post


Link to post
Share on other sites

Just guessing, but maybe you should check the power safe functions of your laptop, because maybe those prevent it from running 3D graphics and games on the NVIDIA card instead of the iGPU.

Share this post


Link to post
Share on other sites

Servus Michael,

 

thx i will check this. Is there any specific setting which I need to check?

Share this post


Link to post
Share on other sites

Just to be sure....You said you have FSX Gold Edition installed.  All 3 discs so you have Acceleration?

Share this post


Link to post
Share on other sites

If you have both an Intel HD Graphics AND a NVIDIA graphics chip (which I have in my laptop - Intel HD 4600 + NVIDIA 870M) I would definately NOT recommend any type of trying to disable the Intel Graphics chip.

 

I suppose, that your system is equipped with Optimus from NVIDIA, which makes the Intel chip and NVIDIA chip work in 'symbiosis'. In other words, the NVIDIA chip won't function without the Intel Graphics chip... (on some motherboards/laptops there's an option to disable Optimus - but I don't know, what effect that will have...)

 

The correct (and possibly best way) is to launch NVIDIA Control Panel, and setup individual programs to use either the NVIDIA graphics card, or Intel HD Graphics card...  :smile: Try right-clicking and select NVIDIA Control Panel and select 3D settings or something like that... 

There should be an option to change between default graphics chip (which by default is AUTO) and NVIDIA and Intel.

 

The full NVIDIA Control Panel, is ONLY available with the drivers downloaded from NVIDIA's website! They're NOT available when using drivers from Windows Update (as far as I've experienced).

 

Hope that helped a little ...  :smile:

Share this post


Link to post
Share on other sites

@Charlie: Yes it is ACC Version

 

@Anders: Thx. I already have the Nvidia Control Panel installed and to start the fsx.exe with the NVIDIA card is selected already.

Share this post


Link to post
Share on other sites

Servus Michael,

 

thx i will check this. Is there any specific setting which I need to check?

It depends a lot how your laptop system is designed. May you share what type/model it is?

 

General I would advice to set it to maximum performance when you play games and let it run on power line and not battery.

 

Second thing that comes to my mind is wether your laptop vendor supports the general graphics driver provided by NVIDIA itself or restricts to his own adaption?

Share this post


Link to post
Share on other sites

Hi Michael,

 

i set it to max performance but didnt change anything...still the Intel card is displayed.

 

it is a pure gaming laptop and before I rebuilt the laptop the nvidia card worked perfectly

Share this post


Link to post
Share on other sites

before I rebuilt the laptop the nvidia card worked perfectly

 

What do you mean by "rebuild the laptop"?

Share this post


Link to post
Share on other sites

Ah!  Now all of the hidden truths come out.  Time to spill all of the beans about what you did to the laptop! :wink:

Share this post


Link to post
Share on other sites

What do you mean by "rebuild the laptop"?

 

Install windows 7 from scratch and then fresh install FSX, all drivers etc

Share this post


Link to post
Share on other sites

Have you done a Goggle Search for "FSX laptop intel chipset and Nvidia graphics card not showing"?  Leave off the quotes!

 

Lots of different things out there with folks having the same issue.

Share this post


Link to post
Share on other sites

Have you done a Goggle Search for "FSX laptop intel chipset and Nvidia graphics card not showing"?  Leave off the quotes!

 

Lots of different things out there with folks having the same issue.

 

Yes i googled since days about this issue but without any positive outcome

Share this post


Link to post
Share on other sites

I know you mentioned, as part of your "rebuild",  that you installed updated drivers.  Is the driver for the Nvidia card the

same exact driver that was in there before the "rebuild"?  Just thinking that the new driver might be the culprit.

Share this post


Link to post
Share on other sites

I know you mentioned, as part of your "rebuild",  that you installed updated drivers.  Is the driver for the Nvidia card the

same exact driver that was in there before the "rebuild"?  Just thinking that the new driver might be the culprit.

After install windows 7 i installed the orginal drivers (the older ones) and then the actual ones from nvidia

Share this post


Link to post
Share on other sites

and then the actual ones from nvidia

 

And is that the driver version you had running before you rebuild your system?

 

If not then I would assume that your problems come from the NVIDIA driver you have installed lately.

 

Maybe you should try uninstalling this version - a freeware utility called DDU (Display Driver Uninstaller) helps totally removing the video drivers and let's you start from a fresh point with just the basic Windows VGA drivers. From there I would suggest trying the original drivers from your laptops manufacturer (or if there are updated versions provided by the manufacturer try those) and then check with the manufacturer if its possible to upgrade to the newest general NVIDIA versions - be careful: NVIDIA has for most of its chips different versions for mobile systems, the so called M-Versions.

Share this post


Link to post
Share on other sites

And is that the driver version you had running before you rebuild your system?

 

If not then I would assume that your problems come from the NVIDIA driver you have installed lately.

 

Maybe you should try uninstalling this version - a freeware utility called DDU (Display Driver Uninstaller) helps totally removing the video drivers and let's you start from a fresh point with just the basic Windows VGA drivers. From there I would suggest trying the original drivers from your laptops manufacturer (or if there are updated versions provided by the manufacturer try those) and then check with the manufacturer if its possible to upgrade to the newest general NVIDIA versions - be careful: NVIDIA has for most of its chips different versions for mobile systems, the so called M-Versions.

Ok I will try that one and will report!

Share this post


Link to post
Share on other sites

And is that the driver version you had running before you rebuild your system?

 

If not then I would assume that your problems come from the NVIDIA driver you have installed lately.

 

Maybe you should try uninstalling this version - a freeware utility called DDU (Display Driver Uninstaller) helps totally removing the video drivers and let's you start from a fresh point with just the basic Windows VGA drivers. From there I would suggest trying the original drivers from your laptops manufacturer (or if there are updated versions provided by the manufacturer try those) and then check with the manufacturer if its possible to upgrade to the newest general NVIDIA versions - be careful: NVIDIA has for most of its chips different versions for mobile systems, the so called M-Versions.

 

Michael you made my day. I installed the drivers with the DDU utility and installed "only" the nvidia drivers which came with the laptop. Now I can see the nvidia card in fsx. But now I need to be carefull which nvidia drivers I will install now right?

Share this post


Link to post
Share on other sites

I knew it had to be a driver problem!  Wasn't anything else left! :wink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this