Sign in to follow this  
PC Pilot Dave

"SODE" error after installing Aerosoft's Kilimanjaro airport add-on

Recommended Posts

Hi all,

 

Was hoping someone could help me out. I recently purchased Aerosoft's Kilimanjaro Airport add-on through Steam. However, after installing the add-on I get the below error message each time I launch FSX:

 

Flight Simulator is attempting to start "SODE" (Version 1.1.0.0, Config Entry Number 2). Do you want to run this program?

 

DLC\379550\SODE\SimObjectDisplayEngine.exe

 

After uninstalling the airport add-on, the message stopped appearing. Has anyone encountered this before? 

 

Many thanks for your feedback and support. It is greatly appreciated! 

 

Dave

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

SODE has a history of giving folks grief.  Take a look at the lengthy thread on the Aerosoft scenery forums. The dev is very active in assisting users with issues.

 

DJ

Share this post


Link to post
Share on other sites

 

 


Flight Simulator is attempting to start "SODE" (Version 1.1.0.0, Config Entry Number 2). Do you want to run this program?

 

Looks less like an error and more like the program wasn't set to True in the <Launch.Manual Load> tag in .EXE.XML.

 

Next time you get the message, answer Yes and you should be fine.

  • Upvote 1

Share this post


Link to post
Share on other sites

SODE has a history of giving folks grief.  Take a look at the lengthy thread on the Aerosoft scenery forums. The dev is very active in assisting users with issues.

 

DJ

 

Thanks, I'll check over there as well.

 

Looks less like an error and more like the program wasn't set to True in the <Launch.Manual Load> tag in .EXE.XML.

 

Next time you get the message, answer Yes and you should be fine.

 

Thanks for the info. I select Yes each time the error message comes up, but it comes back the next time I launch FSX:SE. Is there something else I should be doing? 

Share this post


Link to post
Share on other sites

Its Not an Error,  FSX is asking You for "Permissions" to Run SODE 

 

You could try this  (Give FSX Permission to Run SODE) 

 

Go to: >  AppData \ Roaming \ Microsoft \ FSX   DLL.XML   Right Click  Open with < Notepad

 

Change this  <ManualLoad>True</ManualLoad>  To This  <ManualLoad>False</ManualLoad>

 

<Launch.Addon>

<Name>SODE Animation Module</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
 <Path>C:\Program Files (x86)\12bPilot\SODE\SimObjectAnimationModule.dll</Path>
 </Launch.Addon>
</SimBase.Document>

Share this post


Link to post
Share on other sites

 

Its Not an Error,  FSX is asking You for "Permissions" to Run SODE 

 

You could try this  (Give FSX Permission to Run SODE) 

 

Go to: >  AppData \ Roaming \ Microsoft \ FSX   DLL.XML   Right Click  Open with < Notepad

 

Change this  <ManualLoad>True</ManualLoad>  To This  <ManualLoad>False</ManualLoad>

 

<Launch.Addon>

<Name>SODE Animation Module</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
 <Path>C:\Program Files (x86)\12bPilot\SODE\SimObjectAnimationModule.dll</Path>
 </Launch.Addon>
</SimBase.Document>

 

 

Thanks. I browsed to the DLL.XML file but did not see the text you listed anywhere in the document unfortunately :/

Share this post


Link to post
Share on other sites

I do not use SODE so i cant tell you how it works when using with different Scenery Add On's.  

 

But

 

When you Install SODE it will Install to a Default Location  ► Local Disk © ► Program Files (x86) ► 12bPilot ► SODE  

 

To Activate "Register"  SODE  go to the above location, Right Click on SODEPlatformManager.exe  and run as administrator  This will bring up a Box "Sode Platform Manager"  Click Register 

 

By doing this you will Add The above Entry (my last post)  into your dll.xml file.  To turn off SODE Click Unregister  This will remove the Entry in total.

 

If you see the Permissions message again you can follow my last Post to  "Give it permissions" to run in FSX  

Share this post


Link to post
Share on other sites

I do not use SODE so i cant tell you how it works when using with different Scenery Add On's.  

 

But

 

When you Install SODE it will Install to a Default Location  ► Local Disk © ► Program Files (x86) ► 12bPilot ► SODE  

 

To Activate "Register"  SODE  go to the above location, Right Click on SODEPlatformManager.exe  and run as administrator  This will bring up a Box "Sode Platform Manager"  Click Register 

 

By doing this you will Add The above Entry (my last post)  into your dll.xml file.  To turn off SODE Click Unregister  This will remove the Entry in total.

 

If you see the Permissions message again you can follow my last Post to  "Give it permissions" to run in FSX  

 

Thanks, I'll give this a try this weekend!

Share this post


Link to post
Share on other sites

I do not use SODE so i cant tell you how it works when using with different Scenery Add On's.  

 

But

 

When you Install SODE it will Install to a Default Location  ► Local Disk © ► Program Files (x86) ► 12bPilot ► SODE  

 

To Activate "Register"  SODE  go to the above location, Right Click on SODEPlatformManager.exe  and run as administrator  This will bring up a Box "Sode Platform Manager"  Click Register 

 

By doing this you will Add The above Entry (my last post)  into your dll.xml file.  To turn off SODE Click Unregister  This will remove the Entry in total.

 

If you see the Permissions message again you can follow my last Post to  "Give it permissions" to run in FSX  

 

Just a quick update - 

 

I tried searching for SODEPlatformManager.exe in the location you described above, but could not find that file path (there was no 12bPIlot folder). I also tried running SimObjectDisplayEngine.exe as administrator, but it made no difference. A search of my entire PC for SODEPlatformManager.exe yielded no results.

 

Interestingly though - I bought a few additional add-ons during Steam's FSX flash sale. Most of the add-ons installed fine. Steam installed them, and when I launched FSX it asked me if I wanted to run a specific component > I'd hit Run > and then I'd get the second prompt from Windows asking if I wanted to run that same component and I would again hit Run. After that I wouldn't see those messages anymore.

 

But one of the add-ons I purchased (Air Alaska Add-On) has the same issue. I only get the first prompt from FSX asking if I want to run the component (pictured below). I never get the second prompt from Windows asking if I want to run that same component. 

 

https://flic.kr/p/Ng6Kkb

Share this post


Link to post
Share on other sites

it will be in your start menu as well under i think its called simobjects display engine

Share this post


Link to post
Share on other sites

Might not be your best solution but I installed Kilimanjaro into P3D by first installing it into a "fake" FSX folder on a PC that did not have FSX or P3D installed and then copying the folder structure into my P3D without any SODE folders or SODE entries and the airport works perfectly. Not sure what SODE actually brings to Kilimanjaro but you would not miss it. Similar procedure might work for FSX Steam.

 

It is a great airport scenery in what is a continent mostly ignored by scenery developers.

Share this post


Link to post
Share on other sites

Interestingly though - I bought a few additional add-ons during Steam's FSX flash sale. Most of the add-ons installed fine. Steam installed them, and when I launched FSX it asked me if I wanted to run a specific component > I'd hit Run > and then I'd get the second prompt from Windows asking if I wanted to run that same component and I would again hit Run. After that I wouldn't see those messages anymore

 

Go back now have a peep at the <ManualLoad> Entries in your dll.xml and your exe.xml file to insure you have them set to False

 

Go to: >  AppData \ Roaming \ Microsoft \ FSX   DLL.XML  EXE.XML   Right Click  Open with < Notepad

 

Change this  <ManualLoad>True</ManualLoad>  To This  <ManualLoad>False</ManualLoad>   In all the Entries and Save them 

 

=======================

 

Also, Check your UAC User Account Control,  Maybe this is the reason for Windows "asking Permission"   Type UAC into your windows search bar,  Drag down to Never Notify  Click Ok 

Share this post


Link to post
Share on other sites

Go back now have a peep at the <ManualLoad> Entries in your dll.xml and your exe.xml file to insure you have them set to False

 

Go to: >  AppData \ Roaming \ Microsoft \ FSX   DLL.XML  EXE.XML   Right Click  Open with < Notepad

 

Change this  <ManualLoad>True</ManualLoad>  To This  <ManualLoad>False</ManualLoad>   In all the Entries and Save them 

 

=======================

 

Also, Check your UAC User Account Control,  Maybe this is the reason for Windows "asking Permission"   Type UAC into your windows search bar,  Drag down to Never Notify  Click Ok 

 

Thank you very much for your continued help, it is truly appreciated. 

 

I confirmed that UAC is set to "Never notify". I went back and checked the DLL.XML file and the EXE.XML file. In the EXE.XML file, I found one <ManualLoad> which had TRUE and changed it to FALSE:

 

This did prevent those pop-ups from displaying when FSX launched! I went and tested both of the add-ons that were causing me issue:

 

  • The Air Alaska add-on seemed to work fine (I tested a minute or two of the first mission w/o issue). Though it did take maybe 30-45 seconds for the loading bar to progress past 0% - if that means anything
  • The Kilimanjaro airport add-on did not load when I tried to start a flight there. It appears only the default scenery loaded

I should also note, that I used the Steam client to uninstall all of the FSX DLC (I unchecked the Install box), rebooted, and then installed each DLC item again (checked the install box and let the download/install take place), launched FSX, closed FSX, and then installed the next DLC item.

 

When I checked the scenery library in FSX I did not see anything in the list which referenced Kilimanjaro or Aerosoft - though, to be honest, I'm not exactly sure the exact phrase I was looking for.

 

Again - I sincerely appreciate all of the assistance. Thank you! 

Share this post


Link to post
Share on other sites

I see now why you could Not find SODE on your PC,  Its actually built into the Kilimanjaro Airport DLC,  So when you Uninstalled the DLC,   Sode also gets Uninstalled.  FSX is Not my strong point. 

 

============

 

 

Can't see the Airport ? 

 

(1) You have "Ticked"  the box for Kilimanjaro Airport DLC  But it still says Not Installed.  In this case,  Log out of your Steam Account (Don't X out of it, Log out) and Sign back in again, The DLC should Download now and Install.  

 

(2)  You have "Ticked"  the box for Kilimanjaro Airport DLC and it says Installed but there is no Listing for it in your scenery Library.  Restart FSX and check again

 

Still No go.......

 

In this case Launch FSX,   Go to settings > Scenery Library > Add Area  Navigate to............. 

 

► Program Files (x86) ► Steam ► steamapps ►common ► FSX ► DLC ► 3xxxxx ► Aerosoft  Click  Kilimanjaro Airport   Click Ok 

  • Upvote 1

Share this post


Link to post
Share on other sites

That did it! I was able to manually load the scenery. Now when I launch FSX I do not get a prompt from either the Kilimanjaro airport DLC or the Air Alaska missions DLC (and both seem to work properly). 

 

Thank you VERY much for your help Poppet! It is truly appreciated!

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this