Sign in to follow this  
Michael Moe

W10 64 bit Update just updated to Nvidia 376.53?

Recommended Posts

Hi,

 

Anyone else have 376.33 installed and Windows Update just updated my driver to 376.53 (29.12.2016) ?

 

Not even on the list at Nvidia

 

Thanks

 

Michael Moe

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sigh, yes, windows updated for me, even though back when I set this computer up last year I selected the option not to download updates for drivers.

 

Attempting (with difficulty) to roll back now


God help us all, windows 10 keeps putting the latest driver back. I can't roll back. On computer restart, the latest problematic driver is in place. 

Share this post


Link to post
Share on other sites

yep NVIDIA - Display - 12/29/2016 12:00:00 AM - 21.21.13.7653  I will post if any issue comes up.

Share this post


Link to post
Share on other sites

I was going mad last night trying to roll drivers back to 376.33 and having Windows update immediately install 376.53. Glad to hear it's not just me having this issue!

Share this post


Link to post
Share on other sites

Option 1

Preferred option: http://winsupersite.com/windows-10/stop-automatic-driver-updates-windows-10

 

 

Option 2.

If you have Win10 Pro you'll already have PowerShell installed, if you have the Home Edition download & install PowerShell from the link below:
http://www.microsoft.com/en-us/downl....aspx?id=46889

Next you'll need to download the Windows Update PowerShell Modules, grab it from here: https://gallery.technet.microsoft.co...2-88dff796b0bc

Unzip the file you downloaded and move the "PSWindowsUpdate" folder to: C:\Windows\System32\WindowsPowerShell\v1.0\Modules

------
Now launch PowerShell as an Administrator.
(Quick PowerShell tip... use the "Tab" key to auto-complete commands. Hit tab a few times to see what options are available.)

By default PowerShell is setup to restrict any scripts which require admin privileges. You'll need to set it to Unrestricted mode to install the modules and run the WindowsUpdate commands.

Set PowerShell to Unrestricted Mode, using the command below.
> Set-ExecutionPolicy Unrestricted CurrentUser
- Answer yes to the next prompt.

Now to install the WindowsUpdate PS Modules, type this command at the PowerShell command line. (You'll only need to do this once.)
> Import-Module PSWindowsUpdate

Next you'll type the command to hide Nvidia Updates.
> Hide-WUUpdate -Title "NVIDIA*"
(Now any update released starting with the name NVIDIA will be blocked/hidden.)

After completing these commands you'll want to set the Execution Policy back to restricted. This will return PowerShell to the default permissions level.
> Set-ExecutionPolicy Restricted CurrentUser

 

Please Note, When you execute this command, > Hide-WUUpdate -Title "NVIDIA*"  be patient, it can take 1 to 2 mins. You may think it has not worked. Also, do not remove the quotes.

Share this post


Link to post
Share on other sites

BTW, the above worked for me. For some, it does not work. I would go for option 1 if it works for you.Go figure. Stick that Microsoft lol

Share this post


Link to post
Share on other sites

Thanks, I didn't have the above setting correct... However I think I had it set correctly originally, but a windows update "changed" my preference.

 

I work for a carrier that uses microsoft products, and let me tell you... headaches with those products. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks, I didn't have the above setting correct... However I think I had it set correctly originally, but a windows update "changed" my preference.

 

I work for a carrier that uses microsoft products, and let me tell you... headaches with those products. 

Yes, it changed mine as well. They won't catch me again though :)

 

Edit: And they did lol

Share this post


Link to post
Share on other sites

You guys should shut down auto W10 updates. I did to avoid these issues.

Share this post


Link to post
Share on other sites

You guys should shut down auto W10 updates. I did to avoid these issues.

I don't have that option. Only defer updates. Can you tell me how ? Please ? :)

 

Now, it is possiable that option has been removed with a recent update, as I use to have it not update graphic drivers, now it has become very difficult to stop it updating. All the usual tricks are not working.

Just tried option 3, so will see how that goes.

Share this post


Link to post
Share on other sites

I also thought I had turned off Driver updates a few weeks ago,  now turned on and says the driver  Nvidia Display  376.53 (12/29/2016)  has been installed today.?

 

Didn't see the normal NVidia  install program run at any point !

 

I see there is a new version out though 378.49, which was released 24/1/17

 

Wonder why it didn't install that one?

 

v Strange......

Share this post


Link to post
Share on other sites

I also thought I had turned off Driver updates a few weeks ago,  now turned on and says the driver  Nvidia Display  376.53 (12/29/2016)  has been installed today.?

 

Didn't see the normal NVidia  install program run at any point !

 

I see there is a new version out though 378.49, which was released 24/1/17

 

Wonder why it didn't install that one?

 

v Strange......

It is strange. So far with option 3, I still have 376.33 drivers, so fingers crossed. I had to download Guru3D DDU nvidia uninstaller in safe mode to stop windows from re installing.

Share this post


Link to post
Share on other sites

Is there any particular issues with this driver anyone aware of ? If not I will just leave it installed !

Share this post


Link to post
Share on other sites

Is there any particular issues with this driver anyone aware of ? If not I will just leave it installed !

Has a memory leak I believe.As posted in the P3D forum

Share this post


Link to post
Share on other sites

I use fsx not p3d will that not effect me then ?

As the memory leak is in the driver, I suppose it would. Try the latest. BTW, option 3 worked.

Share this post


Link to post
Share on other sites

Typical MS.

 

I hope this isn't a taste of things to come.

 

Whenever they say they're making changes to "make games better", you can bet hard cash that the BOHICA is on its way. Which is a shame. And the new and coming windows update is "all about making games run better."

Share this post


Link to post
Share on other sites

This is why I stayed with W7 on my dedicated Sim Rig.  Shame really, that M$ should spoil a good OS like this.  But then I guess computer game players are a minority in terms of worldwide PC usage.  Consequently of no real interest to the powers that be.

Share this post


Link to post
Share on other sites

I really have no inherent problems with Windows 10... but I just wish I could yell out "please! Let me run and control my own computer!" 

Share this post


Link to post
Share on other sites

This is needed to and make notes

 

http://www.howtogeek.com/263851/how-to-prevent-windows-from-automatically-updating-specific-drivers/

 

1) download 376.33 installer. 

 

2) Then follow these instructions http://winsupersite.com/windows-10/stop-automatic-driver-updates-windows-10

 

3) Disable Internet

 

4) Uninstalled the nvidia drivers on your computer (I used DDU app, you don't have to)

 

5) Reboot PC and login and install 376.33 Drivers (make sure internet is off).

 

6) Now Follow these simple instructions on group policy http://winsupersite.com/windows-10/stop-automatic-driver-updates-windows-10

 

7) Reboot pc and enable Internet.

 

Now Windows will try to update but those nvidia drivers won't update.

 

But down the road you will need to dis-enable the group policy to update drivers - place a note or sticky on the desktop to remind you to do that step prior to updating any new drivers.

Share this post


Link to post
Share on other sites

 

 


But then I guess computer game players are a minority in terms of worldwide PC usage. Consequently of no real interest to the powers that be.

 

The next major update has a built in game mode aimed at giving games more resources to run better,

If the Powers to be have no interest ing gaming, why are they building this mode ?

It is the best OS these days for gaming and Microsoft is making it better with each free update.

The new Nvidia drivers that MS kindly installed for us are running fine, nothing to fear here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this