RichieFly

Tips for QOTS II Performance with P3Dv4

Recommended Posts

Hi,

I've installed the new QOTS II for P3Dv4. She's quite the looker!

Anyway, I'm having FPS problems while interior viewing and pretty close to steady 30 FPS exterior viewing.

I've tried this and that with no luck. I'm even seeing single digits! Noooo.

Why I'm asking for tips is that I'm swamped with all the newness; AS16, Orbx, new simulator version and a new version of the Queen.

I won't list my settings to save space, although you can see my setup in my signature. My CPU isn't maxed, neither is my video card during a run.

I would be thankful if any of the folks seeing steady 30 FPS in the cockpit could share their general settings or suggest a place to start sorting this out.

Regards,

P.S.

The Queen runs great in P3D v3 with steady-eddy frames at all times.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try with the landing lights off the dynamic lighting is killing interior FPS quite massively...

Share this post


Link to post
Share on other sites

Dynamic lightning is killing frames by 50% (on the ground), at least on my setup. Once airborne frames get up. So much about that for me.

Share this post


Link to post
Share on other sites

I agree.  With lights on my GPU sounds like a jet taking off.  Running at 100%.  Turn the lights off it runs at 50%.  If you turn dynamic lighting off though you will have no landing lights so there is the problem.  

But its early days.

 

Sean 

Share this post


Link to post
Share on other sites

What graphic cards are hitting 100% with the lights? Something older, or cutting edge tech? 

Share this post


Link to post
Share on other sites

Thanks for the replys. 

Yes, it is the lighting. I turned off the P3D options RE lighting and things are much better.

Back to normal-ish.

Thanks again.

Share this post


Link to post
Share on other sites

Yeah..I was wondering why I was getting a massive FPS hit in VC... hmm... let me try turning off the dynamic lighting.

Share this post


Link to post
Share on other sites

Bizarre - I am not experiencing this at all.  I found a slight momentary drop when I switch on the storm lights and then right back up to where it was.

Try and turn down (off) your dynamic reflections to see if that helps and run your card at unlimited,

I have been testing these setting since v4 came out and I am in a good place now.  I will offer any assistance that I can.

Testing at FSDT CYVR with traffic and such - sliders NOT maxed - because they dont need to be!!!!

Share this post


Link to post
Share on other sites

I was having similar FPS problems and was very disappointed.    I have a decent rig, but couldn't get passed 20fps.    UNTIL...

I was monitoring my GPU (processing load, memory, temp) and CPU (processing load, temp).     I realized that my GPU (NVIDIA 1070 w/ 8GB) had plenty of processing and memory to give with graphics settings maxed.    My CPU (Intel Core i7-3970X Extreme Edition / hexacore, HT disabled) was only running at about 60% overall.    When I looked at each core utilization it turned out that P3D was using Core #0 almost exclusively and very little was on Core #1 - #5.

I tried the AffinityMask in the Prepar3D.cfg file, but that doesn't work well at all.   In fact, no matter how I set the AffinityMask P3D wanted to always use the first CPU core in my affinity and not use much of the other cores.

What did work was...

I removed the AffinityMask setting from the Prepar3D.cfg file, I started P3D up (PMDG QOTSII at FlightBeam's KIAD active runway) then I used Windows Task manager to change the AffinityMask for Prepard3D.exe that way (specifically to ignore CPU#0, and only use CPU#1 - #5).  Great results!    FPS increased by 50+% from 20 or below to 30 or above steady (inside the cockpit, with dynamic lighting on!)

What worked even better...

I then set the AffinityMask using the Task manager back to using ALL cores #0 - #5 and I got even more FPS.  Core #0 was used just as much as Cores #1 - #5.  Silky smooth!

Why?   This is only a theory, based on the testing I did -- I am no hardware / operating system expert!

Since P3D appears to inject itself mainly into Core #0 at startup, and minimally uses the rest... Windows seems to allow P3D to do what it wants with CPU cores (even if the Task Manager indicates that P3D appears to have an affinity for all the cores).    However, my experience was that once you explicitly assign CPU cores to P3D using the task manager then Windows takes over the handling of work across the cores you choose.

Anyway, some folks might find this helpful.   Some might not get the same mileage as me.   I know I'm excited because I almost thought v4 was too much for my rig.

Good luck guys!

  • Upvote 2

Share this post


Link to post
Share on other sites

Hi, tried that, but no results. Only difference I did in test that I am suing lasso program to switch off and on cores.....

JM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now