ahuimanu

stutters on long haul

Recommended Posts

Typical route for me EKCH - KMIA

About 1/2 way through I get steady rhythmic "stutters" where the whole sims lags and lurches using the latest version.  Things are okay in the first hours.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jeff.  I, too, have this issue, and it is due to a couple things.

  • My hardware is 2+ years old (see signature). With lots of eye candy and heavy weather scenarios, it falls behind the current breed of CPU/GPUs in the market today.
  • My settings are too high, so I'm slowly trimming them down before new flights in the hunt for a good compromise.

There may be other ancillary reasons in addition to these, but I believe these are the main contributors to the steady long stutters when arriving at my destination.  It's a slow process, but it is getting better.

Edit: You will get flagged for not using your full name here in the PMDG forums.  Just sayin... ;)

Share this post


Link to post
Share on other sites

Are you both running FSUIPC? Check if the autosave function is enabled.

1 hour ago, ahuimanu said:

Typical route for me EKCH - KMIA

About 1/2 way through I get steady rhythmic "stutters" where the whole sims lags and lurches using the latest version.  Things are okay in the first hours.

And Jeff, PMDG ask that all forum posts must be signed with your full name.

Share this post


Link to post
Share on other sites
12 minutes ago, PMDG777 said:

Are you both running FSUIPC? Check if the autosave function is enabled.

And Jeff, PMDG ask that all forum posts must be signed with your full name.

shouldnt  it be  disabled   the  auto  save  feature  for  fsuipc

Share this post


Link to post
Share on other sites
Just now, pete_auau said:

shouldnt  it be  disabled   the  auto  save  feature  for  fsuipc

Yes sorry I'll clarify, check if it's enabled and if it is, disable it.

Share this post


Link to post
Share on other sites
22 minutes ago, PMDG777 said:

Are you both running FSUIPC? Check if the autosave function is enabled.

I did this when on P3Dv3 for long hauls because of OOM threat, and know what you mean.  But I've already disabled the feature with P3Dv4.  Thanks, Chris.

Share this post


Link to post
Share on other sites
14 hours ago, dmiannay said:

Hi Jeff.  I, too, have this issue, and it is due to a couple things.

  • My hardware is 2+ years old (see signature). With lots of eye candy and heavy weather scenarios, it falls behind the current breed of CPU/GPUs in the market today.
  • My settings are too high, so I'm slowly trimming them down before new flights in the hunt for a good compromise.

There may be other ancillary reasons in addition to these, but I believe these are the main contributors to the steady long stutters when arriving at my destination.  It's a slow process, but it is getting better.

Edit: You will get flagged for not using your full name here in the PMDG forums.  Just sayin... ;)

Thank you for replies.

FSUIPC autosave is off.  I do notice that I can see WAY more of the horizon in v4.  Settings it is then...

BTW, I can't imagine a reality where your system specs are "old."

Share this post


Link to post
Share on other sites
8 hours ago, ahuimanu said:

BTW, I can't imagine a reality where your system specs are "old."

LOL... viewed from the perspective of how rapidly computing hardware is advancing, I believe CPUs/GPUs are already "old" technologically after 12 months.  I traditionally build a new rig every 2 years so I can try and stay as close to the ragged edge as possible.  Since its been 2.5 years since I built this one, to me, it is getting old.  Perspective is everything.  But, I do understand your point, Jeff.

I hope you find that sweet spot where you can just sit back and enjoy a flight with no performance distractions.

Share this post


Link to post
Share on other sites

So, Doug,

What settings have  you dialed back and have you reduced stutters?

Thanks.

Share this post


Link to post
Share on other sites

Hi again, Jeff.

Here are my current settings, which still currently result in stutters after roughly 4 hours.  I have still not discovered the offending combination.  I continue to adjust, but no "magic bullet" has revealed itself yet.  

I have zero Prepar3D.cfg tweaks except adding "TextureMaxLoad=36" to the [Display] section.  This is supposed to help with scenery buildings turning black when you look away, and then popping back with the correct textures when you look back at them.  Too soon to see it this setting works since I just made that change yesterday.

Display - Nothing really dialed back here.
World - Definite throttling here, especially with LOD radius, texture resolution, and autogen settings.
Lighting - I have never enjoyed the look of HDR lighting, so it is disabled.  Shadows dialed back for performance.
Weather - Nothing out of the ordinary here.
Traffic - I use MyTraffic6, and this setting keeps the FPS-stealing AI to a minimum, but still provides adequate immersion.

Share this post


Link to post
Share on other sites

H

2 hours ago, Morvious said:

I just came across this because I have the exact same issue!

https://www.navigraph.com/forum/viewtopic.php?f=93&t=4654

Hey, Stefan. I am also testing Navigraph's new desktop charts app, but I don't run their SimLink DLL since I have no interest in following my flight's progress on their map.  So, for me, that isn't contributing to the problem.  Thanks for weighing-in.

Share this post


Link to post
Share on other sites

I also get stutters after a number of hours.  I have no idea if it is P3D-related, PMDG-related, AS-related etc.  I don't really have the patience to turn off one-by-one and try it for hours on end.  I save and re-load my flight at TOD, and the stutters go.  I know it's not a solution, but if anyone finds one, I'll be interested to hear.

Cheers,

Share this post


Link to post
Share on other sites
8 hours ago, dmiannay said:

H

Hey, Stefan. I am also testing Navigraph's new desktop charts app, but I don't run their SimLink DLL since I have no interest in following my flight's progress on their map.  So, for me, that isn't contributing to the problem.  Thanks for weighing-in.

Hi Doug,

You don't need to run/use it to get the stutters, just the fact that it loads the dll in the background as a sim process can cause this.
Go to your DLL.xml file and disable or remove the entry to simlink dll.

You can also go to Control Panel, Programs and Features and uninstall the SimLink.

Share this post


Link to post
Share on other sites

Will give it a go, Jannie.  Thanks!  Will report back next long-haul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now