jay281

Autogen V4

Recommended Posts

Hello All, Im experiencing autogen popping, and sometimes complete lack of autogen in V4. I have no FFTF tweak and a clean config. Im running a 7700K at 5.0ghz and a Titan Xp. Is this a widespread problem? If you want to test, take off from EGCC and turn onto a heading of 150, after 5min look for autogen.  Im running Open LC, UK2000, PMDG 747 and AS16. My CPU core 0 is not maxed. 

Ive tried all of the normal antidotes, its actually getting me down.

Kind Regards

James

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

And do you see this same issue without the scenery addons?

Share this post


Link to post

Do you have Dynamic Autogen/Speed Trees ON ? If so, uncheck it from options menu.

Share this post


Link to post

Ill be perfectly honest i have not tried, the only addons i have active are the ones stated in the post. Its just bizarr, i consider myself quite o'fey with the ESP engine, but im just compleatly stuck. I would prefer to not go for the nuclear option if you know what i mean lol! 

Share this post


Link to post

To add more context this is a compleatly clean install of the latest build of P3D. 

Share this post


Link to post

What are your autogen settings? There's more autogen that renders further out, even with comparable settings to V3. So if you've cranked it too high, you might just be completely overloading those 4 cores / 8 threads (got HT enabled or disabled?) and it just starts to queue up a ton of the autogen loading. Though I'd think that would only happen if you traveled fast like in a jet. 

Share this post


Link to post

Hey jay281,

I discovered the same issue with my V4. Have FTX Global, FTX Europe LC and FTX Germay North installed. It seems that it only occurs if I set the internal framerate limiter to "unlimited". If I set it to 30 or so it seems to be better. Guess the simulator has more time loading this stuff then. Maybe here it makes sense to play a little with FFTF since I do not like setting the internal frame rate limiter. 

Share this post


Link to post

@Sethos1988 agreed,  I have tried HT off and On (AM245 follow SteveW advice) still the same conclusion im afraid. My Autogen settings are one or two from max. 

Share this post


Link to post

@Rollmopsyeah i have tried that too. I run my monitor refresh rate @75hz and lock my frames at 37, this gives me a smooth experience. I have tried locking internal and external to no provail. Mabe its time to look at the 6 and 8 core offerings from Intel lol! #anyexcuse 

Share this post


Link to post

Does sound very weird. Even Rob said you are better off with a fast 4 core / 8 thread than a CPU with more cores and lower IPC, because that high IPC serves the sim much better. So I very much doubt there's anything wrong with that 7700k. Sounds like there may be a setting or some circumstance that's tripping you up. Could probably throw a lot of suggestions out there but ultimately it might just end up being a waste of your time.

Share this post


Link to post

@Sethos1988im thinking of going for the nuclear option....... i just cant for the life of me think what would cause this? Other than poor AM and incorrect use of FFTF leading to over satuaration of the CPU. The one observation i have is that the rendering cores 2 + 3 (HT off) are redlined. Even using an AM of 245 does not fix this. Hmmmmm

Share this post


Link to post

Well, that's a good thing. Under V4, it'll use all the additional cores fully to render terrain and autogen. So they will often peak. My 8 core / 16 thread CPU does the same, there's times where every single core is maxed out, especially taking off out of KLAX with OrbX's SoCal, that'll eat up a CPU fast. Though I have my doubts how effective it really is and if it isn't just some job scheduler malarkey.

My personal suggestion would be to download Process Lasso, if you've heard of it. Great tool to manage processes, power profiles, see their CPU affinity etc. set P3D to run "Bitsum Highest Performance" (which also unparks cores, if they are parked) and also check out it's using all your cores. At the same time, as you've messed with your CFG, I'd flat out delete it and let P3D generate a new one for you. Then you are absolutely sure it's running clean, then set up what you need again. Then make sure every single core (enable HT if you're currently on HT off) except core 0's physical and logical, are working when you hit heavy autogen. Core 0 only handles the sim calculations itself, so that may have a different load. As it doesn't multi-thread this load, core 0's logical core won't see much action.

Then you can make sure the sim is running clean, CPU is doing the work it's supposed to and then take it from there. That's what I'd do.

 

Share this post


Link to post

@Sethos1988thanks for the advice, i have used process lasso in the past and went back to running the same type of programme but with a powershell script. (Essentially made sure i isolated core 0) however since this autogen problem i have reverted to using nothing. I clean wiped my CFG before posting. 🤢

Share this post


Link to post

At first, autogen popping is much less noticeable than in Prepar3d3 on my system. Its visibility depends on a number of factors like weather, possible shader tweaks etc. There are regions where I don't notice it at all but there are others (like the plains in Silicon Valley) where I still find it distracting.

There is a parameter

AUTOGEN_DRAW_DISTANCE

under SCENERY which regulates this. It defaults to 30000.000000.  Raising it to, say, 45000.000000 mitigates the remaining autogen popping, however at the price of (i) remarkably longer Prepar3d startup times, (ii) a noticeable fps loss.

Kind regards, Michael

Share this post


Link to post

@pmb thanks, i havn't tried that, however the more alarming fact is i dont have any autogen whatsoever after about 5min. Its like P3D just gives up loading it. I dont even have blurries, the textures are pin sharp. 

Share this post


Link to post

Do we have a feel for how much autogen loads the CPU in V4?  I was under the impression that autogen rendering had been pushed primarily to the GPU, but I will defer to others more knowledgeable on the topic.

Share this post


Link to post

Autogen has been rendered by the gpu using tessellation since P3Dv2 launched.

Share this post


Link to post

Try the AG Distance slider. If set to the left you will see almost nothing. From Medium (12000)in the P3D.cfg file ) and upwards you will see lots of AG.

Surely you will have to set both AG vegetation and buildings sliders also to more than all the way to the left...

Share this post


Link to post

I have exactly the same problem.
I have reinstalled the sim, drastictly reduced the settings but still have have these problems flying the fast jets.
Running with a 4790K at 4.6 and a 1080ti.

All suggestions i've read till now don't seem to fix the problem

Share this post


Link to post

Add TEXTURE_SIZE_EXP=10 in your Config.  This will stop the autogen popping, this will use almost all of your VRAM though.

Share this post


Link to post

With regard to the usage of cores,  what would be the best tool to monitor that usage while P3Dv4 is actively running?

Mike

Share this post


Link to post

@everyone  Thank you for your ideas, im still working through the problem. However, ive made progress by reinstalling the client. Still have further testing to do.

Share this post


Link to post
32 minutes ago, orbmis said:

With regard to the usage of cores,  what would be the best tool to monitor that usage while P3Dv4 is actively running?

Task Manager will display core usage but only for the last minute. Try MSI Afterburner - you can set it up to monitor all of the individual CPU cores in the Monitoring tab of the properties. It will show about 10 minutes of usage.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now