SquawkDirtyToMe

P3D FIX FOR "Error Creating Child Window"

Recommended Posts

Hello Folks,

So recently I have had alot of people message me about an issue with P3D V3 throwing an error "error creating child window" and or crashing due to a recent Windows 10 update. I did a bit of investigating and saw that the issue was caused basically due to some invalid string and return data within the included .NET 4.7 update. After reaching out to a friend whom is an engineer with MS and him looking into it, I was informed that the November 14th patch would resolve the issue, but it didnt of course.. Well, here is a fix that i've tested with a couple of friends experiencing the issue and it resolved the error from coming up and crashing. It's as simple as removing .NET 4.7 and I have included the simple instructions below;

 

Step 1: Click on your start button, search for and open "Control Panel"

Xwnh6pI.png

 

Step 2: Click on Programs

MCFOdqJ.png

 

Step 3: Once in Programs, Click on "Turn Windows Features On or Off"

brpqQ9D.png

 

Step 4: Once the Windows Features window opens, Uncheck ".NET Framework 4.7 Advanced Services" and then press OK.

z9KPD6Y.png

 

This should remove .NET 4.7. Afterwords, you may need to reboot your computer (I would anyways). After the reboot, run Prepa3d and the child window error should not occur! During testing, I also loaded all the addons I could (Such as Active Sky, vPilot, and a few others) but thankfully very little programs are .NET 4.7 dependent therefore there should be no impact to any other programs. 

NOTE: In the event that Microsoft get's it's sh** together and they release a working update, you can easily re enable/install .NET 4.7 by replicating the steps above with the exception to the last step in which you will enable the checkbox and press OK.

Have any issues or questions? Send me a private message and I will be more than happy to help. I'll be looking into the FSX-Steam issue that has recently came up with the latest update and once I find a fix for that, ill post in the appropriate board. 

  • Upvote 5

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Thanks for this, it will help a lot of people.

What version of PD3 you have? I imagine 3.x? this problem hasn't been reported under 4.1.

I just think it would be a good idea to clarify which version of PD3 this fix is for and maybe place this on the sticky list on the forums.

Regards,
Simbol

Share this post


Link to post

That didn't work at al, running P3D v3.4.22l, still the same "Error creating child window" prompt, same CTD when switching to full screen with "Alt-Enter". Nothing changed.

Cedric

Share this post


Link to post

@Cedric Sin If you'd like, feel free to send me a private message and I don't mind troubleshooting for yah. 

 

@simbol The issue is specific to P3D v3 as the issue effects 32bit programs. P3D v4 is in the clear with it being 64bit. I don't recall the specific versions of the few friends i've helped, but I tested locally on 3.4.22.19868

Share this post


Link to post

Guy.. this post did not work for me but, I did find a fix..

You need to go into your simulator Lockheed Martin  

Double click on Prepar3D v3 scroll down until your find

Prepar3D.exe.comfig  open with note pad and it needs to read this:

<?xml version="1.0"?>
<configuration>
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.7" sku=".NETFramework,Version=v4.7"/>
  </startup>
</configuration>

one this part is done it save. and put check mark back in the NET.Frame: see step 4 in this thread.. I'm back in business

Works for me.. :)

 

 

Share this post


Link to post
3 hours ago, mgrimm said:

Guy.. this post did not work for me but, I did find a fix..

You need to go into your simulator Lockheed Martin  

Double click on Prepar3D v3 scroll down until your find

Prepar3D.exe.comfig  open with note pad and it needs to read this:

<?xml version="1.0"?>
<configuration>
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.7" sku=".NETFramework,Version=v4.7"/>
  </startup>
</configuration>

one this part is done it save. and put check mark back in the NET.Frame: see step 4 in this thread.. I'm back in business

Works for me.. :)

 

 

@Poppet

Poppet could you confirm with LM if this approach be better than disabling .NET 4.7 entirely? or perhaps users should remove .NEt 4.7 and edit the config file to point to a previous version?

Best Regards,
Simbol

 

 

Share this post


Link to post

Hi 

I have the "Error child window" issue on P3d v3.1, Windows 10.

Have tried disabling network 4.7, No good

Having tried altering theP3D config file from network 4.0 to 4.7, No good.

Although in any selected cockpit scenario, I momentarily  get the  "Error child window"  but I can continue

with a flight normally,. My trouble starts when selecting  other than full screen mode, or shift 2/3/e etc then it CTD. 

Share this post


Link to post

Every computer is different. In P3D V3.4 its automatic that the Net.Frame is set for 4.0.. Good Luck it worked for me and my brother.

 

 

Share this post


Link to post
On 11/16/2017 at 3:22 AM, kcpilot1420 said:

Hello Folks,

So recently I have had alot of people message me about an issue with P3D V3 throwing an error "error creating child window" and or crashing due to a recent Windows 10 update. I did a bit of investigating and saw that the issue was caused basically due to some invalid string and return data within the included .NET 4.7 update. After reaching out to a friend whom is an engineer with MS and him looking into it, I was informed that the November 14th patch would resolve the issue, but it didnt of course.. Well, here is a fix that i've tested with a couple of friends experiencing the issue and it resolved the error from coming up and crashing. It's as simple as removing .NET 4.7 and I have included the simple instructions below;

 

Step 1: Click on your start button, search for and open "Control Panel"

Xwnh6pI.png

 

Step 2: Click on Programs

MCFOdqJ.png

 

Step 3: Once in Programs, Click on "Turn Windows Features On or Off"

brpqQ9D.png

 

Step 4: Once the Windows Features window opens, Uncheck ".NET Framework 4.7 Advanced Services" and then press OK.

z9KPD6Y.png

 

This should remove .NET 4.7. Afterwords, you may need to reboot your computer (I would anyways). After the reboot, run Prepa3d and the child window error should not occur! During testing, I also loaded all the addons I could (Such as Active Sky, vPilot, and a few others) but thankfully very little programs are .NET 4.7 dependent therefore there should be no impact to any other programs. 

NOTE: In the event that Microsoft get's it's sh** together and they release a working update, you can easily re enable/install .NET 4.7 by replicating the steps above with the exception to the last step in which you will enable the checkbox and press OK.

Have any issues or questions? Send me a private message and I will be more than happy to help. I'll be looking into the FSX-Steam issue that has recently came up with the latest update and once I find a fix for that, ill post in the appropriate board. 

Can you notify your MS friend about the issue?

Share this post


Link to post
I tried the changes to this issues listed above and the changes to the Prepar3D.exe config files corrected my problem.

It did not correct the problem when I run P3D v3 using VR and Flyinside . . . the child error appears.

Hope a solution can fix both Flyinside and P3D issues.  All this started with updates recently.  

Things worked so well and then 'improvements' crash programs that had no issues.  Before this I  could achieve 80 fps in Flyinside w P3D using the VRS Hornet. Then the frame rates dropped to half, then to single digit, then it only ran using P3D by itself, then came the 'child error'.  Now it works with just P3D but not with Flyinside.

Thanks in advance for any help guys,

Chopper

 

Share this post


Link to post

I'm also having this problem and have tried everything under the sun. It's such a pain in the word not allowed.

Share this post


Link to post

Anyone got a fix for this yet?  Really bugging me now :(

Share this post


Link to post

I heard MS did another update on November 30, 2017. I ended up rolling my windows back to Windows7.. works great no issues, I have no time for Windows10. Windows7 will be good until 2020

 

Mike

 

Share this post


Link to post
1 hour ago, mgrimm said:

I heard MS did another update on November 30, 2017. I ended up rolling my windows back to Windows7.. works great no issues, I have no time for Windows10. Windows7 will be good until 2020

 

Mike

 

You're lucky!  I have the Kaby Lake i7 7700K and cannot install Windows 7 using Kaby Lake processors (think Skylake too).  Only Windows 10 must be installed.  Mandatory.... Totally incompatible!  That's what they said when it was first announced - "mandatory", but that only gave techs a major challenge as some got very upset when they heard a chip maker say they are not compatible with anything other than Windows 10 and you cannot do this or that.  It was just a matter of who would be the first to get it to work with Windows 7 and make fools of the chipmaker and Microsoft.  Google says it can be done (but I'm not going to try)!  Now those techs, who made fools of Intel and Microsoft, are all here on AVSIM trying to get their respective flight simulators to work properly without getting so many crashes and freezes. :smile:  Just joking...

Best regards,

Jim

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now