ndflieger

New to Prepar3Dv4 - Getting Stutters

Rate this topic

18 posts in this topic

Greetings all,

Yesterday I purchased, downloaded and installed Prepar3Dv4.2 (This is the first time I've used P3D). I have not added on anything as of yet. When I load a default aircraft (Bonanza, for example), I am getting a stutter about every 1 - 2 seconds. Pretty much makes the sim unusable for me. I have purchased the Process Lasso CPU manager software as I saw it recommended in a couple of threads https://bitsum.com/, but that did not fix the problem. I have also updated my video and sound card drivers to the latest versions.

I have my graphics, display and nvidia inspector settings set to those recommended for my video card on various threads. My PC is relatively new, as I had it built in November 2017. It runs FSX-SE (lots of add ons) and X-Plane 11.1 flawlessly. Here are my PC specs:

Corsair Hydro Series Liquid CPU Cooler H60

Intel 7th Gen Intel Core Desktop Processor i7-7700K 4.2 GHz

LGA1151 DDR4 DP HDMI M.2 USB 3.1 ATX Motherboard

Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz

Asus 24x DVD-RW Serial-ATA Internal OEM Optical Drive DRW-24B1ST

2 x Samsung 850 EVO 500GB 2.5-Inch SATA III Internal SSD 

Toshiba 3TB Desktop 7200RPM Internal HD

Corsair Power Supply RMX 850W

Corsair Obsidian Series 750D Performance Full Tower Case

MSI Gaming GeForce GTX 1070 8GB GDDR5 SLI DirectX 12 VR Ready Graphics Card

Windows 10 Home

Any help will be greatly appreciated.

Regards,

Scott

Edited by ndflieger
Added info

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can you post your P3D settings?  You're machine is very similar to mine and I don't have any stuttering issues.

Here are my settings:

0dtRsEI.jpg

qCTgsKv.jpg

qoN1nnQ.jpg

 

Share this post


Link to post
Share on other sites

Hi,

Thanks for the quick reply! I will give your settings a try. Sorry, but I don't know how to insert images into a post here - I'll figure that out when I have the time ;-)

Scott

 

Share this post


Link to post
Share on other sites

Hi Gridley,

I tried your settings, but it didn't make any difference. Stutters are still there.

Regards,

Scott

Share this post


Link to post
Share on other sites
1 minute ago, ndflieger said:

Hi Gridley,

I tried your settings, but it didn't make any difference. Stutters are still there.

Regards,

Scott

Try Vsync on and tic triple buffering.

Share this post


Link to post
Share on other sites

I have the same setup as you Scott. Get "Micro" stutters, not really pauses  but very minute stutters in quick turns. Tried everything here and there everyone suggested and things you couldn't imagine. Both P3DV3 and 4. Xplane 11 is smooth as silk. I'll set here on the fence post and read all the suggestions. :) . Unlimited, Vsync on seems the best for me.

Share this post


Link to post
Share on other sites

Hi Tony & Adrian,

Yes, Windows Defender is running.

I may have gotten lucky and fixed it. I followed the "repair" instructions contained in the post in this link. You have to scroll down a bit to get to it:

Loaded the sim with the default settings and with the same aircraft and location I had been testing at. All worked well. I exited the sim, started it back up and changed the options settings to my preferences. The pause/stutter is not there any longer.

Hope things stay good. Will do more testing tomorrow and add some things.

Cheers,

Scott

Share this post


Link to post
Share on other sites

If you're using FSUIPC v5.123x revert back to v5.122--there's apparently a problem with 5.123c that causes exactly those sorts of stutters and Pete Dowson won't be back to look at it for another week.

Regards

 

Share this post


Link to post
Share on other sites

Please try this suggestion. I'd be surprised if you don't see a big improvement. If you haven't already done so...

  • Switch off HDR
  • Switch off dynamic lighting
  • Don't be drawn into copying others' settings, start by all sliders at half way and don't move autogen draw distance more than medium
  • Set AA to either 8MSAA or 4SSAA or less
  • This is the big one: Delete your cfg file, restart p3d. Then close down and open the cfg file. Don't add anything except FIBER_FRAME_TIME_FRACTION=0.01 to the MAIN section.
  • Then go into display properties and set your monitor refresh rate to 30Hz then lock your framerate in P3D settings to 30 and Switch Vsync on.

Any one of these has a big impact on performance, used together they should help you a lot. The last two tweaks will help enormously with smoothness. Good luck and let us all know how you get on.

Share this post


Link to post
Share on other sites

Thanks for the replies. Yes, I do have the latest of Dowson's utility. Will look more into that tomorrow.

Regards,

Scott

Share this post


Link to post
Share on other sites

I added affinity in prepar3d.cfg

[JOBSCHEDULER]
AffinityMask=31  // all 6 cores for a 8600K

This does NOT change any affinity (as per Task Manager) but stutters, gone ........

 

Share this post


Link to post
Share on other sites

@ndflieger This is definitely  FSUIPC causing  this.

I had a perfectly  new install of 4.2 working  fine,  installed  the latest FSUIPC and got massive stutters. I reverted back  to  fsuipc version 5.122  and the stutters were gone.

 

delete everything  in your P3Dv4/Modules/ folder and  install this version:

http://fsuipc.simflight.com/beta/Install_FSUIPC5122.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now