Jump to content

slait

Studders every few seconds after time

Recommended Posts

Hey all,

Thought I would make a post about this issue in case anyone has some suggestions for me. I've recently upgraded my system to something pretty solid (details below), and overall the performance is great when I start, but by the time I reach my destination the sim has deteriorated into studdering every few seconds, with good frame rates in between. In other words it seems to perform well, then pause, then catch up again, then pause, then catch up. It does this every two seconds or so through the rest of taxiing, parking, etc. I'm not quite sure where to go with it. Things I've tried:

  • Renamed and rebuilt the p3d.cfg file
  • Cleared the shader cache and reapplied ENVTEX
  • Reset any and all tweaks to my hardware (overclocking) to default, and ultimately reapplied when it made no difference
  • Tried locking frames in nVidia inspector, then rolled back when I started getting those DX errors
  • Adjusted various in sim settings with no change one way or the other

My new system:

  • Intel i7-8700k Over clocked to 4.9ghz
  • 32GB Gskill RAM at 3200mhz
  • Samsung 970EVO NVMe boot drive
  • OCZ SSD P3D drive
  • Nvidia 1070 8GB video card
  • 4k monitor

I'm at a loss as to what is causing this. Any thoughts from the experts?

Share this post


Link to post

Do you use Navigraph charts and simlink, by any chance?

If so, download and install the very latest simlink.

I had this issue myself but only after flying for a few hours.

Otherwise, make sure your sim is excluded from antivirus scans, or disable antivirus all together for test purposes.

 

Stu

Share this post


Link to post

4.9ghz? how are those temps? Check if you CPU are in safe temps and is not down clocking...also open your task manager when flying and check whats having more activity when the stutters happen!

Share this post


Link to post

Mine is overclocked to 5.0GHz and temps are not an issue. However, I only get rid of most of those stutters only with either an internal or external frame limiter. Using "unlimited" in P3D and no limit in nVidia profile inspector -> stutters. Using either limit -> almost no stutters.

Share this post


Link to post
1 hour ago, AnkH said:

Mine is overclocked to 5.0GHz and temps are not an issue. However, I only get rid of most of those stutters only with either an internal or external frame limiter. Using "unlimited" in P3D and no limit in nVidia profile inspector -> stutters. Using either limit -> almost no stutters.

Try locking your framerate inside P3D

Edited by GSalden

Share this post


Link to post
11 hours ago, slait said:

Hey all,

Thought I would make a post about this issue in case anyone has some suggestions for me. I've recently upgraded my system to something pretty solid (details below), and overall the performance is great when I start, but by the time I reach my destination the sim has deteriorated into studdering every few seconds, with good frame rates in between. In other words it seems to perform well, then pause, then catch up again, then pause, then catch up. It does this every two seconds or so through the rest of taxiing, parking, etc. I'm not quite sure where to go with it. Things I've tried:

  • Renamed and rebuilt the p3d.cfg file
  • Cleared the shader cache and reapplied ENVTEX
  • Reset any and all tweaks to my hardware (overclocking) to default, and ultimately reapplied when it made no difference
  • Tried locking frames in nVidia inspector, then rolled back when I started getting those DX errors
  • Adjusted various in sim settings with no change one way or the other

 

For trouble shooting interest only: have you looked at the skies? ..try clouds with the simple detail box checked.

Edited by FunknNasty

Share this post


Link to post
4 minutes ago, FunknNasty said:

For trouble shooting interest only: have you looked at the skies? ..try clouds with the simple detail box checked.

I've had this problem also.

This could be a problem if you have Active Sky P3Dv4 running with a lot of layers of clouds.  Flying through weather Active Sky seems to cause a pause when loading if there are too many cloud layers.

I've had mine pause so long that Pilotedge disconnects, AAvirtual shows the pause and the sim even disappears to the desktop.

It doesn't seem to happen if I turn down the cloud layers and shut off AI.

It can be very frustrating and disappointing after setting up and losing a great flight.

I'm also going to check to see if I have FPS limited.

  • Like 1

Share this post


Link to post
16 hours ago, Bunchy said:

Do you use Navigraph charts and simlink, by any chance?

If so, download and install the very latest simlink.

I had this issue myself but only after flying for a few hours.

Otherwise, make sure your sim is excluded from antivirus scans, or disable antivirus all together for test purposes.

 

Stu

I don't, no. Also, part of my pre-flight checklist is to disable Windows defender. I don't have any other A/V running.

13 hours ago, dmarques69 said:

4.9ghz? how are those temps? Check if you CPU are in safe temps and is not down clocking...also open your task manager when flying and check whats having more activity when the stutters happen!

Temps are good, never above 70C in P3D.

13 hours ago, AnkH said:

Mine is overclocked to 5.0GHz and temps are not an issue. However, I only get rid of most of those stutters only with either an internal or external frame limiter. Using "unlimited" in P3D and no limit in nVidia profile inspector -> stutters. Using either limit -> almost no stutters.

I would love to do that, which used to be through nVidia inspector, but that has recently started crashing the sim with those DX errors. I just pulled down Riva Tuner Statistics Server based on some other readings and I may give that a try to limit framerates. The internal limiter always comes at a hefty performance cost.

11 hours ago, FunknNasty said:

For trouble shooting interest only: have you looked at the skies? ..try clouds with the simple detail box checked.

I haven't yet, no, though the interesting thing is it seems to be fine for most of the flight, but be very prevalent on the ground at the destination airport. From landing through shutdown is where it gets really bad. Everything up to that point is quite good.

Share this post


Link to post
32 minutes ago, slait said:

From landing through shutdown is where it gets really bad. Everything up to that point is quite good.

What are your parameters in Terrain: detail radius, Tessellation factor, Mesh resolution, Texture resolution...and in Scenery Objects?

Regards,

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...