Chapstick

4.5 hot fix is out

Recommended Posts

15 minutes ago, SunDevil56 said:

Since you apparently prefer FSX Steam, why does this even matter to you....ūüėŹ

I own all sims and love them all.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

Dear all,

Be sure to delete the Prepard3.cfg file after installing the hotfix.

Regards,
Simbol

Edited by simbol
  • Like 1

Share this post


Link to post
5 minutes ago, Ekim said:

If you have the Fsalbs, you should uninstall or deactivate it before starting P3D.

They are testing the build now and will release a new update soon.

I tried to remove the FSLabs folder outside of the add-ons folder, but P3D still doesn't launch. Is it for sure I have to uninstall and deactivate it? Any source?

Share this post


Link to post
3 minutes ago, Daedalus said:

I tried to remove the FSLabs folder outside of the add-ons folder, but P3D still doesn't launch. Is it for sure I have to uninstall and deactivate it? Any source?

De-activate all your add-on's temporally, enable one by one until you find which one is causing the problem.

S.

Share this post


Link to post
Posted (edited)

Biggest issue is addon who are still installing inside the root sim.  Orbx will change with FTX 4 (already got confirmation yesterday on a post).  

I managed to get Majestic Q400 outside the sim using Lorby (will post a howto here - very simple).  

Once all addons go outside - it will be super easy to install P3D (hardly any issues) - just like Xplane makes all addons outside the root. Bug all the lazy developers who do not want to change their of way of thinking. 

We are getting there slowly.

Happy about this Hotfix 1 - I wonder is 2 coming soon...lol.  I am betting V5 will be in Fall

Edited by Skywolf
  • Upvote 3

Share this post


Link to post

"Added configuration option to toggle UI hardware acceleration mode (UIHardwareAcceleration)"

I assume that's the "DisableHWAcceleration" registry edit that was suggested when ReShade was acting up in 4.4, which has now become a user option?

Share this post


Link to post
Posted (edited)

Dear All,

Anyone still having issues with performance after the hotfix, please rebuild your shaders and be sure to check if you have this registry key:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

If you do, please delete it, restart your PC and launch P3D again..

There is a new setting under Ptepra3d.cfg called UIHardwareAcceleration, it is important to have this setting set to True.

The setting works as follow:

UIHardwareAcceleration=False - Disables Hardware Acceleration for P3D.

UIHardwareAcceleration=True - Enables Hardware Acceleration for P3D.

People using Reshade might need to disable it, however please try your performance first with HW acceleration enabled.

Regards,
Simbol

Edited by simbol
  • Like 2
  • Upvote 4

Share this post


Link to post
Posted (edited)
4 minutes ago, Sethos1988 said:

"Added configuration option to toggle UI hardware acceleration mode (UIHardwareAcceleration)"

I assume that's the "DisableHWAcceleration" registry edit that was suggested when ReShade was acting up in 4.4, which has now become a user option?

Correct, please delete your registry key.. and use the setting instead, however be advised performance might be affected with this disabled on certain systems.

S.

Edited by simbol
  • Upvote 2

Share this post


Link to post

@simbol - Awesome Posts...Thank you for the work!

It is great you get to beta test P3D :laugh: 

I wish I had the time to Beta test these days unfortunately I do not.

  • Upvote 2

Share this post


Link to post
14 minutes ago, simbol said:

Dear All,

Anyone still having issues with performance after the hotfix, please rebuild your shaders and be sure to check if you have this registry key:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

[...]

Thanks Simbol, but honestly, a little bit to much to ask users to modify their registry for a "hotfix", no? Obviosuly the problem is not solved by the hotfix? Can you elaborate a little bit further on this registry entry? I have it in my registry, but as I did not observe any FPS issues already without the hotfix, I wonder what the registry entry stands for? Reason I ask: I might simply not have seen the FPS drop due to my FPS limit at 30. But if this registry entry might be the reason for reduced FPS, I also want to get rid of it...

  • Like 1

Share this post


Link to post
6 minutes ago, AnkH said:

Thanks Simbol, but honestly, a little bit to much to ask users to modify their registry for a "hotfix", no? Obviosuly the problem is not solved by the hotfix? Can you elaborate a little bit further on this registry entry? I have it in my registry, but as I did not observe any FPS issues already without the hotfix, I wonder what the registry entry stands for? Reason I ask: I might simply not have seen the FPS drop due to my FPS limit at 30. But if this registry entry might be the reason for reduced FPS, I also want to get rid of it...

This registry setting disables hardware acceleration for all applications on your PC, you want this enabled to get the best performance out of your system.

P3D 4.4 enabled hardware acceleration hardcoded inside the source code, but some people complained about this change since Reshade and other overlaying /recording software were not working correctly with P3D 4.4. and as a result LM gave the registry setting for a work around for user experiencing this problem.

P3D 4.5 disabled hardware acceleration via internal code, to correct the issues stated above as people were complaining about issues, etc.

P3D 4.5 HotFix has re-enabled Hardware Acceleration by default, and included a setting via Prepard3.cfg to override it if necesary: UIHardwareAcceleration=false. NOTE: It was determined via beta tests that the change in hardware acceleration via internal code caused the performance drops in comparison with P3D 4.4 under certain systems.

So you need to delete this registry setting if you have it in your system.

Regards,
Simbol

 

 

  • Like 4
  • Upvote 2

Share this post


Link to post
1 hour ago, SunDevil56 said:

Pete, you can do the full installer, or just the client, which apparently addresses the quote, "performance issues seen on some systems and configurations" according to the hotfix page at LM. 

Thank you very much 

  • Upvote 1

Share this post


Link to post
Posted (edited)
14 minutes ago, simbol said:

This registry setting disables hardware acceleration for all applications on your PC, you want this enabled to get the best performance out of your system.

P3D 4.4 enabled hardware acceleration hardcoded inside the source code, but some people complained about this change since Reshade and other overlaying /recording software were not working correctly with P3D 4.4. and as a result LM gave the registry setting for a work around for user experiencing this problem.

P3D 4.5 disabled hardware acceleration via internal code, to correct the issues stated above as people were complaining about issues, etc.

P3D 4.5 HotFix has re-enabled Hardware Acceleration by default, and included a setting via Prepard3.cfg to override it if necesary: UIHardwareAcceleration=false. NOTE: It was determined via beta tests that the change in hardware acceleration via internal code caused the performance drops in comparison with P3D 4.4 under certain systems.

So you need to delete this registry setting if you have it in your system.

 

 

 

Was that related to cpu affinty issues? By any chance? 

Very interesting. 

Edited by tooting

Share this post


Link to post
19 minutes ago, simbol said:

This registry setting disables hardware acceleration for all applications on your PC, you want this enabled to get the best performance out of your system.

P3D 4.4 enabled hardware acceleration hardcoded inside the source code, but some people complained about this change since Reshade and other overlaying /recording software were not working correctly with P3D 4.4. and as a result LM gave the registry setting for a work around for user experiencing this problem.

P3D 4.5 disabled hardware acceleration via internal code, to correct the issues stated above as people were complaining about issues, etc.

P3D 4.5 HotFix has re-enabled Hardware Acceleration by default, and included a setting via Prepard3.cfg to override it if necesary: UIHardwareAcceleration=false. NOTE: It was determined via beta tests that the change in hardware acceleration via internal code caused the performance drops in comparison with P3D 4.4 under certain systems.

So you need to delete this registry setting if you have it in your system.

Regards,
Simbol

 

 

So essentially, we've now reached a point where for some users, they might be 'forced' to take the 4.5 performance decrease if they need to use ReShade and disable HWA?

Share this post


Link to post
12 minutes ago, tooting said:

with P3D 4.4 under certain systems.

......looks like KEY word to me. 

Share this post


Link to post
2 hours ago, Christopher Low said:

......smug 4.4 user enters stage left with popcorn in hand :tongue:

I haven’t got popcorn I got a beer lol

Share this post


Link to post
3 minutes ago, Sethos1988 said:

So essentially, we've now reached a point where for some users, they might be 'forced' to take the 4.5 performance decrease if they need to use ReShade and disable HWA?

Not necessarily.

I use Reshade with 4.5 on my main simulation PC and I don't have any performance issues with 4.5, as I said, no all systems are affected so you will need to TEST on your own computer.

S.

 

Share this post


Link to post
2 hours ago, Christopher Low said:

......smug 4.4 user enters stage left with popcorn in hand :tongue:

I haven’t got popcorn I got beer lol

Share this post


Link to post
5 minutes ago, Sethos1988 said:

So essentially, we've now reached a point where for some users, they might be 'forced' to take the 4.5 performance decrease if they need to use ReShade and disable HWA?

You beat me too it 

Share this post


Link to post

I found the problem of P3D not starting after the hotfix. The WX Advantage Radar is the reason. Removed the MV_WXM.dll from the Modules folder and problem solved. I guess it needs to be updated.

  • Like 1

Share this post


Link to post
Just now, tooting said:

You beat me too it 

See my response..

S.

  • Upvote 1

Share this post


Link to post

initially 5 min testing very promising

Share this post


Link to post
15 minutes ago, cyyzrwy24 said:

......looks like KEY word to me. 

It definitely was an issue for some people, like I said I know all 3 of my regular 'sim buddies' had it. 

We all tried to do a lgw krk lgw together none of us made it  the stutters where unbearable 

Its going to be interesting seeing people now tweaking the registry

Share this post


Link to post
Posted (edited)

Installed the "hot fix". See no difference at all.

I did not notice any fps drop in 4.5 before.

I was happy and I'm still happy.

Edited by kiek
  • Like 1

Share this post


Link to post
Posted (edited)
7 minutes ago, tooting said:

Its going to be interesting seeing people now tweaking the registry

The registry key I mentioned should not be there, in fact Windows do not have it at all by default.

People have been add-in it since they installed P3D 4.4 to allow specific compatibility things to run, IE: Reshade and some recording software.

The best approach is to remove it and use the prepar3d.cfg file instead to control the hardware acceleration behaviour for the simulator.

S.

 

Edited by simbol
  • Like 2
  • Upvote 2

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now